source: projects/specs/branches/6/b/busybox/busybox-vl.spec @ 3963

Revision 3963, 8.9 KB checked in by daisuke, 13 years ago (diff)

busybox: update to 1.18.4, build with system uClibc, update configs

Line 
1Summary: Statically linked binary providing simplified versions of system commands
2Name: busybox
3Version: 1.18.4
4Release: 1%{?_dist_release}
5License: GPLv2
6Group: System Environment/Shells
7Source: http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
8Source10: busybox-static.config
9Source11: busybox-anaconda.config
10Patch12: busybox-1.2.2-ls.patch
11Patch16: busybox-1.10.1-hwclock.patch
12URL: http://www.busybox.net
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14BuildRequires: uClibc-devel
15
16Vendor: Project Vine
17Distribution: Vine Linux
18Packager: daisuke
19
20%description
21Busybox is a single binary which includes versions of a large number
22of system commands, including a shell.  This package can be very
23useful for recovering from certain types of system failures,
24particularly those involving broken shared libraries.
25
26%package anaconda
27Group: System Environment/Shells
28Summary: Version of busybox configured for use with anaconda
29
30%description anaconda
31Busybox is a single binary which includes versions of a large number
32of system commands, including a shell.  The version contained in this
33package is designed for use with the Red Hat installation program,
34anaconda. The busybox package provides a binary better suited to
35normal use.
36
37
38%prep
39%setup -q
40%patch12 -b .ls -p1
41%patch16 -b .ia64 -p1
42
43
44%build
45# create static busybox
46arch=`uname -m | sed -e 's/i.86/i386/' -e 's/ppc/powerpc/' -e 's/ppc64//' -e 's/powerpc64//'`
47cp %{SOURCE10} .config
48yes "" | make oldconfig
49# gcc needs to be convinced to use neither system headers, nor libs,
50# nor startfiles (i.e. crtXXX.o files)
51if test "$arch"; then \
52    mv .config .config1 && \
53    grep -v ^CONFIG_SELINUX .config1 >.config && \
54    yes "" | make oldconfig && \
55    cat .config && \
56    make V=1 \
57        EXTRA_CFLAGS="-isystem %{_includedir}/uClibc" \
58        CFLAGS_busybox="-static -nostartfiles -L%{_libdir}/uClibc %{_libdir}/uClibc/crt1.o %{_libdir}/uClibc/crti.o %{_libdir}/uClibc/crtn.o"; \
59else \
60    cat .config && \
61    make V=1 CC="gcc $RPM_OPT_FLAGS"; \
62fi
63cp busybox busybox.static
64cp docs/busybox.1 docs/busybox.static.1
65
66# create busybox optimized for anaconda
67make clean
68#
69cp %{SOURCE11} .config
70yes "" | make oldconfig
71make CONFIG_DEBUG=y CC="gcc $RPM_OPT_FLAGS"
72cp busybox busybox.anaconda
73cp docs/busybox.1 docs/busybox.anaconda.1
74
75%install
76rm -rf $RPM_BUILD_ROOT
77mkdir -p $RPM_BUILD_ROOT/sbin
78install -m 755 busybox.static $RPM_BUILD_ROOT/sbin/busybox
79install -m 755 busybox.anaconda $RPM_BUILD_ROOT/sbin/busybox.anaconda
80mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
81install -m 644 docs/busybox.static.1 $RPM_BUILD_ROOT/%{_mandir}/man1/busybox.1
82install -m 644 docs/busybox.anaconda.1 $RPM_BUILD_ROOT/%{_mandir}/man1/busybox.anaconda.1
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%files
88%defattr(-,root,root,-)
89%doc LICENSE README
90/sbin/busybox
91%{_mandir}/man1/busybox.1.gz
92
93%files anaconda
94%defattr(-,root,root,-)
95%doc LICENSE README
96/sbin/busybox.anaconda
97%{_mandir}/man1/busybox.anaconda.1.gz
98
99%changelog
100* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18.4-1
101- update to 1.18.4
102- build with system uClibc
103
104* Fri May 08 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.13.4-2
105- add Patch20 to fix build failure on ppc
106  http://lists.uclibc.org/pipermail/uclibc-cvs/2009-January/025891.html
107
108* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.13.4-1
109- new upstream release
110- use uClibc for static build instead of glibc
111
112* Fri Sep 19 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.0-1vl5
113- applied new versioning policy
114
115* Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
116- initial build for Vine Linux based on FC-devel
117
118* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:1.2.0-1.1
119- rebuild
120
121* Tue Jul  4 2006 Ivana Varekova <varekova@redhat.com> - 1:1.2.0-1
122- update to 1.2.0
123
124* Thu Jun  8 2006 Jeremy Katz <katzj@redhat.com> - 1:1.1.3-2
125- fix so that busybox.anaconda has sh
126
127* Wed May 31 2006 Ivana Varekova <varekova@redhat.com> - 1:1.1.3-1
128- update to 1.1.3
129
130* Mon May 29 2006 Ivana Varekova <varekova@redhat.com> - 1:1.1.2-3
131- fix Makefile typo (#193354)
132
133* Fri May  5 2006 Ivana Varekova <varekova@redhat.com> - 1:1.1.2-1
134- update to 1.1.2
135
136* Thu May  4 2006 Ivana Varekova <varekova@redhat.com> - 1:1.1.1-2
137- add -Z option to id command, rename ps command -Z option (#190534)
138
139* Wed May 03 2006 Ivana Varekova <varekova@redhat.com> - 1:1.1.1-1
140- update to 1.1.1
141- fix CVE-2006-1058 - BusyBox passwd command
142  fails to generate password with salt (#187386)
143- add -minimal-toc option
144- add RPM_OPT_FLAGS
145- remove asm/page.h used sysconf command to get PAGE_SIZE
146- add overfl patch to aviod Buffer warning
147
148* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1:1.01-2.2.1
149- bump again for double-long bug on ppc(64)
150
151* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1:1.01-2.2
152- rebuilt for new gcc4.1 snapshot and glibc changes
153
154* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
155- rebuilt
156
157* Thu Oct 13 2005 Daniel Walsh <dwalsh@redhat.com> -  1.01-2
158- Add sepol for linking load_policy
159
160* Thu Sep  1 2005 Ivana Varekova <varekova@redhat.com> - 1.01-1
161- update to 1.01
162 
163* Tue May 11 2005 Ivana Varekova <varekova@redhat.com> - 1.00-5
164- add debug files to debug_package
165
166* Mon Mar  7 2005 Ivana Varekova <varekova@redhat.com> - 1.00-4
167- rebuilt
168
169* Wed Jan 26 2005 Ivana Varekova <varekova@redhat.com> - 1.00-3
170- update to 1.00 - fix bug #145681
171- rebuild
172
173* Thu Jan 13 2005 Jeremy Katz <katzj@redhat.com> - 1.00.rc1-6
174- enable ash as the shell in busybox-anaconda
175
176* Sat Oct  2 2004 Bill Nottingham <notting@redhat.com> - 1.00.rc1-5
177- fix segfault in SELinux patch (#134404, #134406)
178
179* Fri Sep 17 2004 Phil Knirsch <pknirsch@redhat.com> - 1.00.rc1-4
180- Fixed double free in freecon() call (#132809)
181
182* Fri Sep 10 2004 Daniel Walsh <dwalsh@redhat.com> - 1.00.rc1-3
183- Add CONFIG_STATIC=y for static builds
184
185* Wed Aug 25 2004 Jeremy Katz <katzj@redhat.com> - 1.00.rc1-2
186- rebuild
187
188* Fri Jun 25 2004 Dan Walsh <dwalsh@redhat.com> 1.00-pre10.1
189- Add BuildRequires libselinux-devel
190- Update to latest from upstream
191
192* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
193- rebuilt
194
195* Tue May 11 2004 Karsten Hopp <karsten@redhat.de> 1.00.pre8-4
196- add mknod to busybox-anaconda
197
198* Wed Apr 21 2004 Karsten Hopp <karsten@redhat.de> 1.00.pre8-3
199- fix LS_COLOR in anaconda patch
200
201* Tue Mar 23 2004 Jeremy Katz <katzj@redhat.com> 1.00.pre8-2
202- add awk to busybox-anaconda
203
204* Sat Mar 20 2004 Dan Walsh <dwalsh@redhat.com> 1.00-pre8.1
205- Update with latest patch.
206- Turn off LS_COLOR in static patch
207
208* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
209- rebuilt
210
211* Tue Jan 27 2004 Dan Walsh <dwalsh@redhat.com> 1.00-pre5.2
212- Fix is_selinux_enabled calls
213
214* Mon Dec 29 2003 Dan Walsh <dwalsh@redhat.com> 1.00-pre5.1
215-Latest update
216
217* Wed Nov 26 2003 Dan Walsh <dwalsh@redhat.com> 1.00-pre3.2
218- Add insmod
219
220* Mon Sep 15 2003 Dan Walsh <dwalsh@redhat.com> 1.00-pre3.1
221- Upgrade to pre3
222
223* Thu Sep 11 2003 Dan Walsh <dwalsh@redhat.com> 1.00.2
224- Upgrade selinux support
225
226* Wed Jul 23 2003 Dan Walsh <dwalsh@redhat.com> 1.00.1
227- Upgrade to 1.00 package
228
229* Wed Jul 16 2003 Elliot Lee <sopwith@redhat.com> 0.60.5-10
230- Rebuild
231
232* Mon Jul 14 2003 Jeremy Katz <katzj@redhat.com> 0.60.5-9
233- rebuild
234
235* Mon Jul 14 2003 Jeremy Katz <katzj@redhat.com> 0.60.5-8
236- add dmesg to busybox-anaconda
237
238* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
239- rebuilt
240
241* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
242- rebuilt
243
244* Mon Jan 13 2003 Jeremy Katz <katzj@redhat.com> 0.60.5-5
245- lost nolock for anaconda mount when rediffing, it returns (#81764)
246
247* Mon Jan 6 2003 Dan Walsh <dwalsh@redhat.com> 0.60.5-4
248- Upstream developers wanted to eliminate the use of floats
249
250* Thu Jan 3 2003 Dan Walsh <dwalsh@redhat.com> 0.60.5-3
251- Fix free to work on large memory machines.
252
253* Sat Dec 28 2002 Jeremy Katz <katzj@redhat.com> 0.60.5-2
254- update Config.h for anaconda build to include more useful utils
255
256* Thu Dec 19 2002 Dan Walsh <dwalsh@redhat.com> 0.60.5-1
257- update latest release
258
259* Thu Dec 19 2002 Dan Walsh <dwalsh@redhat.com> 0.60.2-8
260- incorporate hammer changes
261
262* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
263- automated rebuild
264
265* Thu May 23 2002 Tim Powers <timp@redhat.com>
266- automated rebuild
267
268* Mon May 06 2002 Florian La Roche <Florian.LaRoche@redhat.de>
269- fix compilation on mainframe
270
271* Tue Apr  2 2002 Jeremy Katz <katzj@redhat.com>
272- fix static busybox (#60701)
273
274* Thu Feb 28 2002 Jeremy Katz <katzj@redhat.com>
275- don't include mknod in busybox.anaconda so we get collage mknod
276
277* Fri Feb 22 2002 Jeremy Katz <katzj@redhat.com>
278- rebuild in new environment
279
280* Wed Jan 30 2002 Jeremy Katz <katzj@redhat.com>
281- update to 0.60.2
282- include more pieces for the anaconda version so that collage can go away
283- make the mount in busybox.anaconda default to -onolock
284
285* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
286`- automated rebuild
287
288* Mon Jul  9 2001 Tim Powers <timp@redhat.com>
289- don't obsolete sash
290- fix URL and spelling in desc. to satisfy rpmlint
291
292* Thu Jul 05 2001 Florian La Roche <Florian.LaRoche@redhat.de>
293- add missing defattr for anaconda subpackage
294
295* Thu Jun 28 2001 Erik Troan <ewt@redhat.com>
296- initial build for Red Hat
Note: See TracBrowser for help on using the repository browser.