source: projects/specs/branches/6/b/bootparamd/bootparamd-vl.spec @ 521

Revision 521, 5.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define version 0.17
2%define release 15%{?_dist_release}
3%define _snapshot       -pre20000412
4
5Summary: A server process which provides boot information to diskless clients.
6Summary(ja): ディスクレスクライアントに起動情報を提供するサーバプロセス
7Name: bootparamd
8Version: %{version}
9Release: %{release}
10License: BSD
11Group: System Environment/Daemons
12Source: ftp://ftp.uk.linux.org/pub/linux/Networking/netkit-devel/netkit-bootparamd-%{version}%{_snapshot}.tar.gz
13Source1: bootparamd.init
14Patch: bootparamd-manpage-63567.patch
15#Prereq: /sbin/chkconfig /sbin/init.d
16Prereq: /sbin/chkconfig
17Requires: portmap
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19
20
21%description
22The bootparamd process provides bootparamd, a server process which
23provides the information needed by diskless clients in order for them
24to successfully boot.  Bootparamd looks first in /etc/bootparams for an
25entry for that particular client; if a local bootparams file doesn't
26exist, it looks at the appropriate Network Information Service (NIS)
27map.  Some network boot loaders (notably Sun's) rely on special boot
28server code on the server, in addition to the RARP and TFTP servers.
29This bootparamd server process is compatible with SunOS bootparam clients
30and servers which need that boot server code.
31
32You should install bootparamd if you need to provide boot information to
33diskless clients on your network.
34
35%description -l ja
36bootparamd はディスクレスクライアントが正しく起動する為の情報を
37提供するサーバプロセスです.bootparamd は最初に /etc/bootparams を
38見て特定のクライアントの情報を探します./etc/bootparams がなければ
39NIS (Network Information Service) のマップを探します.
40ネットワークブートローダの中には (特に Sun のものが) RARP や TFTP
41サーバに加えて特別なブートサーバを必要とします.この bootparamd サーバは
42SunOS の bootparam クライアント/サーバと互換性があります.
43
44ネットワーク上のディスクレスクライアントに起動情報を提供する必要が
45ある場合は bootparamd パッケージをインストールして下さい.
46
47
48%prep
49%setup -q -n netkit-bootparamd-%{version}%{_snapshot}
50%patch -p1
51
52%build
53sh configure --with-c-compiler=gcc
54perl -pi -e '
55    s,^CC=.*$,CC=cc,;
56    s,-O2,\$(RPM_OPT_FLAGS) -D_BSD_SOURCE,;
57    s,^BINDIR=.*$,BINDIR=%{_bindir},;
58    s,^MANDIR=.*$,MANDIR=%{_mandir},;
59    s,^SBINDIR=.*$,SBINDIR=%{_sbindir},;
60    ' MCONFIG
61make
62
63
64%install
65rm -rf %{buildroot}
66mkdir -p %{buildroot}%{_bindir}
67mkdir -p %{buildroot}%{_mandir}/man{1,8}
68mkdir -p %{buildroot}%{_sbindir}
69mkdir -p %{buildroot}%{_initdir}
70
71make INSTALLROOT=%{buildroot} install
72install -m 755 $RPM_SOURCE_DIR/bootparamd.init %{buildroot}%{_initdir}/bootparamd
73
74
75%clean
76rm -rf %{buildroot}
77
78
79%post
80/sbin/chkconfig --add bootparamd
81
82
83%preun
84if [ $1 = 0 ]; then
85    /sbin/chkconfig --del bootparamd
86fi
87
88
89%files
90%defattr(-,root,root)
91%{_sbindir}/rpc.bootparamd
92%{_bindir}/callbootd
93%{_mandir}/man8/rpc.bootparamd.*
94%{_mandir}/man8/bootparamd.*
95%config %{_initdir}/bootparamd
96
97
98%changelog
99* Fri Sep 19 2008 Shu KONNO <owa@bg.wakwak.com> 0.17-15vl5
100- applied new versioning policy, spec in utf-8
101
102* Thu Jul  3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-14vl1
103- based on Redhat Rawhide 0.17-14
104- rebuild with new toolchains
105- s/Copyright/License/
106
107* Wed Jan 10 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
108- 0.17-5vl3
109- use better macros (%%{_initdir})
110- added Japanese summary and description
111- rebuilt with newer %%{_mandir} definition
112
113* Tue Dec 12 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17-5vl2
114- remove /etc/init.d from PreReq
115
116* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 0.17-5vl1
117- build on Vine Linux with gcc-2.95.3
118
119* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
120- condrestart fixes
121
122* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
123- move initscript back
124
125* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
126- automatic rebuild
127
128* Mon Jul 10 2000 Preston Brown <pbrown@redhat.com>
129- move initscript
130 
131* Sun Jun 18 2000 Matt Wilson <msw@redhat.com>
132- FHS packaging
133- 0.17
134
135* Thu Feb 03 2000 Erik Troan <ewt@redhat.com>
136- gzipped man pages
137
138* Tue Dec 21 1999 Jeff Johnson <jbj@redhat.com>
139- update to 0.16.
140
141* Fri Sep 25 1999 Bill Nottingham <notting@redhat.com>
142- *sigh*.
143
144* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
145- initrscript munging
146
147* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
148- auto rebuild in the new build environment (release 22)
149
150* Mon Mar 15 1999 Jeff Johnson <jbj@redhat.com>
151- compile for 6.0
152
153* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
154- removed triggerpostun.
155
156* Fri May 01 1998 Jeff Johnson <jbj@redhat.com>
157- added triggerpostun
158
159* Wed Apr 22 1998 Michael K. Johnson <johnsonm@redhat.com>
160- enhanced initscript
161
162* Thu Jan 08 1998 Erik Troan <ewt@redhat.com>
163- updated initscript to include functions
164- fixed 'stop' action of initscript
165- added requirement for portmap
166
167* Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
168- added an initscript
169
170* Tue Jul 15 1997 Erik Troan <ewt@redhat.com>
171- initial build
Note: See TracBrowser for help on using the repository browser.