source: projects/specs/branches/6/b/bonobo/bonobo-vl.spec @ 1929

Revision 1929, 5.7 KB checked in by owa, 14 years ago (diff)

rebuilt bonobo, gnome-print, gtk+

Line 
1# Note this is NOT a relocatable thing :)
2%define name    bonobo
3%define ver     1.0.22
4%define rel     8%{?_dist_release}
5
6Summary:        CORBA-based component system
7Summary(ja):    CORBAベースのコンポーネントシステム
8Name:           %{name}
9Version:        %{ver}
10Release:        %{rel}
11License:        GPL
12Group:          System Environment/Libraries
13Source:         ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.0/%{name}-%{ver}.tar.bz2
14URL:            http://www.gnome.org/
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17BuildRequires:  gnome-libs-devel >= 1.4.2-2vl5
18BuildRequires:  ORBit-devel >= 0.5.8
19BuildRequires:  oaf-devel
20BuildRequires:  libxml-devel >= 1.8.15
21BuildRequires:  gdk-pixbuf-devel >= 0.21.0-0vl2
22BuildRequires:  gnome-print-devel >= 0.37-2vl5
23BuildRequires:  openjade gtk+-devel glib-devel
24#BuildRequires:  autoconf213, automake14
25Requires:       gnome-libs >= 1.4.2-2vl5
26Requires:       ORBit >= 0.5.8
27Requires:       oaf >= 0.6.2
28Requires:       libxml >= 1.8.15
29Requires:       gdk-pixbuf >= 0.21.0-0vl2
30Requires:       libgnomeprint15 >= 0.37-2vl5
31
32Patch0:         bonobo-1.0.17-config.patch
33Patch1:         bonobo-1.0.22-nonstatic.patch
34
35%description
36Bonobo is a library that provides the necessary framework for GNOME
37applications to deal with compound documents, i.e. those with a
38spreadsheet and graphic embedded in a word-processing document.
39
40%package devel
41Summary:        Libraries and include files for the Bonobo document model
42Summary(ja):    Bonobo の開発用ライブラリおよびヘッダファイル
43Group:          Development/Libraries
44Requires:       pkgconfig
45Requires:       %{name} = %{version}
46
47%description devel
48This package provides the necessary development libraries and include
49files to allow you to develop programs using the Bonobo document model.
50
51%prep
52%setup -q
53%patch1 -p1 -b .nonstatic
54
55%build
56%configure --disable-gtk-doc --disable-static
57export tagname=CC
58make LIBTOOL=/usr/bin/libtool
59
60%install
61[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
62export tagname=CC
63%makeinstall LIBTOOL=/usr/bin/libtool
64
65%find_lang %{name}
66
67## remove unuse files
68rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
69rm -rf $RPM_BUILD_ROOT%{_libdir}/*.a
70#rm -rf $RPM_BUILD_ROOT%{_libdir}/bonobo/*.la
71rm -rf $RPM_BUILD_ROOT%{_libdir}/bonobo/*/*.la
72rm -rf $RPM_BUILD_ROOT%{_libdir}/bonobo/*/*.a
73
74%clean
75[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
76
77%post -p /sbin/ldconfig
78 
79%postun -p /sbin/ldconfig
80
81%files -f %{name}.lang
82%defattr(-, root, root)
83%doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README
84%{_bindir}/*
85%exclude %{_bindir}/libefs-config
86%{_libdir}/*.so.*
87%{_libdir}/bonobo/plugin/*.so
88%{_libdir}/bonobo/monikers/*.so
89%{_datadir}/bonobo/*
90%{_datadir}/gnome/*
91%{_datadir}/oaf/*
92#%{_datadir}/libefs/*
93%{_datadir}/idl/*
94
95%files devel
96%defattr (-, root, root)
97%{_bindir}/libefs-config
98%{_libdir}/*.so
99#{_libdir}/*.a
100#{_libdir}/*.la
101%{_libdir}/*.sh
102#%{_libdir}/bonobo/*/*.a
103#%{_libdir}/bonobo/*/*.la
104%{_libdir}/pkgconfig/*.pc
105%{_includedir}/*
106
107%changelog
108* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.22-8
109- rebuilt with gnome-print-0.37-3
110
111* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.22-7
112- rebuilt with rpm-4.8.1 for pkg-config
113
114* Sat May  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.22-6
115- rebuilt with gnome-libs-1.4.2-2vl5 (linking with db-4.6)
116- remove *.a
117
118* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.22-5vl5
119- applied new versioning policy, spec in utf-8
120- remove *.la
121
122* Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.22-4vl3
123- rebuild with new toolchain
124- dropped Patch0
125- added Patch1 for compiling new toolchain
126
127* Tue Oct 26 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.22-4vl2
128- rebuild with db4-4.2.52 and libgnomeprint-0.37
129- s/Copyright/License/
130- add Japanese summary
131- libefs-config moved to devel package
132
133* Sun May 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.22-4vl1
134- 1.0.22 based on Redhat Rawhide 1.0.22-4
135- changed Summary and Source URL
136
137* Wed Mar  5 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.17-0vl3
138- rebuilt with new toolchains
139- rebuilt with gdk-pixbuf-0.21.0-0vl2
140- use legacy autoconf-2.13 and automake-1.4
141
142* Wed Mar 27 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.17-0vl2
143- rebuilt with gdk-pixbuf-0.16.0-0vl1
144
145* Tue Dec 18 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.17-0vl1
146- New upstream release.
147
148* Fri Nov 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.9-0vl1
149- updated to the new upstream 1.0.9 release
150
151* Sat Jul 28 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
152- 1.0.7-0vl1
153- updated to new upstream release
154
155* Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.4-0vl1
156- New upstream release.
157- Fixed packaging mistake.
158
159* Tue May  8 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl2
160- Fixed missing files.
161
162* Tue May  8 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl1
163- New upstream release.
164
165* Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.37-0vl2
166- Fixed defattr macro.
167
168* Tue Mar 13 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.37-0vl1
169- New upstream release.
170- Added relative execute for config.
171
172* Thu Dec 28 2000 Akira TAGOH <tagoh@gnome.gr.jp> 0.31.cvs20001221-0vl1
173- Build for Vine
174
175* Wed Oct 18 2000 Eskil Heyn Olsen <eskil@eazel.com>
176- Added requirements to the base package
177- Added bonobo-ui-extract to the file list of the base pacakge
178
179* Tue Feb 22 2000 Jens Finke <jens.finke@informatik.uni-oldenburg.de>
180- Added bonobo.h to the file list of devel package.
181
182* Wed Nov 10 1999 Alexander Skwar <ASkwar@DigitalProjects.com>
183- Updated to version 0.5
184- fixed spec file
185- Un-quiet things
186- stripped binaries
187- unsetted language environment variables
188
189* Sat Oct 2 1999 Gregory McLean <gregm@comstar.net>
190- Updated the spec for version 0.4
191- Updated the files section.
192
193* Sun Aug 1 1999 Gregory McLean <gregm@comstar.net>
194- Some updates. sysconfdir stuff, quiet down the prep/configure stage.
195
196* Sat May 1 1999 Erik Walthinsen <omega@cse.ogi.edu>
197- created spec file
Note: See TracBrowser for help on using the repository browser.