source: projects/specs/branches/6/b/bogofilter/bogofilter-vl.spec @ 3801

Revision 3801, 5.3 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME packages: new upstream release, bogofilter: fix perl requirements, perl-modules: new package

Line 
1Name:           bogofilter
2Summary:        fast anti-spam filtering by Bayesian statistical analysis
3Summary(ja):    ベイジアン解析による高速アンチスパムフィルタリング
4Version:        1.2.2
5Release:        2%{?_dist_release}
6URL:            http://bogofilter.sourceforge.net/
7Source0:        http://prdownloads.sourceforge.net/bogofilter/bogofilter-%{version}.tar.bz2
8Source999:      filter-requires-bogofilter.sh
9#Patch10:       http://www.ono.org/software/dist/%{name}-%{version}+kakasi-0.5.patch.gz
10Patch10:        http://www.c-wind.com/bogofilter/%{name}-%{version}+kakasi-0.5.patch.gz
11License:        GPL
12Group:          Applications/Internet
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14
15Requires:       kakasi
16BuildRequires:  db4-devel >= 4.3.29, kakasi, kakasi-devel, gsl-devel, flex
17
18%define __find_requires %{SOURCE999}
19
20%description
21Bogofilter is a Bayesian spam filter.  In its normal mode of
22operation, it takes an email message or other text on standard input,
23does a statistical check against lists of "good" and "bad" words, and
24returns a status code indicating whether or not the message is spam.
25Bogofilter is designed with fast algorithms (including Berkeley DB system),
26coded directly in C, and tuned for speed, so it can be used for production
27by sites that process a lot of mail.
28
29%prep
30[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
31
32%setup -q
33%patch10 -p1 -b .kakasi
34
35%build
36%configure --program-prefix=
37%__make
38
39%install
40[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
41make install DESTDIR=$RPM_BUILD_ROOT
42
43%__cp -p %{buildroot}%{_sysconfdir}/bogofilter.cf.example \
44        %{buildroot}%{_sysconfdir}/bogofilter.cf
45
46for n in xml html ; do
47        %__install -d -m755 .inst/$n
48        %__install -p -m644 doc/*.$n .inst/$n
49done
50
51#for d in contrib ; do
52#       %__install -d -m755 %{buildroot}%{_datadir}/%{name}/$d
53#       for f in $(%{_bindir}/find $d -maxdepth 1 -type f) ; do
54#               case $f in
55#                       *.c|*.o|*.obj|*/Makefile*)
56#                               continue
57#                               ;;
58#                       *.1)
59#                               %__cp -p $f %{buildroot}%{_mandir}/man1
60#                               ;;
61#                       *)
62#                               %__cp -p $f %{buildroot}%{_datadir}/%{name}/$d
63#                               ;;
64#               esac
65#       done
66#done
67%{__chmod} -x contrib/*
68
69for README in contrib randomtrain ; do
70        %__ln_s ../../%{name}/contrib/README.$README doc/README.$README
71done
72
73# drop executable bit from contrib/* to avoid unneeded dependencies
74#%{_bindir}/find %{buildroot}%{_datadir}/%{name}/contrib -type f \
75#       -exec %__chmod -x '{}' \;
76
77%clean
78[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
79
80%files
81%defattr(-,root,root)
82%doc AUTHORS COPYING INSTALL NEWS
83%doc README* RELEASE.NOTES* TODO GETTING.STARTED
84%doc doc/README* doc/bogofilter-SA* doc/integrating* doc/rpm.notes.BerkeleyDB
85%doc doc/programmer
86%doc .inst/html .inst/xml
87%doc contrib
88
89%{_sysconfdir}/bogofilter.cf.example
90%config(noreplace) %{_sysconfdir}/bogofilter.cf
91
92%{_bindir}/bogofilter
93%{_bindir}/bogolexer
94%{_bindir}/bogotune
95%{_bindir}/bogoutil
96%{_bindir}/bogoupgrade
97%{_bindir}/bf_compact
98%{_bindir}/bf_copy
99%{_bindir}/bf_tar
100%{_mandir}/man1/bogofilter.1*
101%{_mandir}/man1/bogolexer.1*
102%{_mandir}/man1/bogotune.1*
103%{_mandir}/man1/bogoutil.1*
104%{_mandir}/man1/bogoupgrade.1*
105%{_mandir}/man1/bf_compact.1*
106%{_mandir}/man1/bf_copy.1*
107%{_mandir}/man1/bf_tar.1*
108
109%changelog
110* Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-2
111- rebuild with current VineSeed environment
112- fix perl requirements
113
114* Thu Dec 30 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.2.2-1
115- new upstream release
116- update Patch10
117- add Requires: kakasi (<BTS:VineLinux:852>)
118- updates Source999: add filtering string
119
120* Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.2-1vl5
121- applied new versioning policy, spec in utf-8
122
123* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl5
124- rebuild with gsl-1.9
125
126* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl4
127- rebuild with db4-4.3
128
129* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl3
130- add filter-requires-bogofilter.sh (source999)
131
132* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
133- rebuild
134
135* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
136- new upstream release
137- modified kakasi patch
138
139* Mon Feb 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl2
140- rebuild
141
142* Mon Feb 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl1
143- new upstream release
144- update kakasi patch
145- remove unneeded macro %%mydocdir
146- fix symlink
147- add Japanese summary
148- drop executable bit from contrib/*
149
150* Tue Oct 11 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.96.2-0vl2
151- rebuild
152
153* Tue Oct 11 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.96.2-0vl1
154- new upstream release
155- update and modify kakasi patch
156- fix dependencies
157  - add BuildRequires: kakasi-devel, gsl-devel, flex
158  - add Requires: gsl
159- update %%files
160  - update %%doc
161  - add %%{_bindir}/bf_{compact,copy,tar} and corresponding man pages
162
163* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.92.6-0vl2
164- rebuilt with db4-4.2.52
165
166* Tue Sep 21 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.92.6-0vl1
167- new upstream release.
168- update kakasi patch.
169
170* Sun May  2 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.5-0vl1
171- new upstream release
172- add kakasi patch (http://www.ono.org/software/bogofilter/)
173
174* Sun Jun 15 2003 IWAI Masaharu <iwai@alib.jp> 0.13.6.2-0vl1
175- upstream release
176- using --program-prefix option with configure script
177- update %%files section
178
179* Fri May 16 2003 IWAI Masaharu <iwai@alib.jp> 0.12.3-0vl1
180- first release for Vine Linux
181
Note: See TracBrowser for help on using the repository browser.