source: projects/specs/branches/6/b/blueman/blueman-vl.spec @ 3585

Revision 3585, 5.1 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with rpm-4.8.1

Line 
1Summary:        Full featured bluetooth manager for GNOME/GTK
2Summary(ja):    GNOME/GTK 用の高機能な Bluetooth マネージャ
3
4Name:           blueman
5Version:        1.21
6Release:        4%{?_dist_release}
7License:        GPLv2+
8Group:          Applications/System
9Url:            http://blueman-project.org/
10
11Source0:        %{name}-%{version}.tar.gz
12
13Buildroot:      %{_tmppath}/%{name}-%{version}
14BuildRequires:  desktop-file-utils
15BuildRequires:  perl(XML::Parser)
16BuildRequires:  glib2-devel
17BuildRequires:  gtk2-devel
18BuildRequires:  GConf2-devel
19BuildRequires:  pygtk2-devel
20BuildRequires:  intltool
21BuildRequires:  startup-notification-devel
22BuildRequires:  pygobject-devel
23BuildRequires:  notify-python
24BuildRequires:  bluez-libs-devel >= 4.37
25BuildRequires:  python-devel
26BuildRequires:  python-pyrex
27BuildRequires:  dbus-python
28Requires:       obex-data-server
29Requires:       notify-python
30Requires:       pygtk2
31Requires:       gnome-python
32Requires:       dbus-python
33Requires:       pygobject
34Requires:       PolicyKit-gnome
35Provides:       dbus-bluez-pin-helper
36
37Vendor: Project Vine
38Distribution: Vine Linux
39Packager: daisuke
40
41
42%description
43Blueman is designed to provide simple, yet effective means for
44controlling BlueZ API and simplifying bluetooth tasks such as:
45
46* Connecting to 3G/EDGE/GPRS via dial-up
47* Connecting to/Creating bluetooth networks
48* Connecting to input devices
49* Connecting to audio devices
50* Sending/Receiving/Browsing files via OBEX
51* Pairing
52
53Blueman also integrates with Network Manager 0.7, so any Dialup/Network
54 connections will be made available (via HAL) to Network Manager.
55
56%prep
57%setup -q
58
59%build
60%configure --disable-desktop-update --disable-icon-update --disable-schemas-install
61%__make %{?_smp_mflags}
62
63%install
64rm -rf %{buildroot}
65%__make install DESTDIR=${RPM_BUILD_ROOT}
66
67mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/devices
68cp $RPM_BUILD_ROOT%{_datadir}/blueman/icons/hicolor/scalable/devices/* \
69   $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/devices/
70
71desktop-file-install --vendor="" \
72  --add-category="GNOME;GTK" \
73  --add-category="Settings;HardwareSettings" \
74  --dir %{buildroot}%{_datadir}/applications %{buildroot}%{_datadir}/applications/%{name}-manager.desktop
75
76%find_lang %{name}
77
78%clean
79rm -rf %{buildroot}
80
81%post
82export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
83gconftool-2 --makefile-install-rule \
84    %{_sysconfdir}/gconf/schemas/blueman-manager.schemas >& /dev/null ||:
85update-desktop-database %{_datadir}/applications >& /dev/null || :
86touch --no-create %{_datadir}/icons/hicolor
87if [ -x /usr/bin/gtk-update-icon-cache ]; then
88  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
89fi
90 
91%pre
92if [ "$1" -gt 1 ]; then
93  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
94  gconftool-2 --makefile-uninstall-rule \
95      %{_sysconfdir}/gconf/schemas/blueman-manager.schemas >& /dev/null ||:
96fi
97
98%preun
99if [ "$1" -eq 0 ]; then
100  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
101  gconftool-2 --makefile-uninstall-rule \
102      %{_sysconfdir}/gconf/schemas/blueman-manager.schemas >& /dev/null ||:
103fi
104
105%postun
106update-desktop-database %{_datadir}/applications >& /dev/null || :
107touch --no-create %{_datadir}/icons/hicolor
108if [ -x /usr/bin/gtk-update-icon-cache ]; then
109  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
110fi
111
112
113%files -f %{name}.lang
114%defattr(-,root,root)
115%{_sysconfdir}/dbus-1/system.d/org.%{name}*.conf
116%{_sysconfdir}/xdg/autostart/%{name}.desktop
117%{_bindir}/%{name}-*
118%{_datadir}/applications/%{name}-manager.desktop
119%{_datadir}/%{name}/ui/*.ui
120%{_datadir}/%{name}/icons/hicolor/*/*s/*.png
121%{_datadir}/%{name}/icons/hicolor/scalable/status/*.svg
122%{_datadir}/%{name}/icons/hicolor/scalable/actions/*.svg
123%{_datadir}/icons/hicolor/scalable/devices/*.svg
124%{_datadir}/icons/hicolor/*/apps/*.png
125%{_datadir}/icons/hicolor/scalable/apps/*.svg
126%{_datadir}/blueman/icons/hicolor/scalable/devices/blueman-device.svg
127%{_datadir}/blueman/icons/hicolor/scalable/devices/blueman-serial.svg
128%{_datadir}/dbus-1/services/%{name}-applet.service
129%{_datadir}/dbus-1/system-services/org.%{name}*.service
130%{_datadir}/polkit-1/actions/org.blueman.policy
131%{_mandir}/man1/%{name}*1.*
132%{python_sitelib}/*
133%if %_lib == lib64
134%{python_sitearch}/*
135%endif
136%{_libexecdir}/%{name}-*
137
138
139%changelog
140* Mon Apr 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.21-4
141- rebuild with rpm-4.8.1
142
143* Sun Feb 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.21-3
144- add BuildRequires: gtk2-devel
145
146* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.21-2
147- rebuilt with python-2.6.4
148
149* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.21-1
150- new upstream release
151
152* Mon Jan 04 2010 Shu KONNO <owa@bg.wakwak.com> 1.10-2
153- added _blueman to %%files (if lib64)
154
155* Tue May 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-1
156- initial build for Vine Linux
157
158* Fri Mar 27 2009 Emmanuel Andry <eandry@mandriva.org> 1.02-4mdv2009.1
159+ Revision: 361574
160- don't explicitely requires notification-daemon
161
162* Mon Mar 02 2009 Emmanuel Andry <eandry@mandriva.org> 1.02-3mdv2009.1
163+ Revision: 347587
164- requires python-blueman
165
166* Mon Mar 02 2009 Emmanuel Andry <eandry@mandriva.org> 1.02-2mdv2009.1
167+ Revision: 347346
168- fix files
169- BR python-dbus
170- fix BR
171- BR python-devel
172- import blueman
173
174
Note: See TracBrowser for help on using the repository browser.