source: projects/specs/branches/6/b/blender/blender-vl.spec @ 2416

Revision 2416, 10.3 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1%define blenderlib %{_datadir}/blender
2%define plugins %{_libdir}/blender/plugins
3Summary:       3D modeling, animation, rendering and post-production.
4Summary(ja):   3D モデリング、アニメーション、レンダリング、ポストプロダクション
5Name:           blender
6Version:        2.49b
7Release:        1%{?_dist_release}
8Group:          Applications/Multimedia
9License:        GPL
10URL:            http://www.blender.org/
11Source0:        http://download.blender.org/source/blender-%{version}.tar.gz
12Source1:        http://bane.servebeer.com/programming/blender/import-3ds-0.92.py
13Source2:        http://bane.servebeer.com/programming/blender/export-3ds-0.72.py
14Source3:        blender.png
15Source4:        blender.desktop
16Source5:        blender.xml
17
18Patch1: blender-2.49-scons.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21BuildRequires:  desktop-file-utils
22BuildRequires:  esound-devel
23BuildRequires:  glut-devel
24BuildRequires:  gettext-devel
25BuildRequires:  libjpeg-devel
26BuildRequires:  libogg-devel
27BuildRequires:  libpng-devel
28BuildRequires:  libtiff-devel
29BuildRequires:  libtool
30BuildRequires:  libvorbis-devel
31BuildRequires:  freealut-devel
32BuildRequires:  openssl-devel
33BuildRequires:  python-devel
34BuildRequires:  scons
35BuildRequires:  SDL-devel
36BuildRequires:  zlib-devel
37BuildRequires:  libXi-devel
38BuildRequires:  xorg-x11-proto-devel
39BuildRequires:  mesa-libGL-devel
40BuildRequires:  mesa-libGLU-devel
41BuildRequires:  freetype-devel
42BuildRequires:  OpenEXR-devel
43BuildRequires:  glew-devel
44BuildRequires:  freetype2-devel
45
46Requires(post): desktop-file-utils
47Requires(post): shared-mime-info
48Requires(postun): desktop-file-utils
49Requires(postun): shared-mime-info
50
51
52%description
53Blender is an integrated suite of tools enabling the creation of a broad
54range of 3D content. It offers full functionality for modelling, rendering,
55animation, post-production, creation and playback of interactive 3D content
56with the singular benefits of cross-platform operability.
57
58Aimed at media professionals and artists, Blender can be used to create 3D
59visualizations, stills as well as broadcast quality video, while the
60incorporation of a real-time 3D engine allows for the creation of 3D
61interactive content for stand-alone playback.
62
63%description -l ja
64Blender は、幅広い 3D コンテンツの製作を可能にする統合ソフトウェアです。
65Blender は、モデリング、レンダリング、アニメーション、ポストプロダクション、
66インタラクティブな 3D コンテンツの製作と再生といった全機能を、複数の OS への
67対応という他には類のない利点と共に提供しています。
68
69Blender は、メディアの専門家や達人もターゲットにしているので、3D の視覚化や、
70良質なテレビ放送映像や静止画像の作成にも使用できます。さらに、リアルタイム
713D エンジンを統合したことにより、スタンドアロン再生用のインタラクティブな
723D コンテンツの製作も可能です。
73
74%prep
75%setup -q -n %{name}-%{version}
76#%patch1 -p1 -b .scons
77
78%build
79cat > user-config.py <<EOF
80WITH_BF_OPENAL = 'false'
81#BF_OPENAL = '%{_prefix}'
82#BF_OPENAL_INC = '%{_includedir}/AL'
83#BF_OPENAL_LIB = '%{_libdir}'
84WITH_BF_FFMPEG = 'false'
85BF_PYTHON = '%{_prefix}'
86BF_PYTHON_INC = '%{_includedir}/python%{pyver}'
87BF_PYTHON_LIB = 'python%{pyver}'
88BF_OPENEXR_INC = '%{_includedir}/OpenEXR'
89BF_GETTEXT = '%{_prefix}'
90BF_GETTEXT_INC = '%{_includedir}'
91BF_GETTEXT_LIB = 'gettextlib'
92BF_BUILDDIR = './builddir'
93BF_INSTALLDIR='./installdir'
94EOF
95
96## don't use parallel build
97#scons -i -k %{?_smp_mflags} BF_QUIET=0
98scons BF_QUIET=0
99
100install -d release/plugins/include
101install -m 644 source/blender/blenpluginapi/*.h release/plugins/include
102chmod +x release/plugins/bmake
103make -C release/plugins/
104
105
106%install
107rm -rf ${RPM_BUILD_ROOT}
108
109mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
110install -D -m 755 ./builddir/bin/blender ${RPM_BUILD_ROOT}/%{_bindir}/blender
111install -D -m 755 ./builddir/bin/blenderplayer ${RPM_BUILD_ROOT}/%{_bindir}/blenderplayer
112
113mkdir -p ${RPM_BUILD_ROOT}/%{_datadir}
114pushd bin/.blender/locale
115rm -rf $(find -name '.svn' -print)
116popd
117cp -a bin/.blender/locale ${RPM_BUILD_ROOT}/%{_datadir}
118install -p -D -m0644 %{SOURCE3} ${RPM_BUILD_ROOT}%{_datadir}/pixmaps/blender.png
119install -p -D -m0644 %{SOURCE5} ${RPM_BUILD_ROOT}%{_datadir}/mime/packages/blender.xml
120
121mkdir -p ${RPM_BUILD_ROOT}%{blenderlib}/scripts/
122install -p -D -m0644 release/scripts/*.py ${RPM_BUILD_ROOT}%{blenderlib}/scripts/
123install -m 644 release/VERSION ${RPM_BUILD_ROOT}/%{blenderlib}
124install -m 644 bin/.blender/.Blanguages ${RPM_BUILD_ROOT}/%{blenderlib}
125install -m 644 bin/.blender/.bfont.ttf ${RPM_BUILD_ROOT}/%{blenderlib}
126install -p -D -m0644 %{SOURCE1} ${RPM_BUILD_ROOT}%{blenderlib}/scripts/import-3ds-0.7.py
127install -p -D -m0644 %{SOURCE2} ${RPM_BUILD_ROOT}%{blenderlib}/scripts/export-3ds-0.71.py
128
129install -d ${RPM_BUILD_ROOT}/%{plugins}/sequence
130install -d ${RPM_BUILD_ROOT}/%{plugins}/texture
131install -m 644 release/plugins/sequence/*.so ${RPM_BUILD_ROOT}/%{plugins}/sequence
132install -m 655 release/plugins/texture/*.so ${RPM_BUILD_ROOT}/%{plugins}/texture
133
134desktop-file-install --vendor "" --dir ${RPM_BUILD_ROOT}%{_datadir}/applications %{SOURCE4}
135
136%find_lang %name
137
138
139%clean
140rm -rf ${RPM_BUILD_ROOT}
141
142
143%post
144update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
145update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
146
147
148%postun
149update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
150update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
151
152
153%files -f %name.lang
154%defattr(-,root,root,-)
155%doc COPYING README doc/python-dev-guide.txt doc/GPL-license.txt doc/bf-members.txt
156%{_bindir}/*
157%{_libdir}/blender/
158%{blenderlib}/
159%{_datadir}/applications/blender.desktop
160%{_datadir}/pixmaps/*.png
161%{_datadir}/mime/packages/blender.xml
162
163
164%changelog
165* Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.49b-1
166- new upstream release
167- add BuildRequires: freetype2-devel
168
169* Sat Nov 13 2010 Shu KONNO <owa@bg.wakwak.com> 2.49-2
170- rebuilt with gettext-0.18
171
172* Wed May 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.49-1
173- updated blender to 2.49
174- applied new versioning policy, and spec in utf-8
175- built without smp option
176- disable OpenAL, FFMPEG at user-config.py
177- added BR: libXi-devel xorg-x11-proto-devel mesa-libGL-devel mesa-libGLU-devel
178- added BR: freetype-devel OpenEXR-devel glew-devel
179
180* Mon Jan 02 2006 IKEDA Katsumi <ikeda@webmasters.gr.jp> 2.40-0vl2
181- new upstream release.
182
183* Sat Oct 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.35-0vl1
184- initial build for Vine Linux
185
186* Mon Nov 15 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 2.35-1
187- 2.35.
188
189* Thu Nov 11 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 2.34-0.fdr.3
190- Mime-type corrections for FC3.
191- Dropped redundent BR XFree86-devel.
192
193* Thu Aug 05 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.34-0.fdr.2
194- blender.applications file.
195- blender.xml file.
196- post/postun update-mime-database.
197
198* Thu Aug 05 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.34-0.fdr.1
199- Updated to 2.34.
200
201* Thu Aug 05 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.33-0.fdr.2.a
202- Include 3ds import/export scripts.
203- Added mime info.
204- Added mime icon (from yattacier theme).
205
206* Wed Aug 04 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.33-0.fdr.1.a
207- 2.33a.
208- Now building with scons.
209
210* Tue Feb 10 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.32-0.fdr.2
211- Now including scripts.
212
213* Thu Feb 05 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.32-0.fdr.1
214- Updated to 2.32.
215
216* Sun Jan 11 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.31-0.fdr.3.a
217- --enable-openal.
218- --disable-rpath.
219- remove --enable-international.
220- modify .desktop to execute with -w.
221
222* Thu Dec 04 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.31-0.fdr.2.a
223- Updated to 2.31a.
224
225* Sun Nov 30 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.31-0.fdr.1
226- Updated to 2.31.
227- enable-international.
228
229* Tue Nov 18 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.30-0.fdr.1
230- Updated to 2.30.
231
232* Fri Oct 10 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28-0.fdr.5.c
233- Updated to 2.28c.
234
235* Tue Oct 07 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28-0.fdr.4.a
236- Removed BuildReq smpeg-devel
237
238* Mon Sep 15 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28-0.fdr.3.a
239- Moved 'a' out of version according to naming guidelines.
240
241* Fri Sep 12 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28a-0.fdr.2
242- changed file permission on tarball.
243- dropped redundant messages about aclocal, etc.
244- configure --disable-shared.
245- automake --foreign.
246- added doc/python-dev-guide.txt doc/GPL-license.txt doc/bf-members.txt to %%doc.
247
248* Wed Sep 10 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28a-0.fdr.1
249- Updated to 2.28a.
250
251* Wed Aug 13 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28-0.fdr.2
252- New Icon.
253
254* Thu Jul 24 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28-0.fdr.1
255- Updated to 2.28.
256- BuildReq libvorbis-devel.
257- BuildReq smpeg-devel.
258- BuildReq esound-devel.
259- BuildReq libogg-devel.
260- BuildReq vorbis-tools.
261- BuildReq openal-devel
262- BuildReq libtool
263
264* Mon May 26 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.27-0.fdr.2
265- Removed post/postun ldconfig.
266- Added autoconf workaround.
267
268* Mon May 19 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.27-0.fdr.1
269- Updated to 2.27.
270- Removed devel package.
271
272* Wed Apr 09 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.26-0.fdr.9
273- Corrected devel Group.
274
275* Tue Apr 01 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.26-0.fdr.8
276- Added desktop-file-utils to BuildRequires.
277- Changed category to X-Fedora-Extra.
278
279* Mon Mar 31 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.26-0.fdr.7
280- Added Missing BuildRequires.
281
282* Sun Mar 30 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.26-0.fdr.6
283- Cleaned up BuildRequires.
284- Added Epoch:0.
285
286* Sat Mar 22 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 2.26-0.fdr.5
287- Spec file cleanup.
288
289* Sat Mar 08 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 2.26-1.fdr.4
290- Spec file cleanup.
291
292* Wed Feb 26 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 2.26-1.fedora.3
293- Spec file cleanup.
294
295* Thu Feb 20 2003 Warren Togami
296- Add BuildRequires python-devel
297
298* Wed Feb 19 2003 Phillip Compton
299- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.