source: projects/specs/branches/6/b/bitmap-mule/bitmap-mule-vl.spec @ 521

Revision 521, 2.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define       emacsver 20.4
2%define       version 8.0
3%define       release 2%{?_dist_release}
4Name:         bitmap-mule
5Version:      %{version}
6Release:      %{release}
7License:      GPL2
8Group:        Applications/Editors/Emacs
9Source0:      ftp://ftp.jpl.org/pub/elisp/bitmap/bitmap-mule-%{version}.tar.gz
10BuildRoot:    %{_tmppath}/%{name}-%{version}-root
11BuildArch:    noarch
12Requires:     xorg-x11-libs, faces, faces-xface
13Summary:      Display Bitmaps like X-Face on FSF Emacs
14Summary(ja):  Emacs 上で X-Face などの bitmap を表示するツール
15
16Vendor: Project Vine
17Distribution: Vine Linux
18
19%description
20bitmap-mule is a package to use bitmap in MULE or Emacs/mule.
21After installation, please don't forget to add the following lines
22to your .emacs file:
23
24(if window-system
25    (progn
26      (require 'bitmap)
27      (mapcar (lambda (fontset)
28                (set-fontset-font
29                  fontset 'bitmap
30                  "-etl-fixed-medium-r-*--16-*-100-100-m-*-bitmap.8x16-0"))
31              (fontset-list))))
32
33(setq wl-highlight-x-face-function
34   'x-face-mule-x-face-decode-message-header)
35
36
37%description -l ja
38
39bitmap-mule は MULE や Emacs/mule 上で bitmap を扱うパッケージです.
40インストール後に以下の記述を .emacs に追加して下さい.
41
42(if window-system
43    (progn
44      (require 'bitmap)
45      (mapcar (lambda (fontset)
46                (set-fontset-font
47                  fontset 'bitmap
48                  "-etl-fixed-medium-r-*--16-*-100-100-m-*-bitmap.8x16-0"))
49              (fontset-list))))
50
51(setq wl-highlight-x-face-function
52   'x-face-mule-x-face-decode-message-header)
53
54
55%prep
56[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
57
58
59%setup
60
61
62%build
63make EMACS=emacs
64
65
66%install
67make EMACS=emacs \
68     PREFIX=${RPM_BUILD_ROOT}/usr \
69     install
70
71bdftopcf -o etl8x16-bitmap.pcf etl8x16-bitmap.bdf
72mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/X11/fonts/misc
73install -m 644 etl8x16-bitmap.pcf \
74    ${RPM_BUILD_ROOT}%{_datadir}/X11/fonts/misc/.
75
76
77%clean
78[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf $RPM_BUILD_ROOT
79
80
81%post
82(cd %{_datadir}/X11/fonts/misc; %{_bindir}/mkfontdir)
83
84
85%postun
86(cd %{_datadir}/X11/fonts/misc; %{_bindir}/mkfontdir)
87
88
89%triggerin -- XFree86
90(cd %{_datadir}/X11/fonts/misc; %{_bindir}/mkfontdir)
91
92
93%files
94%defattr(-,root,root)
95%doc ChangeLog NEWS README.en
96%{_datadir}/X11/fonts/misc/etl8x16-bitmap.pcf
97%{_datadir}/emacs/site-lisp/bitmap
98
99%changelog
100* Fri Sep 19 2008 Shu KONNO <owa@bg.wakwak.com> 8.0-2vl5
101- applied new versioning policy, spec in utf-8
102
103* Wed Sep 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.0-1vl2
104- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
105- s/Copyright/License/
106
107* Thu Mar 28 2002 Jun Nishii <jun@vinelinux.org> 8.0-1vl1
108- fix description
109
110* Tue Dec  7 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
111 - 8.0-1
112 - first rpm package
Note: See TracBrowser for help on using the repository browser.