source: projects/specs/branches/6/b/bind-current/bind-current-vl.spec @ 4001

Revision 4001, 20.5 KB checked in by iwaim, 13 years ago (diff)

bind-current-9.8.0p2-2

Line 
1%define _localstatedir /var
2
3%define sname bind
4%define pname bind-current
5%define pversion 9.8.0p2
6%define sversion 9.8.0-P2
7%define bind_epoch 1
8# fixed <BTS:VineLinux:1139>
9%define old_bind_version 1:9.6.ESV.R1
10
11%define bind_uid  25
12%define bind_gid  25
13
14Summary: A DNS (Domain Name System) server.
15Summary(ja): DNS (Domain Name System) サーバ
16Name: %{pname}
17Version: %{pversion}
18Release: 2%{?_dist_release}
19Epoch: %{bind_epoch}
20License: distributable
21Group: System Environment/Daemons
22Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{sname}-%{sversion}.tar.gz
23Source1: bind-manpages.tar.bz2
24Source2: named.sysconfig
25Source3: named.init
26Source4: named.logrotate
27Source5: keygen.c
28URL: http://www.isc.org/bind.html
29Patch1: bind-9.3.3rc2-rndckey.patch
30
31Buildroot: %{_tmppath}/%{name}-%{version}-root
32BuildRequires: openssl-devel glibc-devel libtool
33BuildRequires: libxml2-devel
34BuildRequires: libcap-devel
35Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
36Requires(pre): shadow-utils
37Requires(post): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
38Requires(post): coreutils, chkconfig
39Requires(preun): initscripts, chkconfig
40Requires(triggerpostun): chkconfig
41Conflicts: bind9 <= 9.2.1-0vl5, bind < %{bind_epoch}:%{version}-%{release}
42Obsoletes: bind9 <= 9.2.1-0vl5, bind < %{old_bind_version}
43
44Vendor: Project Vine
45Distribution: Vine Linux
46Packager: daisuke
47
48%description
49BIND (Berkeley Internet Name Domain) is an implementation of the DNS
50(Domain Name System) protocols. BIND includes a DNS server (named),
51which resolves host names to IP addresses, and a resolver library
52(routines for applications to use when interfacing with DNS).  A DNS
53server allows clients to name resources or objects and share the
54information with other network machines.  The named DNS server can be
55used on workstations as a caching name server, but is generally only
56needed on one machine for an entire network.  Note that the
57configuration files for making BIND act as a simple caching nameserver
58are included in the caching-nameserver package. 
59
60Install the bind package if you need a DNS server for your network.  If
61you want bind to act a caching name server, you will also need to install
62the caching-nameserver package.
63
64
65%package libs
66Summary: Libraries used by various DNS packages
67Group: System Environment/Libraries
68Conflicts: bind9-libs <= 9.2.1-0vl5
69Conflicts: bind-libs < %{bind_epoch}:%{version}-%{release}
70Obsoletes: bind9-libs <= 9.2.1-0vl5
71Obsoletes: bind-libs < %{old_bind_version}
72
73%description libs
74Contains libraries used by both the bind server package as well as the utils packages.
75
76
77%package utils
78Summary: Utilities for querying DNS name servers.
79Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
80Group: Applications/System
81Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
82Conflicts: bind9-utils <= 9.2.1-0vl5
83Conflicts: bind-utils < %{bind_epoch}:%{version}-%{release}
84Obsoletes: bind9-utils <= 9.2.1-0vl5
85Obsoletes: bind-utils < %{old_bind_version}
86
87%description utils
88Bind-utils contains a collection of utilities for querying DNS (Domain
89Name Service) name servers to find out information about Internet hosts.
90These tools will provide you with the IP addresses for given host names,
91as well as other information about registered domains and network
92addresses.
93
94You should install bind-utils if you need to get information from DNS name
95servers.
96
97
98%package devel
99Summary: Include files and libraries needed for bind DNS development.
100Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
101Group: Development/Libraries
102Requires: %{pname} = %{bind_epoch}:%{version}-%{release}
103Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
104Conflicts: bind9-devel <= 9.2.1-0vl5
105Conflicts: bind-devel < %{bind_epoch}:%{version}-%{release}
106Obsoletes: bind9-devel <= 9.2.1-0vl5
107Obsoletes: bind-devel < %{old_bind_version}
108
109%description devel
110The bind-devel package contains all the include files and the
111library required for DNS (Domain Name Service) development for
112BIND versions 9.x.x.
113
114You should install bind-devel if you want to develop bind DNS
115applications. If you install bind-devel, you'll also need to install
116bind.
117#'
118
119%prep
120%setup -n bind-%{sversion} -q
121%patch1 -p1 -b .key
122
123%build
124libtoolize --copy --force
125aclocal
126autoconf
127%configure --with-libtool --with-openssl=/usr --enable-threads
128make %{?_smp_mflags}
129
130%install
131rm -rf $RPM_BUILD_ROOT
132mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
133mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
134mkdir -p ${RPM_BUILD_ROOT}/var/named
135mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
136mkdir -p ${RPM_BUILD_ROOT}/var/run/named
137
138make DESTDIR=$RPM_BUILD_ROOT install
139install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
140install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
141install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
142install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
143touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
144gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
145cd $RPM_BUILD_ROOT%{_mandir}
146tar xjf %{SOURCE1}
147# newer version is contained in source
148rm -f man5/named.conf.5.gz
149mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
150cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
151
152
153%pre
154if [ "$1" -eq 1 ]; then
155  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
156  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
157fi;
158:;
159
160%post
161/sbin/ldconfig
162/sbin/chkconfig --add named
163if [ "$1" -eq 1 ]; then
164  if [ ! -e /etc/rndc.key ]; then
165    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
166  fi
167  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
168  # rndc.key has to have correct perms and ownership, CVE-2007-6283
169  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
170  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
171
172  # Check DNSSEC settings if this is a fresh install
173  if [ -r /etc/sysconfig/dnssec ]; then
174    . /etc/sysconfig/dnssec
175    [ -x /usr/sbin/dnssec-configure ] && \
176      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
177        /dev/null 2>&1
178  fi;
179fi
180:;
181
182%preun
183if [ "$1" -eq 0 ]; then
184   /sbin/service named stop >/dev/null 2>&1 || :
185   /sbin/chkconfig --del named ||:
186fi
187exit 0
188
189
190%postun
191if [ "$1" -ge 1 ]; then
192        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
193fi
194/sbin/ldconfig
195
196%triggerpostun -- bind < 8.2.2_P5-15
197/sbin/chkconfig --add named
198/sbin/ldconfig
199
200%clean
201rm -rf ${RPM_BUILD_ROOT} ${RPM_BUILD_DIR}/%{name}-%{version}
202
203
204%post libs -p /sbin/ldconfig
205
206%postun libs -p /sbin/ldconfig
207
208
209%files
210%defattr(-,root,root)
211%doc CHANGES README
212%doc doc/arm doc/draft doc/rfc doc/misc
213%config(noreplace) %{_sysconfdir}/logrotate.d/named
214%config %{_sysconfdir}/rc.d/init.d/named
215%config(noreplace) %{_sysconfdir}/sysconfig/named
216%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
217%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
218%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
219
220%{_sbindir}/dnssec*
221%{_sbindir}/lwresd
222%{_sbindir}/named
223%{_sbindir}/named-bootconf
224%{_sbindir}/named-check*
225%{_sbindir}/named-compilezone
226%{_sbindir}/rndc*
227%{_sbindir}/dns-keygen
228%{_sbindir}/arpaname
229%{_sbindir}/ddns-confgen
230%{_sbindir}/genrandom
231%{_sbindir}/isc-hmac-fixup
232%{_sbindir}/named-journalprint
233%{_sbindir}/nsec3hash
234
235%{_mandir}/man1/arpaname.1*
236%{_mandir}/man5/resolv.conf.5*
237%{_mandir}/man5/named.conf.5*
238%{_mandir}/man5/rndc.conf.5*
239%{_mandir}/man8/rndc.8*
240%{_mandir}/man8/named.8*
241%{_mandir}/man8/lwresd.8*
242%{_mandir}/man8/dnssec*.8*
243%{_mandir}/man8/named-checkconf.8*
244%{_mandir}/man8/named-checkzone.8*
245%{_mandir}/man8/named-compilezone.8*
246%{_mandir}/man8/rndc-confgen.8*
247%{_mandir}/man8/ddns-confgen.8*
248%{_mandir}/man8/genrandom.8*
249%{_mandir}/man8/isc-hmac-fixup.8*
250%{_mandir}/man8/named-journalprint.8*
251%{_mandir}/man8/nsec3hash.8*
252
253%attr(-,named,named) %dir %{_var}/named
254%attr(-,named,named) %dir %{_var}/run/named
255     
256
257%files libs
258%defattr(-,root,root)
259%{_libdir}/*.so.*
260
261%files utils
262%defattr(-,root,root)
263%{_bindir}/dig
264%{_bindir}/host
265%{_bindir}/nslookup
266%{_bindir}/nsupdate
267%{_mandir}/man1/host.1*
268%{_mandir}/man1/nsupdate.1*
269%{_mandir}/man1/dig.1*
270%{_mandir}/man5/resolver.5*
271%{_mandir}/man1/nslookup.1*
272%{_mandir}/man8/nslookup.8*
273
274
275%files devel
276%defattr(-,root,root)
277%{_libdir}/*.so
278%{_libdir}/*.la
279%{_libdir}/*.a
280%{_includedir}/*
281%{_mandir}/man3/*
282%{_mandir}/man1/isc-config.sh.1*
283%{_bindir}/isc-config.sh
284
285%changelog
286* Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.8.0p2-2
287- Obosoletes: bind.* < 1:9.6.ESV.R1
288 - fixed <BTS:VineLinux:1139>
289
290* Sun May 29 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p2-1
291- new upstream release with security fix (CVE-2011-1910)
292
293* Tue May 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.8.0p1-2
294- add BuildRequires: libxml2-devel, libcap-devel
295
296* Mon May  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p1-1
297- new upstream release with security fix (CVE-2011-1907)
298- fix changelog typo
299
300* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-2
301- Obosoletes: bind.* < 1:9.6.ESV.R1
302
303* Thu Apr 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-1
304- update to 9.8.0
305- remove Provides: bind.* = %%{bind_epoch}:%{version}-%{release}
306
307* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.7.2P2-3
308- rebuild with openssl-1.0.0c
309
310* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-2
311- fix Req: in bind package
312
313* Wed Oct 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-1
314- change package name bind -> bind-current
315- add epoch 1
316- new upstream release
317
318* Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9.7.1P2-1
319- new upstream release
320
321* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
322- rebuilt with gcc-4.4.3-3 on ppc
323
324* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
325- rebuilt with new toolchains (for VineSeed)
326- s/BuildPrereq/BuildRequires/
327
328* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
329- add man1/isc-config.sh.1 into devel file list
330
331* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
332- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
333
334* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
335- new upstream release with security fix (CVE-2009-4022)
336
337* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
338- new upstream release with security fix
339
340* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
341- new upstream release
342- clean up %%post/%%pre scriptlet
343  - create named user and group in %%pre
344  - don't remove named user/group in %%preun
345  - use rndc-confgen to create rndc.key
346
347* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
348- new upstream release
349- drop patch0 and patch14, merged in upstream
350
351* Sat Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
352- new upstream release with security fix
353
354* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
355- new upstream release with security fix
356- new versioning policy
357
358* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
359- new upstream release with security fix
360
361* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
362- new upstream release
363- build with new openssl/toolchain
364
365* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
366- new upstream release with security fix
367
368* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
369- new upstream release
370
371* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
372- add Prereq sed
373
374* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
375- new upstream release for security fix (CVE-2006-4095,4096)
376
377* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
378- separate -libs package
379- remove old named.conf.5.gz
380  - newer version is contained in source
381
382* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
383- add bsdcompat patch (Patch4)
384- add fix_h_errno patch from FC
385  - h_errno not being accessed / set correctly in libbind
386
387* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
388- new upstream release
389
390* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
391- added PreReq to bind-utils (see: [VineSeed:09555])
392
393* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
394- new upstream release
395
396* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
397- fix /etc/init.d/named to use rndc
398
399* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
400- rebuild to remove unneeded dependancy
401
402* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
403- new upstream release
404
405* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
406- new upstream release
407
408* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
409- fix dependancies.
410
411* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
412- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
413- change package name to bind for VineSeed.
414- use more macros.
415
416* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
417- fixed some macros
418- add conflicts: to bind-* in bind9-devel and bind9-utils
419- add provides: bind = %%{version}
420
421* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
422- use %%configure macros
423
424* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
425- fixed inconsistent dependency
426
427* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
428- updated to 9.2.2rc1
429
430* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
431- updated to bind9(9.2.1), test packages ;)
432        -- based on Rawhide's bind-9.2.0-8
433        -- changed name bind9
434        -- added Conflicts: bind
435
436* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
437- release 8.3.1 includes security fixes
438
439* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
440- Upgraded to current stable release 8.3.0
441
442* Mon Oct  8 2001 <zn@mbf.nifty.com>
443- 8.2.5-0vl0: Upgraded to new upstream version.
444
445* Thu May 24 2001 <sagami@vinelinux.org>
446- 8.2.4-0vl1: eliminate CVS related files from %%doc
447
448* Thu May 17 2001 <sagami@vinelinux.org>
449- 8.2.4-0vl0
450
451* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
452- 8.2.3-1vl2
453- built on VineSeed
454
455* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
456- add doc/old
457- build for Vine 2.1
458
459* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
460- 8.2.3, fixes several security problems
461
462* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
463- static libraries may be used in shared objects. Build with -fPIC on ia64
464
465* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
466- 8.2.2-P7 (fixes Bug #20546)
467
468* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
469- condrestart fixes
470
471* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
472- change the init script to take condrestart, not cond-restart
473- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
474  the %pre and %post scripts
475
476* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
477- Don't prereq /etc/init.d
478
479* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
480- move initscript back
481
482* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
483- automatic rebuild
484
485* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
486- add "exit 0" for uninstall case
487
488* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
489- add prereq init.d and cleanup install section
490
491* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
492- fix the init script
493
494* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
495- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
496
497* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
498- Fix up the initscript (Bug #13033)
499- Fix build with current glibc (Bug #12755)
500- /etc/rc.d/init.d -> /etc/init.d
501- use %%{_mandir} rather than /usr/share/man
502
503* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
504- fix conflict with man-pages
505- remove compatibilty chkconfig links
506- initscript munging
507
508* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
509- modify logrotate setup to use PID file
510- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
511- actually bump the release this time
512
513* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
514- FHS compliance
515
516* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
517- clean up restart patch
518
519* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
520- provide /var/named (fix for bugs #9847, #10205)
521- preserve args when restarted via ndc(8) (bug #10227)
522- make resolv.conf(5) a link to resolver(5) (bug #10245)
523- fix SYSTYPE bug in all makefiles
524- move creation of named user from %%post into %%pre
525
526* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
527- Fix TTL (patch from ISC, Bug #9820)
528
529* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
530- fix typo in spec (it's %post, without a leading blank) introduced in -6
531- change SYSTYPE to linux
532
533* Sat Feb 11 2000 Bill Nottingham <notting@redhat.com>
534- pick a standard < 100 uid/gid for named
535
536* Thu Feb 04 2000 Elliot Lee <sopwith@redhat.com>
537- Pass named a '-u named' parameter by default, and add/remove user.
538
539* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
540- fix host mx bug (Bug #9021)
541
542* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
543- rebuild to fix dependencies
544- man pages are compressed
545
546* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
547- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
548
549* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
550- Fix up location of named-bootconf.pl and make it executable
551  (Bug #8028)
552- bind-devel requires bind
553
554* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
555- update to 8.2.2-P5
556
557* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
558- update to 8.2.2-P3
559
560* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
561- add patch to stop a cache only server from complaining about lame servers
562  on every request.
563
564* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
565- use real stop and start in named.init for restart, not ndc restart, it has
566  problems when named has changed during a package update... (# 4890)
567
568* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
569- chkconfig --del in %preun, not %postun
570
571* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
572- initscript munging
573
574* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
575- fix installed chkconfig links to match init file
576
577* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
578- conflict with new (in man-1.24) man pages (#3876,#3877).
579
580* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
581- fix named.logrotate (wrong %SOURCE)
582
583* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
584- update to 8.2.1.
585- add named.logrotate (#3571).
586- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
587- vet file list.
588
589* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
590- don't run by default
591
592* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
593- nslookup fixes (#2463).
594- missing files (#3152).
595
596* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
597- nslookup patched:
598  to count numRecords properly
599  to fix subsequent calls to ls -d
600  to parse "view" and "finger" commands properly
601  the view hack updated for bind-8 (using sed)
602
603* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
604- add ISC patch
605- add quick hack to make host not crash
606- add more docs
607
608* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
609- add probing information in the init file to keep linuxconf happy
610- dont strip libbind
611
612* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
613- auto rebuild in the new build environment (release 3)
614
615* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
616- removed 'done' output at named shutdown.
617
618* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
619- version 8.2
620
621* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
622- patch to use the __FDS_BITS macro
623- build for glibc 2.1
624
625* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
626- change named.restart to /usr/sbin/ndc restart
627
628* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
629- install man pages correctly.
630- change K10named to K45named.
631
632* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
633- don't start if /etc/named.conf doesn't exist.
634
635* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
636- autmagically create /etc/named.conf from /etc/named.boot in %post
637- remove echo in %post
638
639* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
640- merge in 5.1 mods
641
642* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
643- Several essential modifications to build and install correctly.
644- Modified 'ndc' to avoid deprecated use of '-'
645
646* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
647- Used buildroot
648- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
649  on Redhat 5.0 instead of <nlist.h>
650
Note: See TracBrowser for help on using the repository browser.