source: projects/specs/branches/6/b/baobab/baobab-vl.spec @ 521

Revision 521, 3.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name    baobab
2%define version 2.4.2
3%define release 1%{?_dist_release}
4
5Summary:        A graphical disk usage analyzer
6Summary(ja):    グラフィカルなハードディスク使用量の分析ツール
7Name:           %{name}
8Version:        %{version}
9Release:        %{release}
10Source0:        %{name}-%{version}.tar.gz
11Patch1:         baobab-2.4.2-fix-encoding.patch
12Patch2:         baobab-2.4.2-ja.po.patch
13License:        GPL
14Group:          User Interface/Desktops
15URL:            http://www.marzocca.net/linux/baobab.html
16
17Requires:       gtk2 >= 2.6.0
18Requires:       libgtop2 >= 2.10.0, libgnomeui >= 2.0.0
19Requires:       libgnomecanvas >= 2.10.2, gnome-vfs2 >= 2.6.0
20Requires:       libglade2 >= 2.5.1, GConf2
21BuildRequires:  gtk2-devel >= 2.6.0
22BuildRequires:  libgtop2-devel >= 2.10.0, libgnomeui-devel >= 2.0.0
23BuildRequires:  libgnomecanvas-devel >= 2.10.2, gnome-vfs2-devel >= 2.6.0
24BuildRequires:  libglade2-devel >= 2.5.1, GConf2-devel
25BuildRoot:      %{_tmppath}/%{name}-%{version}-root
26
27
28%description
29A graphical tool to analyse disk usage in local and remote filesystems.
30
31Baobab is able to scan either specific directories (local or remote) or
32the whole filesystem, in order to give the user a graphical tree repre-
33sentation including each directory size or percentage in the branch.
34It also includes a complete file-search functionality and auto-detects
35in real-time any changes made to your home directory as far as any
36mounted/unmounted device.
37
38%description -l ja
39ローカル及びリモートファイルシステムの、ハードディスク使用量をグラフィ
40カルに分析するツールです。
41
42Baobab は、各ディレクトリのサイズと使用量をグラフィカルに表示する為に、
43指定したディレクトリ(ローカルまたはリモート)やファイルシステム全体を
44スキャンできます。また完全なファイル検索機能や、ホームディレクトリへの
45変更をリアルタイムに自動で検出する機能も含んでいます。
46
47
48%prep
49
50%setup -q
51%patch1 -p1 -b .fix-encoding
52%patch2 -p1 -b .updated
53
54%build
55%configure
56%__make
57
58
59%install
60%__rm -rf ${RPM_BUILD_ROOT}
61export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
62%makeinstall
63unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
64
65%find_lang %{name}
66
67# remove unnecessary files
68%__rm -rf ${RPM_BUILD_ROOT}/%{_datadir}/icons/hicolor/icon-theme.cache
69
70
71%clean
72%__rm -rf ${RPM_BUILD_ROOT}
73
74
75%post
76export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
77gconftool-2 --makefile-install-rule \
78    %{_sysconfdir}/gconf/schemas/baobab.schemas > /dev/null
79
80
81%preun
82export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
83gconftool-2 --makefile-uninstall-rule \
84    %{_sysconfdir}/gconf/schemas/baobab.schemas >/dev/null;
85
86
87%files -f %{name}.lang
88%defattr(-,root,root)
89%doc AUTHORS COPYING ChangeLog NEWS README TODO
90%{_bindir}/baobab
91%{_datadir}/applications/baobab.desktop
92%{_datadir}/baobab
93%{_datadir}/icons/hicolor/48x48/apps/baobab.png
94%{_sysconfdir}/gconf/schemas/baobab.schemas
95%{_mandir}/man1/baobab.1*
96
97%changelog
98* Sat Sep 06 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.2-1vl5
99- applied new versioning policy, spec in utf-8
100
101* Fri Jan 26 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.2-0vl2
102- add patch1; workaround to fix non utf-8 character encoding.
103- add patch2 to update ja.po.
104- coorrectly handle gconf scheme at post & preun.
105
106* Sun Sep 24 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.2-0vl1
107- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.