source: projects/specs/branches/6/a/automake/automake-vl.spec @ 6740

Revision 6740, 7.2 KB checked in by iwamoto, 12 years ago (diff)

automake: fix CVE-2012-3386

Line 
1%define api_version 1.11
2
3Summary: A GNU tool for automatically creating Makefiles.
4Summary(ja): Makefile を自動生成するための GNU ツール
5Name: automake
6Version: %{api_version}.1
7Release: 3%{?_dist_release}
8License: GPL
9Group: Development/Tools
10Source: ftp://ftp.gnu.org/gnu/automake/automake-%{version}.tar.bz2
11Patch100: automake-1.11.1_CVE-2012-3386.patch
12
13URL: http://sources.redhat.com/automake
14Requires: perl, autoconf >= 2.58
15Buildrequires: autoconf >= 2.58
16Prereq: install-info
17BuildArchitectures: noarch
18Buildroot: %{_tmppath}/%{name}-%{version}-root
19
20Vendor: Project Vine
21Distribution: Vine Linux
22Packager: daisuke
23
24# run "make check" by default
25%{?_without_check: %define _without_check 1}
26%{!?_without_check: %define _without_check 0}
27
28%description
29Automake is an experimental Makefile generator. Automake was inspired
30by the 4.4BSD make and include files, but aims to be portable and to
31conform to the GNU standards for Makefile variables and targets.
32
33You should install Automake if you are developing software and would
34like to use its ability to automatically generate GNU standard
35Makefiles. If you install Automake, you will also need to install
36GNU's Autoconf package.
37
38
39%prep
40%setup -q -n automake-%{version}
41
42%patch100 -p1 -b .CVE-2012-3386
43
44%build
45./configure --prefix=%{_prefix}
46%{__make} %{?_smp_mflags}
47%if ! %{_without_check}
48  %{__make} check
49%endif
50
51
52%install
53rm -rf ${RPM_BUILD_ROOT}
54%makeinstall
55
56# create this dir empty so we can own it
57mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/aclocal
58rm -f $RPM_BUILD_ROOT%{_infodir}/dir
59
60
61%clean
62rm -rf ${RPM_BUILD_ROOT}
63
64
65%post
66/sbin/install-info %{_infodir}/automake.info.gz %{_infodir}/dir
67
68
69%preun
70if [ $1 = 0 ]; then
71    /sbin/install-info --delete %{_infodir}/automake.info.gz %{_infodir}/dir
72fi
73
74
75%files
76%defattr(-,root,root)
77%doc AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO
78%{_bindir}/*
79%{_infodir}/*.info*
80%{_datadir}/automake-%{api_version}
81%{_datadir}/aclocal-%{api_version}
82%dir %{_datadir}/aclocal
83
84
85%changelog
86* Sat Aug 11 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.11.1-3
87- add patch100 for fix CVE-2012-3386 (world-writable tmp dir)
88
89* Tue Apr 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.1-2
90- rebuild for Vine 6
91
92* Sat Jan 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.1-1
93- new upstream release
94
95* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 1.10.1-2
96- spec in utf-8
97
98* Wed Apr 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.1-1
99- new upstream release
100
101* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.6-0vl1
102- new upstream release
103
104* Thu Jun  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.5-0vl1
105- new upstream release
106
107* Wed May  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.4-0vl1
108- new upstream release
109
110* Thu Apr 1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.3-0vl1
111- new upstream release
112
113* Wed Feb 25 2004 Tomoya TAKA <taka@vinelinux.org> 1.8.2-0vl3
114- rebuild
115
116* Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.8.2-1vl2
117- rebuild
118
119* Thu Feb 05 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.2-0vl1
120- new upstream release
121
122* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.8-1vl1
123- based on 1.8-1 from Rawhide and built for Vine Linux
124
125* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.9-0vl1
126- new upstream release
127
128* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-0vl1
129- new upstream release
130
131* Mon Jun 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.7.5-1vl1
132- based on 1.7.5-1 from Rawhide and built for Vine Linux
133
134* Wed Apr 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.7.3-1vl1
135- based on 1.7.3-1 from Rawhide and built for Vine Linux
136
137* Sun Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-1vl2
138- based on 1.6.3-1 from Rawhide and built for Vine Linux
139
140* Mon Jul 29 2002 Jens Petersen <petersen@redhat.com> 1.6.3-1
141- bug fix release 1.6.3
142
143* Thu Jul 11 2002 Jens Petersen <petersen@redhat.com> 1.6.2-2
144- add buildrequires autoconf 2.52 or greater (reported by Edward Avis)
145
146* Wed Jun 19 2002 Jens Petersen <petersen@redhat.com> 1.6.2-1
147- 1.6.2 (bug fix release)
148- do "make check" after building
149
150* Thu May 23 2002 Tim Powers <timp@redhat.com> 1.6.1-2
151- automated rebuild
152
153* Tue Apr 23 2002 Jens Petersen <petersen@redhat.com> 1.6.1-1
154- 1.6.1
155
156* Tue Mar 12 2002 Jens Petersen <petersen@redhat.com> 1.6-1
157- new package based on automake15
158- 1.6
159
160* Wed Jan 23 2002 Jens Petersen <petersen@redhat.com> 1.5-8
161- better aclocal versioning
162
163* Wed Jan 23 2002 Jens Petersen <petersen@redhat.com> 1.5-7
164- don't version datadir/automake
165
166* Tue Jan 15 2002 Jens Petersen <petersen@redhat.com> 1.5-6
167- version suffix programs and data directories
168- own symlinks to programs and /usr/share/aclocal
169
170* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.5-5
171- automated rebuild
172
173* Wed Jan  9 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.5-4
174- Completely back out the fix for #56624 for now, it causes more problems
175  than it fixes in either form.
176
177* Wed Jan  9 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.5-3
178- Don't use AS_DIRNAME, it doesn't work.
179
180* Tue Jan  7 2002 Jens Petersen <petersen@redhat.com> 1.5-2
181- Patch depout.m4 to handle makefiles passed to make with "-f" (#56624)
182
183* Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.5-1
184- Update to 1.5 - much better to coexist with autoconf 2.52...
185- Fix specfile
186- No patches
187
188* Fri Aug 24 2001 Jens Petersen <petersen@redhat.com> - 1.4p5-2
189- dont raise error when there is source in a subdirectory (bug #35156).
190  This was preventing automake from working in binutuls/gas
191  [patch from HJ Lu <hjl@gnu.org>]
192- format long lines of output properly with backslash + newlines as in 1.4
193  (bug #35259) [patch from HJ Lu <hjl@gnu.org>]
194
195* Sat Jul 21 2001 Florian La Roche <Florian.LaRoche@redhat.de>
196- 1.4-p5, fixes #48788
197
198* Tue Jun 12 2001 Florian La Roche <Florian.LaRoche@redhat.de>
199- add the patch from #20559
200- really update to 1.4-p4
201
202* Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
203- update to 1.4-p4
204
205* Sat May 12 2001 Owen Taylor <otaylor@redhat.com>
206- Version 1.4-p1 to work with libtool-1.4
207
208* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
209- automatic rebuild
210
211* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
212- FHS packaging.
213
214* Fri Feb 04 2000 Nalin Dahyabhai <nalin@redhat.com>
215- fix bug #8870
216
217* Sat Aug 21 1999 Jeff Johnson <jbj@redhat.com>
218- revert to pristine automake-1.4.
219
220* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
221- arm netwinder patch
222
223* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
224- Injected new description and group.
225
226* Mon Feb  8 1999 Jeff Johnson <jbj@redhat.com>
227- add patches from CVS for 6.0beta1
228
229* Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
230- update to 1.4.
231
232* Mon Nov 23 1998 Jeff Johnson <jbj@redhat.com>
233- update to 1.3b.
234- add URL.
235
236* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
237- translations modified for de, fr, tr
238
239* Tue Apr 07 1998 Erik Troan <ewt@redhat.com>
240- updated to 1.3
241
242* Tue Oct 28 1997 Cristian Gafton <gafton@redhat.com>
243- added BuildRoot; added aclocal files
244
245* Fri Oct 24 1997 Erik Troan <ewt@redhat.com>
246- made it a noarch package
247
248* Thu Oct 16 1997 Michael Fulbright <msf@redhat.com>
249- Fixed some tag lines to conform to 5.0 guidelines.
250
251* Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
252- updated to 1.2
253
254* Wed Mar 5 1997 msf@redhat.com <Michael Fulbright>
255- first version (1.0)
Note: See TracBrowser for help on using the repository browser.