source: projects/specs/branches/6/a/autofs/autofs-vl.spec @ 3533

Revision 3533, 17.9 KB checked in by kenta, 13 years ago (diff)

autofs: rebuild for Vine6

Line 
1Summary: A tool for automatically mounting and unmounting filesystems.
2Summary(ja): 自動的にファイルシステムをマウント/アンマウントするツール
3Name: autofs
4Version: 5.0.5
5Release: 2%{?_dist_release}
6Epoch: 1
7License: GPL
8Group: System Environment/Daemons
9Vendor: Project Vine
10Distribution: Vine Linux
11Packager: daisuke, kenta
12
13Source: ftp://ftp.kernel.org/pub/linux/daemons/autofs/autofs-%{version}.tar.bz2
14# upstream patches
15Patch1: autofs-5.0.5-fix-included-map-read-fail-handling.patch
16Patch2: autofs-5.0.5-refactor-ldap-sasl-bind.patch
17Patch3: autofs-5.0.4-add-mount-wait-parameter.patch
18Patch4: autofs-5.0.5-special-case-cifs-escapes.patch
19Patch5: autofs-5.0.5-fix-libxml2-workaround-configure.patch
20Patch6: autofs-5.0.5-more-code-analysis-corrections.patch
21Patch7: autofs-5.0.5-fix-backwards-ifndef-INET6.patch
22Patch8: autofs-5.0.5-fix-stale-init-for-file-map-instance.patch
23Patch9: autofs-5.0.5-fix-ext4-fsck-at-mount.patch
24Patch10: autofs-5.0.5-dont-use-master_lex_destroy-to-clear-parse-buffer.patch
25Patch11: autofs-5.0.5-make-documentation-for-set-log-priority-clearer.patch
26Patch12: autofs-5.0.5-fix-timeout-in-connect_nb.patch
27Patch13: autofs-5.0.5-fix-pidof-init-script-usage.patch
28Patch14: autofs-5.0.5-check-for-path-mount-location-in-generic-module.patch
29Patch15: autofs-5.0.5-dont-fail-mount-on-access-fail.patch
30Patch16: autofs-5.0.5-fix-rpc-large-export-list.patch
31Patch17: autofs-5.0.5-fix-memory-leak-on-reload.patch
32Patch18: autofs-5.0.5-dont-connect-at-ldap-lookup-module-init.patch
33Patch19: autofs-5.0.5-fix-random-selection-option.patch
34Patch20: autofs-5.0.5-fix-disable-timeout.patch
35Patch21: autofs-5.0.5-fix-strdup-return-value-check.patch
36Patch22: autofs-5.0.5-fix-reconnect-get-base-dn.patch
37Patch23: autofs-5.0.5-add-sasl-mutex-callbacks.patch
38Patch24: autofs-5.0.5-fix-get-qdn-fail.patch
39Patch25: autofs-5.0.5-fix-ampersand-escape-in-auto-smb.patch
40Patch26: autofs-5.0.5-add-locality-as-valid-ldap-master-map-attribute.patch
41Patch27: autofs-5.0.5-add-locality-as-valid-ldap-master-map-attribute-fix.patch
42
43## Vine Patch(es)
44Patch100: autofs-3.1.7-initdir.patch
45Patch101: autofs-5.0.3-rc.autofs_LSB.patch
46
47Buildroot: %{_tmppath}/%{name}-%{version}-root
48BuildRequires: openldap-devel
49BuildRequires: bind-devel, libxml2-devel, openssl-devel
50BuildRequires: util-linux-ng, nfs-utils, e2fsprogs
51BuildRequires: flex, bison
52Requires(post): /sbin/chkconfig
53Requires(preun): /sbin/service
54Requires(postun): /sbin/chkconfig
55Requires(postun): /sbin/service
56Requires: kernel >= 2.6.17
57Requires: bash, sed, gawk, coreutils, grep, module-init-tools, procps
58Provides: autofs-ldap
59Obsoletes: autofs-ldap <= 4.1.4-11vl2
60
61
62%description
63Autofs controls the operation of the automount daemons. The automount
64daemons automatically mount filesystems when you use them and
65unmount them after a period of inactivity. Filesystems can include
66network filesystems, CD-ROMs, floppies and others.
67
68Install this package if you want a program for automatically mounting
69and unmounting filesystems. If your Vine Linux machine is on a
70network, you should install autofs.
71
72%description -l ja
73autofs は automount デーモンの動作を制御します.
74automount デーモンは,ファイルシステムを使う時に自動的にマウントし,
75一定時間使わなければアンマウントしてくれます.
76対象となるファイルシステムには NFS, CD-ROM, フロッピー等があります.
77
78ファイルシステムを自動的にマウント/アンマウントさせたい場合は
79このパッケージをインストールして下さい.Vine Linux をインストールした
80マシンをネットワークに接続しているのならば,autofs をインストール
81すると良いでしょう.
82
83
84%prep
85%setup -q
86echo %{version}-%{release} > .version
87%patch1 -p1
88%patch2 -p1
89%patch3 -p1
90%patch4 -p1
91%patch5 -p1
92%patch6 -p1
93%patch7 -p1
94%patch8 -p1
95%patch9 -p1
96%patch10 -p1
97%patch11 -p1
98%patch12 -p1
99%patch13 -p1
100%patch14 -p1
101%patch15 -p1
102%patch16 -p1
103%patch17 -p1
104%patch18 -p1
105%patch19 -p1
106%patch20 -p1
107%patch21 -p1
108%patch22 -p1
109%patch23 -p1
110%patch24 -p1
111%patch25 -p1
112%patch26 -p1
113%patch27 -p1
114
115## Vine Patch(es)
116if [ "%{_initdir}" = "/etc/rc.d/init.d" ]; then
117    patch -p1 -b --suffix .initdir < %{PATCH100}
118fi
119%patch101 -p1 -b .lsb
120
121%build
122CFLAGS="$RPM_OPT_FLAGS -ggdb"; export CFLAGS
123%configure --without-hesiod --without-sasl \
124           --disable-mount-locking --enable-ignore-busy
125make initdir=/etc/rc.d/init.d STRIP=:
126make -C redhat
127
128%install
129[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
130mkdir -p -m755 $RPM_BUILD_ROOT%{_initdir}
131mkdir -p -m755 $RPM_BUILD_ROOT%{_libdir}/autofs
132mkdir -p -m755 $RPM_BUILD_ROOT%{_mandir}/{man5,man8}
133mkdir -p -m755 $RPM_BUILD_ROOT%{_sbindir}
134mkdir -p -m755 $RPM_BUILD_ROOT/etc/sysconfig
135
136make install mandir=%{_mandir} initdir=/etc/rc.d/init.d INSTALLROOT=$RPM_BUILD_ROOT
137make -C redhat
138install -m 755 -d $RPM_BUILD_ROOT/misc
139install -m 755 redhat/autofs.init $RPM_BUILD_ROOT/etc/rc.d/init.d/autofs
140install -m 644 redhat/autofs.sysconfig $RPM_BUILD_ROOT/etc/sysconfig/autofs
141
142%clean
143[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
144
145
146%post
147/sbin/chkconfig --add autofs
148
149
150%postun
151if [ $1 -ge 1 ] ; then
152        /sbin/service autofs condrestart > /dev/null 2>&1 || :
153fi
154
155%preun
156if [ "$1" = 0 ] ; then
157        /sbin/service autofs stop > /dev/null 2>&1
158        chkconfig --del autofs
159fi
160
161
162%files
163%defattr(-,root,root)
164%doc CHANGELOG COPYING COPYRIGHT CREDITS patches/*
165%doc samples/*
166%doc README README.*
167%config %{_initdir}/autofs
168%config(noreplace,missingok) /etc/auto.master
169%config(noreplace,missingok) /etc/auto.misc
170%config(noreplace,missingok) /etc/auto.net
171%config(noreplace,missingok) /etc/auto.smb
172%config(noreplace) /etc/autofs_ldap_auth.conf
173%config(noreplace) /etc/sysconfig/autofs
174%{_sbindir}/automount
175%dir /misc
176%dir %{_libdir}/autofs
177%{_libdir}/autofs/*.so
178%{_mandir}/*/*
179
180
181%changelog
182* Sun Apr 17 2011 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.5-2
183- rebuilt on current VineSeed
184
185* Sun Apr 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0.5-1
186- new upstream release
187- update upstream patches (Patch0-27)
188
189* Wed May 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.3-4
190- added Patch101: autofs-5.0.3-rc.autofs_LSB.patch to support LSB Header
191
192* Mon Jan 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.3-3
193- rebuilt with openldap-2.4.11
194
195* Sun Sep 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0.3-2
196- make autofs.init executable. (<BTS:wishes:0160>)
197
198* Mon Sep 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0.3-1vl5
199- new upstream release
200- update fedora patches
201
202* Sat Aug 30 2008 Shu KONNO <owa@bg.wakwak.com> 4.1.4-12vl5
203- applied new versioning policy, spec in utf-8
204
205* Fri Apr 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.1.4-11vl5
206- fix sort option on auto.net (<BTS:490>)
207
208* Mon Sep 18 2006 NAKAMURA Kenta <kenta@vinelinux.org> 4.1.4-11vl4
209- added patch15 and patch16 imported from Fedora Core 5
210
211* Mon Sep 04 2006 NAKAMURA Kenta <kenta@vinelinux.org> 4.1.4-11vl3
212- added Obsoletes: autofs-ldap
213- added BuildPrereq: openldap-devel
214
215* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 4.1.4-11vl2
216- removed --without-openldap configure option
217- rebuilt with openldap-2.3.27-0vl1
218
219* Sun Oct 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.4-11vl1
220- updated based on Fedora
221  * Wed Oct 26 2005  <jmoyer@redhat.com> - 1:4.1.4-11
222  - Check the return code of is_local_addr in get_best_mount. (bz #169523)
223  * Wed Oct 26 2005  <jmoyer@redhat.com> - 1:4.1.4-10
224  - Fix a buffer overflow with large key lengths
225  - change to the upstream reentrant syslog patch from the band-aid deferred
226    syslog patch.
227  - Get rid of the init script patch that hard-coded the release to redhat.
228    This should be handled properly by all red hat distros.
229  * Wed May  4 2005 Jeff Moyer <jmoyer@redhat.com> - 1:4.1.4-8
230  - Add in the deferred syslog patch.  This fixes a hung automounter issue
231    related to unsafe calls to syslog in signal handler context.
232  * Tue May  3 2005 Jeff Moyer <jmoyer@redhat.com> - 1:4.1.4-7
233  - I reversed the checking for multimount entries, breaking those configs!
234    This update puts the code back the way it was before I broke it.
235  * Tue Apr 26 2005 Jeff Moyer <jmoyer@redhat.com> - 1:4.1.4-6
236  - Fix a race between mounting a share and updating the cache in the parent
237    process.  If the mount completed first, the parent would not expire the
238    stale entry, leaving it first on the list.  This causes map updates to not
239    be recognized (well, worse, they are recognized after the first expire, but
240    not subsequent ones).  Fixes a regression, bug #137026 (rhel3 bug).
241  * Fri Apr 15 2005 Chris Feist <cfeist@redhat.com> - 1:4.1.4-5
242  - Fixed regression with -browse not taking effect.
243  * Wed Apr 13 2005 Jeff Moyer <jmoyer@redhat.com> - 1:4.1.4-4
244  - Finish up with the merge breakage.
245  - Temporary fix for the multimount detection code.  It seems half-baked.
246  * Wed Apr 13 2005 Jeff Moyer <jmoyer@redhat.com> - 1:4.1.4-3
247  - Fix up the one-auto-master patch.  My "improvements" had side-effects.
248  * Wed Oct 27 2004 Chris Feist <cfeist@redhat.com> - 1:4.1.3-34
249  - Added a patch to fix the automounter failing on ldap maps
250    when it couldn't get the whole map.  (ie. when the search
251    limit was lower than the number of results)
252- updated Patch101
253- s/Red Hat/Vines/ in description
254
255* Wed Jun 23 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.1.7-42vl3
256- fix init script (Patch102)
257  not to create lock file when no mountpoints are defined
258
259* Tue Oct 28 2003 Tomoya TAKA <taka@vinelinux.org> 3.1.7-42vl2
260- do not compile/install autofs-ldap-auto-master
261
262* Sun Oct  5 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.7-42vl1
263- based on Rawhide 3.1.7-42
264  - Fri Apr 25 2003 Nalin Dahyabhai <nalin@redhat.com> 3.1.7-37
265  - sync with current linux/auto_fs.h from the current kernel tree (#88562)
266  - Tue Apr  2 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1.7-28
267  - try to properly handle nisplus maps (patch from Steve Foster via the
268    autofs mailing list)
269  - override the STRIP makefile variable to not strip binaries (that's the
270    build root policy's job)
271  - Wed Aug 29 2001 Nalin Dahyabhai <nalin@redhat.com> 3.1.7-21
272  - don't inhibit starting if we have a subsys lock around -- that's the
273    wrong thing to do anyway
274  - don't create a subsys lock if we're unconfigured (#52755)
275- rebuild with new toolchain
276- s/Copyright/License/
277
278* Tue Jan 29 2002 Toru Sagami <sagami@vinelinux.org> 3.1.7-2vl2
279- make /etc/vine-release read by autofs.init
280
281* Fri Jan 19 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
282- 3.1.7-2vl1
283- rebuilt for VineSeed
284- use better macros (%%{_initdir})
285- add Patch100 to cope with initdir :-(
286
287* Thu Jan 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
288- 3.1.7-2vl0
289- based on 3.1.7-2 from Rawhide
290- remove /etc/init.d from PreReq
291- build without openldap and hesiod
292- BuildPreReq: bind-devel again for Vine
293- added Japanese summary and description
294
295* Tue Jan  9 2001 Nalin Dahyabhai <nalin@redhat.com>
296- fix option parsing in lookup_multi (I think)
297- fix multi option handling in our hacked-up init script (reported by Thiago
298  Bartolomei on the autofs mailing list)
299
300* Wed Dec  6 2000 Nalin Dahyabhai <nalin@redhat.com>
301- update to 3.1.7
302- add the man pages back in (fell out in 3.1.6)
303
304* Tue Nov 28 2000 Nalin Dahyabhai <nalin@redhat.com>
305- don't require /etc/auto.master to be there to start
306
307* Mon Nov 27 2000 Nalin Dahyabhai <nalin@redhat.com>
308- update to 3.1.6
309- disable hesiod support because the new bind-devel doesn't include it
310- try to use nsswitch.conf for getting the contents of auto.master
311- only convert YP map names auto_home and auto_mnt
312
313* Fri Sep  8 2000 Nalin Dahyabhai <nalin@redhat.com>
314- add -lresolv to build properly with OpenLDAP 2
315
316* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
317- convert YP map names that start with "auto_" to "auto." (#16753)
318
319* Wed Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
320- add an extra pause after the initial shutdown attempt
321
322* Fri Aug 11 2000 Nalin Dahyabhai <nalin@redhat.com>
323- patch init script to not shut down --submount mounts on reload
324- remove temporary files again during reload
325
326* Thu Aug 10 2000 Nalin Dahyabhai <nalin@redhat.com>
327- revert to 3.1.5
328- add 3.1.6pre1 patch to handle LDAP maps
329- add Epoch: to upgrade from Raw Hide or Pinstripe
330- update to 3.1.6pre2
331
332* Fri Aug  4 2000 Nalin Dahyabhai <nalin@redhat.com>
333- work around kernel insmod concurrency problem (#14972) by loading the module
334  at start-time
335
336* Wed Aug  2 2000 Nalin Dahyabhai <nalin@redhat.com>
337- fix duplicate detection for false matches (e.g. "/user" == "/users") (#15183)
338
339* Mon Aug  1 2000 Nalin Dahyabhai <nalin@redhat.com>
340- merge ldap subpackage back into the main one and Obsolete: it
341- clean up build warnings
342- fix errors automounting ext2 filesystems due to uninitialized option string
343
344* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
345- move initscript back
346
347* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
348- automatic rebuild
349
350* Mon Jul 10 2000 Nalin Dahyabhai <nalin@redhat.com>
351- move the init script to the right place
352
353* Fri Jul  7 2000 Nalin Dahyabhai <nalin@redhat.com>
354- add /net directory to the package
355
356* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
357- do manual unmounting in shutdown script
358- change initscripts prereq to /etc/init.d
359- move autoconf invocation to setup section
360
361* Wed Jul  5 2000 Nalin Dahyabhai <nalin@redhat.com>
362- move condrestart to postun
363- make condrestart check the right file to determine if already running
364
365* Wed Jul  5 2000 Florian La Roche <Florian.LaRoche@redhat.com>
366- ignore errors in post script
367
368* Tue Jul  4 2000 Matt Wilson <msw@redhat.com>
369- use full path to chkconfig
370- full *correct* path to chkconfig
371
372* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
373- smoother starting/stopping on upgrades/removal
374
375* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
376- be more aggressive when shutting down autofs
377- add condrestart support
378
379* Mon Jun  5 2000 Nalin Dahyabhai <nalin@redhat.com>
380- move man pages to %{_mandir}
381
382* Wed May 31 2000 Nalin Dahyabhai <nalin@redhat.com>
383- tweak argument parsing (bug #11801)
384
385* Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com>
386- rebuild in new build environment
387
388* Mon May  8 2000 Nalin Dahyabhai <nalin@redhat.com>
389- fix duplicate detection logic (duh!)
390
391* Tue May  2 2000 Nalin Dahyabhai <nalin@redhat.com>
392- add config: and processname: tags to init script
393
394* Sun Apr 30 2000 Nalin Dahyabhai <nalin@redhat.com>
395- fix shutdown logic (test -z $pid fails with multiple autofs daemons)
396
397* Wed Apr 26 2000 Nalin Dahyabhai <nalin@redhat.com>
398- split off autofs4 for testing & development
399- update patches for autofs4 for feeding back to autofs list
400- make auto.master a noreplace file
401
402* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
403- split lookup_ldap into a subpackage (bug #10874)
404
405* Tue Apr 11 2000 Nalin Dahyabhai <nalin@redhat.com>
406- add LDAP map support, requires openldap
407- tweak init script patch to use fields 2+ for the map name instead of just 2
408
409* Wed Apr 05 2000 Nalin Dahyabhai <nalin@redhat.com>
410- fix bug #10402 by fixing the init script, hopefully for everybody
411- merge patches for the init script into a single patch to send to hpa
412- patch to build on 2.2 and late-series 2.3 kernels
413
414* Tue Feb 29 2000 Nalin Dahyabhai <nalin@redhat.com>
415- enable hesiod support over libbind
416
417* Mon Feb 28 2000 Nalin Dahyabhai <nalin@redhat.com>
418- fix init script bug when startup failed
419- fix option passing in init script
420
421* Sun Feb 13 2000 Nalin Dahyabhai <nalin@redhat.com>
422- make autofs start after ypbind by moving start priority 18, stop to 82
423- make sure that calls to "ps aux" include "www" to avoid snippage
424
425* Wed Feb  2 2000 Nalin Dahyabhai <nalin@redhat.com>
426- make sure all the docs get packaged
427- make init script do status messages like others
428- add "nosuid,nodev" to options for /misc/cd
429- switch to using INSTALLROOT during make install
430
431* Fri Jan 21 2000 Nalin Dahyabhai <nalin@redhat.com>
432- update to 3.1.4
433
434* Mon Sep 20 1999 Cristian Gafton <gafton@redhat.com>
435- use ps axw instead of ps ax in the init script
436
437* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
438- chkconfig --del in %preun, not %postun
439
440* Tue Sep 07 1999 Cristian Gafton <gafton@redhat.com>
441- add patch from HJLu to handle NIS auto.master better
442
443* Wed Aug 25 1999 Cristian Gafton <gafton@redhat.com>
444- fix bug #4708
445
446* Sat Aug 21 1999 Bill Nottingham <notting@redhat.com>
447- fix perms on /usr/lib/autofs/*
448- add support for specifying maptype in auto.master
449
450* Fri Aug 13 1999 Cristian Gafton <gafton@redhat.com>
451- add patch from rth to avoid an infinite loop
452
453* Wed Apr 28 1999 Cristian Gafton <gafton@redhat.com>
454- use "autofs" instead of "automount" for /var/lock/subsys lock file
455
456* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
457- enahanced initscript to try to load maps over NIS
458- changed the mount point back to misc (there is a reason we leave /mnt
459  alone)
460- patched back autofs.misc to the version shipped on 5.2 to avoid replacing
461  yet one more config file for those who upgrade
462
463* Wed Mar 24 1999 Preston Brown <pbrown@redhat.com>
464- upgrade to 3.1.3, fixing smbfs stuff and other things
465- changed mountpoint from /misc to /mnt
466
467* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
468- auto rebuild in the new build environment (release 10)
469
470* Mon Feb  8 1999 Bill Nottingham <notting@redhat.com>
471- build for kernel-2.2/glibc2.1
472
473* Tue Oct  6 1998 Bill Nottingham <notting@redhat.com>
474- fix bash2 breakage in init script
475
476* Sun Aug 23 1998 Jeff Johnson <jbj@redhat.com>
477- typo in man page.
478
479* Mon Jul 20 1998 Jeff Johnson <jbj@redhat.com>
480- added sparc to ExclusiveArch.
481
482* Thu May 07 1998 Prospector System <bugs@redhat.com>
483- translations modified for de, fr, tr
484
485* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
486- updated to 3.1.1
487
488* Wed Apr 22 1998 Michael K. Johnson <johnsonm@redhat.com>
489- enhanced initscripts
490
491* Fri Dec 05 1997 Michael K. Johnson <johnsonm@redhat.com>
492- Link with -lnsl for glibc compliance.
493
494* Thu Oct 23 1997 Michael K. Johnson <johnsonm@redhat.com>
495- exclusivearch for i386 for now, since our kernel packages on
496  other platforms don't include autofs yet.
497- improvements to initscripts.
498
499* Thu Oct 16 1997 Michael K. Johnson <johnsonm@redhat.com>
500- Built package from 0.3.14 for 5.0
Note: See TracBrowser for help on using the repository browser.