source: projects/specs/branches/6/a/autoconf213/autoconf213-vl.spec @ 3473

Revision 3473, 7.8 KB checked in by inagaki, 13 years ago (diff)

updated: autoconf213, jasper

Line 
1Summary: A GNU tool for automatically configuring source code.
2Summary(ja): ソースコードを自動的に設定するための GNU ツール
3Name: autoconf213
4Version: 2.13
5Release: 7%{?_dist_release}
6License: GPLv2
7Group: Development/Tools
8URL: http://www.gnu.org/software/autoconf/
9Source0: ftp://prep.ai.mit.edu/pub/gnu/autoconf/autoconf-%{version}.tar.gz
10Source1: filter-requires-%{name}.sh
11Patch0: autoconf-2.12-race.patch
12Patch1: autoconf-2.13-mawk.patch
13Patch2: autoconf-2.13-notmp.patch
14Patch3: autoconf-2.13-c++exit.patch
15Patch4: autoconf-2.13-headers.patch
16Patch5: autoconf-2.13-autoscan.patch
17Patch6: autoconf-2.13-exit.patch
18Patch7: autoconf-2.13-wait3test.patch
19Patch8: autoconf-2.13-make-defs-62361.patch
20Patch9: autoconf-2.13-versioning.patch
21Patch10: autoconf213-destdir.patch
22Patch11: autoconf213-info.patch
23
24BuildArchitectures: noarch
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: gawk
27BuildRequires: m4
28BuildRequires: perl
29BuildRequires: texinfo
30Requires: coreutils
31Requires: gawk
32Requires: m4
33Requires: perl
34Requires(post): /sbin/install-info
35Requires(preun): /sbin/install-info
36
37%define __find_requires %{SOURCE1}
38
39%description
40GNU's Autoconf is a tool for configuring source code and Makefiles.
41Using Autoconf, programmers can create portable and configurable
42packages, since the person building the package is allowed to specify
43various configuration options.
44
45You should install Autoconf if you are developing software and you
46would like to use it to create shell scripts that will configure your
47source code packages. If you are installing Autoconf, you will also
48need to install the GNU m4 package.
49
50Note that the Autoconf package is not required for the end-user who
51may be configuring software with an Autoconf-generated script;
52Autoconf is only required for the generation of the scripts, not their
53use.
54
55%description -l ja
56GNU autoconf はソースコードと Makefile を自動的に設定する GNU ツール
57です.Autoconf を使えば,プログラマは移植や設定が容易なパッケージを
58作ることができます.そのため,パッケージ作成者はさまざまな設定
59オプションを指定できます。
60
61ソフトウェアを開発していてソースコードパッケージを設定するシェル
62スクリプトを生成したいとお考えなら,Autoconf をインストールしてください.
63Autoconf をインストールするためには GNU m4 パッケージもインストールする
64必要があります.
65
66Autoconf が生成したスクリプトを使ってソフトウェアを設定するかもしれない
67エンドユーザには Autoconf パッケージが必要ないことに注目してください.
68Autoconf が必要になるのはスクリプトを生成するときのみで,使うときには
69必要ありません.
70
71%prep
72%setup -q -n autoconf-%{version}
73%patch0 -p1
74%patch1 -p1
75%patch2 -p1
76%patch3 -p1
77%patch4 -p1
78%patch5 -p1
79%patch6 -p1
80%patch7 -p1
81%patch8 -p1
82%patch9 -p1 -b .version
83%patch10 -p1
84%patch11 -p1
85mv autoconf.texi autoconf213.texi
86rm -f autoconf.info
87
88%build
89%configure --program-suffix=-%{version}
90make
91
92%install
93rm -rf $RPM_BUILD_ROOT
94make install DESTDIR=$RPM_BUILD_ROOT
95
96#mv $RPM_BUILD_ROOT%{_infodir}/autoconf.info $RPM_BUILD_ROOT%{_infodir}/%{name}.info
97
98# We don't want to include the standards.info stuff in the package,
99# because it comes from binutils...
100rm -f $RPM_BUILD_ROOT%{_infodir}/standards*
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105
106%post
107/sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
108
109%preun
110if [ "$1" = 0 ]; then
111    /sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
112fi
113
114%files
115%defattr(-,root,root)
116%doc AUTHORS COPYING NEWS README TODO
117%{_bindir}/*
118%{_infodir}/*.info*
119%{_datadir}/autoconf-%{version}
120
121
122%changelog
123* Mon Apr 11 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13-7
124- rebuilt with perl-5.12.3
125- added Patch11 to add autoconf213 info entry
126
127* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.13-6
128- spec in utf-8
129
130* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13-5
131- rebuilt with perl-5.10.0-1
132- added Source1 (for perl(find.pl))
133
134* Thu Dec 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13-4vl2
135- s/Copyright/License/
136- added Japanese summary and description (copied from autoconf)
137
138* Sun Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.13-4vl1
139- based on 2.13-4 from Rawhide and built for Vine linux
140
141* Fri Jun 28 2002 Jens Petersen <petersen@redhat.com> 2.13-4
142- update url (#66840)
143- added doc files
144
145* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.13-3
146- automated rebuild
147
148* Thu May 23 2002 Tim Powers <timp@redhat.com> 2.13-2
149- automated rebuild
150
151* Wed May 15 2002 Jens Petersen <petersen@redhat.com> 2.13-1
152- new package based on autoconf-2.13-17
153- don't make unversioned bindir symlinks
154- version datadir
155- version info filename, but don't install-info it
156- update AC_OUTPUT_MAKE_DEFS to fix problem with c++exit patch (#62361)
157
158* Wed Mar 27 2002 Jens Petersen <petersen@redhat.com> 2.13-17
159- add URL
160
161* Wed Feb 27 2002 Jens Petersen <petersen@redhat.com> 2.13-16
162- add version suffix to bindir files and symlink them to their
163unversioned names
164
165* Mon Feb 25 2002 Elliot Lee <sopwith@redhat.com> 2.13-15
166- Add wait3test.patch to make sure that the child process actually does
167something that the kernel will take note of. Fixes the failing wait3 test
168that was worked around in time-1.7-15.
169
170* Mon Aug  6 2001 Tim Powers <timp@redhat.com>
171- rebuilt to fix bug #50761
172
173* Thu Jul 26 2001 Than Ngo <than@redhat.com>
174- add patch to fix exit status
175
176* Tue Jul 10 2001 Jens Petersen <petersen@redhat.com>
177- add patch to include various standard C headers as needed
178  by various autoconf tests (#19114)
179- add patch to autoscan.pl to get a better choice of init
180  file (#42071), to test for CPP after CC (#42072) and to
181  detect C++ source and g++ (#42073).
182
183* Tue Jun 26 2001 Jens Petersen <petersen@redhat.com>
184- Add a back-port of _AC_PROG_CXX_EXIT_DECLARATION
185  from version 2.50 to make detection of C++ exit()
186  declaration prototype platform independent.  The check is
187  done in AC_PROG_CXX with the result stored in "confdefs.h".
188  The exit() prototype in AC_TRY_RUN_NATIVE is no longer needed.
189  (fixes #18829)
190
191* Wed Nov 29 2000 Bernhard Rosenkraenzer <bero@redhat.com>
192- Fix up interoperability with glibc 2.2 and gcc 2.96:
193  AC_TRY_RUN_NATIVE in C++ mode added a prototype for exit() to
194  the test code without throwing an exception, causing a conflict
195  with stdlib.h --> AC_TRY_RUN_NATIVE for C++ code including stdlib.h
196  always failed, returning wrong results
197
198* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
199- add textutils as a dependency (#14439)
200
201* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
202- automatic rebuild
203
204* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
205- FHS packaging.
206
207* Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
208- fix preun
209
210* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
211- add patch to help autoconf clean after itself and not leave /tmp clobbered
212  with acin.* and acout.* files (can you say annoying?)
213
214* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
215- auto rebuild in the new build environment (release 4)
216- use gawk, not mawk
217
218* Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
219- moved /usr/lib/autoconf to /usr/share/autoconf (with automake)
220
221* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
222- Injected new description and group.
223
224* Tue Jan 12 1999 Jeff Johnson <jbj@redhat.com>
225- update to 2.13.
226
227* Fri Dec 18 1998 Cristian Gafton <gafton@redhat.com>
228- build against glibc 2.1
229
230* Mon Oct 05 1998 Cristian Gafton <gafton@redhat.com>
231- requires perl
232
233* Thu Aug 27 1998 Cristian Gafton <gafton@redhat.com>
234- patch for fixing /tmp race conditions
235
236* Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
237- spec file cleanups
238- made a noarch package
239- uses autoconf
240- uses install-info
241
242* Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
243- built with glibc
Note: See TracBrowser for help on using the repository browser.