source: projects/specs/branches/6/a/autoconf/autoconf-vl.spec @ 3534

Revision 3534, 10.5 KB checked in by owa, 13 years ago (diff)

rebuit

Line 
1%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
2%define emacsen_pkgdir /usr/lib/emacsen-common/packages
3
4Summary: A GNU tool for automatically configuring source code.
5Summary(ja): ソースコードを自動的に設定するための GNU ツール
6Name: autoconf
7Version: 2.65
8Release: 2%{?_dist_release}
9License: GPL
10Group: Development/Tools
11URL: http://www.gnu.org/software/autoconf/
12
13Source: ftp://ftp.gnu.org/pub/gnu/autoconf/autoconf-%{version}.tar.xz
14
15# Vine Source(s)
16Source10: autoconf-mode-install.sh
17Source11: autoconf-mode-remove.sh
18
19Prereq(post,preun): /sbin/install-info
20Requires: gawk, m4, mktemp, perl, textutils
21Obsoletes: autoconf253
22BuildArch: noarch
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24
25%description
26GNU's Autoconf is a tool for configuring source code and Makefiles.
27Using Autoconf, programmers can create portable and configurable
28packages, since the person building the package is allowed to
29specify various configuration options.
30
31You should install Autoconf if you are developing software and
32would like to create shell scripts that configure your source code
33packages. If you are installing Autoconf, you will also need to
34install the GNU m4 package.
35
36Note that the Autoconf package is not required for the end-user who
37may be configuring software with an Autoconf-generated script;
38Autoconf is only required for the generation of the scripts, not
39their use.
40
41%description -l ja
42GNU autoconf はソースコードと Makefile を自動的に設定する GNU ツール
43です.Autoconf を使えば,プログラマは移植や設定が容易なパッケージを
44作ることができます.そのため,パッケージ作成者はさまざまな設定
45オプションを指定できます。
46
47ソフトウェアを開発していてソースコードパッケージを設定するシェル
48スクリプトを生成したいとお考えなら,Autoconf をインストールしてください.
49Autoconf をインストールするためには GNU m4 パッケージもインストールする
50必要があります.
51
52Autoconf が生成したスクリプトを使ってソフトウェアを設定するかもしれない
53エンドユーザには Autoconf パッケージが必要ないことに注目してください.
54Autoconf が必要になるのはスクリプトを生成するときのみで,使うときには
55必要ありません.
56
57%package mode
58Summary: Emacs-lisp autoconf-mode for autoconf/autotest
59Group: Applications/Editors/Emacs
60%prereq_ge emacsen-common
61PreReq: emacsen
62
63%description mode
64Emacs-lisp autoconf-mode for autoconf/autotest
65
66
67%prep
68%setup -q -n autoconf-%{version}
69#patch0 -p1
70
71
72%build
73%configure
74make
75
76#make check
77
78%install
79rm -rf ${RPM_BUILD_ROOT}
80%makeinstall
81
82gzip -9nf ${RPM_BUILD_ROOT}%{_infodir}/autoconf.info*
83
84# We don't want to include the standards.info stuff in the package,
85# because it comes from binutils...
86rm -f ${RPM_BUILD_ROOT}%{_infodir}/standards*
87# cp install-sh ${RPM_BUILD_ROOT}%{_datadir}/autoconf
88
89# remove info dir file since it isn't packaged
90rm -f ${RPM_BUILD_ROOT}%{_infodir}/dir
91
92# move elisp files
93pushd ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp
94mkdir -p ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/autoconf-mode
95mv *.el autoconf-mode/
96popd
97
98# emacsen-common-ize
99mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/autoconf-mode
100#mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
101#mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
102mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/install
103mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/remove
104
105%_installemacsenscript autoconf-mode %{SOURCE10}
106
107%_removeemacsenscript  autoconf-mode %{SOURCE11}
108
109
110%clean
111rm -rf ${RPM_BUILD_ROOT}
112
113
114%post
115/sbin/install-info %{_infodir}/autoconf.info.gz %{_infodir}/dir
116
117
118%post mode
119
120if [ "$1" = 2 ]; then
121
122%_emacsenPackageRemove autoconf-mode
123
124fi
125
126%_addemacsenlist autoconf-mode
127
128%_emacsenPackageInstall autoconf-mode
129
130
131%preun
132if [ "$1" = 0 ]; then
133    /sbin/install-info --del %{_infodir}/autoconf.info.gz %{_infodir}/dir
134fi
135
136
137%preun mode
138
139if [ "$1" = 0 ]; then
140
141%_emacsenPackageRemove autoconf-mode
142
143%_removeemacsenlist autoconf-mode
144
145fi
146
147
148%files
149%defattr(-,root,root)
150%doc AUTHORS COPYING ChangeLog NEWS README THANKS TODO
151%{_bindir}/*
152%{_infodir}/*.info*
153%{_datadir}/autoconf
154%{_mandir}/man1/*
155
156
157%files mode
158%defattr(-,root,root)
159%{_datadir}/emacs/site-lisp/autoconf-mode/
160#/usr/lib/emacsen-common/packages/install/autoconf-mode
161#/usr/lib/emacsen-common/packages/remove/autoconf-mode
162%{emacsen_pkgdir}/install/autoconf-mode
163%{emacsen_pkgdir}/remove/autoconf-mode
164
165
166%changelog
167* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2.65-2
168- rebuilt with rpm-4.8.1-3
169
170* Sun Apr 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.65-1
171- new upstream release
172
173* Sun Sep 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.63-1
174- new upstream release
175- dropped Patch0 (merged into upstream)
176
177* Wed Sep 10 2008 Shu KONNO <owa@bg.wakwak.com> 2.62-3
178- added %%emacsen_pkgdir macro
179- spec in utf-8
180
181* Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.62-2
182- import Patch0 from Fedora 2.62-2
183  * Fri Jun 06 2008 Karsten Hopp <karsten@redhat.com> 2.62-2
184  - add upstream fix from Eric Blake for #449973,
185    m4_if releated error message from autotest
186
187* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.62-1
188- new upstream release
189
190* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.61-0vl1
191- new upstream release
192
193* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.59-2vl4
194- changed autoconf-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
195- added Japanese summary and description from vinedocs.sourceforge.jp
196- s/Copyright/License/
197
198* Wed Feb 25 2004 Tomoya TAKA <taka@vinelinux.org> 2.59-2vl3
199- rebuild
200
201* Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.59-2vl2
202- rebuild
203
204* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.59-2vl1
205- update to 2.59 bugfix release
206
207* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.58-0vl1
208- new upstream release
209
210* Tue Apr 08 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.57-3vl1
211- source update
212
213* Mon Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.56-1vl2
214- don't show annoying messages during elisp compilation
215
216* Sun Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.56-1vl1
217- based on 2.56-1 from Rawhide and built for Vine Linux
218- emacsen-common-ize
219
220* Mon Nov 18 2002 Jens Petersen <petersen@redhat.com> 2.56-1
221- update to 2.56
222- obsolete autoheader-warn patch
223- no longer provide autoconf253
224- include site-lisp and man files
225- remove info dir which is not in the manifest
226- do not version suffix bin files for now
227
228* Mon Aug 19 2002 Jens Petersen <petersen@redhat.com> 2.53-8
229- make check
230
231* Fri Jun 28 2002 Jens Petersen <petersen@redhat.com> 2.53-7
232- update url (#66840)
233- added doc files
234
235* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.53-6
236- automated rebuild
237
238* Sun May 26 2002 Tim Powers <timp@redhat.com> 2.53-5
239- automated rebuild
240
241* Mon May 20 2002 Bill Nottingham <notting@redhat.com> 2.53-4
242- provide autoconf253
243
244* Thu May 16 2002 Bill Nottingham <notting@redhat.com> 2.53-3
245- obsolete autoconf253
246
247* Wed May  8 2002 Jens Petersen <petersen@redhat.com> 2.53-2
248- patch autoheader so that --warnings=CATEGORY works (#64566)
249  [reported with fix by hjl@gnu.org]
250
251* Tue Apr 23 2002 Jens Petersen <petersen@redhat.com> 2.53-1
252- update to autoconf-2.53
253- drop mawk patch again
254- version suffix bindir files and add symlinks to unversioned names
255
256* Fri Feb  1 2002 Jens Petersen <petersen@redhat.com> 2.52-7
257- revert to 2.52 (also fixes #58210!)
258- remove relversion variable
259- bring back mawk -> gawk patch
260
261* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 2.52-6
262- automated rebuild
263
264* Thu Dec 20 2001 Jens Petersen <petersen@redhat.com> 2.52-5
265- update to 2.52f
266- add URL
267- minor description improvements
268- define relversion to carry version number
269- mawk.patch no longer needed
270
271* Sat Nov 17 2001 Florian La Roche <Florian.LaRoche@redhat.de> 2.52-4
272- rebuild
273
274* Wed Sep 19 2001 Jens Petersen <petersen@redhat.com> 2.52-3
275- restore patch to prefer gawk to mawk
276
277* Tue Sep 18 2001 Florian La Roche <Florian.LaRoche@redhat.de> 2.52-2
278- update to 2.52d
279
280* Mon Sep 17 2001 Jens Petersen <petersen@redhat.com> 2.52-1
281- update to 2.52
282- remove obsolete patches, since already new version
283- dont install install-sh
284
285* Tue Jul 10 2001 Jens Petersen <petersen@redhat.com>
286- add patch to include various standard C headers as needed
287  by various autoconf tests (#19114)
288- add patch to autoscan.pl to get a better choice of init
289  file (#42071), to test for CPP after CC (#42072) and to
290  detect C++ source and g++ (#42073).
291
292* Tue Jun 26 2001 Jens Petersen <petersen@redhat.com>
293- Add a back-port of _AC_PROG_CXX_EXIT_DECLARATION
294  from version 2.50 to make detection of C++ exit()
295  declaration prototype platform independent.  The check is
296  done in AC_PROG_CXX with the result stored in "confdefs.h".
297  The exit() prototype in AC_TRY_RUN_NATIVE is no longer needed.
298  (fixes #18829)
299
300* Wed Nov 29 2000 Bernhard Rosenkraenzer <bero@redhat.com>
301- Fix up interoperability with glibc 2.2 and gcc 2.96:
302  AC_TRY_RUN_NATIVE in C++ mode added a prototype for exit() to
303  the test code without throwing an exception, causing a conflict
304  with stdlib.h --> AC_TRY_RUN_NATIVE for C++ code including stdlib.h
305  always failed, returning wrong results
306
307* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
308- add textutils as a dependency (#14439)
309
310* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
311- automatic rebuild
312
313* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
314- FHS packaging.
315
316* Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
317- fix preun
318
319* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
320- add patch to help autoconf clean after itself and not leave /tmp clobbered
321  with acin.* and acout.* files (can you say annoying?)
322
323* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
324- auto rebuild in the new build environment (release 4)
325- use gawk, not mawk
326
327* Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
328- moved /usr/lib/autoconf to /usr/share/autoconf (with automake)
329
330* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
331- Injected new description and group.
332
333* Tue Jan 12 1999 Jeff Johnson <jbj@redhat.com>
334- update to 2.13.
335
336* Fri Dec 18 1998 Cristian Gafton <gafton@redhat.com>
337- build against glibc 2.1
338
339* Mon Oct 05 1998 Cristian Gafton <gafton@redhat.com>
340- requires perl
341
342* Thu Aug 27 1998 Cristian Gafton <gafton@redhat.com>
343- patch for fixing /tmp race conditions
344
345* Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
346- spec file cleanups
347- made a noarch package
348- uses autoconf
349- uses install-info
350
351* Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
352- built with glibc
353
Note: See TracBrowser for help on using the repository browser.