source: projects/specs/branches/6/a/attr/attr-vl.spec @ 3372

Revision 3372, 10.9 KB checked in by inagaki, 13 years ago (diff)

update: acl, attr

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: Utilities for managing filesystem extended attributes
4Name: attr
5Version: 2.4.44
6Release: 1%{?_dist_release}
7
8License: GPLv2+
9URL: http://oss.sgi.com/projects/xfs/
10Group: System Environment/Base
11
12Source: http://download.savannah.gnu.org/releases-noredirect/attr/attr-%{version}.src.tar.gz
13
14# a file available in the upstream git repo, but not in the release
15Source2: sort-getfattr-output
16
17# make it ready for rpmbuild
18Patch1: attr-2.4.32-build.patch
19
20# bz #485473
21Patch2: attr-2.4.43-leak.patch
22
23# prepare the test-suite for SELinux
24Patch3: attr-2.4.44-tests.patch
25
26# silence compile-time warnings
27Patch4: attr-2.4.44-warnings.patch
28
29# setfattr.1: document supported encodings of values (#587516)
30Patch5: attr-2.4.44-bz587516.patch
31
32# getfattr: encode NULs properly with --encoding=text (#650539)
33Patch6: attr-2.4.44-bz650539.patch
34
35# getfattr: return non-zero exit code on failure (#660619)
36Patch7: attr-2.4.44-bz660619.patch
37
38# walk_tree: do not follow symlink to directory with -h (#660613)
39Patch8: attr-2.4.44-bz660613.patch
40
41# fix typos in attr(1) man page (#669095)
42Patch9: attr-2.4.44-bz669095.patch
43
44BuildRoot: %{_tmppath}/%{name}-%{version}-root
45BuildRequires: gettext
46BuildRequires: libtool
47Requires: libattr = %{version}-%{release}
48
49Conflicts: xfsdump < 2.0.0
50
51%description
52A set of tools for manipulating extended attributes on filesystem
53objects, in particular getfattr(1) and setfattr(1).
54An attr(1) command is also provided which is largely compatible
55with the SGI IRIX tool of the same name.
56
57%package -n libattr
58Summary: Dynamic library for extended attribute support
59Group: System Environment/Libraries
60License: LGPLv2+
61
62%description -n libattr
63This package contains the libattr.so dynamic library which contains
64the extended attribute system calls and library functions.
65
66%package -n libattr-devel
67Summary: Extended attribute static libraries and headers
68Group: Development/Libraries
69License: LGPLv2+
70Requires: libattr = %{version}-%{release}
71
72%description -n libattr-devel
73This package contains the libraries and header files needed to
74develop programs which make use of extended attributes.
75For Linux programs, the documented system call API is the
76recommended interface, but an SGI IRIX compatibility interface
77is also provided.
78
79Currently only ext2, ext3 and XFS support extended attributes.
80The SGI IRIX compatibility API built above the Linux system calls is
81used by programs such as xfsdump(8), xfsrestore(8) and xfs_fsr(8).
82
83You should install libattr-devel if you want to develop programs
84which make use of extended attributes.  If you install libattr-devel,
85you'll also want to install attr.
86
87# compat32
88%package -n compat32-libattr
89Summary: Dynamic library for extended attribute support
90Group: System Environment/Libraries
91License: LGPLv2+
92
93%description -n compat32-libattr
94This package contains the libattr.so dynamic library which contains
95the extended attribute system calls and library functions.
96
97%package -n compat32-libattr-devel
98Summary: Extended attribute static libraries and headers
99Group: Development/Libraries
100License: LGPLv2+
101Requires: libattr-devel = %{version}-%{release}
102Requires: compat32-libattr = %{version}-%{release}
103
104%description -n compat32-libattr-devel
105This package contains the libraries and header files needed to
106develop programs which make use of extended attributes.
107For Linux programs, the documented system call API is the
108recommended interface, but an SGI IRIX compatibility interface
109is also provided.
110
111Currently only ext2, ext3 and XFS support extended attributes.
112The SGI IRIX compatibility API built above the Linux system calls is
113used by programs such as xfsdump(8), xfsrestore(8) and xfs_fsr(8).
114
115You should install libattr-devel if you want to develop programs
116which make use of extended attributes.  If you install libattr-devel,
117you'll also want to install attr.
118
119
120%prep
121%setup -q
122%setup -q
123%patch1 -p1
124%patch2 -p1
125%patch3 -p1
126%patch4 -p1
127%patch5 -p1
128%patch6 -p1
129%patch7 -p1
130%patch8 -p1
131%patch9 -p1
132
133# test-suite helper script
134install -m0755 %{SOURCE2} test/
135
136
137%build
138# attr abuses libexecdir
139%configure --libdir=/%{_lib} --libexecdir=%{_libdir}
140make %{?_smp_mflags} LIBTOOL="libtool --tag=CC"
141
142%install
143rm -rf $RPM_BUILD_ROOT
144make install DESTDIR=$RPM_BUILD_ROOT
145make install-dev DESTDIR=$RPM_BUILD_ROOT
146make install-lib DESTDIR=$RPM_BUILD_ROOT
147
148# get rid of libattr.a and libattr.la
149rm -f $RPM_BUILD_ROOT/%{_lib}/libattr.a
150rm -f $RPM_BUILD_ROOT/%{_lib}/libattr.la
151rm -f $RPM_BUILD_ROOT%{_libdir}/libattr.a
152rm -f $RPM_BUILD_ROOT%{_libdir}/libattr.la
153
154# fix links to shared libs and permissions
155rm -f $RPM_BUILD_ROOT/%{_libdir}/libattr.so
156ln -sf ../../%{_lib}/libattr.so $RPM_BUILD_ROOT/%{_libdir}/libattr.so
157chmod 0755 $RPM_BUILD_ROOT/%{_lib}/libattr.so.*.*.*
158
159%find_lang %{name}
160
161%check
162if ./setfattr/setfattr -n user.name -v value .; then
163    make tests || exit $?
164
165    # FIXME: root-tests are not ready for the SELinux
166    #if test 0 = `id -u`; then
167    #    make root-tests || exit $?
168    #fi
169else
170    echo '*** xattrs are probably not supported by the file system,' \
171         'the test-suite will NOT run ***'
172fi
173
174%clean
175rm -rf $RPM_BUILD_ROOT
176
177%post -n libattr -p /sbin/ldconfig
178
179%postun -n libattr -p /sbin/ldconfig
180
181%post -n compat32-libattr -p /sbin/ldconfig
182
183%postun -n compat32-libattr -p /sbin/ldconfig
184
185%files -f %{name}.lang
186%defattr(-,root,root)
187%doc doc
188%{_bindir}/attr
189%{_bindir}/getfattr
190%{_bindir}/setfattr
191%{_mandir}/man1/attr.1*
192%{_mandir}/man1/getfattr.1*
193%{_mandir}/man1/setfattr.1*
194%{_mandir}/man5/attr.5*
195
196%files -n libattr-devel
197%defattr(-,root,root)
198/%{_lib}/libattr.so
199%{_includedir}/attr
200%{_libdir}/libattr.*
201%{_mandir}/man2/*attr.2*
202%{_mandir}/man3/attr_*.3.*
203
204%files -n libattr
205/%{_lib}/libattr.so.*
206
207# compat32
208%if %{build_compat32}
209%files -n compat32-libattr-devel
210%defattr(-,root,root)
211/%{_lib}/libattr.so
212%{_libdir}/libattr.*
213
214%files -n compat32-libattr
215/%{_lib}/libattr.so.*
216%endif
217
218%changelog
219* Sat Apr  9 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.44-1
220- new upstream release
221- remove static library from devel package
222- added Patch2-9
223  * Tue Mar 29 2011 Kamil Dudka <kdudka@redhat.com> 2.2.44-8
224  - fix typos in attr(1) man page (#669095)
225  * Wed Dec 22 2010 Kamil Dudka <kdudka@redhat.com> 2.2.44-6
226  - setfattr.1: document supported encodings of values (#587516)
227  - getfattr: encode NULs properly with --encoding=text (#650539)
228  - getfattr: return non-zero exit code on failure (#660619)
229  - walk_tree: do not follow symlink to directory with -h (#660613)
230  * Tue May 25 2010 Kamil Dudka <kdudka@redhat.com> 2.2.44-5
231  - let attr depend on the same version of libattr (#595689)
232  - silence compile-time warnings
233  * Wed Feb 18 2009 Zdenek Prikryl <zprikryl@redhat.com> 2.4.43-2
234  - Fixed memory leaks (#485473)
235
236* Wed Jul 15 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.43-2
237- added compat32 package for x86_64 arch support
238
239* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.43-1
240- new upstream release
241
242* Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.41-2
243- initial build for Vine Linux
244
245* Tue Feb 13 2008 Zdenek Prikryl <zprikryl@redhat.com> 2.4.41-1
246- New version 2.4.41
247- Removed useless attr-2.0.8-docperms.patch
248
249* Wed Oct 31 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.39-1
250- New version 2.4.39
251- Resolves #284121
252
253* Tue Oct 30 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.38-2
254- Removed explicit Requires(post + postun)
255- Resolves #225290
256
257* Tue Jul 31 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.38-1
258- New version 2.4.38
259- Resolves #245415
260
261* Fri Feb 23 2007 Karsten Hopp <karsten@redhat.com> 2.4.32-2
262- add disttag
263- remove trailing dot from summary
264- fix buildroot
265- -devel package requires same libattr version
266- change prereq to Requires(post)
267- escape macro in changelog
268- replace absolute link with relative link (libattr.so)
269- use %%doc macro
270
271* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.4.32-1.1
272- rebuild
273
274* Wed Jul  5 2006 Thomas Woerner <twoerne@redhat.com> 2.4.32-1
275- new version 2.4.32
276- fixes segmentation fault in attr, which affects #189106
277
278* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 2.4.28-2
279- rebuild for -devel deps
280
281* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.4.28-1.2
282- bump again for double-long bug on ppc(64)
283
284* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.4.28-1.1
285- rebuilt for new gcc4.1 snapshot and glibc changes
286
287* Fri Feb  3 2006 Thomas Woerner <twoerner@redhat.com> 2.4.28-1
288- new version 2.4.28
289
290* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
291- rebuilt
292
293* Tue Dec  6 2005 Thomas Woerner <twoerner@redhat.com> 2.4.24-2
294- spec file cleanup
295- mark po files as lang specific
296
297* Sun Nov 06 2005 Florian La Roche <laroche@redhat.com>
298- 2.4.24
299
300* Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.4.23-1
301- update to 2.4.23
302
303* Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.4.16-6
304- get rid of *.la files
305- remove duplicate doc files
306
307* Wed Feb  9 2005 Stephen C. Tweedie <sct@redhat.com> 2.4.16-4
308- Rebuild
309
310* Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.16-3
311- Build requires libtool >= 1.5
312
313* Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.16-2
314- Make libattr.so.* executable.
315
316* Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.16-1
317- Update to latest upstream version.
318
319* Sun Aug  8 2004 Alan Cox <alan@redhat.com> 2.4.1-6
320- Fix bug #125304 (Steve Grubb: build requires gettext)
321
322* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
323- rebuilt
324
325* Wed Mar 31 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.1-4
326- Add missing %%defattr
327
328* Tue Mar 30 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.1-3
329- Add /usr/include/attr to files manifest
330- Fix location of doc files, add main doc dir to files manifest
331
332* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
333- rebuilt
334
335* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
336- rebuilt
337
338* Tue Aug  5 2003 Elliot Lee <sopwith@redhat.com> 2.4.1-2
339- Fix libtool
340
341* Tue Jun  3 2003 Stephen C. Tweedie <sct@redhat.com> 2.4.1-1
342- update to attr-2.4.1
343
344* Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.0-1
345- update/rebuild
346
347* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 2.0.8-6
348- set execute bits on library so that requires are generated.
349
350* Thu Nov 21 2002 Elliot Lee <sopwith@redhat.com> 2.0.8-5
351- Redo multilib patch to work everywhere
352
353* Wed Sep 11 2002 Than Ngo <than@redhat.com> 2.0.8-4
354- Added fix to install libs in correct directory on 64bit machine
355
356* Thu Aug 08 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-3
357- Made the package only own the one directory that is unique to it:
358  /usr/include/attr
359
360* Wed Jun 26 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-2
361- get perl out of base with attr-2.0.8-docperms.patch
362
363* Mon Jun 24 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-1
364- Initial Red Hat package
365  Made as few changes as possible relative to upstream packaging to
366  make it easier to maintain long-term.  This means that some of
367  the techniques used here are definitely not standard Red Hat
368  techniques.  If you are looking for an example package to fit
369  into Red Hat Linux transparently, this would not be the one to
370  pick.
371- attr-devel -> libattr-devel
Note: See TracBrowser for help on using the repository browser.