source: projects/specs/branches/6/a/atlas/atlas-vl.spec @ 5915

Revision 5915, 25.1 KB checked in by kenta, 12 years ago (diff)

atlas: initial build for Vine Linux

Line 
1%define enable_native_atlas 0
2
3Name:           atlas
4Version:        3.8.4
5%if "%{?enable_native_atlas}" != "0"
6%define dist .native
7%endif
8Release:        4%{?_dist_release}
9Summary:        Automatically Tuned Linear Algebra Software
10
11Group:          System Environment/Libraries
12License:        BSD
13URL:            http://math-atlas.sourceforge.net/
14Source0:        http://downloads.sourceforge.net/math-atlas/%{name}%{version}.tar.bz2
15Source1:        PPRO32.tgz
16Source2:        K7323DNow.tgz
17Source3:        README.Fedora
18Source4:        USII64.tgz                                             
19Source5:        USII32.tgz                                             
20Source6:        IBMz1032.tgz
21Source7:        IBMz1064.tgz
22Source8:        IBMz19632.tgz
23Source9:        IBMz19664.tgz
24Patch0:         atlas-fedora_shared.patch
25Patch1:         atlas-s390port.patch
26Patch2:         atlas-fedora-arm.patch
27BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
28
29BuildRequires:  gcc-gfortran lapack-static
30
31%description
32The ATLAS (Automatically Tuned Linear Algebra Software) project is an
33ongoing research effort focusing on applying empirical techniques in
34order to provide portable performance. At present, it provides C and
35Fortran77 interfaces to a portably efficient BLAS implementation, as
36well as a few routines from LAPACK.
37
38The performance improvements in ATLAS are obtained largely via
39compile-time optimizations and tend to be specific to a given hardware
40configuration. In order to package ATLAS for Fedora some compromises
41are necessary so that good performance can be obtained on a variety
42of hardware. This set of ATLAS binary packages is therefore not
43necessarily optimal for any specific hardware configuration.  However,
44the source package can be used to compile customized ATLAS packages;
45see the documentation for information.
46
47%package devel
48Summary:        Development libraries for ATLAS
49Group:          Development/Libraries
50Requires:       %{name} = %{version}-%{release}
51Obsoletes:      %name-header <= %version-%release
52Requires(posttrans):    chkconfig
53Requires(preun):        chkconfig
54Requires(post):         /usr/sbin/alternatives
55Requires(postun):       /usr/sbin/alternatives
56
57%description devel
58This package contains the libraries and headers for development
59with ATLAS (Automatically Tuned Linear Algebra Software).
60
61%define types base
62
63%if "%{?enable_native_atlas}" == "0"
64############## Subpackages for architecture extensions #################
65#
66%ifarch x86_64
67%define types base sse3
68
69%package sse3
70Summary:        ATLAS libraries for SSE3 extensions
71Group:          System Environment/Libraries
72
73%description sse3
74This package contains the ATLAS (Automatically Tuned Linear Algebra
75Software) libraries compiled with optimizations for the SSE3
76extensions to the x86_64 architecture. The base ATLAS builds in Fedora for the
77x86_64 architecture are made for the SSE2 extensions.
78
79%package sse3-devel
80Summary:        Development libraries for ATLAS with SSE3 extensions
81Group:          Development/Libraries
82Requires:       %{name}-sse3 = %{version}-%{release}
83Obsoletes:      %name-header <= %version-%release
84Requires(posttrans):    chkconfig
85Requires(preun):        chkconfig
86Requires(post):         /usr/sbin/alternatives
87Requires(postun):       /usr/sbin/alternatives
88
89%description sse3-devel
90This package contains shared and static versions of the ATLAS
91(Automatically Tuned Linear Algebra Software) libraries compiled with
92optimizations for the SSE3 extensions to the x86_64 architecture.
93
94%endif
95
96%ifarch %{ix86}
97%define types base 3dnow sse sse2 sse3
98
99%package 3dnow
100Summary:        ATLAS libraries for 3DNow extensions
101Group:          System Environment/Libraries
102
103%description 3dnow
104This package contains the ATLAS (Automatically Tuned Linear Algebra
105Software) libraries compiled with optimizations for the 3DNow extension
106to the ix86 architecture. Fedora also produces ATLAS build with SSE, SSE2
107and SSE3 extensions.
108
109%package 3dnow-devel
110Summary:        Development libraries for ATLAS with 3DNow extensions
111Group:          Development/Libraries
112Requires:       %{name}-3dnow = %{version}-%{release}
113Obsoletes:      %name-header <= %version-%release
114Requires(posttrans):    chkconfig
115Requires(preun):        chkconfig
116
117%description 3dnow-devel
118This package contains headers and shared versions of the ATLAS
119(Automatically Tuned Linear Algebra Software) libraries compiled with
120optimizations for the 3DNow extensions to the ix86 architecture.
121
122%package sse
123Summary:        ATLAS libraries for SSE extensions
124Group:          System Environment/Libraries
125
126%description sse
127This package contains the ATLAS (Automatically Tuned Linear Algebra
128Software) libraries compiled with optimizations for the SSE(1) extensions
129to the ix86 architecture. Fedora also produces ATLAS build with SSE2 and SSE3
130extensions.
131
132%package sse-devel
133Summary:        Development libraries for ATLAS with SSE extensions
134Group:          Development/Libraries
135Requires:       %{name}-sse = %{version}-%{release}
136Obsoletes:      %name-header <= %version-%release
137Requires(posttrans):    chkconfig
138Requires(preun):        chkconfig
139
140%description sse-devel
141This package contains headers and shared versions of the ATLAS
142(Automatically Tuned Linear Algebra Software) libraries compiled with
143optimizations for the SSE(1) extensions to the ix86 architecture.
144
145%package sse2
146Summary:        ATLAS libraries for SSE2 extensions
147Group:          System Environment/Libraries
148
149%description sse2
150This package contains ATLAS (Automatically Tuned Linear Algebra Software)
151shared libraries compiled with optimizations for the SSE2
152extensions to the ix86 architecture. Fedora also produces ATLAS build with
153SSE(1) and SSE3 extensions.
154
155%package sse2-devel
156Summary:        Development libraries for ATLAS with SSE2 extensions
157Group:          Development/Libraries
158Requires:       %{name}-sse2 = %{version}-%{release}
159Obsoletes:      %name-header <= %version-%release
160Requires(posttrans):    chkconfig
161Requires(preun):        chkconfig
162
163%description sse2-devel
164This package contains ATLAS (Automatically Tuned Linear Algebra Software)
165shared libraries compiled with optimizations for the SSE2 extensions to the
166ix86 architecture.
167
168%package sse3
169Summary:        ATLAS libraries for SSE3 extensions
170Group:          System Environment/Libraries
171
172%description sse3
173This package contains the ATLAS (Automatically Tuned Linear Algebra
174Software) libraries compiled with optimizations for the SSE3.
175Fedora also produces ATLAS build with SSE(1) and SSE2 extensions.
176
177%package sse3-devel
178Summary:        Development libraries for ATLAS with SSE3 extensions
179Group:          Development/Libraries
180Requires:       %{name}-sse3 = %{version}-%{release}
181Obsoletes:      %name-header <= %version-%release
182Requires(posttrans):    chkconfig
183Requires(preun):        chkconfig
184
185%description sse3-devel
186This package contains ATLAS (Automatically Tuned Linear Algebra Software)
187shared libraries compiled with optimizations for the SSE3 extensions to the ix86 architecture.
188
189%endif
190
191%ifarch s390 s390x
192%define types base z10 z196
193
194%package z196
195Summary:        ATLAS libraries for z196
196Group:          System Environment/Libraries
197
198%description z196
199This package contains the ATLAS (Automatically Tuned Linear Algebra
200Software) libraries compiled with optimizations for the z196.
201
202%package z196-devel
203Summary:        Development libraries for ATLAS for z196
204Group:          Development/Libraries
205Requires:       %{name}-z196 = %{version}-%{release}
206Obsoletes:      %name-header <= %version-%release
207Requires(posttrans):    chkconfig
208Requires(preun):        chkconfig
209
210%description z196-devel
211This package contains headers and shared versions of the ATLAS
212(Automatically Tuned Linear Algebra Software) libraries compiled with
213optimizations for the z196 architecture.
214
215%package z10
216Summary:        ATLAS libraries for z10
217Group:          System Environment/Libraries
218
219%description z10
220This package contains the ATLAS (Automatically Tuned Linear Algebra
221Software) libraries compiled with optimizations for the z10.
222
223%package z10-devel
224Summary:        Development libraries for ATLAS for z10
225Group:          Development/Libraries
226Requires:       %{name}-z10 = %{version}-%{release}
227Obsoletes:      %name-header <= %version-%release
228Requires(posttrans):    chkconfig
229Requires(preun):        chkconfig
230
231%description z10-devel
232This package contains headers and shared versions of the ATLAS
233(Automatically Tuned Linear Algebra Software) libraries compiled with
234optimizations for the z10 architecture.
235
236%endif
237%endif
238
239%global mode %{__isa_bits}
240%ifarch %{arm}
241%define arch_option -A 38
242%define threads_option -t 2
243%global mode ' '
244%endif
245
246%prep
247%setup -q -n ATLAS
248%patch0 -p0 -b .shared
249%ifarch s390 s390x
250%patch1 -p1 -b .s390
251%endif
252%ifarch %{arm}
253%patch2 -p0 -b .arm
254%endif
255cp %{SOURCE1} CONFIG/ARCHS/
256cp %{SOURCE2} CONFIG/ARCHS/
257cp %{SOURCE3} doc
258cp %{SOURCE4} CONFIG/ARCHS/
259cp %{SOURCE5} CONFIG/ARCHS/
260cp %{SOURCE6} CONFIG/ARCHS/
261cp %{SOURCE7} CONFIG/ARCHS/
262cp %{SOURCE8} CONFIG/ARCHS/
263cp %{SOURCE9} CONFIG/ARCHS/
264
265%build
266for type in %{types}; do
267        if [ "$type" = "base" ]; then
268                libname=atlas
269                %define pr_base %(echo $((%{__isa_bits}+0)))
270        else
271                libname=atlas-${type}
272        fi
273        mkdir -p %{_arch}_${type}
274        pushd %{_arch}_${type}
275        ../configure -b %{mode} %{?threads_option} %{?arch_option} -D c -DWALL -Fa alg '-g -Wa,--noexecstack -fPIC'\
276        --prefix=%{buildroot}%{_prefix}                 \
277        --incdir=%{buildroot}%{_includedir}             \
278        --libdir=%{buildroot}%{_libdir}/${libname}      \
279        --with-netlib-lapack=%{_libdir}/liblapack_pic.a
280
281%if "%{?enable_native_atlas}" == "0"
282%ifarch x86_64
283        if [ "$type" = "base" ]; then
284                sed -i 's#ARCH =.*#ARCH = HAMMER64SSE2#' Make.inc
285                sed -i 's#-DATL_SSE3##' Make.inc
286                sed -i 's#-msse3#-msse2#' Make.inc
287        elif [ "$type" = "sse3" ]; then
288                sed -i 's#ARCH =.*#ARCH = HAMMER64SSE3#' Make.inc
289                %define pr_sse3 %(echo $((%{__isa_bits}+4)))
290        fi
291%endif
292
293%ifarch %{ix86}
294        if [ "$type" = "base" ]; then
295                sed -i 's#ARCH =.*#ARCH = PPRO32#' Make.inc
296                sed -i 's#-DATL_SSE3 -DATL_SSE2 -DATL_SSE1##' Make.inc
297                sed -i 's#-mfpmath=sse -msse3#-mfpmath=387#' Make.inc
298        elif [ "$type" = "3dnow" ]; then
299                sed -i 's#ARCH =.*#ARCH = K7323DNow#' Make.inc
300                sed -i 's#-DATL_SSE3 -DATL_SSE2 -DATL_SSE1##' Make.inc
301                sed -i 's#-mfpmath=sse -msse3#-mfpmath=387#' Make.inc
302                %define pr_3dnow %(echo $((%{__isa_bits}+1)))
303        elif [ "$type" = "sse" ]; then
304                sed -i 's#ARCH =.*#ARCH = PIII32SSE1#' Make.inc
305                sed -i 's#-DATL_SSE3 -DATL_SSE2##' Make.inc
306                sed -i 's#-msse3#-msse#' Make.inc
307                %define pr_sse %(echo $((%{__isa_bits}+2)))
308        elif [ "$type" = "sse2" ]; then
309                sed -i 's#ARCH =.*#ARCH = P432SSE2#' Make.inc
310                sed -i 's#-DATL_SSE3##' Make.inc
311                sed -i 's#-msse3#-msse2#' Make.inc
312                %define pr_sse2 %(echo $((%{__isa_bits}+3)))
313        elif [ "$type" = "sse3" ]; then
314                sed -i 's#ARCH =.*#ARCH = P4E32SSE3#' Make.inc
315                %define pr_sse3 %(echo $((%{__isa_bits}+4)))
316        fi
317%endif
318
319%ifarch s390 s390x
320# we require a z9/z10/z196 but base,z10 and z196
321# we also need a compiler with -march=z196 support
322# the base support will use z196 tuning
323        if [ "$type" = "base" ]; then
324                %ifarch s390x
325                        sed -i 's#ARCH =.*#ARCH = IBMz19664#' Make.inc
326                %endif
327                %ifarch s390
328                        sed -i 's#ARCH =.*#ARCH = IBMz19632#' Make.inc
329                %endif
330                sed -i 's#-march=z196#-march=z9-109 -mtune=z196#' Make.inc
331                sed -i 's#-march=z10 -mtune=z196#-march=z9-109 -mtune=z196#' Make.inc
332                sed -i 's#-march=z10#-march=z9-109 -mtune=z10#' Make.inc
333                sed -i 's#-DATL_ARCH_IBMz196#-DATL_ARCH_IBMz9#' Make.inc
334                sed -i 's#-DATL_ARCH_IBMz10#-DATL_ARCH_IBMz9#' Make.inc
335                sed -i 's#-DATL_ARCH_IBMz9#-DATL_ARCH_IBMz9#' Make.inc
336        elif [ "$type" = "z10" ]; then
337                %ifarch s390x
338                        sed -i 's#ARCH =.*#ARCH = IBMz1064#' Make.inc
339                %endif
340                %ifarch s390
341                        sed -i 's#ARCH =.*#ARCH = IBMz1032#' Make.inc
342                %endif
343                sed -i 's#-march=z196#-march=z10#' Make.inc
344                sed -i 's#-march=z10 -mtune=z196#-march=z10#' Make.inc
345                sed -i 's#-march=z9-109#-march=z10#' Make.inc
346                sed -i 's#-DATL_ARCH_IBMz196#-DATL_ARCH_IBMz10#' Make.inc
347                sed -i 's#-DATL_ARCH_IBMz9#-DATL_ARCH_IBMz10#' Make.inc
348                %define pr_z10 %(echo $((%{__isa_bits}+1)))
349        elif [ "$type" = "z196" ]; then
350                %ifarch s390x
351                        sed -i 's#ARCH =.*#ARCH = IBMz19664#' Make.inc
352                %endif
353                %ifarch s390
354                        sed -i 's#ARCH =.*#ARCH = IBMz19632#' Make.inc
355                %endif
356                sed -i 's#-march=z196#-march=z10 -mtune=z196#' Make.inc
357                sed -i 's#-march=z10#-march=z10 -mtune=z196#' Make.inc
358                sed -i 's#-march=z9-109#-march=z10 -mtune=z196#' Make.inc
359                sed -i 's#-DATL_ARCH_IBMz10#-DATL_ARCH_IBMz196#' Make.inc
360                sed -i 's#-DATL_ARCH_IBMz9#-DATL_ARCH_IBMz196#' Make.inc
361                %define pr_z196 %(echo $((%{__isa_bits}+2)))
362        fi
363%endif
364
365%endif
366        make build
367        cd lib
368        make shared
369        make ptshared
370        popd
371done
372
373%install
374rm -rf %{buildroot}
375for type in %{types}; do
376        pushd %{_arch}_${type}
377        make DESTDIR=%{buildroot} install
378        mv %{buildroot}%{_includedir}/atlas %{buildroot}%{_includedir}/atlas-%{_arch}-${type}
379        if [ "$type" = "base" ]; then
380                cp -pr lib/*.so* %{buildroot}%{_libdir}/atlas/
381                rm -f %{buildroot}%{_libdir}/atlas/*.a
382        else
383                cp -pr lib/*.so* %{buildroot}%{_libdir}/atlas-${type}/
384                rm -f %{buildroot}%{_libdir}/atlas-${type}/*.a
385        fi
386        popd
387
388        mkdir -p %{buildroot}/etc/ld.so.conf.d
389        if [ "$type" = "base" ]; then
390                echo "%{_libdir}/atlas"         \
391                > %{buildroot}/etc/ld.so.conf.d/atlas-%{_arch}.conf
392        else
393                echo "%{_libdir}/atlas-${type}" \
394                > %{buildroot}/etc/ld.so.conf.d/atlas-%{_arch}-${type}.conf
395        fi
396done
397mkdir -p %{buildroot}%{_includedir}/atlas
398
399
400%clean
401rm -rf %{buildroot}
402
403%post -p /sbin/ldconfig
404
405%postun -p /sbin/ldconfig
406
407%posttrans devel
408if [ $1 -eq 0 ] ; then
409/usr/sbin/alternatives  --install %{_includedir}/atlas atlas-inc        \
410                %{_includedir}/atlas-%{_arch}-base %{pr_base}
411fi
412
413%preun devel
414if [ $1 -ge 0 ] ; then
415/usr/sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-base
416fi
417
418%if "%{?enable_native_atlas}" == "0"
419%ifarch x86_64
420
421%post -n atlas-sse3 -p /sbin/ldconfig
422
423%postun -n atlas-sse3 -p /sbin/ldconfig
424
425%posttrans sse3-devel
426if [ $1 -eq 0 ] ; then
427/usr/sbin/alternatives  --install %{_includedir}/atlas atlas-inc        \
428                %{_includedir}/atlas-%{_arch}-sse3  %{pr_sse3}
429fi
430
431%preun sse3-devel
432if [ $1 -ge 0 ] ; then
433/usr/sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-sse3
434fi
435
436%endif
437
438%ifarch %{ix86}
439%post -n atlas-3dnow -p /sbin/ldconfig
440
441%postun -n atlas-3dnow -p /sbin/ldconfig
442
443%posttrans 3dnow-devel
444if [ $1 -eq 0 ] ; then
445/usr/sbin/alternatives  --install %{_includedir}/atlas atlas-inc        \
446                %{_includedir}/atlas-%{_arch}-3dnow  %{pr_3dnow}
447fi
448
449%preun 3dnow-devel
450if [ $1 -ge 0 ] ; then
451/usr/sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-3dnow
452fi
453
454%post -n atlas-sse -p /sbin/ldconfig
455
456%postun -n atlas-sse -p /sbin/ldconfig
457
458%posttrans sse-devel
459if [ $1 -eq 0 ] ; then
460/usr/sbin/alternatives  --install %{_includedir}/atlas atlas-inc        \
461                %{_includedir}/atlas-%{_arch}-sse  %{pr_sse}
462fi
463
464%preun sse-devel
465if [ $1 -ge 0 ] ; then
466/usr/sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-sse
467fi
468
469%post -n atlas-sse2 -p /sbin/ldconfig
470
471%postun -n atlas-sse2 -p /sbin/ldconfig
472
473%posttrans sse2-devel
474if [ $1 -eq 0 ] ; then
475/usr/sbin/alternatives  --install %{_includedir}/atlas atlas-inc        \
476                %{_includedir}/atlas-%{_arch}-sse2  %{pr_sse2}
477fi
478
479%preun sse2-devel
480if [ $1 -ge 0 ] ; then
481/usr/sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-sse2
482fi
483
484%post -n atlas-sse3 -p /sbin/ldconfig
485
486%postun -n atlas-sse3 -p /sbin/ldconfig
487
488%posttrans sse3-devel
489if [ $1 -eq 0 ] ; then
490/usr/sbin/alternatives  --install %{_includedir}/atlas atlas-inc        \
491                %{_includedir}/atlas-%{_arch}-sse3  %{pr_sse3}
492fi
493
494%preun sse3-devel
495if [ $1 -ge 0 ] ; then
496/usr/sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-sse3
497fi
498
499%endif
500
501%ifarch s390 s390x
502%post -n atlas-z10 -p /sbin/ldconfig
503
504%postun -n atlas-z10 -p /sbin/ldconfig
505
506%posttrans z10-devel
507if [ $1 -eq 0 ] ; then
508/usr/sbin/alternatives  --install %{_includedir}/atlas atlas-inc        \
509                %{_includedir}/atlas-%{_arch}-z10  %{pr_z10}
510fi
511
512%preun z10-devel
513if [ $1 -ge 0 ] ; then
514/usr/sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-z10
515fi
516
517%post -n atlas-z196 -p /sbin/ldconfig
518
519%postun -n atlas-z196 -p /sbin/ldconfig
520
521%posttrans z196-devel
522if [ $1 -eq 0 ] ; then
523/usr/sbin/alternatives  --install %{_includedir}/atlas atlas-inc        \
524                %{_includedir}/atlas-%{_arch}-z196  %{pr_z196}
525fi
526
527%preun z196-devel
528if [ $1 -ge 0 ] ; then
529/usr/sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-z196
530fi
531
532%endif
533
534%endif
535
536%files
537%defattr(-,root,root,-)
538%doc doc/README.Fedora
539%dir %{_libdir}/atlas
540%{_libdir}/atlas/*.so.*
541%config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}.conf
542
543%files devel
544%defattr(-,root,root,-)
545%doc doc
546%{_libdir}/atlas/*.so
547%{_includedir}/atlas-%{_arch}-base/
548%{_includedir}/*.h
549%ghost %{_includedir}/atlas
550
551%if "%{?enable_native_atlas}" == "0"
552
553%ifarch x86_64
554
555%files sse3
556%defattr(-,root,root,-)
557%doc doc/README.Fedora
558%dir %{_libdir}/atlas-sse3
559%{_libdir}/atlas-sse3/*.so.*
560%config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}-sse3.conf
561
562%files sse3-devel
563%defattr(-,root,root,-)
564%doc doc
565%{_libdir}/atlas-sse3/*.so
566%{_includedir}/atlas-%{_arch}-sse3/
567%{_includedir}/*.h
568%ghost %{_includedir}/atlas
569
570%endif
571
572%ifarch %{ix86}
573
574%files 3dnow
575%defattr(-,root,root,-)
576%doc doc/README.Fedora
577%dir %{_libdir}/atlas-3dnow
578%{_libdir}/atlas-3dnow/*.so.*
579%config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}-3dnow.conf
580
581%files 3dnow-devel
582%defattr(-,root,root,-)
583%doc doc
584%{_libdir}/atlas-3dnow/*.so
585%{_includedir}/atlas-%{_arch}-3dnow/
586%{_includedir}/*.h
587%ghost %{_includedir}/atlas
588
589%files sse
590%defattr(-,root,root,-)
591%doc doc/README.Fedora
592%dir %{_libdir}/atlas-sse
593%{_libdir}/atlas-sse/*.so.*
594%config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}-sse.conf
595
596%files sse-devel
597%defattr(-,root,root,-)
598%doc doc
599%{_libdir}/atlas-sse/*.so
600%{_includedir}/atlas-%{_arch}-sse/
601%{_includedir}/*.h
602%ghost %{_includedir}/atlas
603
604%files sse2
605%defattr(-,root,root,-)
606%doc doc/README.Fedora
607%dir %{_libdir}/atlas-sse2
608%{_libdir}/atlas-sse2/*.so.*
609%config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}-sse2.conf
610
611%files sse2-devel
612%defattr(-,root,root,-)
613%doc doc
614%{_libdir}/atlas-sse2/*.so
615%{_includedir}/atlas-%{_arch}-sse2/
616%{_includedir}/*.h
617%ghost %{_includedir}/atlas
618
619%files sse3
620%defattr(-,root,root,-)
621%doc doc/README.Fedora
622%dir %{_libdir}/atlas-sse3
623%{_libdir}/atlas-sse3/*.so.*
624%config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}-sse3.conf
625
626%files sse3-devel
627%defattr(-,root,root,-)
628%doc doc
629%{_libdir}/atlas-sse3/*.so
630%{_includedir}/atlas-%{_arch}-sse3/
631%{_includedir}/*.h
632%ghost %{_includedir}/atlas
633
634%endif
635
636%ifarch s390 s390x
637%files z10
638%defattr(-,root,root,-)
639%doc doc/README.Fedora
640%dir %{_libdir}/atlas-z10
641%{_libdir}/atlas-z10/*.so.*
642%config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}-z10.conf
643
644%files z10-devel
645%defattr(-,root,root,-)
646%doc doc
647%{_libdir}/atlas-z10/*.so
648%{_includedir}/atlas-%{_arch}-z10/
649%{_includedir}/*.h
650%ghost %{_includedir}/atlas
651
652%files z196
653%defattr(-,root,root,-)
654%doc doc/README.Fedora
655%dir %{_libdir}/atlas-z196
656%{_libdir}/atlas-z196/*.so.*
657%config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}-z196.conf
658
659%files z196-devel
660%defattr(-,root,root,-)
661%doc doc
662%{_libdir}/atlas-z196/*.so
663%{_includedir}/atlas-%{_arch}-z196/
664%{_includedir}/*.h
665%ghost %{_includedir}/atlas
666%endif
667%endif
668
669%changelog
670* Thu Mar 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.8.4-4
671- initial build for Vine Linux
672
673* Thu Sep 01 2011 Deji Akingunola <dakingun@gmail.com> - 3.8.4-3
674- Apply patch to enable arm build (Patch provided by Jitesh Shah <jiteshs@marvell.com>)
675- Stop turning off throttle checking, upstream frown at it (seems O.K. for Koji)
676
677* Mon Jun 20 2011 Dan Horák <dan[at]danny.cz> - 3.8.4-2
678- Use -march=z10 for z196 optimised build because the builder is a z10
679  (Christian Bornträger)
680
681* Tue Jun 14 2011 Deji Akingunola <dakingun@gmail.com> - 3.8.4-1
682- Update to 3.8.4
683- Build the default package for SSE2 and add a SSE3 subpackage on x86_64
684- Apply patch (and arch defs.) to build on s390 and s390x (Dan Horák)
685- Fix-up build on s390 and s390x (Christian Bornträger)
686
687* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
688- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
689
690* Mon Jul 26 2010 Deji Akingunola <dakingun@gmail.com> - 3.8.3-18
691- Create a subpackage for SSE2 on x86_64
692
693* Sat Jul 17 2010 Dan Horák <dan[at]danny.cz> - 3.8.3-17
694- rebuild against fixed lapack libraries
695
696* Thu Jul 15 2010 Dan Horák <dan[at]danny.cz> - 3.8.3-16
697- fix build on s390 (patch by Karsten Hopp)
698
699* Wed Feb 10 2010 Deji Akingunola <dakingun@gmail.com> - 3.8.3-15
700- Disable the problematic sparc patch
701- Change lapack-devel BR to lapack-static, where liblapack_pic.a now resides.
702
703* Wed Feb 03 2010 Dennis Gilmore <dennis@ausil.us> - 3.8.3-14
704- fix sparc build
705
706* Fri Jan 29 2010 Deji Akingunola <dakingun@gmail.com> - 3.8.3-13
707- Remove static libraries.
708- Fix typo in SSE3 subpackage's summary.
709
710* Sat Oct 24 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-12
711- Use alternatives to workaround multilib conflicts (BZ#508565).
712
713* Tue Sep 29 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-11
714- Obsolete the -header subpackage properly.
715
716* Sat Sep 26 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-10
717- Use the new arch. default for Pentium PRO (Fedora bug #510498)
718- (Re-)Introduce 3dNow subpackage
719
720* Sun Sep  6 2009 Alex Lancaster <alexlan[AT]fedoraproject org> - 3.8.3-9
721- Rebuild against fixed lapack (see #520518)
722
723* Wed Aug 13 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-8
724- Revert the last change, it doesn't solve the problem.
725
726* Tue Aug 04 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-7
727- Create a -header subpackage to avoid multilib conflicts (BZ#508565).
728
729* Tue Aug 04 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-6
730- Add '-g' to build flag to allow proper genration of debuginfo subpackages (Fedora bug #509813)
731- Build for F12
732
733* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.8.3-5
734- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
735
736* Sat May 02 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-4
737- Use the right -msse* option for the -sse* subpackages (Fedora bug #498715)
738
739* Tue Apr 21 2009 Karsten Hopp <karsten@redhat.com> 3.8.3-3.1
740- add s390x to 64 bit archs
741
742* Fri Feb 27 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-3
743- Rebuild
744
745* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.8.3-2
746- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
747
748* Sun Feb 22 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-1
749- Update to version 3.8.3
750
751* Sun Dec 21 2008 Deji Akingunola <dakingun@gmail.com> - 3.8.2-5
752- Link in appropriate libs when creating shared libs, reported by Orcan 'oget' Ogetbil (BZ#475411)
753
754* Tue Dec 16 2008 Deji Akingunola <dakingun@gmail.com> - 3.8.2-4
755- Don't symlink the atlas libdir on i386, cause upgrade issue (BZ#476787)
756- Fix options passed to gcc when making shared libs
757
758* Tue Dec 16 2008 Deji Akingunola <dakingun@gmail.com> - 3.8.2-3
759- Use 'gcc -shared' to build shared libs instead of stock 'ld'
760
761* Sat Dec 13 2008 Deji Akingunola <dakingun@gmail.com> - 3.8.2-2
762- Properly obsolete/provide older subpackages that are no longer packaged.
763
764* Mon Sep 01 2008 Deji Akingunola <dakingun@gmail.com> - 3.8.2-1
765- Upgrade to ver 3.8.2 with refined build procedures.
766
767* Thu Feb 28 2008 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-15
768- Disable altivec package--it is causing illegal instructions during build.
769
770* Thu Feb 28 2008 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-14
771- Enable compilation on alpha (bug 426086).
772- Patch for compilation on ia64 (bug 432744).
773
774* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.6.0-13
775- Autorebuild for GCC 4.3
776
777* Mon Jun  4 2007 Orion Poplawski <orion@cora.nwra.com> 3.6.0-12
778- Rebuild for ppc64
779
780* Fri Sep  8 2006 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-11
781- Rebuild for FC6.
782- Remove outdated comments from spec file.
783
784* Mon Feb 13 2006 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-10
785- Rebuild for Fedora Extras 5.
786- Add --noexecstack to compilation of assembly kernels. These were
787  previously marked executable, which caused problems with selinux.
788
789* Mon Dec 19 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-9
790- Rebuild for gcc 4.1.
791
792* Mon Oct 10 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-8
793- Make all devel subpackages depend on their non-devel counterparts.
794- Add /etc/ld.so.conf.d files for -sse and -3dnow, because they don't
795  seem to get picked up automatically.
796
797* Wed Oct 05 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-7
798- Forgot to add the new patch to sources.
799
800* Tue Oct 04 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-6
801- Use new Debian patch, and enable shared libs (they previously failed
802  to build on gcc 4).
803- Minor updates to description and README.Fedora file.
804- Fix buildroot name to match FE preferred form.
805- Fixes for custom optimized builds.
806- Add dist tag.
807
808* Wed Sep 28 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-5
809- fix files lists.
810
811* Mon Sep 26 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-4
812- generate library symlinks earlier for the benefit of later linking steps.
813
814* Wed Sep 14 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-3
815- Change lapack dependency to lapack-devel, and use lapack_pic.a for
816  building liblapack.so.
817
818* Wed Sep 14 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-2
819- Add "bit" macro to correctly build on x86_64.
820
821* Tue Aug 16 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-1
822- Initial version.
Note: See TracBrowser for help on using the repository browser.