source: projects/specs/branches/6/a/atk/atk-vl.spec @ 2041

Revision 2041, 8.6 KB checked in by Takemikaduchi, 14 years ago (diff)

update to GNOME-2.32.0

Line 
1# Something's not quite right with libtool....
2%define __libtoolize :
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4
5%define glib2_base_version 2.26.0
6%define glib2_version %{glib2_base_version}
7
8Summary: Interfaces for accessibility support.
9Summary(ja): アクセシビリティサポートのためのインタフェース
10Name: atk
11Version: 1.32.0
12Release: 1%{?_dist_release}
13License: LGPL
14Group: System Environment/Libraries
15Source: ftp://ftp.gnome.org/pub/GNOME/sources/atk/1.32/atk-%{version}.tar.bz2
16URL: http://developer.gnome.org/projects/gap/
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: glib2-devel >= %{glib2_version}
19BuildRequires: gobject-introspection-devel >= 0.6.7
20
21%description
22The ATK library provides a set of interfaces for adding accessibility
23support to applications and graphical user interface toolkits. By
24supporting the ATK interfaces, an application or toolkit can be used
25with tools such as screen readers, magnifiers, and alternative input
26devices.
27
28%package -n compat32-%{name}
29Summary: Interfaces for accessibility support.
30Summary(ja): アクセシビリティサポートのためのインタフェース
31Group: System Environment/Libraries
32Requires: atk = %{version}
33
34%description -n compat32-%{name}
35The ATK library provides a set of interfaces for adding accessibility
36support to applications and graphical user interface toolkits. By
37supporting the ATK interfaces, an application or toolkit can be used
38with tools such as screen readers, magnifiers, and alternative input
39devices.
40
41%package devel
42Summary: Accessability Toolkit development files
43Summary(ja): アクセシビリティツールキットの開発用ファイル
44Group: Development/Libraries
45Requires: atk = %{version}
46Requires: glib2-devel >= %{glib2_version}
47
48%description devel
49The atk-devel package includes the static libraries, header files, and
50developer docs for the atk package.
51
52Install atk-devel if you want to develop programs which will use ATK.
53
54%package -n compat32-%{name}-devel
55Summary: Accessability Toolkit development files
56Summary(ja): アクセシビリティツールキットの開発用ファイル
57Group: Development/Libraries
58Requires: %{name}-devel    = %{version}
59Requires: compat32-%{name} = %{version}
60
61%description -n compat32-%{name}-devel
62The atk-devel package includes the static libraries, header files, and
63developer docs for the atk package.
64
65Install atk-devel if you want to develop programs which will use ATK.
66
67%prep
68%setup -q -n atk-%{version}
69
70%build
71#libtoolize --force --copy
72#aclocal
73#autoconf
74%configure --disable-gtk-doc --enable-introspection=yes
75make %{?_smp_mflags}
76
77%install
78rm -rf $RPM_BUILD_ROOT
79
80%makeinstall
81
82%find_lang atk10
83
84# remove unpackaged files
85rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%post -p /sbin/ldconfig
91
92%postun -p /sbin/ldconfig
93
94%post -n compat32-%{name} -p /sbin/ldconfig
95
96%postun -n compat32-%{name} -p /sbin/ldconfig
97
98
99%files -f atk10.lang
100%defattr(-, root, root)
101%doc README AUTHORS COPYING ChangeLog
102%{_libdir}/libatk*.so.*
103%{_libdir}/girepository-1.0
104
105%files devel
106%defattr(-, root, root)
107%{_includedir}/*
108%{_libdir}/libatk*.so
109%{_libdir}/pkgconfig/*.pc
110%{_datadir}/gtk-doc/*
111%{_datadir}/gir-1.0
112
113%if %{build_compat32}
114%files -n compat32-%{name}
115%defattr(-, root, root)
116%{_libdir}/libatk*.so.*
117
118%files -n compat32-%{name}-devel
119%defattr(-, root, root)
120%{_libdir}/libatk*.so
121%{_libdir}/pkgconfig/*.pc
122%endif
123
124%changelog
125* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.2-1
126- add BuildRequires: gobject-introspection-devel
127- add configure option (--enable-introspection=yes)
128
129* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.30.0-2
130- build with rpm-4.8.1-1 for pkg-config file
131
132* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
133- new upstream release
134
135* Fri Sep 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.28.0-1
136- new upstream release
137
138* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26.0-1
139- new upstream release
140
141* Mon Sep 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.24.0-1
142- new upstream release
143- spec in UTF-8
144
145* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.22.0-1vl5
146- used %%{?_dist_release}
147
148* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.22.0-0vl1
149- new upstream release
150
151* Sun Nov 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-0vl1
152- new upstream release
153
154* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18.0-0vl1
155- new upstream release
156
157* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.4-0vl1
158- new upstream release
159
160* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.1-0vl1
161- new upstream release
162
163* Fri Mar 17 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 1.11.3-0vl2
164- added compat32-* packages for x86_64 architecture support
165
166* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.3-0vl1
167- new upstream release
168
169* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.2-0vl1
170- new upstream release
171
172* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.3-0vl1
173- new upstream release
174
175* Fri May 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-0vl1
176- new upstream release
177
178* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0-0vl1
179- new upstream release
180
181* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
182- new upstream release
183
184* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.1-0vl1
185- new upstream release
186
187* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
188- new upstream release
189
190* Sun Feb 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-0vl1
191- new upstream release
192- fix kanji code of spec file.
193
194* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-0vl1
195- new upstream release
196
197* Mon Sep 01 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.6-0vl1
198- new upstream release
199
200* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.3-0vl1
201- new upstream release
202
203* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
204- new upstream release
205
206* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
207- new upstream release
208
209* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
210- new upstream release
211
212* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.4-0vl1
213- new upstream release
214- build for Vine Linux
215
216* Wed Jul 31 2002 Owen Taylor <otaylor@redhat.com>
217- Remove fixed-ltmain.sh
218- Version 1.0.3
219
220* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
221- automated rebuild
222
223* Tue Jun 04 2002 Havoc Pennington <hp@redhat.com>
224- rebuild in different environment
225
226* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
227- 1.0.2
228
229* Thu May 23 2002 Tim Powers <timp@redhat.com>
230- automated rebuild
231
232* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
233 - rebuild in different environment
234
235* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
236- Update to version 1.0.1
237
238* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
239- Version 1.0.0
240
241* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
242- Update to 0.13
243
244* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
245- Bump for rebuild
246
247* Mon Feb 18 2002 Havoc Pennington <hp@redhat.com>
248- rebuild for glib 1.3.14
249
250* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
251- add horrible buildrequires hack
252
253* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
254- 0.12.90 cvs snap
255
256* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
257- Version 0.10
258
259* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
260- automated rebuild
261
262* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
263- new snap 0.8.90
264
265* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
266- rebuild with glib hacked to work on 64-bit
267
268* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
269- Version 0.7
270- add explicit check for required glib2 version before we do the build,
271  so we don't end up with bad RPMs on --nodeps builds
272
273* Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
274- rebuild due to hosage on ia64 build system causing link to old glib
275
276* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
277- Version 0.6
278
279* Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
280- 0.5
281- sync with Owen's version
282
283* Wed Sep 19 2001 Havoc Pennington <hp@redhat.com>
284- 0.4
285- fix requires
286- --enable-static
287- put static libs back in file list
288
289* Mon Sep 10 2001 Havoc Pennington <hp@redhat.com>
290- update to CVS snapshot
291
292* Wed Sep 05 2001 Havoc Pennington <hp@redhat.com>
293- require specific pango version
294- fix ltmain.sh to destroy all relinking BS
295
296* Tue Sep  4 2001 root <root@dhcpd37.meridian.redhat.com>
297- Version 0.2
298
299* Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
300- Configure with --disable-gtk-doc
301
302* Tue Jul 10 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
303- Add post- and postun-sections running ldconfig
304
305* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
306- 0.2
307
308* Fri May  4 2001 Owen Taylor <otaylor@redhat.com>
309- Initial version
Note: See TracBrowser for help on using the repository browser.