source: projects/specs/branches/6/a/asymptote/asymptote-vl.spec @ 4027

Revision 4027, 14.5 KB checked in by munepi, 13 years ago (diff)

updated asymptote-vl.spec

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3
4%define texmf           %{_datadir}/texmf
5%define build_texmf     %{buildroot}%{texmf}
6
7%define exec_texhash    [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
8
9%define emacspkg asy-mode
10
11Name:           asymptote
12Version:        2.10
13Release:        1%{?_dist_release}
14Summary:        Descriptive vector graphics language
15Summary(ja):    MetaPost に触発されたスクリプトベースのベクターグラフィック言語
16
17Group:          Applications/Publishing
18License:        GPLv3+
19URL:            http://asymptote.sourceforge.net/
20Source0:        http://dl.sourceforge.net/sourceforge/asymptote/asymptote-%{version}.src.tgz
21Source1:        asy.gif
22Source2:        xasy.desktop
23#Source3:       asymptote.sty.204
24
25Source11:       %{emacspkg}-install.sh
26Source12:       %{emacspkg}-remove.sh
27#Source13:      %{name}-init.el
28
29#Patch0:         asymptote-2.00-settings.patch
30Patch0:         asymptote-2.00-settings-vine.patch
31Patch1:         asymptote-1.63-gcc44.patch
32Patch2:         asymptote-1.91-fix-implicit-DSO-linking-libGL.patch
33# This doesn't need to go upstream. We put the info file in the topdir, not a subdir, so we need this fix.
34Patch3:         asymptote-2.08-info-path-fix.patch
35BuildRoot:      %{_tmppath}/%{name}-%{version}-root
36
37BuildRequires:  ncurses-devel
38BuildRequires:  readline-devel
39BuildRequires:  fftw3-devel >= 3.0
40BuildRequires:  gc-devel >= 6.8
41BuildRequires:  gsl-devel
42BuildRequires:  texlive-common
43BuildRequires:  texlive-collection-texinfo
44BuildRequires:  texlive-collection-genericrecommended
45BuildRequires:  ghostscript
46BuildRequires:  texinfo
47BuildRequires:  ImageMagick
48BuildRequires:  desktop-file-utils
49BuildRequires:  freeglut-devel
50BuildRequires:  zlib-devel
51BuildRequires:  libtool
52
53Requires:       texlive-common
54
55Requires(post): desktop-file-utils
56Requires(postun): desktop-file-utils
57
58# for /usr/bin/texhash and /sbin/install-info
59Requires(post): texlive, info
60Requires(postun): texlive, info
61
62%define texpkgdir   %{texmf}/tex/latex/%{name}
63
64%description
65Asymptote is a powerful descriptive vector graphics language for technical
66drawings, inspired by MetaPost but with an improved C++-like syntax.
67Asymptote provides for figures the same high-quality level of typesetting
68that LaTeX does for scientific text.
69
70This package is custmized for Japanese.
71- added eplatex, platex to latex engines
72- use pdvips as dvips command
73
74%description -l ja
75Asymptote は MetaPost に触発されているが,C++ のような構文に改良された,
76テクニカルな図面のための強力な記述ベクターグラフィックス言語です.
77Asymptote は科学的なテキストに対して LaTeX がしている組版のと
78同じくらい高品質なレベルの図を提供します.
79
80このパッケージは日本語向けにカスタマイズされています.
81- latex エンジンに eplatex, platex を追加
82- dvips コマンドとして pdvips を使う
83
84
85%package gui
86Summary: A graphical interface for Asymptote
87Summary(ja): Asymptote のためのグラフィカルインターフェース
88Group: Applications/Graphics
89Requires: %{name} = %{version}-%{release}
90Requires:       tkinter
91Requires:       python-imaging
92BuildArch:     noarch
93
94%description gui
95A graphical interface for Asymptote
96
97
98%package -n %{emacspkg}
99Summary: Emacs mode for editing Asymptote source code
100Summary(ja): Asymptote ソースコードを編集するための Emacs モード
101Group: Applications/Editors/Emacs
102Requires: %{name} = %{version}-%{release}
103BuildRequires: emacsen
104%prereq_ge     emacsen-common
105BuildArch:     noarch
106
107%description -n %{emacspkg}
108Emacs mode for editing Asymptote source code
109
110
111%prep
112%setup -q
113%patch0 -p1 -b .settings
114%patch1 -p1 -b .gcc44
115%patch2 -p1 -b .DSO
116%patch3 -p1 -b .path-fix
117%{__sed} -i 's/\r//' doc/CAD1.asy
118
119# convert to UTF-8
120iconv -f iso-8859-1 -t utf-8 -o examples/interpolate1.asy{.utf8,}
121%__mv examples/interpolate1.asy{.utf8,}
122autoreconf -i
123
124%build
125%configure \
126    --enable-gc=system \
127    --with-docdir=%{_defaultdocdir}/%{name}-%{version}/ \
128    --with-latex=%{texmf}/tex/latex \
129     --with-context=%{texmf}/tex/context \
130     ;
131%__make %{?_smp_mflags}
132cd doc/
133%__make asy-latex.pdf
134%__make all
135
136%install
137%__rm -rf $RPM_BUILD_ROOT
138%__make install DESTDIR=%{buildroot} mandir=%{buildroot}%{_mandir}
139
140%__install -p -m 644 BUGS ChangeLog LICENSE README ReleaseNotes TODO \
141    $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}-%{version}/
142
143# # Vim syntax file
144# for vimver in 63 64 70 71 ; do
145#     install -dm 755 $RPM_BUILD_ROOT%{_datadir}/vim/vim$vimver/syntax
146#     cd $RPM_BUILD_ROOT%{_datadir}/vim/vim$vimver/syntax
147#     ln -s ../../../%{name}/asy.vim .
148# done
149
150# Move info file
151%__mv %{buildroot}%{_infodir}/asymptote/asymptote.info %{buildroot}%{_infodir}/asymptote.info
152
153# copy icon to pixmaps dir
154%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/pixmaps/
155%__cp %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/pixmaps/
156
157%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/applications
158desktop-file-install --vendor "vine"                  \
159        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
160        %{SOURCE2}
161
162# Clean up symlink
163%__rm -rf $RPM_BUILD_ROOT%{_bindir}/xasy
164cd $RPM_BUILD_ROOT%{_bindir}
165%__ln_s ../share/%{name}/GUI/xasy.py xasy
166
167
168## <asy-mode>
169%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{name}
170%__mkdir_p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/install
171%__mkdir_p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/remove
172
173#
174# install el files
175#
176
177# install -dm 755 $RPM_BUILD_ROOT%{emacs_sitelisp}/site-start.d
178# cd $RPM_BUILD_ROOT%{emacs_sitelisp}
179# ln -s ../../%{name}/asy-{mode,keywords}.el .
180# cd $RPM_BUILD_ROOT%{emacs_sitelisp}/site-start.d
181# ln -s ../../../%{name}/asy-init.el .
182
183%__mv $RPM_BUILD_ROOT%{_datadir}/%{name}/asy-{init,mode,keywords}.el \
184    $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{name}/
185
186
187#
188# install script (bytecompile el and install elc, remove)
189#
190
191%_installemacsenscript %{name} %{SOURCE11}
192
193%_removeemacsenscript  %{name} %{SOURCE12}
194
195## </asy-mode>
196
197
198%clean
199%__rm -rf $RPM_BUILD_ROOT
200
201
202%post
203/sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir 2>/dev/null || :
204/sbin/install-info %{_infodir}/asy-faq.info.gz %{_infodir}/dir 2>/dev/null || :
205%{exec_texhash}
206
207
208%post -n %{emacspkg}
209if [ "$1" = 2 ]; then
210
211  %_emacsenPackageRemove %{name}
212
213fi
214
215%_addemacsenlist %{name}
216
217%_emacsenPackageInstall %{name}
218     
219
220%postun
221if [ $1 = 0 ]; then
222    /sbin/install-info --delete %{name} %{_infodir}/dir 2>/dev/null || :
223    /sbin/install-info --delete asy-faq %{_infodir}/dir 2>/dev/null || :
224    %{exec_texhash}
225fi
226
227
228%preun -n %{emacspkg}
229if [ "$1" = 0 ]; then
230
231  %_emacsenPackageRemove %{name}
232
233  %_removeemacsenlist %{name}
234
235fi
236
237
238%files
239%defattr(-,root,root,-)
240%doc %{_defaultdocdir}/%{name}-%{version}/
241%{_bindir}/asy
242%{_datadir}/%{name}/
243%exclude %{_datadir}/asymptote/GUI/
244%{texpkgdir}/
245%{texmf}/tex/context/
246%{_mandir}/man1/*.1*
247%{_infodir}/*.info*
248##%{_datadir}/vim/vim*/syntax/asy.vim
249
250
251%files gui
252%{_bindir}/xasy
253%{_datadir}/applications/vine-xasy.desktop
254%{_datadir}/pixmaps/asy.gif
255%{_datadir}/asymptote/GUI/
256%{_mandir}/man*/xasy.*
257
258
259%files -n %{emacspkg}
260%defattr(-,root,root)
261%{_datadir}/emacs/site-lisp/%{name}
262%{_prefix}/lib/emacsen-common/packages/install/%{name}
263%{_prefix}/lib/emacsen-common/packages/remove/%{name}
264
265
266%changelog
267* Sat Jun 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 2.10-1
268- new upstream release
269
270* Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 1.70-5
271- TeX Live 2009
272
273* Tue Feb 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.70-4
274- rebuilt with new toolchain, libsigsegv-2.8
275- appled Patch1 again
276
277* Tue Jun 16 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.70-3
278- don't apply Patch1 until gcc44 comes to VineSeed
279
280* Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.70-2
281- separated Xasy to gui subpackage
282
283* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.70-1
284- initial build based on Fedora Development (fc11) package
285- applied asymptote-1.70-settings-vine.patch
286
287* Mon Apr 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.70-1
288- update to 1.70
289
290* Tue Apr  7 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.69-1
291- update to 1.69
292
293* Wed Mar 25 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.68-1
294- update to 1.68
295
296* Thu Mar 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.67-1
297- update to 1.67
298
299* Fri Feb 27 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.66-1
300- update to 1.66
301
302* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.63-5
303- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
304
305* Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-4
306- more gcc44 fixes with BIG_ENDIAN platforms
307
308* Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-3
309- fix gcc44 issue with BIG_ENDIAN platforms
310
311* Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-2
312- forgot to put in new source
313
314* Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-1
315- 1.63
316
317* Fri Jan 30 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.60-1
318- 1.60
319
320* Mon Jan 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.59-1
321- 1.59
322
323* Mon Jan 12 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.58-1
324- 1.58
325
326* Mon Dec 15 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.57-1
327- 1.57
328
329* Tue Dec  9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.56-1
330- 1.56
331
332* Tue Dec  2 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.54-1
333- 1.54
334
335* Tue Nov 25 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.52-1
336- 1.52
337
338* Tue Nov 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.51-1
339- update to 1.51
340
341* Mon Nov  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.49-1
342- update to 1.49
343
344* Sun Oct 26 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.47-1
345- update to 1.47
346
347* Mon Oct 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.46-1
348- update to 1.46
349
350* Mon Oct  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-2
351- add missing BuildRequires
352
353* Mon Oct  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-1
354- update to 1.44
355
356* Fri Jun 13 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.43-1
357- update to 1.43
358
359* Fri Apr 25 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-3
360- explicitly call "make asymptote.pdf" in doc/
361
362* Fri Apr  4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-2
363- fix build failure (use _POSIX_ARG_MAX) resolves bz 440799
364
365* Thu Feb 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-1
366- update to 1.42
367
368* Wed Feb  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.41-1
369- update to 1.41
370- enable desktop file for xasy
371
372* Thu Jan  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.37-1
373- bump to 1.37
374- fix gcc43 failures
375- drop triggers
376
377* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - sh: kpsewhich: command not found
378- Rebuild for selinux ppc32 issue.
379
380* Sun Jul 29 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.33-1
381- Update 1.33.
382
383* Sat Jun 30 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.32-1
384- Update to 1.32.
385- vim-common triggers: correction and improvements (#246131).
386
387* Wed Jun 27 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.31-1
388- Update to 1.31.
389
390* Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.30-1
391- Update to 1.30.
392
393* Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-3
394- Using "evince" as the default PS and PDF viewers (#244151).
395  (patch file: asymptote-1.29-settings.patch)
396- Use relative symbolic links in the {emacs,xemacs}-common triggers (#155750).
397- Use relative symbolic links in the vim-common triggers.
398
399* Sat Jun  2 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-2
400- Add asy-faq to install-info (#155750).
401- Add support for vim 7.1.
402
403* Mon May 21 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-1
404- Update to 1.29.
405
406* Tue May  8 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.28-1
407- Update to 1.28.
408
409* Sat May  5 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.27-1
410- Update to 1.27.
411
412* Wed Apr 25 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.26-1
413- Update to 1.26.
414
415* Tue Apr 10 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.25-1
416- Update to 1.25.
417
418* Sun Apr  1 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.24-1
419- Update to 1.24.
420
421* Sun Mar 11 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.23-1
422- Update to 1.23.
423
424* Tue Mar  6 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.22-1
425- Update to 1.22.
426
427* Sat Mar  3 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.21-1
428- Update to 1.21.
429
430* Fri Dec 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.20-1
431- Update to 1.20.
432
433* Sat Dec 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.19-1
434- Update to 1.19.
435
436* Sun Nov  5 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.18-1
437- Update to 1.18.
438
439* Wed Nov  1 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.17-1
440- Update to 1.17.
441
442* Wed Oct 25 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.16-1
443- Update to 1.16.
444
445* Sun Oct 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.15-1
446- Update to 1.15.
447
448* Wed Sep  6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.13-1
449- Update to 1.13.
450
451* Thu Aug  3 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.12-1
452- Update to 1.12.
453
454* Thu Jul  6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.11-1
455- Update to 1.11.
456
457* Wed Jun 28 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.10-1
458- Update to 1.10.
459
460* Fri Jun 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.09-1
461- Update to 1.09.
462
463* Thu Jun 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.08-1
464- Update to 1.08.
465- Also installs the info file.
466
467* Mon May 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-5
468- Fedora Core 6: the texinfo package has been splitted (texinfo + texinfo-tex).
469
470* Sat May 27 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-4
471- Group: Development/Tools -> Applications/Publishing (#193154).
472
473* Sat May 27 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-3
474- Emacs/Xemacs init file (#193154 comment 6).
475
476* Fri May 26 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-2
477- Directories ownership (#193154).
478
479* Wed May 24 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-1
480- Update to 1.06.
481- Using triggers to install the Vim syntax file and the Emacs/Xemacs mode file.
482
483* Mon May 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.05-1
484- Update to 1.05.
485
486* Sun May  7 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.04-1
487- Update to 1.04.
488
489* Fri Mar 31 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.03-1
490- Update to 1.03.
491
492* Thu Mar 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.02-1
493- First build.
494
495# vim:set ai ts=4 sw=4 sts=4 et:
Note: See TracBrowser for help on using the repository browser.