source: projects/specs/branches/6/a/aspell/aspell-vl.spec @ 3772

Revision 3772, 13.3 KB checked in by iwaim, 13 years ago (diff)

aspell-0.60.6-2

Line 
1%define _noVersionedDependencies        1
2
3%define ver 0.60.6
4%define rel 2
5
6Summary: A spelling checker.
7Summary(ja): スペルチェッカ
8Name: aspell
9Version: %{ver}
10Release: %{rel}%{?_dist_release}
11License: LGPL
12Group: Applications/Text
13URL: http://aspell.net/
14Source0: ftp://ftp.gnu.org/gnu/aspell/aspell-%{version}.tar.gz
15Source10: %{name}-install.sh
16Source11: %{name}-remove.sh
17Source12: %{name}-init.el
18Source100: aspell.conf
19Patch1003: aspell-0.60.3-install_info.patch
20Patch1005: aspell-0.60.5-fileconflict.patch
21Patch1007: aspell-0.60.5-pspell_conf.patch
22Patch1008: aspell-0.60.6-zero.patch
23
24Buildrequires: gcc-c++
25Requires(post,preun): %{_syssbindir}/install-info
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27Provides: pspell
28Obsoletes: ispell, pspell
29
30
31%description
32GNU Aspell is a spell checker designed to eventually replace Ispell. It can
33either be used as a library or as an independent spell checker. Its main
34feature is that it does a much better job of coming up with possible
35suggestions than just about any other spell checker out there for the
36English language, including Ispell and Microsoft Word. It also has many
37other technical enhancements over Ispell such as using shared memory for
38dictionaries and intelligently handling personal dictionaries when more
39than one Aspell process is open at once.
40
41
42%package        devel
43Summary: Static libraries and header files for Aspell development.
44Group: Development/Libraries
45Requires: aspell = %{version}-%{release}
46Obsoletes: pspell-devel
47
48%description    devel
49Aspell is a spelling checker. The aspell-devel package includes the
50static libraries and header files needed for Aspell development.
51
52
53%package        el
54Summary: Emacs lisp for aspell
55Group: Applications/Editors/Emacs
56Requires: aspell = %{version}-%{release}
57Requires: emacsen-common
58
59%description    el
60Aspell is a spelling checker. The aspell-el package includes the
61elisp for using aspell within emacsen.
62
63
64%prep
65rm -rf $RPM_BUILD_ROOT
66%setup -q
67%patch1003 -p1 -b .iinfo
68%patch1005 -p1 -b .fc
69%patch1007 -p1 -b .mlib
70%patch1008 -p1 -b .zero
71iconv -f windows-1252 -t utf-8 manual/aspell.info -o manual/aspell.info.aux
72mv manual/aspell.info.aux manual/aspell.info
73
74%build
75%configure
76make %{?_smp_mflags}
77
78%install
79%makeinstall
80
81mv ${RPM_BUILD_ROOT}%{_libdir}/aspell-*/ispell ${RPM_BUILD_ROOT}%{_bindir}
82mv ${RPM_BUILD_ROOT}%{_libdir}/aspell-*/spell ${RPM_BUILD_ROOT}%{_bindir}
83
84rm -f ${RPM_BUILD_ROOT}%{_libdir}/libaspell.la
85rm -f ${RPM_BUILD_ROOT}%{_libdir}/libpspell.la
86rm -f ${RPM_BUILD_ROOT}%{_libdir}/aspell-0.60/*-filter.la
87
88# Add by H.Irokawa(2004.02.23)
89mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}
90install -m 644 %{SOURCE100} $RPM_BUILD_ROOT%{_sysconfdir}/aspell.conf
91
92mkdir -p $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/aspell
93mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/install
94mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/remove
95
96install -m 644 %{SOURCE12} $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/%{name}
97
98# install  script( bytecompile el and install elc , remove )
99
100%_installemacsenscript %{name} %{SOURCE10}
101
102%_removeemacsenscript  %{name} %{SOURCE11}
103
104rm -f $RPM_BUILD_ROOT/usr/share/doc/aspell/manual.aux
105
106%find_lang %{name}
107   
108%post
109/sbin/ldconfig
110# info
111if [ "$1" = 0 ] ; then
112%{_syssbindir}/install-info %{_infodir}/aspell.info.gz %{_infodir}/dir
113fi
114
115%post devel
116/sbin/ldconfig
117# info
118if [ "$1" = 0 ] ; then
119%{_syssbindir}/install-info %{_infodir}/aspell-dev.info.gz %{_infodir}/dir
120fi
121
122%post el
123if [ "$1" = 2 ]; then
124
125  %_emacsenPackageRemove %{name}
126
127fi
128
129%_addemacsenlist %{name}
130
131%_emacsenPackageInstall %{name}
132       
133
134%postun
135/sbin/ldconfig
136
137%preun
138if [ $1 = 0 ]; then
139%{_syssbindir}/install-info --delete %{_infodir}/aspell.info.gz %{_infodir}/dir
140fi
141
142%preun devel
143if [ $1 = 0 ]; then
144%{_syssbindir}/install-info --delete %{_infodir}/aspell-dev.info.gz %{_infodir}/dir
145fi
146
147%preun el
148if [ "$1" = 0 ]; then
149
150  %_emacsenPackageRemove %{name}
151
152  %_removeemacsenlist %{name}
153
154fi
155
156
157%clean
158rm -rf $RPM_BUILD_ROOT
159
160%files -f %{name}.lang
161%defattr(-,root,root)
162%config(noreplace) %{_sysconfdir}/aspell.conf
163%doc README TODO
164%{_bindir}/*
165%{_libdir}/lib*.so.*
166%{_libdir}/aspell-*
167%{_infodir}/aspell.info*
168%{_mandir}/man1/*
169
170%files          devel
171%defattr(-,root,root)
172%{_includedir}/aspell.h
173%{_includedir}/pspell
174%{_infodir}/aspell-dev.info*
175%{_libdir}/lib*spell.so
176%{_libdir}/pkgconfig/aspell.pc
177
178%files          el
179%{_datadir}/emacs/site-lisp/%{name}/
180%{_prefix}/lib/emacsen-common/packages/install/%{name}
181%{_prefix}/lib/emacsen-common/packages/remove/%{name}
182
183%changelog
184* Tue May  3 2011 IWAI, Masaharu <iwai@alib.jp> 0.60.6-2
185- update aspell.conf (Source100)
186
187* Sat Apr 16 2011 IWAI, Masaharu <iwai@alib.jp> 0.60.6-1
188- new upstream release
189- sync Fedora 0.60.6-14
190 - split English dictionary package: create aspell-en package
191 - drop unnecessary patches
192  - prefix patch (Patch0)
193  - fix compress patch (Patch1)
194 - add some patches (Patch1003, 1005, 1007, 1008)
195 - create aspell.pc file
196 - update files
197 - add post, preun scripts for info file
198 - add Requires(post,preun) for installing info file
199- noreplace aspell.conf
200
201* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.50.5-1vl5
202- applied new versioning policy, spec in utf-8
203
204* Sun May 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.5-0vl3
205- rebuilt with new toolchain
206
207* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.5-0vl2
208- changed aspell-el Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
209
210* Sun Jul 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.50.5-0vl1
211- upgrade to new upstream
212- drop aspell-0.50.3-gcc33.patch
213- update prefix.patch
214
215* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl8
216- merged with errata package
217  * Wed Oct  6 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.50.3-0vl5.1
218  - added aspell-compress-bug.patch (CAN-2004-0548).
219
220* Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.3-0vl7
221- fixed typo (s/%postun el/%preun el/)
222
223* Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.3-0vl6
224- split elisp-related files into the aspell-el subpackage
225
226* Thu Mar  4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl5
227- add PreReq: emacsen-common
228
229* Mon Feb 23 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 0.50.3-0vl4
230- add /etc/aspell.conf
231- modded aspell-init.el(Japanese blended English spell check)
232
233* Wed Feb 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl3
234- add %{_bindir}/{ispell,spell} for compatibility script
235- enable site-start.d stuff
236
237* Mon Nov 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.3-0vl2
238- fixed spec file character code to EUC-JP
239
240* Wed Jun 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl1
241- build for Vine Linux
242- merge aspell-en
243
244* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
245- rebuilt
246
247* Fri May 30 2003 Joe Orton <jorton@redhat.com> 7:0.50.3-10
248- rebuild again to fix libpspell deps
249
250* Fri May 30 2003 Joe Orton <jorton@redhat.com> 7:0.50.3-9
251- remove ExcludeArch
252
253* Thu May 22 2003 Jeremy Katz <katzj@redhat.com> 7:0.50.3-8
254- fix build with gcc 3.3
255
256* Wed May 22 2003 Adrian Havill <havill@redhat.com> 0.50.3-7
257- require aspell-en for upgrades
258
259* Sun May 11 2003 Jeremy Katz <katzj@redhat.com> 6:0.50.3-6
260- -devel should obsolete pspell-devel
261
262* Tue May  6 2003 Joe Orton <jorton@redhat.com> 0.50.3-5
263- include libpspell.so in devel package
264
265* Wed May  1 2003 Adrian Havill <havill@redhat.com> 0.50.3-4
266- removed .la files
267
268* Wed Apr 16 2003 Adrian Havill <havill@redhat.com> 0.50.3-3
269- Changed the header for provides, obsoletes, epoch
270- fixed config prefix in dirs.h
271
272* Wed Apr 16 2003 Adrian Havill <havill@redhat.com> 0.50.3-1
273- upgrade to 0.50.3
274
275* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
276- rebuilt
277
278* Fri Nov  8 2002 Tim Powers <timp@redhat.com>
279- fix broken pspell epoch dep
280- create $RPM_BUILD_ROOT/usr/bin by hand
281- remove /usr/doc
282- fix hardcoding of /usr/lib so that we can build on x86_64
283
284* Tue Aug 13 2002 Nalin Dahyabhai <nalin@redhat.com> 0.33.7.1-16
285- require pspell and pspell-devel using the proper epoch
286
287* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
288- rebuilt with gcc-3.2 (we hope)
289
290* Mon Jul 22 2002 Tim Powers <timp@redhat.com> 0.33.7.1-14
291- rebuild using gcc-3.2-0.1
292
293* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 0.33.7.1-13
294- automated rebuild
295
296* Thu Jun 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-12
297- Rebuild to make it work again... #66708
298
299* Thu May 23 2002 Tim Powers <timp@redhat.com>
300- automated rebuild
301
302* Mon May 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-10
303- Rebuild
304
305* Thu Feb 21 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-9
306- Disable evil patch
307
308* Mon Jan 28 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-8
309- Build on more archs (doh)
310
311* Tue Jan 22 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-7
312- Make it compile with new compiler (evil workaround)
313
314* Wed Jan 16 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-5
315- Rebuild
316- Unexclude alpha
317
318* Fri Dec 14 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-3
319- Rebuild
320- Don't build on alpha
321
322* Mon Oct 29 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.33.7.1-2
323- "make it work with gcc 3.1" ;)
324
325* Tue Sep 18 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-1
326- 0.33.7.1, which is a "make it work with gcc 3" release
327
328* Wed Sep 12 2001 Tim Powers <timp@redhat.com>
329- rebuild with new gcc and binutils
330
331* Thu Aug  9 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7-1
332- 0.33.7 bugfix release. Requested by the author, it fixes
333  coredumps in sug-mode and when not using typo-analyses.
334  It also contains code cleanups so it compiles with -ansi
335- should fix coredump on IA64 (#49746)
336
337* Wed Jul 11 2001 Trond Eivind Glomsrød <teg@redhat.com>
338- Add the .la files in the main package - used for dynamic loading
339
340* Sun Jun  3 2001 Trond Eivind Glomsrød <teg@redhat.com>
341- 0.33.6.3, which includes the fix made yesterday
342
343* Sat Jun  2 2001 Trond Eivind Glomsrød <teg@redhat.com>
344- Make it search for directories in the correct location
345
346* Wed May 30 2001 Trond Eivind Glomsrød <teg@redhat.com>
347- No more workarounds at the specfile level
348
349* Tue May 29 2001 Trond Eivind Glomsrød <teg@redhat.com>
350- Use custom ltmain.sh to work around buggy bundled libtool
351
352* Sun May 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
353- 0.33.6
354- use standard %%configure macro - it works now.
355
356* Fri May 11 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.33.5-2
357- Rebuild with new libltdl
358
359* Mon Apr 23 2001 Trond Eivind Glomsrød <teg@redhat.com>
360- 0.33.5
361
362* Thu Nov 30 2000 Trond Eivind Glomsrød <teg@redhat.com>
363- use new emacs init scheme for Emacs and XEmacs
364
365* Wed Nov 22 2000 Trond Eivind Glomsrød <teg@redhat.com>
366-  .32.6
367
368* Sat Aug 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
369- .32.5 bugfix release (also contains improved documentation),
370  obsolete old patch
371- the compatibility scripts are now part of the package itself
372- clean up build procedure
373- remove manual.aux file from docs (#16424)
374
375* Sun Aug 06 2000 Trond Eivind Glomsrød <teg@redhat.com>
376- .32.1 bugfix release, obsolete old patch
377- rename to 0.32.1
378- add patch from author to change his email address
379- add spell and ispell compatibility scripts
380
381* Fri Aug 04 2000 Trond Eivind Glomsrød <teg@redhat.com>
382- rebuild
383
384* Tue Aug 01 2000 Trond Eivind Glomsrød <teg@redhat.com>
385- remember to obsolete ispell
386- build the Canadian and British dictionaries here now,
387  as part of the main package. Same package names and
388  descriptions.
389
390* Mon Jul 24 2000 Trond Eivind Glomsrød <teg@redhat.com>
391- .32
392- remove old patches, add a patch since namespace isn't
393  polluted as much anymore (as opposed to older toolchain)
394
395* Wed Jul 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
396- rebuild
397
398* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
399- automatic rebuild
400
401* Tue Jul  4 2000 Jakub Jelinek <jakub@redhat.com>
402- Rebuild with new C++
403
404* Fri Jun 30 2000 Trond Eivind Glomsrød <teg@redhat.com>
405- use RPM_OPT_FLAGS, not just -O0
406- dont include .la-files
407
408* Fri Jun 23 2000 Trond Eivind Glomsrød <teg@redhat.com>
409- excludearch ia64
410
411* Fri Jun 23 2000 Trond Eivind Glomsrød <teg@redhat.com>
412- patch to work around compiler bug(?) wrt. inline functions
413- use CFLAGS and CXXFLAGS
414- set them to -O0 to work around YACB
415- copy libtool files for IA64 support
416
417* Sun Jun 18 2000 Trond Eivind Glomsrød <teg@redhat.com>
418- update to .31.1. My patch was upstreamed and is no longer needed.
419- new patch added so DESTDIR works properly
420
421* Fri Jun 16 2000 Trond Eivind Glomsrød <teg@redhat.com>
422- (this entry includes some old ones...)
423- update to .31
424- added patch to make it compile with a pickier compiler
425- include /usr/share/pspell
426
427* Mon May 1 2000 Tim Powers <timp@redhat.com>
428- updated to .30.1
429- used build fixes from Ryan Weaver's 0.30.1-1 package on sourceforge
430- updated URL, download/ftp location
431- removed redundant define's at top of spec file
432
433* Thu Jul 8 1999 Tim Powers <timp@redhat.com>
434- built for Powertools 6.1
435- removed %serial definitions from spec file to make versioning
436  consistant with the other packages we ship.
437- changed build root path
438- general spec file cleanups
439
440* Tue Mar  2 1999 Ryan Weaver <ryanw@infohwy.com>
441  [aspell-.27.2-2]
442- Changes from .27.1 to .27.2 (Mar 1, 1999)
443- Fixed a major bug that caused aspell to dump core when used
444  without any arguments
445- Fixed another major bug that caused aspell to do nothing when used
446  in interactive mode.
447- Added an option to exit in Aspell's interactive mode.
448- Removed some old documentation files from the distribution.
449- Minor changes on to the section on using Aspell with egcs.
450- Minor changes to remove -Wall warnings.
Note: See TracBrowser for help on using the repository browser.