source: projects/specs/branches/6/a/aqbanking/aqbanking-vl.spec @ 1928

Revision 1928, 10.6 KB checked in by owa, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.6.3)
2%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
3%define _qt4_libdir %(pkg-config --variable libdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/lib)
4%define _qt4_headerdir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/include)
5
6
7%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9Name: aqbanking
10Summary: A library for online banking functions and financial data import/export
11Version: 4.2.4
12Release: 2%{?_dist_release}
13
14Group: System Environment/Libraries
15License: GPLv2+
16URL: http://www.aquamaniac.de/aqbanking/
17
18Source: http://download.sourceforge.net/aqbanking/%{name}-%{version}.tar.gz
19
20Patch2: aqbanking-4.2.4-pkgconfig.patch
21Patch3: aqbanking-2.1.0-conflict.patch
22# upstreamable, omit inadvertant(?) qt3 linkage q4banking -- Rex
23Patch4: aqbanking-4.2.4-q4banking_remove_qt3.patch
24
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26# qbanking
27BuildRequires: qt-devel
28BuildRequires: qt4-devel
29BuildRequires: gwenhywfar-devel >= 3.10.0
30BuildRequires: gmp-devel
31BuildRequires: gettext
32BuildRequires: libtool
33Requires(post): /sbin/ldconfig
34Requires(postun): /sbin/ldconfig
35Obsoletes: aqhbci <= 1.0.3
36Obsoletes: g2banking < 3.7.2-1
37Obsoletes: python-aqbanking
38
39%description
40The intention of AqBanking is to provide a middle layer between the
41program and the various Online Banking libraries (e.g. AqHBCI). The
42first backend which is already supported is AqHBCI, a library which
43implements a client for the German HBCI (Home Banking Computer
44Interface) protocol. Additionally, Aqbanking provides various plugins
45to simplify import and export of financial data. Currently there are
46import plugins for the following formats: DTAUS (German financial
47format), SWIFT (MT940 and MT942).
48
49%package devel
50Summary: Development headers for Aqbanking
51Group: Development/Libraries
52Requires: %{name} = %{version}-%{release}
53Requires: pkgconfig
54# for %{_datadir}/aclocal
55Requires: automake
56Obsoletes: aqhbci-devel <= 1.0.3
57Obsoletes: g2banking-devel < %{version}
58
59%description devel
60This package contains aqbanking-config and header files for writing and
61compiling programs using Aqbanking.
62
63%package -n qbanking
64Summary: Qt3 bindings for Aqbanking
65Group: System Environment/Libraries
66Requires: %{name} = %{version}-%{release}
67Requires(post): /sbin/ldconfig
68Requires(postun): /sbin/ldconfig
69Obsoletes: aqhbci-qt-tools <= 1.0.3
70Obsoletes: kbanking < %{version}
71
72%description -n qbanking
73This package contains the qbanking KDE bindings for the Aqbanking
74online banking library.
75
76%package -n qbanking-devel
77Summary: Development headers for qbanking
78Group: Development/Libraries
79Requires: %{name}-devel = %{version}-%{release}
80Requires: qbanking = %{version}-%{release}
81Requires: pkgconfig
82Requires: qt-devel
83Obsoletes: kbanking-devel < 3.7.2-1
84
85%description -n qbanking-devel
86This package contains qbanking-config and header files for writing and
87compiling programs using the qbanking bindings for Aqbanking.
88
89%package -n q4banking
90Summary: Qt4 bindings for Aqbanking
91Group: System Environment/Libraries
92Requires: %{name} = %{version}-%{release}
93Requires: qt4 >= %{_qt4_version}
94
95%description -n q4banking
96%{summary}.
97
98%package -n q4banking-devel
99Summary: Development files for q4banking
100Group: Development/Libraries
101Requires: %{name}-devel = %{version}-%{release}
102Requires: q4banking = %{version}-%{release}
103Requires: qt4-devel
104
105%description -n q4banking-devel
106%{summary}.
107
108%package -n python-%{name}
109Summary: Python bindings for Aqbanking
110Group: Development/Libraries
111Requires: %{name} = %{version}-%{release}
112
113%description -n python-%{name}
114This package contains python bindings for Aqbanking.
115
116%prep
117%setup -q
118%patch2 -p1 -b .pkgconfig
119%patch3 -p1 -b .conflict
120%patch4 -p1 -b .q4banking_remove_qt3
121
122# hack to nuke rpaths, slighly less ugly than using overriding LIBTOOL below
123%if "%{_libdir}" != "/usr/lib"
124sed -i -e 's|"/lib /usr/lib|"/%{_lib} %{_libdir}|' configure
125%endif
126
127%build
128[ -z "$QTDIR" ] && . /etc/profile.d/qt.sh
129
130%configure \
131    --disable-static \
132    --with-frontends="qbanking q4banking" \
133    --enable-qt4 \
134    --with-qt4-includes=%{_qt4_headerdir} \
135    --with-qt4-libs=%{_qt4_libdir} \
136    --with-qt4-moc=%{_qt4_prefix}/bin/moc \
137    --with-qt4-uic=%{_qt4_prefix}/bin/uic
138
139# not smp_mflags safe
140# override LIBTOOL to quash rpath
141make
142#make LIBTOOL=/usr/bin/libtool
143
144%install
145rm -rf $RPM_BUILD_ROOT
146
147make DESTDIR=$RPM_BUILD_ROOT install
148#make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
149
150find $RPM_BUILD_ROOT -name *.la -exec rm -f {} \;
151find $RPM_BUILD_ROOT -name *.a -exec rm -f {} \;
152
153cd tutorials
154make clean
155rm -rf .deps
156rm -f Makefile*
157cd ..
158
159mkdir -p $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
160mv $RPM_BUILD_ROOT/%{_datadir}/doc/{aqbanking,aqhbci} $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
161cp AUTHORS README COPYING ChangeLog NEWS $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
162
163%find_lang %{name}
164
165# Fix multilib errors. (#602879)
166sed -i 's|** Created:.*|** Created |g' $RPM_BUILD_ROOT/%{_includedir}/q4banking/*.ui.h
167
168
169%clean
170rm -rf $RPM_BUILD_ROOT
171
172%post -p /sbin/ldconfig
173
174%postun -p /sbin/ldconfig
175
176%post -n qbanking -p /sbin/ldconfig
177
178%postun -n qbanking -p /sbin/ldconfig
179
180%post -n q4banking -p /sbin/ldconfig
181
182%postun -n q4banking -p /sbin/ldconfig
183
184%files -f %{name}.lang
185%defattr(-,root,root)
186%doc %{_datadir}/doc/%{name}-%{version}
187%{_libdir}/libaq*.so.*
188%dir %{_libdir}/aqbanking
189%dir %{_libdir}/aqbanking/plugins/
190%dir %{_libdir}/aqbanking/plugins/*/
191%dir %{_libdir}/aqbanking/plugins/*/debugger/
192%dir %{_libdir}/aqbanking/plugins/*/debugger/*/
193%dir %{_libdir}/aqbanking/plugins/*/frontends/
194%{_libdir}/aqbanking/plugins/*/bankinfo/
195%{_libdir}/aqbanking/plugins/*/imexporters/
196%{_libdir}/aqbanking/plugins/*/providers/
197%{_libdir}/gwenhywfar/plugins/*/dbio/*
198%dir %{_datadir}/aqbanking
199%dir %{_datadir}/aqbanking/frontends
200%{_datadir}/aqbanking/backends/
201%{_datadir}/aqbanking/bankinfo/
202%{_datadir}/aqbanking/imexporters/
203%{_bindir}/aqbanking-cli
204%{_bindir}/aqhbci-tool4
205
206%files devel
207%defattr(-,root,root)
208%doc doc/0[12]* tutorials
209%{_bindir}/hbcixml3
210%{_bindir}/aqbanking-config
211%{_libdir}/libaq*.so
212%{_includedir}/aq*/
213%{_libdir}/pkgconfig/aqbanking.pc
214%{_datadir}/aclocal/aqbanking.m4
215
216%files -n qbanking
217%defattr(-,root,root)
218%{_bindir}/qb-help8
219%{_libdir}/libqbanking.so.*
220%{_libdir}/aqbanking/plugins/*/debugger/aqhbci/aqhbci-qt3-debug
221%{_libdir}/aqbanking/plugins/*/debugger/aqhbci/qt_debug.xml
222%{_libdir}/aqbanking/plugins/*/frontends/qbanking
223%{_libdir}/aqbanking/plugins/*/wizards/qt3*
224%{_datadir}/aqbanking/i18n
225%{_datadir}/aqbanking/frontends/qbanking/
226
227%files -n qbanking-devel
228%defattr(-,root,root)
229%{_includedir}/qbanking/
230%{_libdir}/libqbanking.so
231
232%files -n q4banking
233%defattr(-,root,root)
234%{_bindir}/q4b-help1
235%{_libdir}/aqbanking/plugins/*/debugger/aqhbci/aqhbci-qt4-debug
236%{_libdir}/aqbanking/plugins/*/debugger/aqhbci/qt4_debug.xml
237%{_libdir}/aqbanking/plugins/*/frontends/q4banking
238%{_libdir}/aqbanking/plugins/*/wizards/qt4*
239%{_datadir}/aqbanking/frontends/q4banking/
240%{_libdir}/libq4banking.so.1*
241
242%files -n q4banking-devel
243%defattr(-,root,root)
244%{_includedir}/q4banking/
245%{_libdir}/libq4banking.so
246
247#%files -n python-%{name}
248#%defattr(-,root,root)
249#%{python_sitelib}/%{name}
250
251%changelog
252* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 4.2.4-2
253- rebuilt with rpm-4.8.1 for pkg-config
254
255* Mon Sep 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.4-1
256- update to 4.2.4
257- added q4banking subpackage
258- obsoletes python-aqbanking subpackage
259
260* Sat Oct 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.7.1-1
261- update to 3.7.2
262- obsolete the no-longer-existing g2banking/kbanking packages
263
264* Mon Jan 21 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.3.3-0vl1
265- update to 2.3.3
266
267* Sat Dec 29 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.3.2-2vl1
268- modify and build for VineSeed
269
270* Wed Aug 29 2007 Bill Nottingham <notting@redhat.com> - 2.3.2-2
271- Rebuild for selinux ppc32 issue.
272- fix build with current glibc/headers
273
274* Fri Aug  3 2007 Bill Nottingham <notting@redhat.com>
275- tweak license tag
276
277* Wed Jul 11 2007 Bill Nottingham <notting@redhat.com> - 2.3.2-1
278- update to 2.3.2
279
280* Mon Jun 25 2007 Bill Nottingham <notting@redhat.com> - 2.2.9-3
281- fix some build bogosity
282
283* Wed Jun 20 2007 Bill Nottingham <notting@redhat.com> - 2.2.9-2
284- add a dist tag
285
286* Mon Mar 19 2007 Bill Nottingham <notting@redhat.com> - 2.2.9-1
287- update to 2.2.9
288
289* Wed Jan 17 2007 Bill Nottingham <notting@redhat.com> - 2.1.0-14
290- fix docdir, obsoletes for aqhbci-devel, and %%clean
291
292* Tue Jan 16 2007 Bill Nottingham <notting@redhat.com> - 2.1.0-13
293- fix docs
294- add PyXML buildreq
295
296* Mon Jan 15 2007 Bill Nottingham <notting@redhat.com> - 2.1.0-12
297- fix missing %%defattrs
298- fix %%excludes
299- other cleanups from review
300- use %%{_python_sitelib}
301- require automake
302- twiddle aqhbci obsoletes
303
304* Sat Jan 13 2007 Bill Nottingham <notting@redhat.com> - 2.1.0-11
305- split into a variety of packages
306
307* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 2.1.0-10
308- rebuild for python 2.5
309
310* Thu Sep  7 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-9
311- rebuild for fixed debuginfo (#205248)
312
313* Fri Sep  1 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-8
314- fix multilib conficts (#205204)
315
316* Mon Aug 28 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-4
317- rebuild against latest libofx
318
319* Tue Aug  1 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-3
320- reenable visibility
321
322* Fri Jul 14 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-2
323- port *-config to pkgconfig
324- don't use -fvisibility=hidden
325
326* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.1.0-1.1
327- rebuild
328
329* Tue Jul 11 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-1
330- update to 2.1.0
331
332* Mon Jun 12 2006 Bill Nottingham <notting@redhat.com> - 1.8.1beta-5
333- buildreq autoconf, libtool
334
335* Tue May 30 2006 Bill Nottingham <notting@redhat.com> - 1.8.1beta-4
336- add gettext buildreq (#193348)
337
338* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.8.1beta-3.1
339- bump again for double-long bug on ppc(64)
340
341* Tue Feb 07 2006 Karsten Hopp <karsten@redhat.de> 1.8.1beta-3
342- buildrequire libofx-devel instead of libofx (pulls in libofx)
343
344* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.8.1beta-2.1
345- rebuilt for new gcc4.1 snapshot and glibc changes
346
347* Sun Jan 22 2006 Bill Nottingham <notting@redhat.com> 1.8.1beta-2
348- add an obsolete (#178554)
349
350* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
351- rebuilt
352
353* Mon Mar  7 2005 Bill Nottingham <notting@redhat.com> 1.0.4beta-2
354- rebuild
355
356* Wed Feb  9 2005 Bill Nottingham <notting@redhat.com> 1.0.4beta-1
357- initial packaging, adopt upstream specfile
Note: See TracBrowser for help on using the repository browser.