source: projects/specs/branches/6/a/apr/apr-vl.spec @ 7260

Revision 7260, 13.4 KB checked in by iwaim, 11 years ago (diff)

apr-1.4.2-2vl6

Line 
1%define aprver 1
2
3# Arches on which the multilib apr.h hack is needed:
4%define multilib_arches %{ix86} ia64 ppc ppc64 s390 s390x x86_64
5
6Name: apr
7Summary: Apache Portable Runtime library
8Summary(ja): Apache ポータブルランタイムライブラリ
9Version: 1.4.2
10Release: 2%{?_dist_release}
11
12Group: System Environment/Libraries
13License: Apache Software License
14URL: http://apr.apache.org/
15
16Source0: %{name}-%{version}.tar.bz2
17Source1: apr-wrapper.h
18Patch2: apr-0.9.7-deepbind.patch
19Patch3: apr-1.2.2-locktimeout.patch
20Patch4: apr-1.2.2-libdir.patch
21Patch5: apr-1.3.3-pkgconf.patch
22# Security fixes
23Patch10: apr-1.3.9-CVE-2011-0419.patch
24Patch11: apr-1.2.7-fnmatch.patch
25
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27BuildRequires: autoconf, libtool, python, doxygen
28BuildRequires: libuuid-devel
29Conflicts: subversion < 0.20.1-2
30Obsoletes: apache2-apr
31
32%description
33The mission of the Apache Portable Runtime (APR) is to provide a
34free library of C data structures and routines, forming a system
35portability layer to as many operating systems as possible,
36including Unices, MS Win32, BeOS and OS/2.
37
38%package devel
39Summary: APR library development kit
40Summary(ja): APR ライブラリ開発キット
41Group: Development/Libraries
42Requires: %{name} = %{version}-%{release}
43Conflicts: subversion-devel < 0.20.1-2
44Obsoletes: apache2-apr-devel
45
46%description devel
47This package provides the support files which can be used to
48build applications using the APR library.  The mission of the
49Apache Portable Runtime (APR) is to provide a free library of
50C data structures and routines.
51
52%prep
53%setup -q
54%patch2 -p1 -b .deepbind
55%patch3 -p1 -b .locktimeout
56%patch4 -p1 -b .libdir
57%patch5 -p1 -b .pkgconf
58
59%patch10 -p1 -b .cve0419
60%patch11 -p1 -b .fnmatch
61
62%build
63# regenerate configure script etc.
64./buildconf
65
66# Forcibly prevent detection of shm_open (which then picks up but
67# does not use -lrt).
68export ac_cv_search_shm_open=no
69
70%configure \
71        --includedir=%{_includedir}/apr-%{aprver} \
72        --with-installbuilddir=%{_libdir}/apr-%{aprver}/build \
73        --with-devrandom=/dev/urandom \
74        --disable-static \
75        CC=gcc CXX=g++
76make %{?_smp_mflags} && make dox
77
78%install
79rm -rf $RPM_BUILD_ROOT
80make install DESTDIR=$RPM_BUILD_ROOT
81
82# Move docs to more convenient location
83rm -rf html
84mkdir -p html
85cp -pr docs/dox/html/* html/
86# mv docs/dox/html html
87
88# Trim exported dependecies
89sed -ri '/^dependency_libs/{s,-l(uuid|crypt) ,,g}' \
90      $RPM_BUILD_ROOT%{_libdir}/libapr*.la
91sed -ri '/^LIBS=/{s,-l(uuid|crypt) ,,g;s/  */ /g}' \
92      $RPM_BUILD_ROOT%{_bindir}/apr-%{aprver}-config
93
94%ifarch %{multilib_arches}
95# Ugly hack to allow parallel installation of 32-bit and 64-bit apr-devel
96# packages:
97mv $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h \
98   $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr-%{_arch}.h
99install -c -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h
100%endif
101
102# Unpackaged files:
103rm -f $RPM_BUILD_ROOT%{_libdir}/apr.exp
104rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
105
106%check
107# Fail if LFS support isn't present in a 32-bit build, since this
108# breaks ABI and the soname doesn't change: see #254241
109if grep 'define SIZEOF_VOIDP 4' include/apr.h \
110   && ! grep off64_t include/apr.h; then
111  cat config.log
112  : LFS support not present in 32-bit build
113  exit 1
114fi
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%post -p /sbin/ldconfig
120
121%postun -p /sbin/ldconfig
122
123%files
124%defattr(-,root,root,-)
125%doc CHANGES LICENSE NOTICE
126%{_libdir}/libapr-%{aprver}.so.*
127
128%files devel
129%defattr(-,root,root,-)
130%doc docs/APRDesign.html docs/canonical_filenames.html
131%doc docs/incomplete_types docs/non_apr_programs
132%doc --parents html
133%{_bindir}/apr-%{aprver}-config
134#{_libdir}/libapr-%{aprver}.a
135%{_libdir}/libapr-%{aprver}.so
136%{_libdir}/pkgconfig/*.pc
137%dir %{_libdir}/apr-%{aprver}
138%dir %{_libdir}/apr-%{aprver}/build
139%{_libdir}/apr-%{aprver}/build/*
140%dir %{_includedir}/apr-%{aprver}
141%{_includedir}/apr-%{aprver}/*.h
142
143%changelog
144* Wed Dec 19 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.2-2
145- SECURITY FIX: patches from CentOS 6 - apr-1.3.9-5.el6_2
146 - CVE-2011-0419: add patch (Patch10)
147 - CVE-2011-1928: fix apr_fnmatch() regression patch (Patch11)
148
149* Wed Sep 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.2-1
150- new upstream release
151- built with rpm-4.8.1
152- removed static libraries from devel package
153
154* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.10-1
155- rebuilt with new toolchain
156
157* Thu Dec 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-1
158- new upstream release
159
160* Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.8-1
161- new upstream release with security fix (CVE-2009-2412)
162
163* Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.5-1
164- new upstream release
165
166* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.3-1vl5
167- new upstream release
168- updated Patch5
169
170* Wed Jun 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-1vl5
171- new upstream release
172- removed Patch1 and 6
173
174* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-2vl5
175- removed *.la files from devel package
176
177* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1vl5
178- new upstream release
179- added Patch2 and 6 from Fedora
180  * Mon Jun 19 2006 Joe Orton <jorton@redhat.com> 1.2.7-9
181  - add fix for use of %%pI with psprintf
182  * Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
183  - use RTLD_DEEPBIND in apr_dso_open by default
184
185* Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
186- new upstream release
187
188* Thu Jul 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
189- new upstream release
190
191* Mon May 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl3
192- remove Requires: gcc = %%(gcc -dumpversion)
193
194* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl2
195- rebuilt with new toolchain
196
197* Sat Jan 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
198- new upstream release
199
200* Mon May 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
201- initial build for Vine Linux based on FC package
202
203* Tue May 23 2006 Joe Orton <jorton@redhat.com> 1.2.7-7
204- fix another multilib conflict (#192659)
205
206* Tue May 16 2006 Joe Orton <jorton@redhat.com> 1.2.7-6
207- BR e2fsprogs-devel for libuuid
208
209* Mon May  8 2006 Joe Orton <jorton@redhat.com> 1.2.7-4
210- use multilib parallel-installation wrapper hack for apr.h
211
212* Tue May  2 2006 Joe Orton <jorton@redhat.com> 1.2.7-3
213- fix installbuilddir in apr-1-config
214
215* Tue May  2 2006 Joe Orton <jorton@redhat.com> 1.2.7-2
216- update to 1.2.7
217- use pkg-config in apr-1-config to make it libdir-agnostic
218
219* Thu Apr  6 2006 Joe Orton <jorton@redhat.com> 1.2.6-2
220- update to 1.2.6
221
222* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.2
223- bump again for double-long bug on ppc(64)
224
225* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.1
226- rebuilt for new gcc4.1 snapshot and glibc changes
227
228* Wed Jan  4 2006 Joe Orton <jorton@redhat.com> 1.2.2-7
229- fix namespace pollution (r354824, r355464)
230
231* Wed Jan  4 2006 Joe Orton <jorton@redhat.com> 1.2.2-6
232- fix build with recent glibc (#176911)
233
234* Tue Jan  3 2006 Jesse Keating <jkeating@redhat.com> 1.2.2-5.2
235- rebuilt again
236
237* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
238- rebuilt
239
240* Fri Dec  9 2005 Joe Orton <jorton@redhat.com> 1.2.2-5
241- rebuild for new gcc
242
243* Thu Dec  8 2005 Joe Orton <jorton@redhat.com> 1.2.2-4
244- add apr_file_seek() fixes from upstream (r326593, r326597)
245
246* Wed Dec  7 2005 Joe Orton <jorton@redhat.com> 1.2.2-3
247- apr-1-config: strip more exports (#175124)
248
249* Tue Dec  6 2005 Joe Orton <jorton@redhat.com> 1.2.2-2
250- avoid linking against -lrt
251- don't print -L${libdir} in --libs output
252- don't export -lcrypt/-luuid in .la file
253
254* Fri Dec  2 2005 Joe Orton <jorton@redhat.com> 1.2.2-1
255- update to 1.2.2
256
257* Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
258- use RTLD_DEEPBIND in apr_dso_open by default
259
260* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-2
261- update to 0.9.7
262
263* Fri Sep 30 2005 Florian La Roche <laroche@redhat.com>
264- rebuild for new gcc
265
266* Thu Sep 15 2005 Joe Orton <jorton@redhat.com> 0.9.6-6
267- don't override CFLAGS at build time
268- allow setting TCP_NODELAY and TCP_CORK concurrently
269- use _exit() not exit() in child if exec*() fails (upstream #30913)
270
271* Fri Sep  9 2005 Joe Orton <jorton@redhat.com> 0.9.6-5
272- add from 0.9.x branch:
273 * fix for apr_{uid,gid}_* error handling (r239592)
274 * fix for apr_file_ write flushing (r267192)
275- add backport for use of readdir64_r (r265032, r265681, r265684)
276
277* Mon Jul 11 2005 Florian La Roche <laroche@redhat.com>
278- rebuild
279
280* Tue May 17 2005 Joe Orton <jorton@redhat.com> 0.9.6-3
281- fix apr_procattr_child_*_set error handling
282
283* Tue Mar  1 2005 Joe Orton <jorton@redhat.com> 0.9.6-2
284- have apr-devel depend on specific version of gcc
285- add NOTICE to docdir
286
287* Wed Feb  9 2005 Joe Orton <jorton@redhat.com> 0.9.6-1
288- update to 0.9.6
289
290* Wed Feb  2 2005 Joe Orton <jorton@redhat.com> 0.9.5-4
291- don't disable sendfile on s390 (IBM LTC, #146891)
292
293* Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-3
294- really fix apr-config --srcdir
295
296* Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-2
297- fix apr-config --srcdir again
298
299* Sun Nov 21 2004 Joe Orton <jorton@redhat.com> 0.9.5-1
300- update to 0.9.5
301
302* Mon Sep 27 2004 Joe Orton <jorton@redhat.com> 0.9.4-24
303- rebuild
304
305* Wed Sep  1 2004 Joe Orton <jorton@redhat.com> 0.9.4-23
306- have -devel require apr of same V-R
307
308* Tue Aug 31 2004 Joe Orton <jorton@redhat.com> 0.9.4-22
309- backport fixes from HEAD:
310 * correct implementation of nested mutexes
311 * support for POSIX semaphores on LP64 platforms
312
313* Thu Jul 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-21
314- rebuild for another attempt at using sem_open
315
316* Tue Jul 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-20
317- move sticky/suid bits outside APR_OS_DEFAULT bitmask (Greg Hudson)
318
319* Thu Jul  1 2004 Joe Orton <jorton@redhat.com> 0.9.4-19
320- rebuild
321
322* Wed Jun 30 2004 Joe Orton <jorton@redhat.com> 0.9.4-18
323- rebuild now /dev/shm is mounted
324
325* Thu Jun 17 2004 Joe Orton <jorton@redhat.com> 0.9.4-17
326- add fix for cleanup structure reuse (part of upstream #23567)
327
328* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
329- rebuilt
330
331* Thu Jun 10 2004 Joe Orton <jorton@redhat.com> 0.9.4-15
332- add support for setuid/setgid/sticky bits (Andr辿 Malo)
333- add apr_threadattr_{guardsize,stacksize}_set() (latter by Jeff Trawick)
334
335* Mon Jun  7 2004 Joe Orton <jorton@redhat.com> 0.9.4-14
336- enable posixsem and process-shared pthread mutex support, but
337  ensure that sysvsem remains the default mechanism
338
339* Mon May 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-13
340- entirely remove 2Gb file size limit from apr_file_copy();
341  fixes "svnadmin hotcopy" on repos with >2Gb strings table
342- work around getnameinfo bugs with v4-mapped addresses
343- fix apr_time_exp_get() for dates in 2038 (Philip Martin)
344
345* Thu May 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-12
346- use APR_LARGEFILE in apr_file_{copy,append}
347
348* Wed Mar 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-11
349- add APR_LARGEFILE flag
350
351* Mon Mar 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-10
352- fix configure check for mmap of /dev/zero
353- just put -D_GNU_SOURCE in CPPFLAGS not _{BSD,SVID,XOPEN}_SOURCE
354
355* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-9.1
356- rebuilt
357
358* Thu Feb 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-9
359- undocument apr_dir_read() ordering constraint and fix tests
360
361* Sun Feb 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-8
362- rebuilt without -Wall -Werror
363
364* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-7
365- rebuilt
366
367* Tue Feb  3 2004 Joe Orton <jorton@redhat.com> 0.9.4-6
368- define apr_off_t as int/long/... to prevent it changing
369  with _FILE_OFFSET_BITS on 32-bit platforms
370
371* Mon Jan 12 2004 Joe Orton <jorton@redhat.com> 0.9.4-5
372- add apr_temp_dir_get fixes from HEAD
373
374* Thu Jan  8 2004 Joe Orton <jorton@redhat.com> 0.9.4-4
375- ensure that libapr is linked against libpthread
376- don't link libapr against -lnsl
377
378* Thu Nov 13 2003 Joe Orton <jorton@redhat.com> 0.9.4-3
379- -devel package no longer requires libtool
380
381* Fri Oct  3 2003 Joe Orton <jorton@redhat.com> 0.9.4-2
382- disable tests on x86_64 (#97611)
383
384* Fri Oct  3 2003 Joe Orton <jorton@redhat.com> 0.9.4-1
385- update to 0.9.4, enable tests
386- ensure that libresolv is not used
387
388* Sun Sep  7 2003 Joe Orton <jorton@redhat.com> 0.9.3-14
389- use /dev/urandom (#103049)
390
391* Thu Jul 24 2003 Joe Orton <jorton@redhat.com> 0.9.3-13
392- add back CC=gcc, CXX=g++
393
394* Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.9.3-12
395- rebuild
396
397* Mon Jul 14 2003 Joe Orton <jorton@redhat.com> 0.9.3-11
398- work round useless autoconf 2.57 AC_DECL_SYS_SIGLIST
399
400* Thu Jul 10 2003 Joe Orton <jorton@redhat.com> 0.9.3-10
401- support --cc and --cpp arguments in apr-config
402
403* Thu Jul  3 2003 Joe Orton <jorton@redhat.com> 0.9.3-9
404- force libtool to use CC=gcc, CXX=g++
405
406* Thu Jul  3 2003 Joe Orton <jorton@redhat.com> 0.9.3-8
407- fix libtool location in apr_rules.mk
408
409* Mon Jun 30 2003 Joe Orton <jorton@redhat.com> 0.9.3-7
410- use AI_ADDRCONFIG in getaddrinfo() support (#73350)
411- include a working libtool script rather than relying on
412 /usr/bin/libtool (#97695)
413
414* Wed Jun 18 2003 Joe Orton <jorton@redhat.com> 0.9.3-6
415- don't use /usr/bin/libtool
416
417* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
418- rebuilt
419
420* Tue May 20 2003 Joe Orton <jorton@redhat.com> 0.9.3-5
421- add fix for psprintf memory corruption (CAN-2003-0245)
422- remove executable bit from apr_poll.h
423
424* Thu May  1 2003 Joe Orton <jorton@redhat.com> 0.9.3-4
425- link libapr against libpthread
426- make apr-devel conflict with old subversion-devel
427- fix License
428
429* Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-3
430- run ldconfig in post/postun
431
432* Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-2
433- patch test suite to not care if IPv6 is disabled
434
435* Mon Apr 28 2003 Joe Orton <jorton@redhat.com> 0.9.3-1
436- initial build
Note: See TracBrowser for help on using the repository browser.