source: projects/specs/branches/6/a/apr-util/apr-util-vl.spec @ 6646

Revision 6646, 13.0 KB checked in by Takemikaduchi, 12 years ago (diff)

fix broken package

Line 
1%define apuver 1
2
3Summary: Apache Portable Runtime Utility library
4Summary(ja): Apache ポータブルランタイムユーティリティライブラリ
5Name: apr-util
6Version: 1.3.9
7Release: 8%{?_dist_release}
8
9License: Apache Software License 2.0
10Group: System Environment/Libraries
11URL: http://apr.apache.org/
12
13Source0: %{name}-%{version}.tar.bz2
14Patch1: apr-util-1.2.7-pkgconf.patch
15Patch2: apr-util-1.3.7-nodbmdso.patch
16#security fix
17Patch100: apr-util-1.3.x-CVE-2009-0023.diff
18Patch110: apr-util-1.3.x-CVE-2009-1955.diff
19Patch120: apr-util-1.3.4_CVE-2009-1956.patch
20Patch130: apr-util-1.3.x-CVE-2009-2412.diff
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: autoconf, doxygen, apr-devel >= 1.2.0
24BuildRequires: db4-devel, expat-devel, libuuid-devel
25BuildRequires: postgresql-devel
26BuildRequires: MySQL-devel
27BuildRequires: zlib-devel
28BuildRequires: sqlite3-devel
29BuildRequires: unixODBC-devel
30BuildRequires: openldap-devel
31Conflicts: subversion < 0.20.1-2
32Obsoletes: apache2-apr
33
34%description
35The mission of the Apache Portable Runtime (APR) is to provide a
36free library of C data structures and routines.  This library
37contains additional utility interfaces for APR; including support
38for XML, LDAP, database interfaces, URI parsing and more.
39
40%package devel
41Summary: APR utility library development kit
42Summary(ja): APR ユーティリティライブラリ開発キット
43Group: Development/Libraries
44Requires: apr-util = %{version}-%{release}, apr-devel, pkgconfig
45Requires: openldap-devel, db4-devel, expat-devel
46Conflicts: subversion-devel < 0.20.1-2
47Obsoletes: apache2-apr-devel
48
49%description devel
50This package provides the support files which can be used to
51build applications using the APR utility library.  The mission
52of the Apache Portable Runtime (APR) is to provide a free
53library of C data structures and routines.
54
55%package pgsql
56Summary: APR utility library PostgreSQL DBD driver
57Group: System Environment/Libraries
58Requires: apr-util = %{version}-%{release}
59
60%description pgsql
61This package provides the PostgreSQL driver for the apr-util
62DBD (database abstraction) interface.
63
64%package mysql
65Summary: APR utility library MySQL DBD driver
66Group: System Environment/Libraries
67Requires: apr-util = %{version}-%{release}
68
69%description mysql
70This package provides the MySQL driver for the apr-util DBD
71(database abstraction) interface.
72
73%package sqlite
74Summary: APR utility library SQLite DBD driver
75Group: System Environment/Libraries
76Requires: apr-util = %{version}-%{release}
77
78%description sqlite
79This package provides the SQLite driver for the apr-util DBD
80(database abstraction) interface.
81
82#%package freetds
83#Group: Development/Libraries
84#Summary: APR utility library FreeTDS DBD driver
85#BuildRequires: freetds-devel
86#Requires: apr-util = %{version}-%{release}
87
88#%description freetds
89#This package provides the FreeTDS driver for the apr-util DBD
90#(database abstraction) interface.
91
92%package odbc
93Summary: APR utility library ODBC DBD driver
94Group: System Environment/Libraries
95Requires: apr-util = %{version}-%{release}
96
97%description odbc
98This package provides the ODBC driver for the apr-util DBD
99(database abstraction) interface.
100
101%package ldap
102Summary: APR utility library LDAP support
103Group: System Environment/Libraries
104Requires: apr-util = %{version}-%{release}
105
106%description ldap
107This package provides the LDAP support for the apr-util.
108
109%prep
110%setup -q
111%patch1 -p1 -b .pkgconf
112%patch2 -p1 -b .nodbmdso
113
114#patch100 -p0 -b .CVE-2009-0023
115#patch110 -p0 -b .CVE-2009-1955
116#patch120 -p0 -b .CVE-2009-1956
117#patch130 -p4 -b .CVE-2009-2412
118
119%build
120autoheader && autoconf
121%configure --with-apr=%{_prefix} \
122        --includedir=%{_includedir}/apr-%{apuver} \
123        --with-ldap --without-gdbm \
124        --with-sqlite3 --with-pgsql --with-mysql --with-odbc \
125        --with-berkeley-db \
126        --without-sqlite2
127#        --disable-util-dso       
128make %{?_smp_mflags} && make dox
129
130%install
131rm -rf $RPM_BUILD_ROOT
132make install DESTDIR=$RPM_BUILD_ROOT
133
134mkdir -p $RPM_BUILD_ROOT/%{_datadir}/aclocal
135install -m 644 build/find_apu.m4 $RPM_BUILD_ROOT/%{_datadir}/aclocal
136
137# Documentation
138rm -rf html
139mkdir -p html
140cp -pr docs/dox/html/* html
141
142# Unpackaged files; remove the static libaprutil
143rm -f $RPM_BUILD_ROOT%{_libdir}/aprutil.exp \
144      $RPM_BUILD_ROOT%{_libdir}/libapr*.a
145
146# remove *.la
147rm -f $RPM_BUILD_ROOT%{_libdir}/libapr*.la
148
149# And remove the reference to the static libaprutil from the .la
150# file.
151#sed -i '/^old_library/s,libapr.*\.a,,' \
152#      $RPM_BUILD_ROOT%{_libdir}/libapr*.la
153
154# Remove unnecessary exports from dependency_libs
155#sed -ri '/^dependency_libs/{s,-l(pq|sqlite[0-9]|rt|dl|uuid) ,,g}' \
156#      $RPM_BUILD_ROOT%{_libdir}/libapr*.la
157
158# Trim libtool DSO cruft
159rm -f $RPM_BUILD_ROOT%{_libdir}/apr-util-%{apuver}/*.*a
160
161%check
162# Run the less verbose test suites
163export MALLOC_CHECK_=2 MALLOC_PERTURB_=$(($RANDOM % 255 + 1))
164cd test
165make %{?_smp_mflags} testall
166# testall breaks with DBD DSO; ignore
167export LD_LIBRARY_PATH="`echo "../dbm/.libs:../dbd/.libs:../ldap/.libs:$LD_LIBRARY_PATH" | sed -e 's/::*$//'`"
168./testall -v -q || true
169./testall testrmm
170./testall testdbm
171
172%clean
173rm -rf $RPM_BUILD_ROOT
174
175%post -p /sbin/ldconfig
176
177%postun -p /sbin/ldconfig
178
179%files
180%defattr(-,root,root,-)
181%doc CHANGES LICENSE NOTICE
182%{_libdir}/libaprutil-%{apuver}.so.*
183%dir %{_libdir}/apr-util-%{apuver}
184
185%files devel
186%defattr(-,root,root,-)
187%{_bindir}/apu-%{apuver}-config
188#{_libdir}/libaprutil-%{apuver}.a
189%{_libdir}/libaprutil-%{apuver}.so
190%{_includedir}/apr-%{apuver}/*.h
191%{_libdir}/pkgconfig/*.pc
192%{_datadir}/aclocal/*.m4
193%doc --parents html
194
195%files pgsql
196%defattr(-,root,root,-)
197%{_libdir}/apr-util-%{apuver}/apr_dbd_pgsql*
198
199%files mysql
200%defattr(-,root,root,-)
201%{_libdir}/apr-util-%{apuver}/apr_dbd_mysql*
202
203%files sqlite
204%defattr(-,root,root,-)
205%{_libdir}/apr-util-%{apuver}/apr_dbd_sqlite*
206
207#files freetds
208#defattr(-,root,root,-)
209#{_libdir}/apr-util-%{apuver}/apr_dbd_freetds*
210
211%files odbc
212%defattr(-,root,root,-)
213%{_libdir}/apr-util-%{apuver}/apr_dbd_odbc*
214
215%files ldap
216%defattr(-,root,root,-)
217%{_libdir}/apr-util-%{apuver}/apr_ldap*
218
219%changelog
220* Sat Jul 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.9-8
221- rebuild with unixODBC-2.2.14
222
223* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 1.3.9-7
224- rebuilt with postgresql-9.0.3
225
226* Sat Apr  9 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-6
227- rebuilt with unixODBC-2.2.14
228
229* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.9-5
230- rebuilt with rpm-4.8.1 for pkg-config
231
232* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.9-4
233- rebuilt with gcc-4.4.3-3 on ppc
234
235* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.9-3
236- rebuilt with rpm-4.8.0-3 (on ppc)
237
238* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.9-2
239- rebuild with db4-4.8.0
240
241* Sat Jan  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-1
242- new upstream release
243- dropped Patch100, 110, 120 and 130 (merged into upstream)
244- added BR: zlib-devel
245
246* Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.4-5
247- add Patch130 for fix CVE-2009-2412 (IOF apr_rmm_malloc)
248- This patch is included in 1.3.9
249
250* Thu Jun 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.4-4
251- add patch100 for fix CVE-2009-0023
252- add patch110 for fix CVE-2009-1955
253- add patch120 for fix CVE-2009-1956
254- These patches are included in 1.3.7 or later
255
256* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.4-3
257- rebuilt with MySQL-5.1.34.
258
259* Thu Apr  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-2
260- rebuilt with openldap-2.4.11
261
262* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-1vl5
263- new upstream release
264- split out DBD drivers and ldap support into subpackage
265
266* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-1vl5
267- new upstream release
268- built with db-4.6.21
269
270* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-2vl5
271- removed *.la files from devel package
272
273* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1vl5
274- new upstream release
275- added Patch3 from Fedora Core
276  * Fri Mar 23 2007 Joe Orton <jorton@redhat.com> 1.2.8-6
277  - add DBD DSO lifetime fix (r521327)
278
279* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.10-0vl2
280- rebuild with expat-2.0.1
281
282* Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
283- new upstream release
284
285* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl2
286- rebuilt with new toolchain
287
288* Sat Jan 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
289- new upstream release
290- dropped Patch1 (merged into upstream)
291
292* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.7-0vl2
293- rebuilt with openldap-2.3.27-0vl1
294
295* Mon May 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
296- initial build for Vine Linux based on FC package
297
298* Tue May  2 2006 Joe Orton <jorton@redhat.com> 1.2.7-2
299- update to 1.2.7
300- use pkg-config in apu-1-config to make it libdir-agnostic
301
302* Thu Apr  6 2006 Joe Orton <jorton@redhat.com> 1.2.6-2
303- update to 1.2.6
304- define LDAP_DEPRECATED in apr_ldap.h (r391985, #188073)
305
306* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-4.2
307- bump again for double-long bug on ppc(64)
308
309* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-4.1
310- rebuilt for new gcc4.1 snapshot and glibc changes
311
312* Mon Jan 30 2006 Joe Orton <jorton@redhat.com> 1.2.2-4
313- rebuild to drop reference to libexpat.la
314
315* Wed Jan 18 2006 Joe Orton <jorton@redhat.com> 1.2.2-3
316- disable sqlite2 support
317- BuildRequire e2fsprogs-devel
318- enable malloc paranoia in %%check
319
320* Tue Jan  3 2006 Jesse Keating <jkeating@redhat.com> 1.2.2-2.2
321- rebuilt again
322
323* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
324- rebuilt
325
326* Tue Dec  6 2005 Joe Orton <jorton@redhat.com> 1.2.2-2
327- trim exports from .la file/--libs output (#174924)
328
329* Fri Nov 25 2005 Joe Orton <jorton@redhat.com> 1.2.2-1
330- update to 1.2.2
331
332* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
333- fix epoch again
334
335* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-2
336- update to 0.9.7
337- drop static libs (#170051)
338
339* Tue Jul 26 2005 Joe Orton <jorton@redhat.com> 0.9.6-3
340- add FILE bucket fix for truncated files (#159191)
341- add epoch to dependencies
342
343* Fri Mar  4 2005 Joe Orton <jorton@redhat.com> 0.9.6-2
344- rebuild
345
346* Wed Feb  9 2005 Joe Orton <jorton@redhat.com> 0.9.6-1
347- update to 0.9.6
348
349* Wed Jan 19 2005 Joe Orton <jorton@redhat.com> 0.9.5-3
350- restore db-4.3 detection lost in 0.9.5 upgrade
351
352* Wed Jan 19 2005 Joe Orton <jorton@redhat.com> 0.9.5-2
353- rebuild
354
355* Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-1
356- update to 0.9.5
357
358* Thu Nov 11 2004 Jeff Johnson <jbj@jbj.org> 0.9.4-19
359- actually explicitly check for and detect db-4.3.
360
361* Thu Nov 11 2004 Jeff Johnson <jbj@jbj.org> 0.9.4-18
362- rebuild against db-4.3.21.
363
364* Fri Sep 17 2004 Joe Orton <jorton@redhat.com> 0.9.4-17
365- add security fix for CAN-2004-0786
366
367* Sat Jun 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-16
368- have -devel require matching release of apr-util
369
370* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
371- rebuilt
372
373* Thu Apr  1 2004 Joe Orton <jorton@redhat.com> 0.9.4-14
374- fix use of SHA1 passwords (#119651)
375
376* Tue Mar 30 2004 Joe Orton <jorton@redhat.com> 0.9.4-13
377- remove fundamentally broken check_sbcs() from xlate code
378
379* Fri Mar 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-12
380- tweak xlate fix
381
382* Fri Mar 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-11
383- rebuild with xlate fixes and tests enabled
384
385* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-10.1
386- rebuilt
387
388* Tue Mar  2 2004 Joe Orton <jorton@redhat.com> 0.9.4-10
389- rename sdbm_* symbols to apu__sdbm_*
390
391* Mon Feb 16 2004 Joe Orton <jorton@redhat.com> 0.9.4-9
392- fix sdbm apr_dbm_exists() on s390x/ppc64
393
394* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-8
395- rebuilt
396
397* Thu Feb  5 2004 Joe Orton <jorton@redhat.com> 0.9.4-7
398- fix warnings from use of apr_optional*.h with gcc 3.4
399
400* Thu Jan 29 2004 Joe Orton <jorton@redhat.com> 0.9.4-6
401- drop gdbm support
402
403* Thu Jan  8 2004 Joe Orton <jorton@redhat.com> 0.9.4-5
404- fix DB library detection
405
406* Sat Dec 13 2003 Jeff Johnson <jbj@jbj.org> 0.9.4-4
407- rebuild against db-4.2.52.
408
409* Mon Oct 13 2003 Jeff Johnson <jbj@jbj.org> 0.9.4-3
410- rebuild against db-4.2.42.
411
412* Mon Oct  6 2003 Joe Orton <jorton@redhat.com> 0.9.4-2
413- fix 'apu-config --apu-la-file' output
414
415* Mon Oct  6 2003 Joe Orton <jorton@redhat.com> 0.9.4-1
416- update to 0.9.4.
417
418* Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.9.3-10
419- rebuild
420
421* Mon Jul  7 2003 Joe Orton <jorton@redhat.com> 0.9.3-9
422- rebuild
423- don't run testuuid test because of #98677
424
425* Thu Jul  3 2003 Joe Orton <jorton@redhat.com> 0.9.3-8
426- rebuild
427
428* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
429- rebuilt
430
431* Tue May 20 2003 Joe Orton <jorton@redhat.com> 0.9.3-6
432- fix to detect crypt_r correctly (CAN-2003-0195)
433
434* Thu May 15 2003 Joe Orton <jorton@redhat.com> 0.9.3-5
435- fix to try linking against -ldb first (#90917)
436- depend on openldap, gdbm, db4, expat appropriately.
437
438* Tue May 13 2003 Joe Orton <jorton@redhat.com> 0.9.3-4
439- rebuild
440
441* Wed May  7 2003 Joe Orton <jorton@redhat.com> 0.9.3-3
442- make devel package conflict with old subversion-devel
443- run the less crufty parts of the test suite
444
445* Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-2
446- run ldconfig in post/postun
447
448* Mon Apr 28 2003 Joe Orton <jorton@redhat.com> 0.9.3-1
449- initial build
Note: See TracBrowser for help on using the repository browser.