source: projects/specs/branches/6/a/apmd/apmd-vl.spec @ 521

Revision 521, 11.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Advanced Power Management (APM) BIOS utilities for laptops.
2Name: apmd
3Version: 3.2.2
4Release: 1%{?_dist_release}
5Source: ftp://ftp.debian.org/debian/pool/main/a/apmd/%{name}_%{version}.orig.tar.gz
6Source1: apmd.init
7Source2: apmscript
8Source3: apmd.conf
9Source4: laptopmode
10Patch: apmd-3.2-build.patch
11Patch1: apmd-3.2-umask.patch
12Patch2: apmd-3.2-error.patch
13Patch4: apmd-3.2-x.patch
14License: GPLv2+
15Group: System Environment/Daemons
16URL: ftp://ftp.debian.org/debian/pool/main/a/apmd
17Prereq: chkconfig
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19ExclusiveArch:%{ix86}
20
21%description
22APMD is a set of programs for controlling the Advanced Power
23Management daemon and utilities found in most modern laptop
24computers. APMD can watch your notebook's battery and warn
25users when the battery is low. APMD is also capable of shutting
26down the PCMCIA sockets before a suspend.
27
28Install the apmd package if you need to control the APM system
29on your laptop.
30
31%prep
32%setup -q -n apmd-%{version}.orig
33%patch -p1 -b .build
34%patch1 -p1 -b .umask
35%patch2 -p1 -b .error
36%patch4 -p1 -b .x
37
38%build
39make CFLAGS="$RPM_OPT_FLAGS"
40
41%install
42rm -rf $RPM_BUILD_ROOT
43
44mkdir -p $RPM_BUILD_ROOT/etc/{sysconfig/apm-scripts,rc.d/init.d}
45
46%makeinstall APMD_PROXY_DIR=$RPM_BUILD_ROOT/etc
47
48mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man{1,8}
49for manpage in apm apmsleep ; do
50  install -m 644 $manpage.1 $RPM_BUILD_ROOT/%{_mandir}/man1/
51done
52install -m 644 apmd.8 $RPM_BUILD_ROOT/%{_mandir}/man8/
53
54install -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/apmd
55install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/apm-scripts/
56install -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/apmd
57install -m 755 %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/apm-scripts/
58rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/apmd_proxy
59rm -rf $RPM_BUILD_ROOT%{_bindir}/on_ac_power
60rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%post
66/sbin/chkconfig --add apmd
67
68%preun
69if [ $1 = 0 ]; then
70    service apmd stop > /dev/null 2>&1
71    /sbin/chkconfig --del apmd
72fi
73
74%postun
75if [ "$1" -ge "1" ]; then
76    service apmd condrestart > /dev/null 2>&1
77fi
78
79%triggerpostun -- apmd <= 3.0final-6
80/sbin/chkconfig --add apmd
81
82%files
83%defattr(-,root,root)
84%doc ChangeLog README LSM
85%{_mandir}/man?/*
86%{_bindir}/*
87%{_sbindir}/*
88%{_libdir}/libapm.a
89%{_includedir}/*.h
90%config /etc/rc.d/init.d/apmd
91%config(noreplace) /etc/sysconfig/apmd
92%dir /etc/sysconfig/apm-scripts
93%config /etc/sysconfig/apm-scripts/*
94
95%changelog
96* Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2-1
97- new upstream (debian)
98- update to 3.2.2
99- refresh patches
100- remove on_ac_power, which is now provided by pm-utils
101
102* Mon Oct 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.0.2-19vl1
103- based on Redhat Rawhide
104  - Mon May 19 2003 Bill Nottingham <notting@redhat.com> 1:3.0.2-19
105  - add support for laptop_mode in apmscript
106  - make LOWPOWER_SERVICES not depend on POWER_SERVICES (#74935)
107  - remove xapm manpage (#77900)
108  - fix soundmodules bogosity (#90592)
109  - fix ordering of network & services (#90512, #85436, <dberger@oubliette.org>)
110  - own /etc/sysconfig/apm-scripts (#74026)
111  - run anacron with -s (#65689)
112  - Thu Feb 20 2003 Bill Nottingham <notting@redhat.com> 1:3.0.2-17
113  - don't remove network modules (#83996)
114  - Tue Feb 18 2003 Bill Nottingham <notting@redhat.com> 1:3.0.2-16
115  - pass arguments to apmcontinue-pre (#83398, <aleksey@nogin.org>)
116  - fix NETDEVICES line (#81153)
117  - Thu Jan  2 2003 Jeremy Katz <katzj@redhat.com> 1:3.0.2-14
118  - add CPUFREQ= to /etc/sysconfig/apmd
119  - if CPUFREQ="yes" and /proc/cpufreq exists, use cpufreq to change between
120    performance and power-save when switching between ac and battery
121  - Wed Apr  3 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.2-8
122  - Fix interoperability with hotplug (#62045)
123  - Fix build with current kernel headers
124  - Tue Feb 26 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.2-6
125  - Fix up network device detection (#59447)
126  - Adapt hwclock calls to current hwclock behavior (#59994)
127  - Fix net device resume (#59009, #49918)
128  - Re-add pre-{suspend,resume} hooks (#44603)
129  - Move LOW_POWER notification file to /var/run/apmd (#56389)
130  - Determine if X is running before anything else (#20892)
131  - Run hwclock earlier on resume (#28234)
132  - Change permissions on /etc/sysconfig/apmd, 0644 is sufficient (#54222)
133  - Fix stab location (#56718)
134  - Don't mess up terminal beep on resume (#57955)
135  - Mon Nov 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.2-1
136  - 3.0.2
137
138- rebuild with new toolchains
139
140* Wed Dec 19 2001 Toru Sagami <sagami@vinelinux.org> 3.0finel-24vl2
141- added a patch to build on glibc22 system
142
143* Sun May 27 2001 <sagami@vinelinux.org>
144- apmd-3.0finel-24vl1
145- use tar with --bzip2 and erased BuildPreReq tar >= 1.13.18
146
147* Thu Nov  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
148- Remove the obsolete -i and -n options from the man page (Bug #19610)
149- Fix build with tar >= 1.13.18
150
151* Tue Oct 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
152- Work around yet another BIOS bug ("Bug" #19674)
153- Fix up the check for running anacron
154
155* Mon Oct  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
156- It's /sbin/cardctl, not /usr/sbin/cardctl (Bug #18021)
157
158* Thu Aug 31 2000 Bernhard Rosenkraenzer <bero@redhat.com>
159- change startup order - apmd should be started after netfs to cope with
160  an NFS /usr (Not that anyone uses NFS mounted filesystems on notebooks,
161  but...) (Bug #16251)
162
163* Wed Aug 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
164- Add NETFS_RESTART feature, fix up LOCK_X to use yes/no like the
165  other settings (Bug #17068 and some other stuff)
166
167* Fri Aug 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
168- Fix typo in suspend script, bug #16957
169
170* Thu Aug 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
171- Fix up "status" in init script, bug #16275
172
173* Tue Aug  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
174- ignore "start" and "stop" events in apmscript instead of claiming
175  they're unknown events (Bug #15598)
176
177* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
178- condrestart fixes
179
180* Thu Aug  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
181- Handle "power" events in apmscript (Bug #15283)
182
183* Tue Aug  1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
184- Fix typo in man page (Bug #14778)
185
186* Mon Jul 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
187- Use cardctl to suspend/resume pcmcia cards instead of restarting
188  the entire subsystem (Bug #13836)
189
190* Mon Jul 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
191- Don't use obsolete parameters (Bug #13710)
192- Add the possibility to lock X displays on suspend, based on patch from
193  Hannu Martikka <Hannu.Martikka@nokia.com>
194- some other fixes to the apmd scripts
195
196* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
197- move initscript back
198
199* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
200- automatic rebuild
201
202* Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
203- don't prereq, just require initscripts
204
205* Mon Jun 26 2000 Bernhard Rosenkraenzer <bero@redhat.com>
206- Fix init script, move to /etc/init.d
207
208* Sun Jun 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
209- Fix resume for users of non-bash shells (Bug #11580)
210- Support restoring sound with the commercial OSS drivers (Bug #11580)
211
212* Mon Jun 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
213- FHSify
214
215* Sat May 27 2000 Bernhard RosenkrçÏzer <bero@redhat.com>
216- Some more changes to apm-scripts:
217  - Fix up HDPARM_AT_RESUME
218  - Add ANACRON_ON_BATTERY, and default to turning it off
219
220* Mon May  8 2000 Bernhard RosenkrçÏzer <bero@redhat.com>
221- Various fixes to the apm-scripts:
222  - use modprobe instead of insmod for restoring sound
223  - don't try to restore the X display if X isn't running
224  - /usr/sbin/anacron, not /usr/bin/anacron
225  - misc. cleanups
226
227* Fri Feb  4 2000 Bernhard RosenkrçÏzer <bero@redhat.com>
228- rebuild to compress man pages
229
230* Mon Jan 17 2000 Bernhard RosenkrçÏzer <bero@redhat.com>
231- Update to 3.0final
232
233* Mon Jan 17 2000 Bernhard RosenkrçÏzer <bero@redhat.com>
234- Fixes for UTC clocks (Bug #7939)
235
236* Thu Jan  6 2000 Bernhard RosenkrçÏzer <bero@redhat.com>
237- If anacron is installed, run it at resume time.
238
239* Sun Nov 21 1999 Bernhard RosenkrçÏzer <bero@redhat.com>
240- Fix up the broken harddisk fix (needs to be done earlier during suspend,
241  also we need to manually wake the drive at resume.)
242
243* Sun Nov 21 1999 Bernhard RosenkrçÏzer <bero@redhat.com>
244- Updates to the apm-scripts and sysconfig/apmd:
245  - Make hwclock --hctosys call optional (CLOCK_SYNC variable)
246  - Add possibility to modify hdparm settings on suspend/resume.
247    Some broken harddisks (Gericom 3xC) require this for suspend
248    to disk to work.
249
250* Wed Nov 10 1999 Bernhard RosenkrçÏzer <bero@redhat.com>
251- Put in new apm scripts to handle PCMCIA suspend/resume, and give the
252  possibility to refresh displays and reload sound modules for some
253  broken chipsets
254- permit builds on i486, i586 and i686 archs
255
256* Mon Sep 20 1999 Michael K. Johnson <johnsonm@redhat.com>
257- accept both "UTC=yes" and "UTC=true"
258
259* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
260- uh-oh, do I own this now?
261- update to 3.0beta9
262
263* Thu Jul  1 1999 Bill Nottingham <notting@redhat.com>
264- start after, die before network fs...
265
266* Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
267- add check for /proc/apm (not on SMP) (#3403)
268
269* Mon May 31 1999 Jeff Johnson <jbj@redhat.com>
270- shell script tweak (#3176).
271
272* Fri May  7 1999 Bill Nottingham <notting@redhat.com>
273- set -u flag for utc
274
275* Sat Apr 17 1999 Matt Wilson <msw@redhat.com>
276- prereqs chkconfig
277
278* Fri Apr 16 1999 Cristian Gafton <gafton@redhat.com>
279- exlusive arch i3786, as sparcs and alphas have no apm support...
280
281* Wed Apr 14 1999 <ewt@redhat.com>
282- removed X bits; gnome has a much better X interface for apm anyway
283
284* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
285- auto rebuild in the new build environment (release 4)
286
287* Fri Mar 19 1999 Preston Brown <pbrown@redhat.com>
288- quoted APMD_OPTIONS variable in the init script
289
290* Tue Mar 09 1999 Preston Brown <pbrown@redhat.com>
291- whoops, making /etc/rc.d/init.d/apmd a directory was a bad idea. fixed.
292
293* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
294- now owned by Avery Pennarun <apenwarr@debian.org>, upgraded to his latest.
295
296* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
297- Injected new description and group.
298
299* Fri Nov 06 1998 Preston Brown <pbrown@redhat.com>
300- updated to latest patchlevel from web page.
301
302* Wed Apr 22 1998 Michael K. Johnson <johnsonm@redhat.com>
303- enhanced init script
304
305* Thu Apr 1 1998 Erik Troan <ewt@redhat.com>
306- moved init script into a separate source file
307- added restart and status options to initscript
308- made it use a build root
309- don't start apm when the package is installed
310- don't stop apm when the package is removed
311
312* Mon Dec  8 1997 Jan "Yenya" Kasprzak <kas@fi.muni.cz>
313- Compiled on RH5.0 against libc6.
314- Renamed /etc/rc.d/init.d/apmd.init to /etc/rc.d/init.d/apmd
315- Make /etc/rc.d/init.d/apmd to be chkconfig-compliant.
316
317* Thu Oct  2 1997 Jan "Yenya" Kasprzak <kas@fi.muni.cz>
318- Fixed buggy /etc/sysconfig/apmd file generation in the spec file.
319- Added a patch for apm.c's option handling.
320- Both fixes were submitted by Richard D. McRobers <rdm@csn.net>
Note: See TracBrowser for help on using the repository browser.