source: projects/specs/branches/6/a/anacron/anacron-vl.spec @ 3435

Revision 3435, 8.0 KB checked in by daisuke, 13 years ago (diff)

anacron: fix typo

Line 
1Summary: A cron-like program that can run jobs lost during downtime.
2Name: anacron
3Version: 2.3
4Release: 31%{?_dist_release}
5License: GPL
6Group: System Environment/Base
7Source: ftp://ftp.debian.org/debian/pool/main/a/anacron/%{name}_%{version}.orig.tar.gz
8Source1: anacrontab
9Source2: anacron.init
10Patch0: anacron-2.3-mk-incl.patch
11Patch1: anacron-2.3-mail-content-type-77108.patch
12Patch2: anacron-2.3-gregor.patch
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
15Requires: /bin/sh
16Requires: crontabs
17Requires(post): chkconfig
18Requires(preun): chkconfig
19Requires(preun): initscripts
20Requires(postun): initscripts
21
22%description
23Anacron (like `anac(h)ronistic') is a periodic command scheduler.  It
24executes commands at intervals specified in days.  Unlike cron, it
25does not assume that the system is running continuously.  It can
26therefore be used to control the execution of daily, weekly and
27monthly jobs (or anything with a period of n days), on systems that
28don't run 24 hours a day.  When installed and configured properly,
29Anacron will make sure that the commands are run at the specified
30intervals as closely as machine-uptime permits. 
31
32This package is pre-configured to execute the daily jobs of the Red
33Hat Linux system. You should install this program if your system isn't
34powered on 24 hours a day to make sure the maintenance jobs of other
35Red Hat Linux packages are executed each day.
36
37%prep
38%setup -q
39%patch0 -p1 -b .incl
40%patch1 -p1 -b .charset
41%patch2 -p1 -b .gregor
42
43%build
44make CFLAGS="$RPM_OPT_FLAGS"
45
46%install
47mkdir -p $RPM_BUILD_ROOT/{etc/,usr/sbin/,%{_mandir}/man5,%{_mandir}/man8/}
48mkdir -p $RPM_BUILD_ROOT/var/spool/anacron/
49
50#
51cp anacron $RPM_BUILD_ROOT/usr/sbin
52cp anacron.8 $RPM_BUILD_ROOT/%{_mandir}/man8/
53cp anacrontab.5 $RPM_BUILD_ROOT/%{_mandir}/man5/
54cp %SOURCE1 $RPM_BUILD_ROOT/etc
55
56for i in cron.daily cron.weekly cron.monthly;do
57mkdir -p $RPM_BUILD_ROOT/etc/$i/
58cat << EOF > $RPM_BUILD_ROOT/etc/$i/0anacron
59#!/bin/sh
60#
61# anacron's cron script
62#
63# This script updates anacron time stamps. It is called through run-parts
64# either by anacron itself or by cron.
65#
66# The script is called "0anacron" to assure that it will be executed
67# _before_ all other scripts.
68
69anacron -u $i
70
71EOF
72chmod +x $RPM_BUILD_ROOT/etc/$i/0anacron
73done
74
75#
76#for i in `find $RPM_BUILD_ROOT/ -type 'f' -perm '+a=x'`;do
77#       file $i|grep -q "not stripped" && strip $i
78#done
79
80mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d/
81install -c -m755 %SOURCE2 $RPM_BUILD_ROOT/etc/rc.d/init.d/anacron
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86
87%post
88/sbin/chkconfig --add anacron
89
90%preun
91if [ "$1" = "0" ]; then
92    service anacron stop >/dev/null 2>&1
93    /sbin/chkconfig --del anacron
94fi
95
96%postun
97if [ "$1" -ge "1" ]; then
98    service anacron condrestart >/dev/null 2>&1
99fi
100
101%files
102%defattr(-,root,root,0755)
103%doc COPYING README
104%config /etc/anacrontab
105%dir /var/spool/anacron/
106%config /etc/rc.d/init.d/*
107/%{_mandir}/man5/*
108/%{_mandir}/man8/*
109/usr/sbin/anacron
110%config /etc/cron.daily/0anacron
111%config /etc/cron.monthly/0anacron
112%config /etc/cron.weekly/0anacron
113
114%changelog
115* Wed Apr 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3-31
116- fix typo..
117
118* Wed Apr 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3-30
119- rebuild for Vine 6
120- use Requires({post,preun,postun}) instead of PreReq
121
122* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.3-29vl5
123- applied new versioning policy
124
125* Sat Jul 08 2006 Shu KONNO <owa@bg.wakwak.com> 2.3-29vl2
126- added anacron-2.3-gregor.patch
127
128* Wed Jul 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3-29vl1
129- rebuild for Vine Linux
130
131* Thu Jul 10 2003 Jens Petersen <petersen@redhat.com> - 2.3-29
132- don't require vixie-cron (#21176) [reported by Gerald Teschl]
133- in init script don't remove /var/lock/subsys/anacron when stopping (#58462)
134- exit init script with actual exit status (#44600) [reported by Enrico Scholz]
135
136* Thu Jul 10 2003 Jens Petersen <petersen@redhat.com> - 2.3-28
137- add a Content-Type header to mails giving the charset encoding (#77108)
138
139* Thu Jul 10 2003 Jens Petersen <petersen@redhat.com> - 2.3-27
140- in init script do not touch /var/lock/subsys/anacron when starting (#58462)
141- require crontabs (#21176)
142- update source url
143
144* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
145- rebuilt
146
147* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
148- rebuilt
149
150* Wed Dec 11 2002 Tim Powers <timp@redhat.com> 2.3-24
151- rebuild on all arches
152
153* Fri Aug 23 2002 Jens Petersen <petersen@redhat.com> 2.3-23
154- delay the start of anacron by 60min to make startup more pleasant (#68304)
155- at startup run jobs serially and nice 19 to reduce load (#65870, #68304)
156- spec file now in utf-8
157- dont install non-existant NEWS file
158- silence make include warnings
159
160* Fri Jul 19 2002 Akira TAGOH <tagoh@redhat.com> 2.3-22
161- fix the stripped binary issue.
162
163* Mon Jul 08 2002 Bill Huang <bhuang@redhat.com>
164- Update "Copyright" to "License" in spec file
165
166* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
167- automated rebuild
168
169* Thu May 23 2002 Tim Powers <timp@redhat.com>
170- automated rebuild
171
172* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
173- automated rebuild
174
175* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
176- Bump release + rebuild.
177
178* Tue Apr  3 2001 Crutcher Dunnavant <crutcher@redhat.com>
179- add dependancy to vixie-cron (for /usr/bin/run-parts)
180
181* Tue Feb 13 2001 Tim Waugh <twaugh@redhat.com>
182- killproc is a shell function and can't be passed as a parameter
183  (bug #27150).
184
185* Mon Feb  5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
186- Fix i18n in initscript ("Stopping anacron" wasn't translated)
187  (#26076)
188
189* Fri Feb  2 2001 Trond Eivind Glomsrød <teg@redhat.com>
190- i18nize initscript
191
192* Thu Dec  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
193- rebuild in rebuild cycle.
194
195* Mon Oct 30 2000 Matt Wilson <msw@redhat.com>
196- touch /var/lock/subsys/anacron to prevent excess startage during
197  init level change
198
199* Wed Aug 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
200- Shut down earlier to prevent NFS mounted /usr filesystems from causing
201  problems (Bug #16257)
202
203* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
204- Start it later so services some cron scripts may depend on are running
205  (Bug #15335)
206
207* Thu Aug  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
208- Fix up initscript (Bug #15123 and an unreported bug)
209
210* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
211- move initscript back
212
213* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
214- automatic rebuild
215
216* Mon Jul 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
217- Fix up initscripts (Bug #13625)
218
219* Tue Jul  4 2000 Matt Wilson <msw@redhat.com>
220- Prereq: /sbin/chkconfig
221
222* Mon Jun 26 2000 Preston Brown <pbrown@redhat.com>
223- move initscript to /etc/init.d, fix up post/preun/postun scripts.
224
225* Sun Jun 26 2000 Bernhard Rosenkraenzer <bero@redhat.com>
226- 2.3
227
228* Sun Jun 18 2000 Matt Wilson <msw@redhat.com>
229- use %%{_mandir}
230
231* Fri Mar 03 2000 Tim Powers <timp@redhat.com>
232- fixed startup script so that it doesn't put stuff in /var/lock/subsys.
233        Complains since anacronda turns itself off when it is run, and the file in
234        /var/lock/subsys isn't removed.
235       
236* Mon Feb 28 2000 Tim Powers <timp@redhat.com>
237- fixed startup script, now it actually stops, gives status and restarts.
238        Fixes bug #9835
239
240* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
241- handle compressed manpages
242
243* Fri Feb  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
244- rebuild to get compressed man pages
245- mark /etc/cron.daily/... as config files
246
247* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
248- fix annoying defines
249- rebuild to update description and group
250
251* Thu Jan  6 2000 Bernhard Rosenkränzer <bero@redhat.com>
252- initial Red Hat package
253
254* Wed Dec 29 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
255- Remove cron.hourly check (unusefull).
256
257* Wed Nov 10 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
258- 2.1 from debian.
259- Fix typo in initscripts.
260
261* Thu Jul 22 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
262- Fix wrong entries in anacrontab.
263- Add a /etc/rc.sysinit/ script
264
265* Tue Apr 27 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
266- Fix bug with /var/spool/anacron/
267
268* Sat Apr 10 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
269- First version mainly inspired from the Debian package.
Note: See TracBrowser for help on using the repository browser.