source: projects/specs/branches/6/a/amarokFS/amarokFS-vl.spec @ 521

Revision 521, 5.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           amarokFS
2Version:        0.5
3Release:        1%{?_dist_release}
4Summary:        full screen front-end for Amarok
5Summary(ja):    Amarok 用のフルスクリーンフロントエンド
6Group:          Applications/Multimedia
7# Python integration script is GPLv2+, everything else is LGPLv2+
8License:        LGPLv2+ and GPLv2+
9URL:            http://www.kde-apps.org/content/show.php?content=52641
10Source0:        http://www.kde-apps.org/CONTENT/content-files/52641-amarokFS-%{version}.tar.gz
11# Source1 is an Amarok integration script
12Source1:        http://www.kde-apps.org/CONTENT/content-files/53125-amarokFS-1.1.amarokscript.tar
13Source2:                Vine-amarokFS.desktop
14Patch0:         amarokFS-0.5-fedora_paths.patch
15Patch1:         amarokFS-0.5-start_amarok.patch
16Patch2:         amarokFS-0.5-theme_howto.patch
17Patch3:         amarokFS-0.5-theme_prev_button.patch
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19
20BuildRequires:  kdelibs-devel desktop-file-utils ImageMagick qt-devel
21Requires:       amarok
22
23%description
24AmarokFS (Amarok Full Screen) is a full screen front-end for Amarok that provides a simple and nice looking graphical user interface.
25It is very suitable for parties and public terminals. The front-end's appearance can be customized using themes.
26
27This package also contains a script that allows AmarokFS to be launched from within Amarok itself.
28
29%description -l ja
30AmarokFS (Amarokフルスクリーン)は、シンプルでナイスな GUI を提供する Amarok 用のフルスクリーン・フロント・エンドです。
31パーティーや公の端末向けとして非常に適しています。フロント・エンドの外観はテーマを使用する事でカスタマイズ可能です。
32
33このパッケージは、さらに AmarokFS が Amarok 上からのスタートを可能にするスクリプトを含んでいます。
34
35%prep
36%setup -q
37%patch0 -p1 -b .fedora_paths
38%patch1 -p1 -b .start_amarok
39%patch2 -p1 -b .theme_howto
40%patch3 -p1 -b .theme_prev_button
41sed -i 's/Application;//' amarokFS.desktop
42sed -i 's/\/usr\/share\/icons\/amarokFS.png/amarokFS/' amarokFS.desktop
43chmod a-x amarokFS.png
44chmod a-x images/*
45
46
47%build
48qmake
49make %{?_smp_mflags}
50
51
52%install
53%{__rm} -rf $RPM_BUILD_ROOT
54%{__make} install INSTALL_ROOT=$RPM_BUILD_ROOT
55
56desktop-file-install --vendor="Vine" \
57        --dir=$RPM_BUILD_ROOT%{_datadir}/applications/ \
58        amarokFS.desktop
59# Install Amarok integration script
60%{__mkdir} -p $RPM_BUILD_ROOT%{_datadir}/apps/amarok/scripts
61cd $RPM_BUILD_ROOT%{_datadir}/apps/amarok/scripts
62tar -xf %{SOURCE1}
63# Install a 48x48 icon
64%{__mkdir} -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
65convert $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/128x128/apps/amarokFS.png \
66        -sample 48x48 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/amarokFS.png
67
68# Desktop File INSTALL(source2)
69%{__install} -D -m 644 -p %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/applications/Vine-amarokFS.desktop
70
71%clean
72%{__rm} -rf $RPM_BUILD_ROOT
73
74
75%post
76touch --no-create %{_datadir}/icons/hicolor || :
77%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
78
79
80%postun
81touch --no-create %{_datadir}/icons/hicolor || :
82%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
83
84
85%files
86%defattr(-,root,root,-)
87%doc README theme-howto.txt
88%{_bindir}/amarokFS
89%{_datadir}/amarokFS/*
90%{_datadir}/applications/Vine-amarokFS.desktop
91%{_datadir}/icons/hicolor/48x48/apps/amarokFS.png
92%{_datadir}/icons/hicolor/128x128/apps/amarokFS.png
93%{_datadir}/apps/amarok/scripts/amarokFS
94
95
96%changelog
97* Mon Jan 12 2009 TOSHI <milk-tea1977@dune.ocn.ne.jp> 0.5.4-1
98- Rebuild For Vine Seed
99- spec in utf-8
100
101* Mon Jul 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5-4
102- fix license tag
103
104* Fri Feb 22 2008 Francois Aucamp <faucamp@fedoraproject.org> - 0.5-3
105- Changed kdelibs-devel build dependency to kdelibs3-devel (RHBZ #434093)
106- Fixed animation of "prev" button in default theme
107- Modified "start_amarok" patch to slow down dcop calls to amarok when starting (RHBZ #247712)
108
109* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5-2
110- Autorebuild for GCC 4.3
111
112* Thu Mar 29 2007 Francois Aucamp <faucamp@csir.co.za> - 0.5-1
113- Update to version 0.5
114- Removed "large_cover_images" patch; included upstream
115- Removed "config_dialog_layout" patch; included upstream
116- Updated "fedora_paths" patch
117- Updated "start_amarok" patch
118- Updated "theme_howto" patch
119- Updated amarok integration script
120
121* Mon Feb 19 2007 Francois Aucamp <faucamp@csir.co.za> - 0.4.2-4
122- Created "theme_prev_button" patch to fix default theme's "previous" button
123- Fixed file permissions of image files
124
125* Wed Feb 14 2007 Francois Aucamp <faucamp@csir.co.za> - 0.4.2-3
126- Added BuildRequires: ImageMagick
127- Create and install a 48x48 icon
128
129* Tue Feb 13 2007 Francois Aucamp <faucamp@csir.co.za> - 0.4.2-2
130- Added BuildRequires: desktop-file-utils
131- Fixed source URLs
132- Removed "Application" from .desktop file's "Categories" tag
133- Install application icon to correct location
134- Added KDE/GTK icon cache update scriptlets
135- Cleaned up the application's qmake file a bit
136
137* Sun Feb 11 2007 Francois Aucamp <faucamp@csir.co.za> - 0.4.2-1
138- Initial RPM build
139- Created "fedora_paths" patch to install files to correct directories in Fedora
140- Created "config_dialog_layout" patch to fix the layout of the configuration dialog
141- Created "large_cover_images" patch to fix filename resolution issues when displaying large CD cover images
142- Created "start_amarok" patch to let AmarokFS start Amarok (upon startup) if it is not already running
143- Created "theme_howto" patch to fix errors in the "theme howto" documentation file
144- Created amarokFS integration script for Asterisk
Note: See TracBrowser for help on using the repository browser.