source: projects/specs/branches/6/a/amarok/amarok-vl.spec @ 10623

Revision 10623, 6.7 KB checked in by tomop, 8 years ago (diff)

amarok-2.4.1-2

Line 
1Name: amarok
2Summary: Amarok Media Player
3Summary(ja): Amarok メディアプレイヤー
4Version: 2.4.1
5Release: 2%{?_dist_release}
6
7Group: Applications/Multimedia
8License: GPLv2
9URL: http://amarok.kde.org
10
11Source0: http://download.kde.org/stable/amarok/%{version}/src/amarok-%{version}.tar.bz2
12Patch0: amarok-2.4.1-bad-declaration.patch
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: curl-devel
16BuildRequires: desktop-file-utils
17BuildRequires: gettext
18BuildRequires: kdelibs4-devel
19#BuildRequires: libifp-devel
20#BuildRequires: liblastfm-devel
21#BuildRequires: libmp4v2-devel
22BuildRequires: libgcrypt-devel
23BuildRequires: libgpod-devel >= 0.7.0
24BuildRequires: libmtp-devel >= 1.0.0
25BuildRequires: libnjb-devel
26BuildRequires: libusb1-devel
27BuildRequires: libxml2-devel
28BuildRequires: libvisual-devel
29BuildRequires: loudmouth-devel
30BuildRequires: MySQL-devel
31BuildRequires: MySQL-embedded-devel
32BuildRequires: phonon-devel
33BuildRequires: qca2-devel
34BuildRequires: qtscriptbindings
35BuildRequires: soprano-devel
36BuildRequires: taglib-devel >= 1.6
37BuildRequires: taglib-extras-devel >= 1.0.1
38BuildRequires: zlib-devel
39
40Requires: qtscriptbindings
41Requires: %{name}-libs = %{version}-%{release}
42Requires: %{name}-utils = %{version}-%{release}
43
44# for trash protocol support, phonon kcm, etc...
45# FIXME: should probably be handled lower in the stack
46Requires: kdebase-runtime >= 4.5
47
48# when we grew a -libs subpkg, multilib love
49Obsoletes: amarok-konqueror < 1.5
50Obsoletes: amarok-helix-engine < 1.5
51Obsoletes: amarok-void-engine < 1.5
52Obsoletes: amarok-xine-engine < 1.5
53Obsoletes: amarok-visualisation < 1.5
54
55Vendor: Project Vine
56Distribution: Vine Linux
57
58%description
59Amarok is a multimedia player with:
60 - fresh playlist concept, very fast to use, with drag and drop
61 - plays all formats supported by the various engines
62 - audio effects, like reverb and compressor
63 - compatible with the .m3u and .pls formats for playlists
64 - nice GUI, integrates into the KDE look, but with a unique touch
65
66%description -l ja
67Amarokは、直感的インターフェースを備えた、Linux および Unix 用の音楽プレーヤーです。
68Amarokはより好きな音楽を簡単に再生します。
69
70%package libs
71Summary: Runtime libraries for %{name}
72Summary(ja): %{name} のランタイムライブラリ
73Group:   System Environment/Libraries
74#Requires: %{name} = %{version}-%{release}
75Requires: qt4 >= 4.6
76
77%description libs
78%{summary}.
79
80%package utils
81Summary: Amarok standalone utilities
82Group: Applications/Multimedia
83Obsoletes: amarok-collectionscanner < 2.0.90-2
84Obsoletes: amarok-utilities < 2.0.96
85
86%description utils
87%{summary}, including amarokcollectionscanner.
88
89%prep
90%setup -q
91%patch0 -p1
92
93sed -i -e 's/cin\.get/std::cin.get/' utilities/afttagger/AFTTagger.cpp
94
95%build
96mkdir -p %{_target_platform}
97pushd %{_target_platform}
98%cmake \
99    -DCMAKE_BUILD_TYPE=release \
100    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
101    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
102    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
103    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
104    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
105    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
106    ..
107popd
108
109make %{?_smp_mflags} -C %{_target_platform}
110
111%install
112rm -rf $RPM_BUILD_ROOT
113make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
114
115%find_lang amarok
116%find_lang amarokcollectionscanner_qt
117%find_lang amarokpkg
118%find_lang amarok_scriptengine_qscript
119cat amarokpkg.lang >> amarok.lang
120cat amarok_scriptengine_qscript.lang >> amarok.lang
121
122# unpackaged files
123rm -f $RPM_BUILD_ROOT%{_libdir}/libamarok{-sqlcollection,-transcoding,_taglib,core,lib,plasma,pud,ocsclient}.so
124
125%check
126desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/kde4/amarok.desktop
127desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/kde4/amarok_containers.desktop
128
129%clean
130rm -rf $RPM_BUILD_ROOT
131
132%post
133touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
134
135%posttrans
136gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
137update-desktop-database -q &> /dev/null ||:
138
139%postun
140if [ $1 -eq 0 ] ; then
141    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
142    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
143    update-desktop-database -q &> /dev/null ||:
144fi
145
146%post libs -p /sbin/ldconfig
147
148%postun libs -p /sbin/ldconfig
149
150
151%files -f %{name}.lang
152%defattr(-,root,root)
153%doc AUTHORS COPYING ChangeLog README
154%doc %{_docdir}/HTML/*/amarok/*
155%{_bindir}/amarok
156%{_bindir}/amarokpkg
157%{_bindir}/amarok_afttagger
158%{_bindir}/amarokmp3tunesharmonydaemon
159%{_datadir}/kde4/apps/amarok/
160%{_datadir}/kde4/apps/desktoptheme/Amarok-Mockup/
161%{_datadir}/kde4/apps/desktoptheme/default/widgets/*
162%{_datadir}/kde4/apps/kconf_update/amarok*
163%{_datadir}/kde4/apps/solid/actions/amarok-play-audiocd.desktop
164%{_datadir}/config/amarok.knsrc
165%{_datadir}/config/amarok_homerc
166%{_datadir}/config/amarokapplets.knsrc
167%{_datadir}/applications/kde4/amarok.desktop
168%{_datadir}/applications/kde4/amarok_containers.desktop
169%{_datadir}/config.kcfg/amarokconfig.kcfg
170%{_datadir}/dbus-1/interfaces/*.xml
171%{_datadir}/kde4/services/*.desktop
172%{_datadir}/kde4/services/*.protocol
173%{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
174%{_datadir}/kde4/servicetypes/*.desktop
175%{_datadir}/icons/hicolor/*/*/*
176%{_libdir}/kde4/*.so
177#{_libdir}/strigi/*
178
179%files libs
180%defattr(-,root,root,-)
181%{_libdir}/libamarokcore.so.1*
182%{_libdir}/libamaroklib.so.1*
183%{_libdir}/libamarokocsclient.so.4*
184%{_libdir}/libamarokpud.so.1*
185%{_libdir}/libamarok-sqlcollection.so.1*
186%{_libdir}/libamarok-transcoding.so.*
187%{_libdir}/libampache_account_login.so
188
189%files utils -f amarokcollectionscanner_qt.lang
190%defattr(-,root,root,-)
191%{_bindir}/amarokcollectionscanner
192
193
194%changelog
195* Fri Jul 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.1-2
196- rebuilt with libmtp-1.1.11.
197
198* Sun Jun  5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-1
199- new upstream release
200
201* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3.2-1
202- new upstream release for KDE 4
203- updated BR
204
205* Mon Nov 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.4.10-5
206- drop helixplayer stuff to resolve unmet dependency
207- drop --with-mp4v2 configure option
208
209* Wed Jun 17 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.10-4vl5
210- add BuildRequires: libvisual-devel
211
212* Tue Jun 16 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.10-3vl5
213- add Patch4 (from Ubuntu/Debian) to fix build against libmtp >= 0.3.0
214
215* Sat Mar 21 2009 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.4.10-2vl5
216- Package Name Changes: self-build-libmad, self-build-faad2
217- add patch100 for fix CVE2009-0135, CVE-2009-0136
218- add PreReq & BuildPreReq: libart_lgpl, libart_lgpl-devel
219
220* Wed Dec 31 2008 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.4.10-1vl5
221- initial build for Vine Seed.
222- add Patch3
223- spec in utf-8, and applied vine versioning policy
224
Note: See TracBrowser for help on using the repository browser.