source: projects/specs/branches/6/a/am-utils/am-utils-vl.spec @ 521

Revision 521, 10.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Automount utilities including an updated version of Amd.
2Summary(ja): Amd ¤Î¥¢¥Ã¥×¥Ç¡¼¥ÈÈǤò´Þ¤à¥ª¡¼¥È¥Þ¥¦¥ó¥È¡¦¥æ¡¼¥Æ¥£¥ê¥Æ¥£
3Name: am-utils
4Version: 6.1.5
5Release: 0vl1
6License: BSD
7Epoch: 5
8Group: System Environment/Daemons
9URL: http://www.am-utils.org/
10Source: ftp://ftp.am-utils.org/pub/am-utils/am-utils-%{version}.tar.gz
11Source1: am-utils.init
12Source2: am-utils.conf
13Source3: am-utils.sysconf
14Source4: am-utils.net.map
15Patch: am-utils-gdbm.patch
16BuildRoot: %{_tmppath}/%{name}-root
17%define autoconf_suffix %{nil}
18%define automake_suffix %{nil}
19BuildPrereq: gdbm-devel, autoconf, automake
20%define with_ldap 0
21%define with_hesiod 0
22%if %{with_ldap}
23BuildPrereq: openldap-devel
24%endif
25%if %{with_hesiod}
26BuildPrereq: hesiod-devel
27%endif
28Requires: portmap, grep, gawk, findutils
29Prereq: /sbin/install-info, /sbin/chkconfig, grep
30Obsoletes: amd
31
32# We need to filter out some perl requirements for now.
33%define _use_internal_dependency_generator 0
34%define __find_requires %{_builddir}/%{name}-%{version}/find-requires
35
36%description
37Am-utils includes an updated version of Amd, the popular BSD
38automounter.  An automounter is a program which maintains a cache
39of mounted filesystems.  Filesystems are mounted when they are
40first referenced by the user and unmounted after a certain period of
41inactivity. Amd supports a variety of filesystems, including NFS, UFS,
42CD-ROMS and local drives. 
43
44You should install am-utils if you need a program for automatically
45mounting and unmounting filesystems.
46
47%description -l ja
48Am-utils ¤Ï¡¢¹­¤¯»È¤ï¤ì¤Æ¤¤¤ëBSD¤Î¥ª¡¼¥È¥Þ¥¦¥ó¥¿¡¼ Amd ¤Î¥¢¥Ã¥×¥Ç¡¼¥È
49ÈǤò´Þ¤à¥ª¡¼¥È¥Þ¥¦¥ó¥È¡¦¥æ¡¼¥Æ¥£¥ê¥Æ¥£¤Ç¤¹¡£¥ª¡¼¥È¥Þ¥¦¥ó¥¿¡¼¤È¤Ï¡¢
50¥Þ¥¦¥ó¥È¤·¤¿¥Õ¥¡¥¤¥ë¥·¥¹¥Æ¥à¤Î¥­¥ã¥Ã¥·¥å¤ò´ÉÍý¤¹¤ë¥×¥í¥°¥é¥à¤Ç¤¹¡£
51¥æ¡¼¥¶¤¬½é¤á¤Æ»²¾È¤·¤¿»þ¤Ë¥Õ¥¡¥¤¥ë¥·¥¹¥Æ¥à¤Ï»²¾È¤µ¤ì¤Æ¡¢»È¤ï¤Ê¤¯¤Ê¤Ã
52¤Æ¾¯¤·¤¿¤Ä¤È¥Þ¥¦¥ó¥È¤ò¤Ï¤º¤·¤Þ¤¹¡£NFS, UFS, CD-ROMS, ¥í¡¼¥«¥ë¥É¥é¥¤¥Ö
53¤ò´Þ¤à¡¢¤µ¤Þ¤¶¤Þ¤Ê¥Õ¥¡¥¤¥ë¥·¥¹¥Æ¥à¤¬¥µ¥Ý¡¼¥È¤µ¤ì¤Æ¤Þ¤¹¡£
54
55¼«Æ°¤Ç¥Õ¥¡¥¤¥ë¥·¥¹¥Æ¥à¤Î¥Þ¥¦¥ó¥È¤ä¥¢¥ó¥Þ¥¦¥ó¥È¤ò¹Ô¤¤¤¿¤¤¤Ê¤é¡¢
56À§Èóam-utils¤ò¥¤¥ó¥¹¥È¡¼¥ë¤·¤Æ¤¯¤À¤µ¤¤¡£
57
58%prep
59%setup -q
60#%patch -p1
61aclocal%{automake_suffix}
62autoconf%{autoconf_suffix}
63automake%{automake_suffix} --gnu  --ignore-deps
64
65find_requires=`rpm --eval %%{__find_requires}`
66echo "$find_requires | grep -v lostaltmail.conf" > find-requires
67chmod +x find-requires
68
69%build
70%configure \
71        ACLOCAL=aclocal%{automake_suffix} \
72        AUTOCONF=autoconf%{autoconf_suffix} \
73        AUTOMAKE=automake%{automake_suffix} \
74        AUTOHEADER=autoheader%{autoconf_suffix} \
75%if %{with_ldap}
76        --with-ldap \
77%else
78        --without-ldap \
79%endif
80%if %{with_hesiod}
81        --with-hesiod \
82%else
83        --without-hesiod \
84%endif
85        --enable-shared \
86        --enable-am-cflags="$RPM_OPT_FLAGS" \
87        --enable-libs="-lnsl -lresolv"
88make %{?_smp_flags}
89
90%install
91rm -rf $RPM_BUILD_ROOT
92%makeinstall
93mkdir -p $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d}
94install -m 755 $RPM_SOURCE_DIR/am-utils.sysconf $RPM_BUILD_ROOT/etc/sysconfig/amd
95#install -m 755 scripts/redhat-ctl-amd $RPM_BUILD_ROOT/etc/rc.d/init.d/amd
96install -m 755 $RPM_SOURCE_DIR/am-utils.init $RPM_BUILD_ROOT/etc/rc.d/init.d/amd
97gzip -q9f $RPM_BUILD_ROOT/%{_infodir}/*info*
98mkdir -p $RPM_BUILD_ROOT/.automount
99rm -f $RPM_BUILD_ROOT/usr/sbin/ctl-amd
100
101# add symlinks to shared libs
102/sbin/ldconfig -n $RPM_BUILD_ROOT/%{_libdir}
103
104# install the default config and map files
105install -m 600 %{SOURCE2} $RPM_BUILD_ROOT/etc/amd.conf
106install -m 640 %{SOURCE4} $RPM_BUILD_ROOT/etc/amd.net
107
108# We don't build a -devel package.
109rm -f $RPM_BUILD_ROOT/%{_libdir}/libamu.a
110rm -f $RPM_BUILD_ROOT/%{_libdir}/libamu.la
111
112# We don't include the info directory.
113rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
114
115# Remove the other sample config file.
116rm -f $RPM_BUILD_ROOT/etc/amd.conf-sample
117rm -f $RPM_BUILD_ROOT/etc/lostaltmail.conf-sample
118
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%pre
123# Check if we have an old fashioned amd.conf and rename if to amd.net
124if [ "$1" = "0" ] ; then
125    if grep -q "auto_dir" /etc/amd.conf 2>/dev/null ; then
126        # this is okay
127        exit 0
128    else
129        # this needs to be renamed. Still, if /etc/amd.net exists, then
130        # don't bother renamig it. RPM will handle it better than us here.
131        if [ -e /etc/amd.net ] ; then
132            exit 0
133        else
134            mv -f /etc/amd.conf /etc/amd.net
135        fi
136    fi
137fi
138exit 0
139
140%post
141/sbin/ldconfig
142/sbin/chkconfig --add amd
143/sbin/install-info %{_infodir}/am-utils.info.gz %{_infodir}/dir
144
145%preun
146if [ $1 = 0 ]; then
147   /sbin/install-info --delete %{_infodir}/am-utils.info.gz %{_infodir}/dir
148   /sbin/service amd stop >/dev/null 2>&1
149   /sbin/chkconfig --del amd
150fi
151
152%postun
153if [ $1 -ge 1 ]; then
154    /sbin/service amd condrestart >/dev/null 2>&1
155fi
156/sbin/ldconfig
157
158%files
159%defattr(-,root,root)
160%doc doc/*.ps AUTHORS BUGS ChangeLog NEWS README* scripts/*-sample
161%dir /.automount
162%{_bindir}/expn
163%{_bindir}/pawd
164%{_sbindir}/*
165%{_mandir}/man[58]/*
166%{_mandir}/man1/expn.1*
167%{_mandir}/man1/pawd.1*
168%config(noreplace) /etc/amd.net
169%config(noreplace) /etc/amd.conf
170%config(noreplace) /etc/sysconfig/amd
171%config /etc/rc.d/init.d/amd
172%{_infodir}/*info*.gz
173%{_libdir}/libamu.so*
174
175%changelog
176* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 6.1.5-0vl1
177- updated to 6.1.5
178- dropt am-utils-gdbm.patch
179
180* Fri Oct 22 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.9-2vl2
181- built for Vine Linux 3.0
182
183* Mon May 26 2003 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.9-2vl1
184- update to 6.0.9 (based on RawHide 6.0.9-2) & built for Vine Linux 2.6
185  using autoconf253 and automake15
186- do not link with openldap and hesiod by default
187
188  * Tue Feb 04 2003 Florian La Roche <Florian.LaRoche@redhat.de>
189  - add symlink to shared lib
190
191  * Fri Jan 31 2003 Nalin Dahyabhai <nalin@redhat.com> 6.0.9-1
192  - disable RPM's internal dependency calculation so that we can filter out
193    dependencies which are expected to be filled in by the site administrator
194
195  * Wed May 29 2002 Nalin Dahyabhai <nalin@redhat.com> 6.0.7-7
196  - adjust the perl reqs so that the lostaltmail config files aren't required
197    by RPM
198
199  * Sat Jan 26 2002 Jeff Johnson <jbj@redhat.com>
200  - add Provides: to white out certain perl Requires:
201
202  * Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 6.0.7-2
203  - require gdbm-devel at build-time instead of db1-devel
204
205  * Thu Sep  6 2001 Nalin Dahyabhai <nalin@redhat.com> 6.0.7-1
206  - update to 6.0.7, fixing EIO on access bugs (#53251)
207  - back out nfs3 patch; no longer needed for current kernels
208  - don't explicitly strip binaries; let the buildroot policies handle it
209
210  * Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
211  - add BuildPrereq: db1-devel (#44987)
212  - use FHS macros
213  - return error codes correctly from init script (#44597)
214
215* Tue May 08 2001 <sagami@vinelinux.org>
216- 6.0.5-1vl1: based on RawHide 6.0.5-1 and built for Vine Linux
217
218* Sat Apr  7 2001 Nalin Dahyabhai <nalin@redhat.com>
219- update to 6.0.5
220- remove /net from the default MOUNTPTS
221
222* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
223- use MOUNTPTS when starting
224
225* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
226- rebuild in new environment
227
228* Wed Feb 14 2001 Nalin Dahyabhai <nalin@redhat.com>
229- redo i18n for the init script (#24082)
230
231* Tue Jan 23 2001 Nalin Dahyabhai <nalin@redhat.com>
232- re-do workaround from advice from the am-utils maintainers
233- redo i18n for the init script
234
235* Sat Jan 20 2001 Nalin Dahyabhai <nalin@redhat.com>
236- work around clash with nfs3_fh definition in 2.4
237
238* Tue Jan 16 2001 Nalin Dahyabhai <nalin@redhat.com>
239- gettextize the init script (#24087)
240
241* Tue Dec 19 2000 Nalin Dahyabhai <nalin@redhat.com>
242- add ldconfig to %%postun
243- chuck the hesiod patch -- new bind-utils doesn't have the support for it
244
245* Fri Sep  8 2000 Nalin Dahyabhai <nalin@redhat.com>
246- rebuild in new environment
247
248* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
249- move initscript back
250
251* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
252- automatic rebuild
253
254* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
255- only create /var/lock/subsys/amd if startup succeeds
256- revamp shutdown procedure to minimize time spent just spinning
257- change initscripts dependency to /etc/init.d
258
259* Tue Jul  4 2000 Florian La Roche <Florian.LaRoche@redhat.com>
260- delete noreplace from initscript
261
262* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
263- fix postun script
264- add requires: initscripts
265
266* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
267- remove unnecessary libamu.so symlink
268
269* Mon Jun 26 2000 Nalin Dahyabhai <nalin@redhat.com>
270- move init script to /etc/init.d
271- add URL: tag
272
273* Wed Jun 21 2000 Preston Brown <pbrown@redhat.com>
274- noreplace config files
275- gracefully stop/restart service
276
277* Fri Jun 16 2000 Matt Wilson <msw@redhat.com>
278- FHS paths
279- 6.0.4 snapshot (as it builds against kernel 2.4 headers)
280
281* Wed Feb 16 2000 Cristian Gafton <gafton@redhat.com>
282- version 6.0.3
283- enhance init script to be more wait4amd2die-like
284- make default map type to be file (#9185)
285- get rid of the kludges
286
287* Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
288- man pages are compressed
289- version 6.0.2
290- fix descriptions
291
292* Mon Sep 13 1999 Cristian Gafton <gafton@redhat.com>
293- version 6.0.1 final
294
295* Tue Aug 24 1999 Cristian Gafton <gafton@redhat.com>
296- remove the noldap patch
297- add amd.net file as the default config map file
298- change the config file to teh new config file format instead of a
299  simple map file name.
300- try to avoid some damage with a new %pre script
301- prereq grep now
302- modify the init file so it calls amd -F /etc/amd.conf now
303
304* Tue Aug 24 1999 Bill Nottingham <notting@redhat.com>
305- update to 6.0.1s11
306
307* Fri Jun 19 1999 Bill Nottingham <notting@redhat.com>
308- don't run by default
309
310* Mon May 31 1999 Kenneth Skaar <kenneths@regina.uio.no>
311- Fixed amd -F core dump and related dumps by other programs
312
313* Thu Apr 08 1999 Preston Brown <pbrown@redhat.com>
314- kill -HUP on reload, restart does a real restart.
315
316* Fri Mar 26 1999 Bill Nottingham <notting@redhat.com>
317- twiddle an echo in initscript
318
319* Tue Mar 23 1999 Cristian Gafton <gafton@redhat.com>
320- version 6.0 proper
321- Serial:1 because to enforce versioning
322
323* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
324- auto rebuild in the new build environment (release 6)
325
326* Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
327- rebuild for glibc 2.1
328- strip all binaries
329
330* Thu Aug 13 1998 Jeff Johnson <jbj@redhat.com>
331- add missing ':' to default 'opts:=nosuid,nodev'
332- install info pages
333
334* Mon Jul 13 1998 Cristian Gafton <gafton@redhat.com>
335- added the NIS support that the broken configure script failed to detect
336
337* Tue May 05 1998 Cristian Gafton <gafton@redhat.com>
338- disabled autofs support on alpha
339- run ldconfig in postinstall
340
341* Mon May 04 1998 Cristian Gafton <gafton@redhat.com>
342- new package to replace the old and unmaintained amd
Note: See TracBrowser for help on using the repository browser.