source: projects/specs/branches/6/a/alsa-firmware/alsa-firmware-vl.spec @ 3813

Revision 3813, 7.5 KB checked in by shaolin, 13 years ago (diff)
  • alsa-firmware
    • rebuild
    • define the _binaries_in_noarch_packages_terminate_build macro to 0, as these are arch-dependent but binary files
  • alsa-utils
    • rebuild
Line 
1# This is a firmware package, so binaries (which are not run on the host)
2# in the end package are expected.
3%define _binaries_in_noarch_packages_terminate_build   0
4
5Summary:        Firmware for several ALSA-supported sound cards
6Summary(ja):    ALSA がサポートするサウンドカード用のファームウェア
7Name:           alsa-firmware
8Version:        1.0.23
9Release:        2%{?_dist_release}
10# See later in the spec for a breakdown of licensing
11License:        GPL+ and BSD and GPLv2+ and GPLv2 and LGPLv2+
12Group:          Applications/Multimedia
13URL:            http://www.alsa-project.org/
14# This source removes the emi_26_62 firmware which is under a questionable
15# license. See bug #217259.
16# To generate the "pruned" tarball, extract the original source, remove
17# the emi_26_62 directory and create a new tarball with a "-pruned" suffix.
18# Original source: ftp://ftp.alsa-project.org/pub/firmware/%{name}-%{version}.tar.bz2
19Source0:        %{name}-%{version}-pruned.tar.bz2
20Source1:        alsa-firmware.README
21BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
22Requires:       alsa-tools-firmware >= %{version}
23Requires:       udev
24BuildRequires:  automake
25BuildRequires:  autoconf
26
27# noarch, since the package is firmware
28BuildArch:      noarch
29
30Vendor: Project Vine
31Distribution: Vine Linux
32Packager: shaolin
33
34%description
35This package contains the firmware binaries for a number of sound cards.
36Some (but not all of these) require firmware loaders which are included in
37the alsa-tools-firmware package.
38
39%description -l ja
40このパッケージには、いろんな種類のサウンドカード用のファームウェアが
41収録されています。これらファームウェアの中には、alsa-tools-firmware
42パッケージに収録されているファームウェアローダを必要とするものがあります。
43
44
45%prep
46%setup -q
47
48
49%build
50# emi_26_62 is not in the pruned tarball
51sed -i s#'emi_26_62/Makefile \\'## configure.in
52sed -i s#emi_26_62## Makefile.am
53
54# Leaving this directory in place ends up with the following crazy, broken
55# symlinks in the output RPM, with no sign of the actual firmware (*.bin) files
56# themselves:
57#
58# /lib/firmware/turtlebeach:
59# msndinit.bin -> /etc/sound/msndinit.bin
60# msndperm.bin -> /etc/sound/msndperm.bin
61# pndsperm.bin -> /etc/sound/pndsperm.bin
62# pndspini.bin -> /etc/sound/pndspini.bin
63#
64# Probably an upstream package bug.
65sed -i s#'multisound/Makefile \\'## configure.in
66sed -i s#multisound## Makefile.am
67
68%__aclocal
69%__automake
70%__autoconf
71%configure --disable-loader
72make %{?_smp_mflags}
73
74# Rename README files from firmware subdirs that have them
75for i in hdsploader mixartloader pcxhrloader usx2yloader vxloader
76do
77  mv ${i}/README README.${i}
78done
79
80
81%install
82rm -rf $RPM_BUILD_ROOT
83make install DESTDIR=%{buildroot}
84cp -p %{SOURCE1} README.00alsa-firmware
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89
90%files
91%defattr(-,root,root,-)
92%doc COPYING README*
93
94# License: KOS (BSD-alike)
95/lib/firmware/aica_firmware.bin
96
97# License: No explicit license; default package license is GPLv2+
98/lib/firmware/asihpi
99
100# License: GPL (undefined version)
101/lib/firmware/digiface_firmware*
102
103%dir /lib/firmware/ea
104# The licenses for the Echo Audio firmware vary slightly so each is enumerated
105# separately, to be really sure.
106# LGPLv2.1+
107/lib/firmware/ea/3g_asic.fw
108# GPL (undefined version)
109/lib/firmware/ea/darla20_dsp.fw
110# LGPLv2.1+
111/lib/firmware/ea/darla24_dsp.fw
112# LGPLv2.1+
113/lib/firmware/ea/echo3g_dsp.fw
114# GPL (undefined version)
115/lib/firmware/ea/gina20_dsp.fw
116# GPL (undefined version)
117/lib/firmware/ea/gina24_301_asic.fw
118# GPL (undefined version)
119/lib/firmware/ea/gina24_301_dsp.fw
120# GPL (undefined version)
121/lib/firmware/ea/gina24_361_asic.fw
122# GPL (undefined version)
123/lib/firmware/ea/gina24_361_dsp.fw
124# LGPLv2.1+
125/lib/firmware/ea/indigo_dj_dsp.fw
126# LGPLv2.1+
127/lib/firmware/ea/indigo_djx_dsp.fw
128# LGPLv2.1+
129/lib/firmware/ea/indigo_dsp.fw
130# LGPLv2.1+
131/lib/firmware/ea/indigo_io_dsp.fw
132# LGPLv2.1+
133/lib/firmware/ea/indigo_iox_dsp.fw
134# GPL (undefined version)
135/lib/firmware/ea/layla20_asic.fw
136# GPL (undefined version)
137/lib/firmware/ea/layla20_dsp.fw
138# GPL (undefined version)
139/lib/firmware/ea/layla24_1_asic.fw
140# GPL (undefined version)
141/lib/firmware/ea/layla24_2A_asic.fw
142# GPL (undefined version)
143/lib/firmware/ea/layla24_2S_asic.fw
144# GPL (undefined version)
145/lib/firmware/ea/layla24_dsp.fw
146# GPL (undefined version)
147/lib/firmware/ea/loader_dsp.fw
148# LGPLv2.1+
149/lib/firmware/ea/mia_dsp.fw
150# GPL (undefined version)
151/lib/firmware/ea/mona_2_asic.fw
152# GPL (undefined version)
153/lib/firmware/ea/mona_301_1_asic_48.fw
154# GPL (undefined version)
155/lib/firmware/ea/mona_301_1_asic_96.fw
156# GPL (undefined version)
157/lib/firmware/ea/mona_301_dsp.fw
158# GPL (undefined version)
159/lib/firmware/ea/mona_361_1_asic_48.fw
160# GPL (undefined version)
161/lib/firmware/ea/mona_361_1_asic_96.fw
162# GPL (undefined version)
163/lib/firmware/ea/mona_361_dsp.fw
164
165%dir /lib/firmware/emu
166# Licenses vary so are enumerated separately
167# GPLv2
168/lib/firmware/emu/audio_dock.fw
169# GPLv2
170/lib/firmware/emu/emu0404.fw
171# GPLv2
172/lib/firmware/emu/emu1010_notebook.fw
173# GPLv2
174/lib/firmware/emu/emu1010b.fw
175# GPLv2
176/lib/firmware/emu/hana.fw
177# GPLv2+
178/lib/firmware/emu/micro_dock.fw
179
180# License: GPL (undefined version)
181/lib/firmware/ess
182
183# License: No explicit license; default package license is GPLv2+
184/lib/firmware/korg
185
186# License: GPL (undefined version)
187/lib/firmware/mixart
188
189# License: GPL (undefined version)
190/lib/firmware/multiface_firmware*
191
192# License: GPL (undefined version)
193/lib/firmware/pcxhr
194
195# License: GPLv2+
196/lib/firmware/sb16
197
198# License: GPL (undefined version)
199/lib/firmware/vx
200
201# License: No explicit license; default package license is GPLv2+
202# See ALSA bug #3412
203/lib/firmware/yamaha
204
205# Even with --disable-loader, we still get usxxx firmware here; looking at the
206# alsa-tools-firmware package, it seems like these devices probably use an old-
207# style hotplug loading method
208# License: GPL (undefined version)
209%{_datadir}/alsa/firmware
210
211
212%changelog
213* Sun May 08 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.23-2
214- rebuild
215- define the _binaries_in_noarch_packages_terminate_build macro to 0,
216  as these files are arch-dependent but binary files
217
218
219* Fri May 28 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.23-1
220- new upstream release
221
222* Thu Jul  2 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.20-1
223- new upstream release
224
225* Thu Feb 19 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.19-1
226- initial build for Vine Linux
227
228* Tue Jan 20 2009 Tim Jackson <rpm@timj.co.uk> - 1.0.19-1
229- Update to 1.0.19
230
231* Mon Jul 21 2008 Jaroslav Kysela <jkysela@redhat.com> - 1.0.17-1
232- Updated to 1.0.17
233
234* Mon May 12 2008 Tim Jackson <rpm@timj.co.uk> - 1.0.16-1
235- Update to upstream 1.0.16
236- Clarify licensing conditions
237
238* Tue Aug 14 2007 Tim Jackson <rpm@timj.co.uk> - 1.0.14-1
239- Update to upstream 1.0.14, but skip turtlebeach firmware as it doesn't seem
240  to install properly
241- Remove files from old-style firmware loader locations
242- Spec file cosmetics, keep rpmlint quiet
243
244* Sat Nov 25 2006 Tim Jackson <rpm@timj.co.uk> - 1.0.12-1
245- Update to 1.0.12
246- Add udev dep
247
248* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
249- rebuilt
250
251* Sat Apr 03 2004 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 1.0.4-0.fdr.1
252- Update to 1.0.4
253
254* Fri Jan 16 2004 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 1.0.1-0.fdr.2
255- add missing rm in install section
256
257* Fri Jan 09 2004 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 1.0.1-0.fdr.1
258- Update to 1.0.1
259- Contains now the license -- is "Distributable under GPL"
260
261* Thu Dec 04 2003 Thorsten Leemhuis <fedora[AT]leemhuis.info> 1.0.0-0.fdr.0.1.rc1
262- Initial build.
Note: See TracBrowser for help on using the repository browser.