source: projects/specs/branches/6/a/alacarte/alacarte-vl.spec @ 2041

Revision 2041, 7.6 KB checked in by Takemikaduchi, 14 years ago (diff)

update to GNOME-2.32.0

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           alacarte
4Version:        0.13.2
5Release:        1%{?_dist_release}
6Summary:        Menu editor for the GNOME desktop
7Summary(ja):    GNOME デスクトップ用メニューエディタ
8
9Group:          Applications/System
10License:        LGPLv2+
11URL:            http://www.gnome.org
12Source0:        http://download.gnome.org/sources/alacarte/0.13/%{name}-%{version}.tar.bz2
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildArch:      noarch
15
16BuildRequires:  python, python-devel, gettext
17BuildRequires:  pygtk2-devel
18BuildRequires:  pkgconfig
19BuildRequires:  gnome-menus-devel >= 2.30.4
20BuildRequires:  intltool
21BuildRequires:  desktop-file-utils
22Requires:       pygtk2, gnome-python
23Requires:       gnome-menus >= 2.30.4
24
25Patch0:         undo-delete.patch
26
27%description
28Alacarte is a graphical menu editor that lets you edit, add, and delete
29menu entries. It follows the freedesktop.org menu specification and
30should work with any desktop environment that uses this specification.
31
32%prep
33%setup -q
34%patch0 -p1 -b .undo-delete
35
36%build
37%configure
38make
39
40%install
41rm -rf $RPM_BUILD_ROOT
42make install DESTDIR=$RPM_BUILD_ROOT
43
44# desktop-file-install can't manipulate NotShowIn
45sed -i -e 's/NotShowIn=KDE;/OnlyShowIn=GNOME;/' \
46  $RPM_BUILD_ROOT%{_datadir}/applications/alacarte.desktop
47desktop-file-validate \
48  $RPM_BUILD_ROOT%{_datadir}/applications/alacarte.desktop
49
50
51%find_lang %{name}
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56%post
57touch --no-create %{_datadir}/icons/hicolor
58if [ -x /usr/bin/gtk-update-icon-cache ]; then
59  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
60fi
61
62%postun
63touch --no-create %{_datadir}/icons/hicolor
64if [ -x /usr/bin/gtk-update-icon-cache ]; then
65  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
66fi
67
68%files -f %{name}.lang
69%defattr(-,root,root,-)
70%doc README AUTHORS COPYING
71%{python_sitelib}/Alacarte
72%{_bindir}/alacarte
73%{_datadir}/applications/alacarte.desktop
74%{_datadir}/alacarte
75%{_datadir}/icons/hicolor/16x16/apps/alacarte.png
76%{_datadir}/icons/hicolor/22x22/apps/alacarte.png
77%{_datadir}/icons/hicolor/24x24/apps/alacarte.png
78%{_datadir}/icons/hicolor/32x32/apps/alacarte.png
79%{_datadir}/icons/hicolor/48x48/apps/alacarte.png
80%{_datadir}/icons/hicolor/256x256/apps/alacarte.png
81
82%changelog
83* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.13.2-1
84- new upstream release
85
86* Sat Apr 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.13.1-1
87- new upstream release
88
89* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.12.4-2
90- initial build for Vine Linux
91
92* Mon Sep 21 2009 Matthias Clasen <mclasen@redhat.com> - 0.12.4-1
93- Update to 0.12.4
94
95* Sat Sep 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.12.3-2
96- Bump the gnome-menus requires
97
98* Tue Sep  8 2009 Matthias Clasen <mclasen@redhat.com> - 0.12.3-1
99- Update to 0.12.3
100
101* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12.1-2
102- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
103
104* Sat May 16 2009 Matthias Clasen <mclasen@redhat.com> - 0.12.1-1
105- Update to 0.12.1
106
107* Tue Mar 17 2009 Matthias Clasen <mclasen@redhat.com> - 0.11.10-1
108- Update to 0.11.10
109
110* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11.9-3
111- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
112
113* Mon Feb 23 2009 Matthias Clasen <mclasen@redhat.com> - 0.11.9-2
114- Only show in GNOME (#486887)
115
116* Tue Feb 17 2009 Matthias Clasen <mclasen@redhat.com> - 0.11.9-1
117- Update to 0.11.9
118
119* Tue Feb  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.11.8-1
120- Update to 0.11.8
121
122* Tue Jan 20 2009 Matthias Clasen <mclasen@redhat.com> - 0.11.7-1
123- Update to 0.11.7
124
125* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.11.6-6
126- Rebuild for Python 2.6
127
128* Fri Nov 21 2008 Matthias Clasen <mclasen@redhat.com> - 0.11.6-5
129- Tweak %%summary and %%description
130
131* Fri Oct 17 2008 Matthias Clasen <mclasen@redhat.com> - 0.11.6-4
132- Make undoing of deletion work
133
134* Mon Sep 22 2008 Matthias Clasen <mclasen@redhat.com> - 0.11.6-3
135- Update to 0.11.6
136
137* Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> - 0.11.5-1
138- Update to 0.11.5
139
140* Thu Feb 21 2008 Matthias Clasen <mclasen@redhat.com> - 0.11.4-1
141- Update to 0.11.4
142
143* Sun Dec 02 2007 Todd Zullinger <tmz@pobox.com> - 0.11.3-5
144- put the python scripts in sitelib, not sitearch
145- remove autoconf, automake, and intltool BRs
146- don't run autoconf/automake in %%build
147- BR perl(XML::Parser)
148- remove smeg Obsoletes and Provides
149- minor rpmlint cleanups
150
151* Sat Aug 11 2007 Matthias Clasen <mclasen@redhat.com> - 0.11.3-4
152- Fix the build with intltool 0.36
153- Update the license field
154
155* Fri Mar 23 2007 Ray Strode <rstrode@redhat.com> - 0.11.3-3
156- change url to gnome.org (bug 233237)
157
158* Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 0.11.3-2
159- Update to 0.11.3
160
161* Mon Feb 12 2007 Matthias Clasen <mclasen@redhat.com> - 0.11.2-1.svn20070212
162- Bring back editing of the System menu
163
164* Fri Jan 26 2007 Matthias Clasen <mclasen@redhat.com> - 0.11.1.1-2
165- Fix the Provides: line
166
167* Thu Jan 11 2007 Matthias Clasen <mclasen@redhat.com> - 0.11.1.1-1
168- Update to 0.11.1.1
169
170* Wed Dec 20 2006 Matthias Clasen <mclasen@redhat.com> - 0.10.2-2
171- Update to 0.10.2
172
173* Sat Dec  9 2006 Matthias Clasen <mclasen@redhat.com> - 0.10.1-4
174- try again
175
176* Wed Dec  6 2006 Jeremy Katz <katzj@redhat.com> - 0.10.1-2
177- build against python 2.5
178
179* Sat Oct 21 2006 Matthias Clasen <mclasen@redhat.com> - 0.10.1-1
180- Update to 0.10.1
181* Mon Sep  4 2006 Matthias Clasen <mclasen@redhat.com> - 0.10.0-1.fc6
182- Update to 0.10.0
183
184* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 0.9.90-7.fc6
185- Fix more build requires
186
187* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 0.9.90-3.fc6
188- Add BR for pkgconfig
189
190* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 0.9.90-1.fc6
191- Update to 0.9.90
192
193* Thu Aug 17 2006 Ray Strode <rstrode@redhat.com> - 0.8-8
194- initial build for Fedora Core
195
196* Wed Feb 15 2006 John Mahowald <jpmahowald@gmail.com> - 0.8-7
197- Rebuild for Fedora Extras 5
198
199* Fri Feb 3 2006  John Mahowald <jpmahowald@gmail.com> - 0.8-3
200- Fix stray reference to smeg
201- Use python sitearch macro from template
202
203* Sat Oct 29 2005  John Mahowald <jpmahowald@gmail.com> - 0.8-2
204- Rebuild
205
206* Thu Oct 27 2005  John Mahowald <jpmahowald@gmail.com> - 0.8-1
207- rename to alacarte
208- Update to 0.8
209
210* Thu Oct 20 2005  John Mahowald <jpmahowald@gmail.com> - 0.7.5-4
211- remove requires gnome-menus
212
213* Tue Aug 30 2005 John Mahowald <jpmahowald@gmail.com> - 0.7.5-3
214- Move to /usr/share
215
216* Tue Jun 28 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.7.5-2
217- Desktop-file-utils for kde desktop entry as well as default one.
218
219* Wed Jun 08 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.7.5-1
220- Rebuilt for 0.7.5
221
222* Sun Jun 06 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.7.4-1
223- Rebuilt for 0.7.4
224
225* Wed Jun 01 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.7.1-1
226- Rebuilt for 0.7.1
227- Smeg now use the stock gnome menu icon, removed pixmaps from %%files
228
229* Wed Jun 01 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.7-2
230- Added missing dependency gnome-python2-gconf
231
232* Tue May 31 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.7-1
233- Rebuilt for 0.7
234
235* Mon May 30 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.6.2-2
236- Added desktop-file-utils to Buildrequires
237- Addded desktop-file-utils %%post and %%postun
238
239* Sat May 29 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.6.2-1
240- Rebuilt for 0.6.2
241
242* Mon May 23 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.5-1
243- Initial build
Note: See TracBrowser for help on using the repository browser.