source: projects/specs/branches/6/a/acl/acl-vl.spec @ 3372

Revision 3372, 9.8 KB checked in by inagaki, 13 years ago (diff)

update: acl, attr

Line 
1Name: acl
2Summary: Access control list utilities
3Version: 2.2.49
4Release: 1%{?_dist_release}
5
6Group: System Environment/Base
7License: GPLv2+
8URL: http://oss.sgi.com/projects/xfs/
9
10Source: http://download.savannah.gnu.org/releases-noredirect/acl/acl-%{version}.src.tar.gz
11Patch1: acl-2.2.39-build.patch
12# bz #488674
13Patch2: acl-2.2.49-setfacl-walk.patch
14# bz #467936
15Patch3: acl-2.2.49-bz467936.patch
16# prepare the test-suite for SELinux and arbitrary umask
17Patch4: acl-2.2.49-tests.patch
18# bz #576550
19Patch5: acl-2.2.49-setfacl-restore.patch
20# fix typos in setfacl(1) man page (#675451)
21Patch6: acl-2.2.49-bz675451.patch
22# add function acl_extended_file_nofollow() (#692982)
23Patch7: acl-2.2.49-bz692982.patch
24
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: gawk
27BuildRequires: gettext
28BuildRequires: libattr-devel >= 2.4.1
29BuildRequires: libtool
30Requires: libacl = %{version}-%{release}
31
32%description
33This package contains the getfacl and setfacl utilities needed for
34manipulating access control lists.
35
36%package -n libacl
37Summary: Dynamic library for access control list support
38License: LGPLv2+
39Group: System Environment/Libraries
40Requires(post): /sbin/ldconfig
41Requires(postun): /sbin/ldconfig
42
43%description -n libacl
44This package contains the libacl.so dynamic library which contains
45the POSIX 1003.1e draft standard 17 functions for manipulating access
46control lists.
47
48%package -n libacl-devel
49Summary: Access control list static libraries and headers.
50License: LGPLv2+
51Group: Development/Libraries
52Requires: libacl = %{version}-%{release}
53Requires: libattr-devel
54
55%description -n libacl-devel
56This package contains static libraries and header files needed to develop
57programs which make use of the access control list programming interface
58defined in POSIX 1003.1e draft standard 17.
59
60%prep
61%setup -q
62%patch1 -p1
63%patch2 -p1
64%patch3 -p1
65%patch4 -p1
66%patch5 -p1
67%patch6 -p1
68%patch7 -p1
69
70%build
71touch .census
72# acl abuses libexecdir
73%configure --libdir=/%{_lib} --libexecdir=%{_libdir}
74make %{?_smp_mflags} LIBTOOL="libtool --tag=CC"
75
76%install
77rm -rf $RPM_BUILD_ROOT
78make install DESTDIR=$RPM_BUILD_ROOT
79make install-dev DESTDIR=$RPM_BUILD_ROOT
80make install-lib DESTDIR=$RPM_BUILD_ROOT
81
82# get rid of libacl.a and libacl.la
83rm -f $RPM_BUILD_ROOT/%{_lib}/libacl.a
84rm -f $RPM_BUILD_ROOT/%{_lib}/libacl.la
85rm -f $RPM_BUILD_ROOT%{_libdir}/libacl.a
86rm -f $RPM_BUILD_ROOT%{_libdir}/libacl.la
87
88# fix links to shared libs and permissions
89rm -f $RPM_BUILD_ROOT/%{_libdir}/libacl.so
90ln -sf ../../%{_lib}/libacl.so $RPM_BUILD_ROOT/%{_libdir}/libacl.so
91chmod 0755 $RPM_BUILD_ROOT/%{_lib}/libacl.so.*.*.*
92
93%find_lang %{name}
94
95%check
96if ./setfacl/setfacl -m u:`id -u`:rwx .; then
97    make tests || exit $?
98    if test 0 = `id -u`; then
99        make root-tests || exit $?
100    fi
101else
102    echo '*** ACLs are probably not supported by the file system,' \
103         'the test-suite will NOT run ***'
104fi
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109%post -n libacl -p /sbin/ldconfig
110
111%postun -n libacl -p /sbin/ldconfig
112
113%files -f %{name}.lang
114%defattr(-,root,root)
115%{_bindir}/chacl
116%{_bindir}/getfacl
117%{_bindir}/setfacl
118%{_datadir}/doc/acl-%{version}
119%{_mandir}/man1/chacl.1*
120%{_mandir}/man1/getfacl.1*
121%{_mandir}/man1/setfacl.1*
122%{_mandir}/man5/acl.5*
123
124%files -n libacl-devel
125%defattr(-,root,root)
126/%{_lib}/libacl.so
127%{_includedir}/acl
128%{_includedir}/sys/acl.h
129%{_libdir}/libacl.*
130%{_mandir}/man3/acl_*
131
132%files -n libacl
133%defattr(-,root,root)
134/%{_lib}/libacl.so.*
135
136%changelog
137* Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.49-1
138- updated to 2.2.49
139- added Patch2-7 from Fedora
140  * Wed Apr 06 2011 Kamil Dudka <kdudka@redhat.com> 2.2.49-11
141  - add function acl_extended_file_nofollow() (#692982)
142  * Tue Mar 29 2011 Kamil Dudka <kdudka@redhat.com> 2.2.49-10
143  - fix typos in setfacl(1) man page (#675451)
144  * Thu Jul 08 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-8
145  - remove dependency of libacl-devel on nfs-utils-lib and openldap
146  * Tue May 25 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-7
147  - let acl depend on the same version of libacl (#595674)
148  * Wed Mar 24 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-6
149  - prevent setfacl --restore from SIGSEGV on malformed restore file (#576550)
150
151* Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.47-2
152- initial build for Vine Linux
153
154* Tue Feb 12 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.47-1
155- new upstream version
156
157* Mon Jan 28 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.45-3
158- Fixed segfault when using only "--" as parameter
159- Resolves: #430458
160
161* Wed Nov  7 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.45-2
162- Fixed setfacl exitcodes
163- Resolves: #368451
164
165* Wed Oct 31 2007 Jiri Moskovcak <jmoskovc@redhat.com> - 2.2.45-1
166- New version
167- dropped walk patch
168
169* Thu Sep 20 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-10
170- Rewriten path_max patch to support long UTF8 names
171- Resolves #287701, #183181
172
173* Fri Aug 31 2007 Steve Dickson <steved@redhat.com> - 2.2.39-9
174- Removed NFS4 ACL patch since it was rejected by upstream.
175
176* Thu Aug 30 2007 Jeremy Katz <katzj@redhat.com> - 2.2.39-8
177- disable nfs patch; linking libacl against libs in /usr will lead to breakage
178
179* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.2.39-7
180- Build Require gawk
181
182* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.2.39-6
183- Rebuild for selinux ppc32 issue.
184
185* Mon Aug 27 2007 Steve Dickson <steved@redhat.com>  2.2.39-5
186- Added NFS v4 ACL support
187
188* Thu Jul 26 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-4.1
189- Updated man page for getfacl
190
191* Wed Jul 25 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-4
192- Added support fort short params to getfacl
193- Resolves: #204087
194
195* Wed Mar 21 2007 Thomas Woerner <twoerner@redhat.com> 2.2.39-3.1
196- new improved walk patch with fixed getfacl exit code (rhbz#232884)
197
198* Fri Feb 23 2007 Karsten Hopp <karsten@redhat.com> 2.2.39-3
199- fix buildroot
200- remove trailing dot from summary
201- -devel requires same version of libacl
202- escape macro in changelog
203- make .so symlink relative
204
205* Thu Feb 22 2007 Steve Grubb <sgrubb@redhat.com> 2.2.39-2
206- Apply patch to make order consistent.
207
208* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.2.39-1.1
209- rebuild
210
211* Wed Jul  5 2006 Thomas Woerner <twoerner@redhat.com> 2.2.39-1
212- new version 2.2.39
213- fixed usage of long UTF-8 filenames (#183181)
214  Thanks to Andrey for the initial patch.
215
216* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 2.2.34-2
217- rebuild for -devel deps
218
219* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2.34-1.2
220- bump again for double-long bug on ppc(64)
221
222* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2.34-1.1
223- rebuilt for new gcc4.1 snapshot and glibc changes
224
225* Fri Feb  3 2006 Thomas Woerner <twoerner@redhat.com> 2.2.34-1
226- new version 2.2.34
227
228* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
229- rebuilt
230
231* Tue Dec  6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2.1
232- fixed permissions of libacl
233
234* Tue Dec  6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2
235- spec file cleanup
236- mark po files as lang specific
237
238* Sun Nov 06 2005 Florian La Roche <laroche@redhat.com>
239- 2.2.32
240
241* Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.2.31-1
242- update to 2.2.31
243
244* Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.2.23-9
245- get rid of *.la files
246- remove duplicate doc files
247
248* Wed Feb  9 2005 Stephen C. Tweedie <sct@redhat.com> 2.2.23-6
249- Rebuild
250
251* Thu Sep 16 2004 Jeremy Katz <katzj@redhat.com> - 2.2.23-5
252- make the libs executable so that we find their dependencies (#132696)
253
254* Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.23-4
255- libacl-devel Requires: libattr-devel for libattr.la
256
257* Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.23-3
258- Requires libtool >= 1.5 for building
259
260* Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.2.23-2
261- Make libacl.so.* executable.
262
263* Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.2.23-1
264- Update to latest upstream version.
265
266* Sun Aug  8 2004 Alan Cox <alan@redhat.com> 2.2.7-7
267- Close bug #125300 (Steve Grubb: build requires libtool,gettext)
268
269* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
270- rebuilt
271
272* Wed Mar 31 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.7-5
273- Add missing %%defattr
274
275* Tue Mar 30 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.7-3
276- Add /usr/include/acl to files manifest
277- Fix location of doc files, add main doc dir to files manifest
278
279* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
280- rebuilt
281
282* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
283- rebuilt
284
285* Tue Aug  5 2003 Elliot Lee <sopwith@redhat.com> 2.2.7-2
286- Fix libtool invocation
287
288* Tue Jun  3 2003 Stephen C. Tweedie <sct@redhat.com> 2.2.7-1
289- Update to acl-2.2.7
290
291* Wed Mar 26 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-2
292- include patch from Jay Berkenbilt to print better error messages
293
294* Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-1
295- udpate/rebuild
296
297* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 2.0.11-7
298- set execute bits on library so that requires are generated.
299
300* Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-5
301- Correct patch in previous fix so that shared libraries go in /lib*
302  instead of /usr/lib*
303
304* Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-4
305- Fix multilibbing
306
307* Wed Sep 11 2002 Than Ngo <than@redhat.com> 2.0.11-3
308- Added fix to install libs in correct directory on 64bit machine
309
310* Thu Aug 08 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-2
311- Made the package only own the one directory that is unique to it:
312  /usr/include/acl
313
314* Mon Jun 24 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-1
315- Initial Red Hat package
316  Made as few changes as possible relative to upstream packaging to
317  make it easier to maintain long-term.  This means that some of
318  the techniques used here are definitely not standard Red Hat
319  techniques.  If you are looking for an example package to fit
320  into Red Hat Linux transparently, this would not be the one to
321  pick.
322- acl-devel -> libacl-devel
Note: See TracBrowser for help on using the repository browser.