source: projects/specs/branches/6/a/abiword/abiword-vl.spec @ 2041

Revision 2041, 26.9 KB checked in by Takemikaduchi, 13 years ago (diff)

update to GNOME-2.32.0

Line 
1%define desktop_file_utils_version 0.16
2%define abiver 2.8
3
4Summary: The AbiWord word processor
5Summary(ja): AbiWord ワードプロセッサ
6Name: abiword
7Version: 2.8.6
8Release: 3%{?_dist_release}
9Epoch: 1
10Group: Applications/Productivity
11License: GPLv2+
12Source0: http://abisource.com/downloads/abiword/%{version}/source/abiword-%{version}.tar.gz
13## Source1: http://abisource.com/downloads/abiword/%{version}/source/abiword-plugins-%{version}.tar.gz
14## Source2: http://abisource.com/downloads/abiword/%{version}/source/abiword-extras-%{version}.tar.gz
15Source3: http://abisource.com/downloads/abiword/%{version}/source/abiword-docs-%{version}.tar.gz
16Source11: abiword.mime
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19
20Vendor: Project Vine
21Distribution: Vine Linux
22#Packager:
23
24# for abiword
25BuildRequires: gcc-c++
26BuildRequires: gtk2-devel
27BuildRequires: libpng-devel
28BuildRequires: libxml2-devel
29BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
30BuildRequires: fribidi-devel
31BuildRequires: enchant-devel
32BuildRequires: libgnomeprint-devel
33BuildRequires: libgnomeprintui-devel
34BuildRequires: wv-devel
35BuildRequires: gucharmap-devel
36BuildRequires: libSM-devel
37
38# some plugin build deps
39BuildRequires: readline-devel
40BuildRequires: bzip2-devel
41BuildRequires: poppler-devel >= 0.14.2
42#BuildRequires: ots-devel >= 0.4.2
43BuildRequires: libwpd-devel >= 0.8.0
44BuildRequires: librsvg2-devel
45#BuildRequires: aiksaurus-gtk-devel >= 1.2.1
46#BuildRequires: link-grammar-devel >= 4.2.1
47#BuildRequires: gtkmathview-devel >= 0.7.5
48BuildRequires: libgsf-devel >= 1.12.1
49BuildRequires: libboost-devel >= 1.33.1
50
51# gnome build deps
52BuildRequires: libbonobo-devel
53BuildRequires: libbonoboui-devel
54BuildRequires: libgnomeui-devel
55
56Requires(pre): desktop-file-utils >= %{desktop_file_utils_version}
57Obsoletes: abiword-fonts abiword-plugins
58
59URL: http://www.abisource.com/
60
61Patch0: abiword-2.6.0-windowshelppaths.patch
62Patch1: abiword-2.6.4-desktop.patch
63Patch2: abiword-2.6.0-boolean.patch
64Patch3: abiword-plugins-2.6.0-boolean.patch
65
66%description
67AbiWord is a cross-platform Open Source word processor. The goal is to make
68AbiWord full-featured, and remain lean.
69
70%description -l ja
71AbiWord はクロスプラットフォームのオープンソースなワードプロセッサーです。
72多機能で機敏に動くことを目標としています。
73
74%package -n libabiword
75Summary: Library for developing applications based on AbiWord's core
76Summary(ja): AbiWord コアで稼動するアプリケーションを開発するためのライブラリ
77Group: System Environment/Libraries
78
79%description -n libabiword
80Library for developing applications based on AbiWord's core.
81
82%description -n libabiword -l ja
83AbiWord コアで稼動するアプリケーションを開発するためのライブラリです。
84
85%package -n libabiword-devel
86Summary: Files for developing with libabiword
87Summary(ja): libabiword を用いた開発に必要なファイル群
88Group: Development/Libraries
89Requires: libabiword = %{epoch}:%{version}-%{release}
90
91%description -n libabiword-devel
92Includes and definitions for developing with libabiword.
93
94%description -n libabiword-devel -l ja
95libabiword で開発するためのインクルードファイル及び定義ファイルです。
96
97%prep
98%setup -q
99## %patch1 -p1 -b .desktop
100%patch2 -p1 -b .boolean
101
102# setup abiword-plugins
103## %setup -q -T -b 1 -n abiword-plugins-%{version}
104## %patch3 -p1 -b .boolean
105
106# setup abiword extras
107## %setup -q -T -b 2 -n abiword-extras-%{version}
108
109# setup abiword documentation
110%setup -q -T -b 3 -n abiword-docs-%{version}
111%patch0 -p1 -b .windowshelppaths
112
113%build
114# build libabiword and abiword
115cd $RPM_BUILD_DIR/abiword-%{version}
116%configure --enable-libabiword -enable-static=no
117make %{?_smp_mflags}
118
119# build abiword-plugins
120## cd $RPM_BUILD_DIR/abiword-plugins-%{version}
121## export PKG_CONFIG_PATH="$RPM_BUILD_DIR/%{name}-%{version}"
122## CXXFLAGS="-L$RPM_BUILD_DIR/%{name}-%{version}/src/wp/main/unix/" %configure --disable-gda --enable-libabiword --with-abiword=$RPM_BUILD_DIR/%{name}-%{version}
123## # Remove libtool predep_objects and postdep_objects wonkiness so that
124## # building without -nostdlib doesn't include them twice.  Because we
125## # already link with g++, weird stuff happens if you don't let the
126## # compiler handle this.
127## sed 's/^predep_objects=.*/predep_objects=\"\"/' < libtool > libtool.foo
128## sed 's/^postdep_objects=.*/postdep_objects=\"\"/' < libtool.foo > libtool.foobar
129## sed 's/-shared -nostdlib/-shared/' < libtool.foobar > libtool
130## make %{?_smp_mflags}
131
132# build abiword-extras
133## cd $RPM_BUILD_DIR/abiword-extras-%{version}
134## # abiword-extras looks at the abiword-%{version}.pc pkg-config file to get its location info
135## # however, that file is not installed yet, so just point to it in the abiword source tree
136## export PKG_CONFIG_PATH="$RPM_BUILD_DIR/%{name}-%{version}"
137## %configure
138## make
139
140# build the documentation
141cd $RPM_BUILD_DIR/abiword-docs-%{version}
142ABI_DOC_PROG=$(pwd)/../%{name}-%{version}/src/wp/main/unix/abiword ./make-html.sh
143
144%install
145rm -rf $RPM_BUILD_ROOT
146
147# install abiword
148cd $RPM_BUILD_DIR/abiword-%{version}
149make install DESTDIR=$RPM_BUILD_ROOT
150# overwrite the static binary with the dynamic one
151## mv -f $RPM_BUILD_DIR/abiword-%{version}/src/wp/main/unix/abiword-dynamic $RPM_BUILD_ROOT%{_bindir}/abiword
152
153# Fix script permission
154#chmod +x $RPM_BUILD_ROOT%{_datadir}/%{name}-%{abiver}/scripts/abw2html.pl
155
156# install abiword-plugins
157## cd $RPM_BUILD_DIR/abiword-plugins-%{version}
158## make install DESTDIR=$RPM_BUILD_ROOT
159
160# install the extras
161## cd $RPM_BUILD_DIR/abiword-extras-%{version}
162## make install DESTDIR=$RPM_BUILD_ROOT
163
164# install the documentation
165cd $RPM_BUILD_DIR/abiword-docs-%{version}
166mkdir -p $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help
167cp -rp help/* $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help/
168# some of the help dirs have bad perms (#109261)
169find $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help/ -type d -exec chmod -c o+rx {} \;
170
171# finish up
172## mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps/
173## cp $RPM_BUILD_DIR/abiword-extras-%{version}/icons/abiword_48.png $RPM_BUILD_ROOT%{_datadir}/pixmaps/abiword_48.png
174
175cd $RPM_BUILD_DIR/abiword-%{version}
176mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
177desktop-file-install \
178  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
179  --add-category X-Red-Hat-Extra --remove-category X-Red-Hat-Base \
180  --add-category Applications --add-category Office \
181  ./abiword.desktop
182# remove the original one (which has X-Red-Hat-Base)  (#107023)
183#rm -f $RPM_BUILD_ROOT/%{_datadir}/applications/abiword.desktop
184
185mkdir -p $RPM_BUILD_ROOT%{_datadir}/mime-info
186install -m 644 %{SOURCE11} $RPM_BUILD_ROOT%{_datadir}/mime-info
187
188# nuke .la files
189rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}-%{abiver}/plugins/*.la
190rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
191# nuke .a files
192rm -f $RPM_BUILD_ROOT/%{_libdir}/*.a
193# nuke custom dictionary files
194rm -f $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/dictionary/ispell_dictionary_list.xml
195
196
197%clean
198rm -rf $RPM_BUILD_ROOT
199
200%post
201update-desktop-database -q %{_datadir}/applications
202
203%postun
204update-desktop-database -q %{_datadir}/applications
205
206%files
207%defattr(-,root,root)
208%{_bindir}/abiword
209%{_datadir}/applications/*
210%{_datadir}/mime-info/*
211## %{_datadir}/pixmaps/*png
212%{_datadir}/icons/*png
213%{_mandir}/man1/abiword.1.gz
214
215%files -n libabiword
216%doc $RPM_BUILD_DIR/%{name}-%{version}/docs $RPM_BUILD_DIR/%{name}-%{version}/COPYING $RPM_BUILD_DIR/%{name}-%{version}/COPYRIGHT.TXT $RPM_BUILD_DIR/%{name}-%{version}/README.TXT
217%{_libdir}/abiword-%{abiver}
218%{_libdir}/libabiword-%{abiver}.so
219%{_datadir}/abiword-%{abiver}
220
221%files -n libabiword-devel
222%{_includedir}/abiword-%{abiver}
223%{_libdir}/pkgconfig/*.pc
224
225%changelog
226* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.8.6-3
227- rebuild with poppler-0.14.2
228
229* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.8.6-2
230- rebuild with rpm-4.8.1 for pkg-config file
231
232* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.8.6-1
233- new upstream release
234- drop Source1, Source2
235- drop Patch1, Patch3
236- fix %setup, %build, %install and %files
237
238* Thu Jul 29 2009 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1:2.6.8-2
239- add Japanese Summary and description
240- add BuildRequires: libSM-devel
241
242* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.6.8-1
243- new upstream release
244
245* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.6.4-1vl5
246- new upstream release
247- built with enchant
248- split libabiword, libabiword-devel subpackage
249
250* Mon Oct 13 2008 Shu KONNO <owa@bg.wakwak.com> 1:2.4.6-2vl5
251- built with gucharmap-2.24.0
252
253* Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 1:2.4.6-1vl5
254- applied new versioning policy, spec in utf-8
255
256* Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.6-0vl2
257- rebuilt with new toolchain
258
259* Thu Dec 21 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.6-0vl1
260- new upstream release
261- rebuilt with wv-1.2.4
262
263* Thu Sep 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.5-2vl2
264- fixed .desktop file
265
266* Fri Aug 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.5-2vl1
267- updated to 2.4.5
268
269* Tue Apr 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.4-2vl1
270- rebuilt for Vine and merged old spec files
271  * Thu Sep 26 2002 Masaki Shinomiya <shino@pos.to>
272  - 1.0.3-0vl1 for VinePlus/2.1 and (-0vl2) for 2.5 and VineSeedPlus
273  - source update, plugins-1.0.3, many plugins enabled in -0vl2
274  - disabled perl
275  - abiword-mkhash.sh for spell check
276  * Mon Jun 24 2002 Masaki Shinomiya <shino@pos.to>
277  - 1.0.2-0vl1 for VinePlus/2.1 and (-0vl2) for 2.5 and VineSeedPlus
278  - source update
279  - touch fonts.dir, abiword-wrapper.patch
280  - no longer segmentation fault on Vine 2.5 (see [vine-users:051609]-)
281  * Wed May 22 2002 Masaki Shinomiya <shino@pos.to>
282  - 1.0.1-0vl1 for VinePlus/2.1 and (-0vl2) for VineSeedPlus
283  - 0vl1 omits plugins because Vine 2.1.x fails to compile
284  - 0vl1 also disables gnome and perl support
285  - Japanese fonts are now usable on VineSeed/Vine 2.5
286  - by using mkjafontsdir.sh made by me
287  - source upstream to 1.0.1, plugins(merged in the main package)
288  - doc, mime-info
289  * Sat Mar 30 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com> 0.99.4-0vl2
290  - new upstream version
291  - fix symbolic link ([VineSeed-Plus:00941])
292  * Sun Mar 18 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com> 0.99.3-0vl2
293  - new upstream version
294  * Sun Feb 24 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com> 0.99.2-0vl0
295  - new upstream version.
296  - disable plugin all and comment out plugin part in build/make section,
297    because 0.99.2's source tar boll doesn't have abiword-plugins directory.
298  * Fri Feb 15 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com>
299  - 0.99.1-0vl3 (0.99.1-0vl2 for VinePlus-2.1)
300  - fix files owner/group ([VineSeed-Plus:00819])
301  * Sat Jan 28 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com>
302  - 0.99.1-0vl0.1
303  - change release number for VinePlus 2.1
304  * Sat Jan 24 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com>
305  - 0.99.1-0vl1
306  - add japanese fonts.dir
307     (see http://www.gnome.gr.jp/ml/gnome-users/200101/msg00034.html)
308    0vl0.1 release for VinePlus-2.1 succeed to input/display japanese,
309    but this release fail to input/display japanese.
310    please someone fix this problem.
311
312* Tue Apr 13 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.4-2.fc6
313- Fix documentation generation
314- Fix charting support
315
316* Tue Apr 11 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.4-1.fc6
317- New upstream version
318- Remove the macro patch and update the desktop patch
319
320* Wed Mar 29 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-8.fc6
321- Rebuild
322
323* Wed Mar 08 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-7.fc5
324- Disable the collaboration plugin; it is not working in 2.4.x
325
326* Thu Feb 16 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-6.fc5
327- Rebuild for Fedora Extras 5
328
329* Sun Feb 05 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-5.fc5
330- bug 171926
331
332* Sat Jan 21 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-4.fc5
333- Disable the PDF plugin for now, as poppler doesn't ship the xpdf
334  headers anymore
335
336* Sat Jan 14 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-3.fc5
337- Remove redundant requires - bug 177305
338
339* Thu Jan 05 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-2.fc5
340- Bump release, forgot to add desktop patch
341
342* Mon Jan 02 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-1.fc5
343- Update to 2.4.2
344- Add BuildRequires readline-devel for the AbiCommand plugin
345- Add BuildRequires bzip2-devel and poppler-devel for plugins
346- Update desktop patch
347- Patch to fix plugin marcros
348
349* Wed Nov 09 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-4.fc5
350- Fix bug 171928
351
352* Sun Oct 23 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-3.fc5
353- Fix bug 161832: "Abiword is not loading certain modules"
354- Add libgsf dependecy, which was needed all along
355- Disable the collaboration plugin, it is not for general use at all
356
357* Tue Oct 11 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-2
358- Use %%{?dist} in the release name
359
360* Sun Oct 9 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-1
361- Update to 2.4.1
362
363* Mon Oct 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.0-1
364- Require mathml-fonts
365- Don't rerun autogen.sh, no need anymore
366- Update gtkmathview dependency to 0.7.5
367- Update to 2.4.0
368
369* Mon Sep 26 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.99-2
370- Fix gtkmathview BuildRequires
371
372* Thu Sep 22 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.99-1
373- Update to 2.3.99
374
375* Sat Sep 10 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.6-1
376- Update to 2.3.6
377- Drop the pango patch
378
379* Sat Sep 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-3
380- Rebuild
381
382* Sat Sep 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-2
383- Enable the abimathview plugin
384
385* Sun Aug 21 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-1
386- Update to 2.3.5
387
388* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-4
389- Update the pango patch to disable more pango code
390
391* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-3
392- Fix the build after applying the pango disabling patch by
393  rerunning autogen.sh
394
395* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-2
396- Disable the experimental pango renderer
397
398* Thu Aug 17 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-1
399- Update to 2.3.4
400- Add link-grammar dependency
401
402* Thu Jul 28 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.9-1
403- Update to 2.2.9
404- Drop the mailmerge patch again
405
406* Sun Jun 6 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.8-2
407- Fix build with mailmerge patch
408
409* Sun Jun 6 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.8-1
410- Update to 2.2.8
411
412* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1:2.2.7-2
413- rebuild on all arches
414
415* Mon Apr 4 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.7-1
416- Because we love brown paper bag releases
417
418* Sun Apr 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.6-1
419- Drop the gcc4, wvread, virtdestr and pt64 patches
420- Update the desktop patch
421
422* Fri Mar 15 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.5-3
423- Fix 64bit build
424- Add virtual destructors to classes with virtual functions
425
426* Fri Mar 14 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.5-2
427- Remove the --disable-magick plugin switch
428- disable GDA support until the plugin is ported to gnomedb 1.2.x
429- Change the download location from SF to http://www.abisource.com/
430- patch libole2
431- fix read as a macro in new glibc
432
433* Fri Mar  2 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.5-1
434- bump to latest stable
435- drop integrated dashboard patch again
436- some gcc4 fixes
437
438* Wed Feb 23 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.4-2
439- rh#149447# dashboard spam revisited
440
441* Tue Feb 22 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.4-1
442- bump to latest stable version
443- drop integrated nautilus depend patch
444- drop integrated libwpd depend patch
445
446* Fri Feb 11 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-4
447- upgrade to libwpd-0.8 and incoroprate necessary changeover patches
448
449* Mon Feb 7 2005 Matthias Clasen <mclasen@redhat.com> - 1:2.2.3-3
450- rebuild
451
452* Mon Feb 2 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-2
453- remove unneccessary nautilus dependency
454
455* Mon Jan 17 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-1
456- bump to new version
457- drop integrated silenceabidash patch
458
459* Fri Jan 14 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-4
460- RH#145085# annoying cluepacket message on stdout/stderr
461
462* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> - 1:2.2.2-3
463- Rebuilt for new readline.
464
465* Tue Jan 11 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-2
466- RH#143368# use enchant as spellchecker
467
468* Mon Dec 13 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-1
469- bump to new version
470
471* Mon Dec 6 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.1-1
472- bump to new version
473- geometry patch upstreamed
474- security patch upstreamed
475- removeoledecod patch upstreamed
476- regenerate desktop patch
477
478* Mon Nov 22 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.0-2
479- #abi7961# remove tempnam usages
480
481* Mon Nov 22 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.0-1
482- bump to latest major stable version
483- #rh140321# sanity check geometry
484
485* Tue Nov  9 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.0.14-1
486- bump to latest stable version
487
488* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.12-4
489- rebuild for python 2.4
490
491* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 1:2.0.12-3
492- Change to PreReq instead of Requires(post), up to 0.9
493
494* Thu Sep 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.12-2
495- Better Requires desktop-file-utils
496
497* Wed Sep 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.12-1
498- update to new abiword, + change norwegian wordprocessor translation
499
500* Tue Sep 14 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-3
501- #132389# Add more abiword supported mime types to abiword.desktop
502
503* Mon Sep 6 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-2
504- merge abiword.keys into abiword.desktop
505
506* Fri Aug 27 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-1
507- 2.0.11
508
509* Tue Aug 10 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.10-2
510- use libgnomedb
511
512* Tue Aug 10 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.10-1
513- 2.0.10
514- use aiksaurus
515
516* Tue Aug 2 2004 Matthias Clasen <mclasen@redhat.com> 1:2.0.9-4
517- rebuilt
518
519* Thu Jul 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-3
520- #126012# some desktop translations
521
522* Wed Jul 28 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-2
523- #128004# fix irritating windows looking filenames for generated pngs
524
525* Fri Jul 16 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-1
526- 2.0.9, new version with security fix
527
528* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
529- rebuilt
530
531* Thu May 20 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.6-1
532- 2.0.7, new version + gcc34 fixes
533
534* Wed Apr 28 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.6-1
535- 2.0.6, 64bit changes made upstream
536
537* Sat Mar 13 2004 Jeremy Katz <> 1:2.0.5-1
538- 2.0.5
539
540* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
541- rebuilt
542
543* Thu Feb 19 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.3-3
544- rebuild for newer libots and libwpd
545- fix verify as non-root (#109261)
546- add wpd files to abiword.keys (#114907)
547
548* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
549- rebuilt
550
551* Thu Jan 29 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.3-1
552- 2.0.3 (fixes build against gtk+ 2.3 and lets us rebuild to fix libcroco dep)
553
554* Wed Dec 17 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.2-2
555- rebuild for new libwpd
556
557* Sun Nov 30 2003 Jeremy Katz <katzj@redhat.com>
558- and librsvg2-devel (#111222)
559
560* Fri Nov 28 2003 Jeremy Katz <katzj@redhat.com>
561- buildrequire libgnomeui-devel (#111164)
562
563* Tue Oct 28 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.1-1
564- 2.0.1
565- really remove duplicate desktop file
566
567* Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-6
568- make the docs with the just built abiword so that we don't have to
569  have abiword installed to build the docs (#107279)
570
571* Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-5
572- fix linkage to glib 1.2 in hancom plugin (#106033)
573
574* Sun Oct 19 2003 Florian La Roche <Florian.LaRoche@redhat.de>
575- add %%clean specfile target
576
577* Tue Oct 14 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-4
578- remove duplicate desktop file (#107023)
579
580* Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-3
581- include the help
582- show the clipart (#104577)
583
584* Mon Sep 15 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-2
585- rebuild with newer libwpd and libots to get those plugins
586
587* Sun Sep 14 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-1
588- 2.0.0
589
590* Thu Sep  4 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.6-1
591- 1.99.6
592
593* Mon Aug 25 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.5-1
594- 1.99.5
595
596* Tue Aug  5 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.3-1
597- 1.99.3
598- put icon in the right place (#101646)
599- fix some 64bit casting issues
600- disable ots plugin for now, doesn't seem to build with ots 0.4.0 :/
601- disable -pedantic -ansi so that it will build
602
603* Mon Jul 14 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.2-2
604- ugly hack to deal with libtool silliness on x86_64
605
606* Fri Jul 11 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.2-1
607- 1.99.2
608- add buildrequires to make sure the ots and wp plugins get built
609- no longer needs libgal2, remove buildrequires
610
611* Mon Jun 16 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.1-1
612- 1.99.1
613
614* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
615- rebuilt
616
617* Mon May 26 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-3
618- rebuild for new libgal2
619
620* Mon May 19 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-2
621- tweak plugins build
622
623* Mon May 12 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-0.2
624- 1.9.1
625- drop old patches, switch to using autoconf based build system instead
626  of diving makefiles
627- build with gnome support
628- build with plugins
629- add patch to build on AMD64
630
631* Mon Apr 28 2003 Tim Powers <timp@redhat.com> 1:1.0.5-2
632- rebuild to fix broken libpspell dep
633
634* Mon Mar 24 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.5-1
635- 1.0.5
636
637* Mon Feb 10 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.4-2
638- fix for abiword starting off the screen (#82425)
639
640* Thu Jan 23 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.4-1
641- 1.0.4
642
643* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
644- rebuilt
645
646* Sun Dec 29 2002 Jeremy Katz <katzj@redhat.com> 1:1.0.3-2
647- make it build on x86_64
648
649* Sun Dec 29 2002 Jeremy Katz <katzj@redhat.com> 1:1.0.3-1
650- 1.0.3 (#80560)
651- set umask before running mkfontdir in %%post
652- patch AbiWord script to convert utf8 locales into non-utf8 variants (#72633)
653
654* Mon Dec 02 2002 Elliot Lee <sopwith@redhat.com> 1.0.2-7
655- Fix doc lines
656- Fix multilib
657
658* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com> 1.0.2-6
659- rebuilt with gcc-3.2 (we hope)
660
661* Sat Aug 10 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-5
662- fix help index symlink (#71219)
663
664* Thu Aug  1 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-4
665- add abiword binary symlink for upstream compatibility (#70267)
666
667* Mon Jul 22 2002 Tim Powers <timp@redhat.com> 1.0.2-3
668- rebuild using gcc-3.2-0.1
669
670* Thu Jul 18 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-2
671- use included desktop file (#64447)
672- use desktop-file-install
673
674* Wed Jun 26 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-1
675- 1.0.2
676- disable perl module build since we weren't including it anyway
677
678* Wed May 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.0.1-1
679- 1.0.1
680
681* Sun Apr 14 2002 Jeremy Katz <katzj@redhat.com> 0.99.5-1
682- zh_CN and zh_TW fonts.dir were flipped
683- update to 0.99.5 as it fixes some major bugs
684- define ABI_BUILD_VERSION so the about screen gives us a version
685
686* Mon Apr  8 2002 Bennhard Rosenkraenzer <bero@redhat.com> 0.99.4-2
687- 1st try at fixing up CJK (#61590)
688- #if 0'ify font warning dialog (#62909, #64556)
689
690* Tue Apr  2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.4-1
691- Update to 0.99.4, fixes #61153
692- Fix #61344
693- Nuke the warning about being unable to add anything to font path,
694  that's not how xfs works.
695
696* Thu Feb 28 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.2-1
697- 0.99.2
698- remove blank lines in fonts.dir
699
700* Thu Jan 31 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.1-1
701- 0.99.1
702
703* Wed Jan 30 2002 Alex Larsson <alexl@redhat.com> 0.9.5-3
704- Added patch to use libpng10
705- Added patch to fix perl build problems.
706
707* Fri Nov 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.9.5-1
708- 0.9.5
709
710* Tue Oct 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.9.4.1-1
711- Update to 0.9.4.1 (RFE #54806)
712- Add URL (RFE #54590)
713
714* Thu Jul 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-7
715- Fix uninstall (#49350)
716
717* Sat Jul  7 2001 Tim Powers <timp@redhat.com>
718- rebuilt so that dirs aren't sgid root
719
720* Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-5
721- Add build requirements (#45157)
722
723* Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-4
724- Remove CVS admin files from documentation (#44916)
725
726* Mon Jun 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
727- add s390x patch from <oliver.paukstadt@millenux.com>
728
729* Sat Jun 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
730- add s390 patch from Helge Deller
731
732* Tue May 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-1
733- Update to 0.7.14
734
735* Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
736- Handle MIME type stuff (Bug #27530)
737- Add BuildPrereqs for some of the less common stuff AbiWord uses
738  (gal-devel, gnome-print-devel, libunicode-devel)
739
740* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
741- 0.7.13
742
743* Mon Jan 15 2001 Than Ngo <than@redhat.com>
744- fixed broken code for building
745
746* Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
747- 0.7.12
748- copy fonts.dir to fonts.scale so mkfontdir doesn't blow it away
749
750* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
751- Rebuild to get rid of 0777 dirs
752
753* Fri Nov 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
754- 0.7.11
755
756* Sun Aug 20 2000 Preston Brown <pbrown@redhat.com>
757- fix path to chkfontpath, it was wrong.
758
759* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
760- Up Epoch and release
761
762* Mon Aug  7 2000 Jakub Jelinek <jakub@redhat.com>
763- Don't ship AbiWord_s if we have AbiWord_d
764- Register AbiWord's fontpath with xfs
765
766* Wed Aug  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
767- Rebuild with new libpng. This fixes Bug #13707 - gotta love it when they
768  change the ABI without increasing the soname!
769- fix tooltip (Bug #14711)
770- move binaries from /usr/share to /usr/lib
771
772* Wed Jul 12 2000 Jakub Jelinek <jakub@redhat.com>
773- Fix build on ia64.
774
775* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
776- automatic rebuild
777
778* Tue Jul  4 2000 Jakub Jelinek <jakub@redhat.com>
779- Rebuild with new gcc.
780
781* Sat Jun 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
782- Fix build on ia64
783
784* Fri Jun 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
785- 0.7.10
786- update download location
787
788* Fri Jun  9 2000 Bernhard Rosenkraenzer <bero@redhat.com>
789- initial build for main CD
790- clean up specfile
791- fix build with gcc 2.96 and glibc 2.2
792- exclude ia64 for now
793
794* Wed May  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
795- 0.7.9
796
797* Wed Feb  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
798- 0.7.8
799- move the desktop file to /etc/X11/applnk so it can be used in both
800  GNOME and KDE
801- fix up handling of RPM_OPT_FLAGS
802
803* Thu Jan 20 2000 Tim Powers <timp@redhat.com>
804- bzipped source to conserve space.
805
806* Sun Jan  9 2000 Matt Wilson <msw@redhat.com>
807- enable GNOME, remove perl hack to do RPM_OPT_FLAGS
808- added libpng requirement.  0.7.7 requires 1.0.5 libpng ABI
809
810* Tue Jan  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
811- 0.7.7
812- handle RPM_OPT_FLAGS
813
814* Mon Nov 15 1999 Tim Powers <timp@redhat.com>
815- first build for inclusion into Powertools.
816- some things in this spec file are from the abisuite-0.7.5-1mdk package
Note: See TracBrowser for help on using the repository browser.