source: projects/specs/branches/6/W/WebKit/WebKit-vl.spec @ 3357

Revision 3357, 10.5 KB checked in by Takemikaduchi, 13 years ago (diff)

WebKit?: new upstream release, yelp: bug fix

Line 
1%define         add_to_doc_files()      \
2        mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
3        cp -p %1  %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
4        echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
5
6#define         svn_revision    43436
7
8# --with coverage: Enables compile-time checking of code coverage. (default: no)
9%bcond_with     coverage
10# --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
11#%bcond_with    jit
12# --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
13%bcond_with     pango
14# --with wml: Build support for WML
15%bcond_with     wml
16
17Name:           WebKit
18Version:        1.2.7
19Release:        1%{?_dist_release}
20Summary:        Web content engine library
21Summary(ja):    ウェブコンテンツエンジンライブラリ
22
23Group:          Development/Libraries
24License:        LGPLv2+ and BSD
25URL:            http://webkitgtk.org/
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: yasumichi
30
31Source0:        http://www.webkitgtk.org/webkit-%{version}.tar.gz
32
33Patch0:         WebKit-1.2.5-gir.patch
34
35# upstream patch
36Patch100:       WebKit-icu44-36381.patch
37
38BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
39
40BuildRequires:  bison
41BuildRequires:  flex
42BuildRequires:  gperf
43BuildRequires:  gtk2-devel
44BuildRequires:  libicu-devel
45BuildRequires:  libjpeg-turbo-devel
46BuildRequires:  libtool
47BuildRequires:  libxslt-devel
48BuildRequires:  libXt-devel
49BuildRequires:  pcre-devel
50BuildRequires:  sqlite3-devel
51BuildRequires:  geoclue-devel
52BuildRequires:  gnome-keyring-devel
53BuildRequires:  gstreamer-devel
54BuildRequires:  gstreamer-plugins-base-devel
55BuildRequires:  enchant-devel
56BuildRequires:  gobject-introspection-devel
57
58%if %{with pango}
59BuildRequires:  pango-devel
60%else
61BuildRequires:  cairo-devel
62BuildRequires:  fontconfig-devel
63BuildRequires:  freetype2-devel
64%endif
65
66BuildRequires:  libsoup-devel >= 2.28.2
67
68
69%description
70WebKit is an open source web browser engine.
71
72%package        gtk
73Summary:        GTK+ port of WebKit
74Summary(ja):    WebKit の GTK+ ポート
75Group:          Development/Libraries
76
77%description    gtk
78%{name} is an open-source Web content engine library. This package contains
79the shared libraries for the WebKit GTK+ port as well as the sample
80GtkLauncher tool.
81
82
83%package        gtk-devel
84Summary:        Development package for %{name}
85Summary(ja):    %{name} の開発パッケージ
86Group:          Development/Libraries
87Requires:       %{name}-gtk = %{version}-%{release}
88Requires:       pkgconfig
89Requires:       gtk2-devel
90Requires:       libsoup-devel >= 2.28.2
91
92%description    gtk-devel
93The %{name}-gtk-devel package contains libraries, build data, and header
94files for developing applications that use %{name}-gtk.
95Please note that the WebKit/GTK+ API is not yet stable. This should
96only be used as a "preview" rather than a stable platform library.
97
98
99%package        doc
100Summary:        Documentation for %{name}
101Summary(ja):    %{name} のドキュメント
102Group:          Documentation
103
104%description    doc
105%{name} is an open-source Web content engine library. This package contains
106the documentation for %{name}, including various LICENSE, README, and
107AUTHORS files.
108
109
110%prep
111%setup -q -n webkit-%{version}
112%patch0 -p1 -b .gir_vine
113
114# upstream
115## %patch100 -p0
116
117%build
118%configure \
119--enable-icon-database \
120--enable-geolocation \
121--enable-introspection=yes \
122%{?with_coverage:       --enable-coverage               }       \
123%{?with_pango:          --with-font-backend=pango       }       \
124%{?with_wml:            --enable-wml                    }
125make %{?_smp_mflags}
126
127# workaround for bug 488112
128# Compile libJavaScriptCore.a with -fno-strict-aliasing
129touch JavaScriptCore/AllInOneFile.cpp
130make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
131
132
133%install
134rm -rf %{buildroot}
135
136make install DESTDIR=%{buildroot}
137install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
138install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
139
140## Finally, copy over and rename the various files for %%doc inclusion.
141rm -f docfiles.list
142%add_to_doc_files JavaScriptCore/COPYING.LIB
143%add_to_doc_files JavaScriptCore/icu/LICENSE
144%add_to_doc_files WebKit/LICENSE
145%add_to_doc_files WebCore/LICENSE-APPLE
146%add_to_doc_files WebCore/LICENSE-LGPL-2
147%add_to_doc_files WebCore/LICENSE-LGPL-2.1
148%add_to_doc_files WebCore/icu/LICENSE
149
150%add_to_doc_files JavaScriptCore/AUTHORS
151%add_to_doc_files JavaScriptCore/pcre/AUTHORS
152
153%add_to_doc_files JavaScriptCore/THANKS
154
155%find_lang webkit
156
157
158%clean
159rm -rf %{buildroot}
160
161
162%post   gtk -p /sbin/ldconfig
163
164%postun gtk -p /sbin/ldconfig
165
166
167%files -f webkit.lang gtk
168%defattr(-,root,root,-)
169%doc
170%{_libdir}/libwebkit-1.0.so.*
171%{_libexecdir}/WebKit/
172%{_bindir}/jsc
173%{_libdir}/girepository-1.0/*.typelib
174
175%files  gtk-devel
176%defattr(-,root,root,-)
177%exclude %{_libdir}/*.la
178%{_includedir}/webkit-1.0
179%{_datadir}/webkit-1.0
180%{_libdir}/libwebkit-1.0.so
181%{_libdir}/pkgconfig/webkit-1.0.pc
182%{_datadir}/gir-1.0/*.gir
183
184%files  doc -f docfiles.list
185%defattr(-,root,root,-)
186
187
188%changelog
189* Sat Apr 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.7-1
190- new upstream release
191
192* Sat Jan 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.6-1
193- new upstream release
194
195* Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.5-1
196- new upstream release
197- add BuildRequires: gobject-introspection-devel
198- add configure option (--enable-introspection=yes)
199- add Patch0 (WebKit-1.2.5-gir.patch)
200
201* Thu Sep 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.4-1
202- new upstream release (built with rpm-4.8.1-1 for pkg-config file)
203- changed BuildRequires: libjpeg-devel to libjpeg-turbo-devel
204
205* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.3-1
206- new upstream release
207- add Requires: libsoup-devel (devel package)
208- fix configure (remove unrecognized option)
209- drop Patch100
210
211* Wed Apr 14 2010 MATSUBAYASHI Kohji <shaoliN@vinelinux.org> - 1.2.0-2
212- rebuilt again on ppc
213
214* Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-1
215- new upstream release
216- rebuilt with libicu-4.4
217- added Patch100 for compiling with libicu-4.4
218- s/sqlite-devel/sqlite3-devel/
219- s/freetype-devel/freetype2-devel/
220
221* Mon Jan 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.18-1
222- updated to 1.1.18
223
224* Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-2
225- change BR from libsoup to libsoup-devel
226
227* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-1
228- new upstream release.
229- add Vendor, Distribution and Packager.
230
231* Mon Jul 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.10-1
232- update to webkit-1.1.10 release version
233- added BuildRequires:  enchant-devel
234
235* Sun May 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
236- update to webkit-1.1.6 release version
237
238* Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-8.svn41944
239- update to new upstream snapshot (svn r41944)
240
241* Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-7.svn40471
242- update to new upstream snapshot (svn r40471)
243
244* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-6.svn37056
245- update to new upstream snapshot (svn r37056)
246- disable html5video by default
247
248* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-5.svn36882
249- update to new upstream snapshot (svn r36882)
250- build with gnome-2.24
251
252* Thu Sep 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-4.svn36053
253- build without pango by default.
254
255* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-3.svn36053
256- update to new upstream snapshot (svn r36053)
257
258* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2.svn34655
259- update to new upstream snapshot (svn r34655)
260
261* Mon Jun 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.0.0-1.svn34279
262- initial build for Vine Linux
263
264* Tue Jun  3 2008 Caol叩n McNamara <caolanm@redhat.com> - 1.0.0-0.12.svn34279
265- rebuild for new icu
266
267* Tue Jun  3 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.11.svn34279
268- Update to new upstream snapshot (SVN 34279) anyway
269- Add BR: libXt-devel
270
271* Tue Apr 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.10.svn32531
272- Remove the -Qt subpackage stuff. QtWebKit is now included in Qt proper, as
273  of qt-4.4.0-0.6.rc1. (We no longer need separate build-qt and build-gtk
274  subdirectories either.)
275- Reference: bug 442200 (RFE: WebKit Migration)
276- Add libjpeg dependency (was previously pulled in by the qt4-devel dependency
277  tree).
278
279* Mon Apr 28 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.9.svn32531
280- Update to new upstream snapshot (SVN 32531).
281- Fix bug 443048 and hopefully fix bug 444445
282- Modify the process of building GTK+ port a bit
283- on qt port WebKit/qt/Plugins is not built for qt >= 4.4.0
284
285* Sat Apr 12 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.8.svn31787
286- Update to new upstream snapshot (SVN 31787).
287- Resolves: CVE-2008-1010 (bug 438532: Arbitrary code execution) and
288  CVE-2008-1011 (bug 438531: Cross-Site Scripting).
289- Switch to using autotools for building the GTK+ port.
290
291* Wed Mar 05 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.7.svn30667
292- Fix the WebKitGtk pkgconfig data (should depend on gtk+-2.0). Resolves
293  bug 436073 (Requires: gtk+-2.0 missing from WebKitGtk.pc).
294- Thanks to Mamoru Tasaka for helping find and squash these many bugs.
295 
296* Sat Mar 01 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.6.svn30667
297- Fix include directory naming. Resolves: bug 435561 (Header file <> header
298  file location mismatch)
299- Remove qt4-devel runtime dependency and .prl file from WebKit-gtk-devel.
300  Resolves: bug 433138 (WebKit-gtk-devel has a requirement on qt4-devel)
301
302* Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.5.svn30667
303- Update to new upstream snapshot (SVN 30667)
304- Add some build fixes for GCC 4.3:
305  + gcc43.patch
306
307* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-0.5.svn29336
308- Autorebuild for GCC 4.3
309
310* Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.4.svn29336
311- Update to new upstream snapshot (SVN 29336).
312- Drop TCSpinLock pthread workaround (fixed upstream):
313  - TCSpinLock-use-pthread-stubs.patch
314
315* Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.3.svn28482
316- Add proper %%defattr line to qt, qt-devel, and doc subpackages.
317- Add patch to forcibly build the TCSpinLock code using the pthread
318  implementation:
319  + TCSpinLock-use-pthread-stubs.patch
320
321* Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.2.svn28482
322- Package renamed from WebKitGtk.
323- Update to SVN 28482.
324- Build both the GTK and Qt ports, putting each into their own respective
325  subpackages.
326- Invoke qmake-qt4 and make directly (with SMP build flags) instead of using
327  the build-webkit script from upstream.
328- Add various AUTHORS, README, and LICENSE files (via the doc subpackage).
329
330* Tue Dec 04 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.1.svn28383
331- Initial packaging for Fedora.
Note: See TracBrowser for help on using the repository browser.