source: projects/specs/branches/6/T/TrueType-liberation/TrueType-liberation-vl.spec @ 6441

Revision 6441, 8.0 KB checked in by kudoh, 12 years ago (diff)
Line 
1%define fontname liberation
2%define archivename %{name}-%{version}
3%define common_desc \
4The Liberation Fonts are intended to be replacements for the three most \
5commonly used fonts on Microsoft systems: Times New Roman, Arial, and Courier \
6New.
7
8%define _fontdir %{_datadir}/fonts/TrueType-%{fontname}
9
10Name:             TrueType-%{fontname}
11Summary:          Fonts to replace commonly used Microsoft Windows fonts
12Summary(ja):      一般に使用されている Microsoft Windows のフォントを置換するためのフォント
13Version:          1.07.2
14Release:          1%{?_dist_release}
15# The license of the Liberation Fonts is a EULA that contains GPLv2 and two
16# exceptions:
17# The first exception is the standard FSF font exception.
18# The second exception is an anti-lockdown clause somewhat like the one in
19# GPLv3. This license is Free, but GPLv2 and GPLv3 incompatible.
20License:          Liberation
21Group:            User Interface/X
22URL:              https://www.redhat.com/promo/fonts/
23Source0:          %{fontname}-fonts-ttf-%{version}.tar.gz
24
25Requires:         TrueType-%{fontname}-sans >= %{version}
26Requires:         TrueType-%{fontname}-serif >= %{version}
27Requires:         TrueType-%{fontname}-mono >= %{version}
28Requires:         TrueType-%{fontname}-doc = %{version}
29BuildRoot:        %{_tmppath}/%{name}-%{version}-root
30BuildArch:        noarch
31
32%description
33%common_desc
34
35Meta-package of Liberation fonts which installs Sans, Serif, and Monospace
36families.
37
38%description -l ja
39liberation fonts はマイクロソフトのシステムでよく使用される3つのフォント、
40Times New Roman・Arial・Courier New を置換することが意図されている
41フォントです。
42
43このパッケージは Liberation フォントのメタパッケージです。
44Sans・Serif・Monospace の3書体をインストールします。
45
46%package sans
47Summary: liberation sans TrueType Fonts
48Summary(ja): liberation sans True Type フォント
49Group: User Interface/X
50Requires: TrueType-liberation-doc
51
52%description sans
53This package includes liberation sans TrueType fonts.
54
55%description -l ja sans
56このパッケージには liberation sans フォントが含まれています。
57
58
59%package serif
60Summary: liberation serif TrueType Fonts
61Summary(ja): liberation serif True Type フォント
62Group: User Interface/X
63Requires: TrueType-liberation-doc
64
65%description serif
66This package includes liberation serif TrueType fonts.
67
68%description -l ja serif
69このパッケージには liberation serif フォントが含まれています。
70
71
72%package mono
73Summary: liberation mono TrueType Fonts
74Summary(ja): liberation mono True Type フォント
75Group: User Interface/X
76Requires: TrueType-liberation-doc
77
78%description mono
79This package includes liberation mono TrueType fonts.
80
81%description -l ja mono
82このパッケージには liberation mono フォントが含まれています。
83
84
85%package doc
86Summary: liberation Font Documents
87Summary(ja): liberation フォントドキュメント
88Group: User Interface/X
89
90%description doc
91This package includes important documents for liberation fonts includes enduser
92license.
93
94%description -l ja doc
95このパッケージには liberation フォントのライセンスを含むドキュメント類が含まれています。
96
97
98%prep
99%setup -q -n %{fontname}-fonts-ttf-%{version}
100
101%clean
102if test -n "${RPM_BUILD_ROOT}" && test "/" != "${RPM_BUILD_ROOT}"; then
103    rm -rf ${RPM_BUILD_ROOT}
104fi
105
106%build
107
108%install
109rm -rf %{buildroot}
110
111mkdir -p $RPM_BUILD_ROOT%{_fontdir}
112cp -a *.ttf $RPM_BUILD_ROOT%{_fontdir}
113
114%post sans
115%__font_install_post %{_fontdir}
116
117%post serif
118%__font_install_post %{_fontdir}
119
120%post mono
121%__font_install_post %{_fontdir}
122
123
124%postun sans
125%__font_install_postun %{_fontdir}
126
127%postun serif
128%__font_install_postun %{_fontdir}
129
130%postun mono
131%__font_install_postun %{_fontdir}
132
133%files
134
135%files sans
136%{_fontdir}/LiberationSans*.ttf
137
138%files serif
139%{_fontdir}/LiberationSerif-*.ttf
140
141%files mono
142%{_fontdir}/LiberationMono-*.ttf
143
144%files doc
145%doc AUTHORS COPYING ChangeLog License.txt README TODO
146
147%changelog
148* Wed Mar 07 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.07.2-1
149- new upstream release
150
151* Wed Sep 21 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.07.1-1
152- new upstream release
153
154* Wed Jun 01 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.07.0-1
155- new upstream release
156
157* Thu Jul 29 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.06.0.20100721-1
158- new upstream release
159- added TODO in %%doc
160
161* Wed Jun 30 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.05.3.20100621-1
162- new upstream release
163
164* Mon May 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.05.3.20100510-1
165- new upstream release
166- added Requires:  TrueType-%{fontname}-doc = %{version}
167
168* Sun Dec 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.05.2.20091227-1
169- new upstream release
170
171* Wed Jul 22 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.05.1.20090721-1
172- new upstream release
173
174* Fri Jul 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.05.1.20090706-1
175- new upstream release
176
177* Tue Apr 28 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.04.93-1
178- initial build for VineSeed
179
180* Fri Jan 09 2009 Caius Chance <cchance@redhat.com> - 1.04.93-3.fc11
181- Resolves: rhbz#477410 (Convert to new font packaging guidelines.)
182
183* Tue Dec 09 2008 Caius Chance <cchance@redhat.com> - 1.04.93-2.fc11
184- Resolves: rhbz#474522 (Cent sign is not coressed in Sans & Mono.)
185
186* Wed Dec 03 2008 Caius Chance <cchance@redhat.com> - 1.04.93-1.fc11
187- Resolves: rhbz#473481
188  (Blurriness of Greek letter m (U+03BC) in Liberation Sans Regular.)
189
190* Thu Jul 17 2008 Caius Chance <cchance@redhat.com> - 1.04.90-1.fc10
191- Resolves: rhbz#258592
192  (Incorrect glyph points and missing hinting instructions for U+0079, U+03BC,
193   U+0431, U+2010..2012.)
194
195* Thu Jul 17 2008 Caius Chance <cchance@redhat.com> - 1.04-1.fc10
196- Resolves: rhbz#455717 (Update sources to version 1.04.)
197- Improved .spec file.
198
199* Thu Jun 12 2008 Caius Chance <cchance@redhat.com> - 1.04-0.1.beta2.fc10
200- Updated source version to 1.04.beta2.
201- Removed License.txt and COPYING as already included in sources.
202
203* Thu Apr 10 2008 Caius Chance <cchance@redhat.com> - 1.03-1.fc9
204- Resolves: rhbz#251890 (Exchanged and incomplete glyphs.)
205- Repack source tarball and re-align source version number.
206
207* Mon Mar 31 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.02-2
208- correct license tag, license explanation added
209
210* Tue Mar 25 2008 Caius Chance <cchance@redhat.com> - 1.02-1.fc9
211- Resolves: rhbz#240525 (Alignment mismatch of dot accents.)
212
213* Wed Jan 16 2008 Caius Chance <cchance@redhat.com> - 1.01-1.fc9
214- Moved source tarball from cvs to separated storage.
215
216* Mon Jan 14 2008 Caius Chance <cchance@redhat.com> - 1.0-1.fc9
217- Resolves: rhbz#428596 (Liberation fonts need to be updated to latest font.)
218
219* Wed Nov 28 2007 Caius Chance <cchance@redhat.com> - 0.2-4.fc9
220- Resolves: rhbz#367791 (remove 59-liberation-fonts.conf)
221
222* Wed Sep 12 2007 Jens Petersen <petersen@redhat.com> - 0.2-3.fc8
223- add fontdir macro
224- create fonts.dir and fonts.scale (reported by Mark Alford, #245961)
225- add catalogue symlink
226
227* Wed Sep 12 2007 Jens Petersen <petersen@redhat.com> - 0.2-2.fc8
228- update license field to GPLv2
229
230* Thu Jun 14 2007 Caius Chance <cchance@redhat.com> 0.2-1.fc8
231- Updated new source tarball from upstream: '-3' (version 0.2).
232
233* Tue May 15 2007 Matthias Clasen <mclasen@redhat.com> 0.1-9
234- Bump revision
235
236* Tue May 15 2007 Matthias Clasen <mclasen@redhat.com> 0.1-8
237- Change the license tag to "GPL + font exception"
238
239* Mon May 14 2007 Matthias Clasen <mclasen@redhat.com> 0.1-7
240- Correct the source url
241
242* Mon May 14 2007 Matthias Clasen <mclasen@redhat.com> 0.1-6
243- Incorporate package review feedback
244
245* Fri May 11 2007 Matthias Clasen <mclasen@redhat.com> 0.1-5
246- Bring the package in sync with Fedora packaging standards
247
248* Wed Apr 25 2007 Meethune Bhowmick <bhowmick@redhat.com> 0.1-4
249- Require fontconfig package for post and postun
250
251* Tue Apr 24 2007 Meethune Bhowmick <bhowmick@redhat.com> 0.1-3
252- Bump version to fix issue in RHEL4 RHN
253
254* Thu Mar 29 2007 Richard Monk <rmonk@redhat.com> 0.1-2rhis
255- New license file
256
257* Thu Mar 29 2007 Richard Monk <rmonk@redhat.com> 0.1-1rhis
258- Inital packaging
Note: See TracBrowser for help on using the repository browser.