source: projects/specs/branches/6/S/SDL_gfx/SDL_gfx-vl.spec @ 5569

Revision 5569, 5.0 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild packages

Line 
1Summary:        SDL graphics drawing primitives and other support functions
2Summary(ja):    SDLの基本的な描画機能とその他の機能を提供するライブラリ
3Name:           SDL_gfx
4Version:        2.0.22
5Release:        2%{?_dist_release}
6Source0:        %{name}-%{version}.tar.gz
7License:        LGPL
8Group:          System Environment/Libraries
9URL:            http://www.ferzkopp.net/joomla/
10
11BuildRequires:  SDL-devel >= 1.2.0
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14%define all_x86 i386 i586 i686 athlon
15
16
17%description
18The SDL_gfx library evolved out of the SDL_gfxPrimitives code which
19provided basic drawing routines such as lines, circles or polygons and
20SDL_rotozoom which implemented a interpolating rotozoomer for SDL
21surfaces.
22
23The current components of the SDL_gfx library are:
24
25   * Graphic Primitives (SDL_gfxPrimitves.h)
26   * Rotozoomer (SDL_rotozoom.h)
27   * Framerate control (SDL_framerate.h)
28%ifarch %{all_x86}
29   * MMX image filters (SDL_imageFilter.h)
30%endif
31
32The library is backwards compatible to the above mentioned code. Its
33is written in plain C and can be used in C++ code.
34
35
36%description -l ja
37SDL_gfx は SDL_gfxPrimitives コードから発展したライブラリであり、線や
38円、ポリゴンの描画を行う基本的な機能と、SDL サーフェースの回転・拡大
39・縮小を行う SDL_rotozoom を提供します。
40
41現在の SDL_gfx ライブラリに含まれているのは:
42
43   * 基本的な画像の描画 (SDL_gfxPrimitves.h)
44   * SDL サーフェースの回転、拡大、縮小 (SDL_rotozoom.h)
45   * フレームレート制御 (SDL_framerate.h)
46%ifarch %{all_x86}
47   * MMX イメージフィルタ (SDL_imageFilter.h)
48%endif
49
50このライブラリは先に述べたコードとの後方互換性を持っています。この
51ライブラリは C 言語で記述されており、C++ からでも使用できます。
52
53#-----------------------------------------------------------------------------
54
55%package devel
56Summary:        Libraries and includes to develop SDL_gfx programs
57Summary(ja):    SDL_gfx 用の開発ライブラリおよびヘッダファイル
58Group:          Development/Libraries
59Requires:       %{name} = %{version}
60
61%description devel
62This package includes the files needed for developing and compiling
63applications which use the SDL_gfx  library.
64
65You should install the SDL_gfx-devel package if you would like to
66develop applications based on SDL_gfx.
67
68%description devel -l ja
69このパッケージは SDL_gfx ライブラリを使用するアプリケーションを開発
70するのに必要なライブラリやヘッダファイルを含んでいます。
71
72SDL_gfx をベースにしたアプリケーションを開発するなら、このパッケージ
73をインストールしてください。
74
75#-----------------------------------------------------------------------------
76
77%package demos
78Summary:        SDL_gfx demo programs
79Summary(ja):    SDL_gfx デモプログラム
80Group:          Applications/Other
81Requires:       %{name} = %{version}
82AutoReqProv: no
83
84%description demos
85SDL_gfx demo applications and source code.
86It is necessary to compile to run demo applications.
87
88%description demos -l ja
89SDL_gfx のデモアプリケーションとソースコードです。
90デモアプリケーションを実行するには自分でコンパイルする必要があります。
91
92#-----------------------------------------------------------------------------
93
94%prep
95%setup -q
96
97%build
98./autogen.sh
99%ifarch %{all_x86}
100./configure
101%else
102./configure --disable-mmx
103%endif
104%__make
105
106
107%install
108%__rm -rf $RPM_BUILD_ROOT
109%makeinstall
110
111%__install -d $RPM_BUILD_ROOT/%{_datadir}/SDL_gfx-demos
112%__install -m755 %{_builddir}/%{name}-%{version}/Test/* $RPM_BUILD_ROOT/%{_datadir}/SDL_gfx-demos
113
114rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
115
116%clean
117%__rm -rf $RPM_BUILD_ROOT
118
119%post -p /sbin/ldconfig
120
121%postun -p /sbin/ldconfig
122
123%files
124%defattr(-,root,root)
125%doc AUTHORS COPYING ChangeLog INSTALL LICENSE NEWS README*
126%doc Docs/
127%{_libdir}/libSDL_gfx.so.*
128
129%files devel
130%defattr(-,root,root)
131%{_libdir}/pkgconfig/SDL_gfx.pc
132%{_libdir}/libSDL_gfx.so
133%{_includedir}/SDL/*
134
135%files demos
136%defattr(-,root,root)
137%{_datadir}/SDL_gfx-demos
138
139
140%changelog
141* Fri Feb 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.22-2
142- rebuild with Vine6 environment
143
144* Mon Sep 20 2010 IWAI, Masaharu <iwai@alib.jp> 2.0.22-1
145- new upstream release
146- add pkg-config file in devel package
147- remove *.a
148- move *.so file: main to devel
149
150* Sat Sep 20 2008 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-1
151- new upstream release
152- applied new versioning policy
153- spec in UTF-8
154
155* Mon Jan 15 2007 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 2.0.15-0vl1
156- new upstream release
157- added %post and %postun section
158
159* Mon Jun 26 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.13-1vl2
160- rebuild to correct version mismatch.(1vl1 already exist in Vine Plus/3.0)
161- change SDL_gfx-demos Group to Applications/Other.
162- add SDL_gfx-demos description.
163
164* Wed Aug 24 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.13-0vl2
165- disable MMX on non-x86 archtecture
166
167* Sat May 14 2005 kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.13-0vl1
168- initial build for VineSeed Plus.
Note: See TracBrowser for help on using the repository browser.