source: projects/specs/branches/6/P/PyYAML/PyYAML-vl.spec @ 8238

Revision 8238, 3.0 KB checked in by iwamoto, 10 years ago (diff)

PyYAML: rebuilt with libyaml 0.1.4

Line 
1# %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Name:           PyYAML
5Version:        3.09
6Release:        3%{?_dist_release}
7Summary:        YAML parser and emitter for Python
8
9Group:          Development/Libraries
10License:        MIT
11URL:            http://pyyaml.org/
12Source0:        http://pyyaml.org/download/pyyaml/%{name}-%{version}.tar.gz
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14
15BuildRequires:  python-devel, python-setuptools, libyaml-devel
16
17Vendor:         Project Vine
18Distribution:   Vine Linux
19
20%description
21YAML is a data serialization format designed for human readability and
22interaction with scripting languages.  PyYAML is a YAML parser and
23emitter for Python.
24
25PyYAML features a complete YAML 1.1 parser, Unicode support, pickle
26support, capable extension API, and sensible error messages.  PyYAML
27supports standard YAML tags and provides Python-specific tags that allow
28to represent an arbitrary Python object.
29
30PyYAML is applicable for a broad range of tasks from complex
31configuration files to object serialization and persistance.
32
33%prep
34%setup -q -n %{name}-%{version}
35
36
37%build
38%{__python} setup.py build
39chmod a-x examples/yaml-highlight/yaml_hl.py
40
41
42%install
43rm -rf $RPM_BUILD_ROOT
44mkdir -p $RPM_BUILD_ROOT/%{_bindir}
45%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
46
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51
52%files
53%defattr(-,root,root,-)
54%doc PKG-INFO README LICENSE examples
55# %{python_sitelib}/*
56%{python_sitearch}/*
57
58
59%changelog
60* Sun Feb  2 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.09-3
61- rebuilt with libyaml 0.1.4
62- add Vendor/Distri Tags
63
64* Fri Mar 02 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.09-2
65- rebuilt with Vine6 environment
66
67* Sun Feb 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.09-1
68- new upstream release
69
70* Thu Jun 11 2009 Shu KONNO <owa@bg.wakwak.com> 3.08-2
71- s/python_sitelib/python_sitearch/
72
73* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.08-1
74- initial build for Vine Linux
75
76* Tue Mar 3 2009 John Eckersberg <jeckersb@redhat.com> - 3.08-4
77- Correction, change libyaml to libyaml-devel in BuildRequires
78
79* Mon Mar 2 2009 John Eckersberg <jeckersb@redhat.com> - 3.08-3
80- Add libyaml to BuildRequires
81
82* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.08-2
83- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
84
85* Wed Feb 18 2009 John Eckersberg <jeckersb@redhat.com> - 3.08-1
86- New upstream release
87
88* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 3.06-2
89- Rebuild for Python 2.6
90
91* Fri Oct 24 2008 John Eckersberg <jeckersb@redhat.com> - 3.06-1
92- New upstream release
93
94* Wed Jan 02 2008 John Eckersberg <jeckersb@redhat.com> - 3.05-2
95- Remove explicit dependency on python >= 2.3
96- Remove executable on example script in docs
97
98* Mon Dec 17 2007 John Eckersberg <jeckersb@redhat.com> - 3.05-1
99- Initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.