source: projects/specs/branches/6/P/PyQt4/PyQt4-vl.spec @ 4450

Revision 4450, 9.6 KB checked in by inagaki, 13 years ago (diff)

update: PyQt4, sip

Line 
1%global python_ver %(%{__python} -c "import sys ; print sys.version[:3]")
2%global python_sitelib  %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
3%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
4
5%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.7.2)
6%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
7%define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
8%define qt4qmake %{_qt4_prefix}/bin/qmake
9
10Name:    PyQt4
11Summary: Python bindings for Qt4
12Summary(ja): Qt4 の Python バインディング
13Version: 4.8.4
14Release: 1%{?_dist_release}
15
16# GPLv2 exceptions(see GPL_EXCEPTIONS*.txt)
17License: GPLv3 or GPLv2 with exceptions
18Group:   Development/Languages
19URL:     http://www.riverbankcomputing.com/software/pyqt/
20
21Source0: http://www.riverbankcomputing.com/static/Downloads/PyQt4/PyQt-x11-gpl-%{version}.tar.gz
22Patch1:  PyQt-x11-gpl-4.8.3-64bit.patch
23# HACK! FIXME: ping upstream why this isn't working right. -- Rex
24Patch2:  PyQt-x11-gpl-4.5.2-QT_SHARED.patch
25Patch4:  PyQt-x11-gpl-4.5.1-pyuic_shebang.patch
26
27# Vine Patch
28Patch100: PyQt-x11-gpl-4.7.3-phononpath_vine.patch
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31#BuildRequires: chrpath
32BuildRequires: dbus-devel dbus-python-devel
33BuildRequires: findutils
34BuildRequires: libXext-devel
35BuildRequires: phonon-devel
36BuildRequires: python-devel
37# beware of PyQt4/qscintilla bootstap issues
38#BuildRequires: qscintilla
39BuildRequires: qt4-devel >= 4.5.0
40BuildRequires: sip-devel >= 4.12.1
41Requires: sip >= 4.12.1
42Requires: dbus-python
43Requires: qt4
44
45%description
46These are Python bindings for Qt4.
47
48%package devel
49Summary: Files needed to build other bindings based on Qt4
50Group:   Development/Libraries
51Requires: %{name} = %{version}-%{release}
52Requires: sip-devel >= 4.12.1
53
54%description devel
55Files needed to build other bindings for C++ classes that inherit from any
56of the Qt4 classes (e.g. KDE or your own).
57
58
59%prep
60%setup -q -n PyQt-x11-gpl-%{version}
61%ifarch x86_64
62%patch1 -p1 -b .64bit
63%endif
64%patch2 -p1 -b .QT_SHARED
65#patch4 -p1
66
67%patch100 -p1 -b .phononpath_vine
68
69## permissions
70# mark examples non-executable
71find examples/ -name "*.py" | xargs chmod a-x
72chmod a+rx pyuic/uic/pyuic.py
73
74
75%build
76unset QTDIR || : ; . /etc/profile.d/qt4.sh
77CFLAGS="${CFLAGS:-%optflags}" \
78CXXFLAGS="${CXXFLAGS:-%optflags} -I%{_includedir}/KDE" \
79%{__python} configure.py \
80  --confirm-license \
81  --qmake=%{qt4qmake} \
82  --no-qsci-api \
83  --verbose
84
85make %{?_smp_mflags}
86
87%install
88rm -rf $RPM_BUILD_ROOT
89
90make install DESTDIR=$RPM_BUILD_ROOT INSTALL_ROOT=$RPM_BUILD_ROOT
91
92# HACK: fix multilb conflict, http://bugzilla.redhat.com/509415
93rm -fv $RPM_BUILD_ROOT%{_bindir}/pyuic4
94mv $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py \
95   $RPM_BUILD_ROOT%{_bindir}/pyuic4
96ln -s %{_bindir}/pyuic4 \
97      $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%files
103%defattr(-,root,root,-)
104%doc NEWS README
105%doc OPENSOURCE-NOTICE.TXT
106%doc LICENSE.GPL2 GPL_EXCEPTION*.TXT
107%doc LICENSE.GPL3
108%{python_sitearch}/PyQt4/
109%exclude %{python_sitearch}/PyQt4/uic/pyuic.py*
110# fixme?  -> sitearch?  -- Rex
111%{python_sitelib}/dbus/mainloop/qt.so
112%{_qt4_plugindir}/designer/*
113
114%files devel
115%defattr(-,root,root,-)
116%doc doc/*
117%doc examples/
118%{_bindir}/pylupdate4
119%{_bindir}/pyrcc4
120%{_bindir}/pyuic4
121%{python_sitearch}/PyQt4/uic/pyuic.py*
122%{_datadir}/sip/PyQt4/
123#{_qt4_prefix}/qsci/api/python/PyQt4.api
124
125%changelog
126* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.4-1
127- new upstream release
128
129* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-4
130- re-add Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch) (x86_64 only)
131- remove %%sip_ver
132
133* Thu Mar 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-3
134- rebuilt with qt4-4.7.2
135
136* Tue Feb 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-2
137- update Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch)
138
139* Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-1
140- new upstream release
141- built with sip-4.12.1 and qt4-4.7.1
142
143* Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-2
144- rebuild with qt4-4.6.3
145- fix %qtver (from 4.6.1 to 4.6.3)
146
147* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
148- new upstream release
149- rebuilt with sip-4.10.5 and qt4-4.6.3
150
151* Sun May 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.3-1
152- new upstream release
153- updated Patch100
154
155* Fri Feb 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7-2
156- updated Patch100 to build phonon module
157
158* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.7-1
159- new upstream release
160- rebuilt with python-2.6.4
161- dropt Patch100: PyQt-x11-gpl-4.5.4-vine_phonon.patch
162
163* Fri Oct 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6-2
164- now BuildRequires sip-devel >= 4.9 (was 4.8.2)
165
166* Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 4.6-1
167- new upstream release
168- added BR: libXext-devel
169
170* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-3
171- added Patch100 for building phonon modules
172
173* Tue Aug 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-2
174- Initial build for Vine
175
176* Tue Jul 28 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.4-1
177- PyQt4-4.5.4
178
179* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.2-2
180- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
181
182* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-1
183- PyQt4-4.5.2
184
185* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-2
186- fix build with qt-4.5.2
187- PyQt4-devel multilib conflict (#509415)
188
189* Tue Jun 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-1
190- PyQt-4.5.1
191
192* Fri Jun 05 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-1
193- PyQt-4.5
194
195* Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.2.20090520
196- fix generation of sip_ver
197
198* Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.1.20090520
199- PyQt-4.5-snapshot-20090520
200
201* Sun Apr 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.4.4-6
202- rebuild for phonon bindings (#497680)
203
204* Wed Mar 05 2009 Rex Dieter <rdieter@fedorproject.org> - 4.4.4-5
205- move designer plugins to main/runtime (#487622)
206
207* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.4-4
208- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
209
210* Fri Feb 13 2009 Than Ngo <than@redhat.com> - 4.4.4-3
211- rebuild against qt-4.5rc1
212
213* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 4.4.4-2
214- Rebuild for Python 2.6
215
216* Mon Nov 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.4-1
217- PyQt-4.4.4
218
219* Tue Aug 26 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.3-1
220- PyQt-4.4.3
221
222* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-2
223- PyQt4 is built without QtWebKit support (#451490)
224
225* Wed May 21 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-1
226- PyQt-4.4.2
227
228* Wed May 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4-1
229- PyQt-4.4
230- License: GPLv3 or GPLv2 with exceptions
231
232* Mon Feb 11 2008 Rex Dieter <rdieter@fedoraproject.org> 4.3.3-2
233- respin (gcc43)
234
235* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.3-1
236- PyQt-4.3.3
237
238* Thu Nov 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-3
239- dbus support (#395741)
240
241* Mon Nov 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-1
242- PyQt-4.3.1
243
244* Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-8
245- drop ExcludeArch: ppc64 , qt4 bug is (hopefully) fixed.
246
247* Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-7
248- fix QtDesigner plugin install
249
250* Wed Oct 03 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-6
251- 64bit QtDesigner patch
252
253* Mon Aug 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-5
254- -devel: Requires: qt4-devel
255
256* Sun Aug 26 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-4
257- use %%python_sitearch
258- License: GPLv2
259
260* Thu Aug 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-3
261- fix python_sitelib typo (wrt chrpath call)
262- move %%_bindir stuff to -devel
263- mark %%doc examples non-executable
264- add shebang to %%_bindir/pyuic4
265
266* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-2
267- remove rpath from QtDesigner.so
268- BR: qt4-devel > 4.3.0-8
269
270* Wed Apr 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-1
271- PyQt4-4.2
272
273* Wed Feb 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.1.1-2
274- fix build against multilib'd qt4
275
276* Mon Dec 11 2006 Rex Dieter <rexdieter[AT]usres.sf.net> 4.1.1-1
277- PyQt4-4.1.1
278- BR: sip-devel >= 4.5.1
279
280* Mon Nov 06 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.1-1
281- PyQt4-4.1
282
283* Wed Oct 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-4
284- don't own %%_datadir/sip (bug #206633)
285
286* Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-3
287- BR: qt4-devel < 4.2
288
289* Sat Jul 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-2
290- fix reference(s) to qmake(4)
291
292* Sun Jul 16 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-1
293- PyQt-4.0.1
294
295* Mon Jun 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-1
296- PyQt-4.0(final)
297- BR: sip-devel >= 4.4.4 (see bug #199430)
298
299* Fri May 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.6.beta1
300- drop BR: qt4-MySQL qt4-ODBC qt4-PostgreSQL
301- drop usage of (undefined) %%sip_min
302
303* Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.5.beta1
304- cleanup for Extras
305
306* Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.4.beta1
307- 4.0beta1
308
309* Thu Apr 27 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.3.20060421
310- respin for sip-4.4.3
311- use sip-abi, sip-abi-min
312
313* Mon Apr 24 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.2.20060421
314- 20060421 snapshot
315
316* Wed Apr 19 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.0-0.1.20060417
317- first try, using 20060417 snapshot
318
Note: See TracBrowser for help on using the repository browser.