source: projects/specs/branches/6/P/PyQt/PyQt-vl.spec @ 6309

Revision 6309, 2.5 KB checked in by inagaki, 12 years ago (diff)

update: PyQt?, cppunit, commoncpp2

Line 
1%define pyexeclib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)')
2%define name    PyQt
3%define version 3.18.1
4%define release 3%{?_dist_release}
5
6Summary:        Python bindings for Qt.
7Name:           %{name}
8Version:        %{version}
9Release:        %{release}
10License:        GPL
11Group:          Development/Languages
12Source:         http://www.riverbankcomputing.com/Downloads/PyQt3/GPL/%{name}-x11-gpl-%{version}.tar.gz
13URL:            http://www.riverbankcomputing.co.uk/pyqt
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildRequires:  python-devel sip-devel qt-devel
16Requires:       python
17
18%description
19Python bindings for the Qt C++ class library.
20
21%package devel
22Summary:        Files needed to build other bindings based on Qt
23Group:          Development/Libraries
24Requires:       %{name} = %{version}
25Requires:       sip-devel qt-devel
26
27%description devel
28Files needed to build other bindings for C++ classes that inherit from any
29of the Qt classes (e.g. KDE or your own).
30
31%prep
32%setup -q -n %{name}-x11-gpl-%{version}
33
34%build
35mkdir -p $RPM_BUILD_ROOT%{pyexeclib}
36python configure.py -d %{pyexeclib} -q %{_libdir}/qt-3.3.8 <<EOF
37    yes
38EOF
39# note that -j2 does not work
40make
41
42%install
43rm -rf $RPM_BUILD_ROOT
44make DESTDIR=$RPM_BUILD_ROOT install
45mkdir -p $RPM_BUILD_ROOT%{_datadir}/sip/qt
46cp -r sip/* $RPM_BUILD_ROOT%{_datadir}/sip/qt/
47
48%clean
49rm -rf %{buildroot}
50
51%files
52%defattr(-, root, root, 755)
53%doc NEWS README ChangeLog THANKS
54%doc doc/PyQt.html
55%{_bindir}/*
56%{pyexeclib}/*
57
58%files devel
59%defattr(-,root,root)
60%doc examples*
61%{_datadir}/sip/*
62
63%changelog
64* Sun Jun 10 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.18.1-3vl6
65- rebuilt with rpm-4.8.1-3
66- fixed %%build script
67
68* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 3.18.1-2
69- rebuilt with python-2.6.4
70
71* Thu Nov 12 2009 Ryoichi INAGAKI <owa@bg.wakwak.com> 3.18.1-1
72- new upstream release
73- removed qscintilla dependency
74
75* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 3.17.3-1vl5
76- rebuilt with python-2.5.2
77- added pyexeclib macro
78- applied new versioning policy
79
80* Fri Nov 30 2007 Shu KONNO <owa@bg.wakwak.com> 3.17.3-0vl2
81- changed source url
82- fixed python site-packages path (for lib64)
83
84* Thu Sep 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.17.3-0vl1
85- updated to 3.16
86- rebuilt with new toolchain
87
88* Sun Jun 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.16-0vl1
89- updated to 3.16
90- changed Group to Development/Languages
91- rebuild with python-2.4.3, sip-4.4.5, qscinteilla-1.6
92
93* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 3.13-0vl2
94- rebuild with python-2.4.1
95
96* Sat Jan 15 2005 Satoshi MACHINO <machino@vinelinux.org> 3.13-0vl1
97- initial release for VineLinux
98
Note: See TracBrowser for help on using the repository browser.