source: projects/specs/branches/6/P/PyOpenGL/PyOpenGL-vl.spec @ 3509

Revision 3509, 3.5 KB checked in by owa, 13 years ago (diff)

rebuilt

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%define pyver %(python -c 'import sys;print(sys.version[0:3])')
3
4Name:           PyOpenGL
5Version:        3.0.0
6Release:        3%{_dist_release}
7Summary:        Python bindings for OpenGL
8License:        BSD
9Group:          System Environment/Libraries
10URL:            http://pyopengl.sourceforge.net/
11Source0:        http://downloads.sourceforge.net/pyopengl/%{name}-%{version}.tar.gz
12Patch0:         PyOpenGL-3.0.0a6-shebang.patch
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildRequires:  python-devel python-setuptools
15BuildArch:      noarch
16Requires:       python-numeric python-setuptools
17Requires:       freeglut
18
19# in some other repositories this is named python-opengl
20Provides:       python-opengl = %{version}-%{release}
21Obsoletes:      python-opengl < %{version}-%{release}
22Vendor: Project Vine
23Distribution: Vine Linux
24
25
26%description
27PyOpenGL is the cross platform Python binding to OpenGL and related APIs. It
28includes support for OpenGL v1.1, GLU, GLUT v3.7, GLE 3 and WGL 4. It also
29includes support for dozens of extensions (where supported in the underlying
30implementation).
31
32PyOpenGL is interoperable with a large number of external GUI libraries
33for Python including (Tkinter, wxPython, FxPy, PyGame, and Qt).
34
35
36%package Tk
37Summary:        %{name} OpenGL Tk widget
38Group:          System Environment/Libraries
39Requires:       %{name} = %{version}-%{release}, tkinter
40
41%description Tk
42%{name} Togl (Tk OpenGL widget) 1.6 support.
43
44
45%package doc
46Summary:        Documentation files for %{name}
47Group:          Development/Languages
48Requires:       %{name} = %{version}-%{release}
49
50%description doc
51Documentation files for %{name}.
52
53
54%prep
55%setup -q
56%patch0 -p1 -z .shebang
57
58%build
59python setup.py build
60
61
62%install
63rm -rf $RPM_BUILD_ROOT
64python setup.py install -O1 --skip-build --root="$RPM_BUILD_ROOT" \
65  --prefix="%{_prefix}"
66chmod -x $RPM_BUILD_ROOT%{python_sitelib}/%{name}-%{version}-py%{pyver}.egg-info
67
68
69%clean
70rm -rf $RPM_BUILD_ROOT
71
72
73%files
74%defattr(-,root,root,-)
75##doc license.txt
76%{python_sitelib}/*OpenGL*
77%exclude %{python_sitelib}/OpenGL/Tk
78
79%files Tk
80%defattr(-,root,root,-)
81%{python_sitelib}/OpenGL/Tk
82
83%files doc
84%defattr(-,root,root,-)
85%doc documentation/*
86
87
88%changelog
89* Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 3.0.0-3
90- rebuilt with rpm-4.8.1-3
91
92* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 3.0.0-2
93- rebuilt with python-2.6.4
94
95* Sat Jul 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
96- new upstream release 3.0.0
97- remove Requires: XOrg-gl (libGL should be pulled by freeglut)
98
99* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.0-0.b1.2
100- rebuilt with python-2.5.2
101
102* Mon Apr 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.0.0-0.b1.1
103- Initial build for Vine Linux
104
105* Mon Dec 31 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.5.b1
106- New upstream release 3.0.0b1
107
108* Thu Aug 30 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.4.a6
109- Change BuildRequires python-setuptools to python-setuptools-devel for
110  the python-setuptools package split
111
112* Fri Apr 13 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.3.a6
113- Add missing freeglut, libGL and libGLU requires (bz 236159)
114
115* Thu Mar 29 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.2.a6
116- Remove tests from the package (bz 234121)
117- Add -Tk subpackage (bz 234121)
118- Remove shebang from files with shebang instead of chmod +x (bz 234121)
119- Better description
120
121* Sat Mar 24 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.1.a6
122- Initial Fedora Extras package
Note: See TracBrowser for help on using the repository browser.