source: projects/specs/branches/6/O/OpenIPMI/OpenIPMI-vl.spec @ 3918

Revision 3918, 13.8 KB checked in by iwaim, 13 years ago (diff)

OpenIPMI-2.0.18-3

Line 
1# TODO: uses private copy of libedit, should be modified to use system one
2
3%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
4Summary: IPMI (Intelligent Platform Management Interface) library and tools
5Summary(ja): IPMI (Intelligent Platform Management Interface) ライブラリおよびツール
6Name: OpenIPMI
7Version: 2.0.18
8Release: 3%{?_dist_release}
9License: LGPLv2+ and GPLv2+ or BSD
10Group: System Environment/Base
11URL: http://sourceforge.net/projects/openipmi/
12Source: http://downloads.sourceforge.net/openipmi/%{name}-%{version}.tar.gz
13Source1: openipmi.sysconf
14Source2: openipmi.initscript
15Source3: openipmigui.desktop
16Source4: README.initscript
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: gdbm-devel swig glib2-devel net-snmp-devel ncurses-devel
19BuildRequires: openssl-devel python-devel perl tcl tkinter
20BuildRequires: desktop-file-utils popt-devel
21Requires(post): chkconfig
22Requires(preun): chkconfig
23
24Patch1: OpenIPMI-2.0.18-pthread-pkgconfig.patch
25
26Vendor: Project Vine
27Distribution: Vine Linux
28
29%description
30The Open IPMI project aims to develop an open code base to allow access to
31platform information using Intelligent Platform Management Interface (IPMI).
32This package contains the tools of the OpenIPMI project.
33
34%package libs
35Group: Development/Libraries
36Summary: The OpenIPMI runtime libraries
37Summary(ja): OpenIPMI ランタイムライブラリ
38
39%description libs
40The OpenIPMI-libs package contains the runtime libraries for shared binaries
41and applications.
42
43%package perl
44Group: Development/Libraries
45Summary: IPMI Perl language bindings
46Summary(ja): IPMI Perl 言語バインディング
47Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
48
49%description perl
50The OpenIPMI-perl package contains the Perl language bindings for OpenIPMI.
51
52%package python
53Group: Development/Libraries
54Summary: IPMI Python language bindings
55Summary(ja): IPMI Python 言語バインディング
56
57%description python
58The OpenIPMI-python package contains the Python language bindings for OpenIPMI.
59
60%package devel
61Group: Development/Libraries
62Summary: The development environment for the OpenIPMI project
63Summary(ja): OpenIPMIの開発キット
64Requires: pkgconfig
65Requires: %{name} = %{version}-%{release}
66
67%description devel
68The OpenIPMI-devel package contains the development libraries and header files
69of the OpenIPMI project.
70
71%package gui
72Group: System Environment/Base
73Summary: IPMI graphical user interface tool
74Summary(ja): IPMI GUI ツール
75Requires: tix tkinter %{name}-python = %{version}-%{release}
76
77%description gui
78The OpenIPMI-gui package contains the graphical user interface to monitor
79and control IPMI-enabled devices.
80
81
82%prep
83%setup -q
84%patch1 -p1
85
86%build
87export CFLAGS="-fPIC $RPM_OPT_FLAGS"
88%configure \
89  --with-pythoninstall=%{python_sitearch} \
90  --disable-dependency-tracking \
91  --with-tcl=no \
92  --with-glib12=no \
93  --disable-static
94# get rid of rpath
95sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
96sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
97
98make   # not %{?_smp_mflags} safe
99
100%install
101rm -rf $RPM_BUILD_ROOT
102make install DESTDIR=$RPM_BUILD_ROOT
103rm -rf $RPM_BUILD_ROOT/%{_libdir}/*.la
104
105install -d ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig
106install -m 644 %SOURCE1 ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/ipmi
107install -d ${RPM_BUILD_ROOT}%{_initrddir}
108install -m 755 %SOURCE2 ${RPM_BUILD_ROOT}%{_initrddir}/ipmi
109
110desktop-file-install --vendor="fedora" --dir=${RPM_BUILD_ROOT}%{_datadir}/applications %{SOURCE3}
111
112install -m 644 %SOURCE4 .
113
114%post
115/sbin/chkconfig --add ipmi
116
117%preun
118if [ $1 = 0 ]; then
119   service ipmi stop >/dev/null 2>&1
120   /sbin/chkconfig --del ipmi
121fi
122
123%postun
124if [ "$1" -ge "1" ]; then
125    service ipmi condrestart >/dev/null 2>&1 || :
126fi
127
128%post libs -p /sbin/ldconfig
129
130%postun libs -p /sbin/ldconfig
131
132%clean
133rm -rf $RPM_BUILD_ROOT
134
135%files
136%defattr(-,root,root)
137%doc CONFIGURING_FOR_LAN COPYING COPYING.BSD COPYING.LIB FAQ README README.Force README.MotorolaMXP README.initscript
138%config(noreplace) %{_sysconfdir}/sysconfig/ipmi
139%{_initrddir}/ipmi
140%{_bindir}/ipmicmd
141%{_bindir}/ipmilan
142%{_bindir}/ipmish
143%{_bindir}/ipmi_ui
144%{_bindir}/openipmicmd
145%{_bindir}/openipmish
146%{_bindir}/rmcp_ping
147%{_bindir}/solterm
148%{_mandir}/man1/ipmi_ui*
149%{_mandir}/man1/openipmicmd*
150%{_mandir}/man1/openipmish*
151%{_mandir}/man1/rmcp_ping*
152%{_mandir}/man1/solterm*
153%{_mandir}/man7/ipmi_cmdlang*
154%{_mandir}/man7/openipmi_conparms*
155%{_mandir}/man8/ipmilan*
156
157%files perl
158%defattr(-,root,root)
159%attr(644,root,root) %{perl_vendorarch}/OpenIPMI.pm
160%{perl_vendorarch}/auto/OpenIPMI/
161
162%files python
163%defattr(-,root,root)
164%{python_sitearch}/*OpenIPMI*
165
166%files libs
167%defattr(-,root,root)
168%{_libdir}/*.so.*
169
170%files devel
171%defattr(-,root,root)
172%{_includedir}/OpenIPMI
173%{_libdir}/*.so
174%{_libdir}/pkgconfig/*.pc
175
176%files gui
177%defattr(-,root,root)
178%{_bindir}/openipmigui
179%{_mandir}/man1/openipmigui*
180%{python_sitearch}/openipmigui
181%{_datadir}/applications/fedora-openipmigui.desktop
182
183%changelog
184* Sat May 21 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.18-3
185- build with perl 5.12.3
186- add Vendor and Distribution tags
187
188* Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-2
189- rebuild with openssl-1.0.0d
190
191* Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.18-1
192- initial build for Vine Linux
193
194* Tue Jun 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.0.18-2
195- Mass rebuild with perl-5.12.0
196
197* Wed May  5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.18-1
198- updated to OpenIPMI-2.0.18
199- fixed OpenIPMIpthread pkgconfig file (#468067)
200
201* Mon May  3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.17-1
202- updated to OpenIPMI-2.0.17
203
204* Thu Mar 18 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-12
205- implemented mandatory 'force-reload' command in ipmi service
206
207* Thu Mar 11 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-11
208- rebuild against new gdbm
209
210* Wed Mar  3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-10
211- add README.initscript describing /etc/init.d/ipmi initscript exit codes
212  (#562151)
213
214* Mon Feb 22 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-9
215- fix package License: field, there *are* sources with BSD header
216- distribute README files and COPYING in package
217
218* Tue Jan  5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-8
219- fix package License: field, there is no source with BSD header
220
221* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 2.0.16-7
222- rebuild against perl 5.10.1
223
224* Tue Dec  1 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-6
225- fix package compilation to remove rpmlint errors
226
227* Wed Sep 30 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-5
228- rebuilt with new net-snmp
229
230* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.16-4
231- rebuilt with new openssl
232
233* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.16-3
234- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
235
236* Wed Apr 15 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-2
237- fix compilation flags, debuginfo package is correctly generated now
238
239* Thu Mar 19 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-1
240- new upstream release
241
242* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.14-11
243- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
244
245* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.14-10
246- rebuild with new openssl
247
248* Thu Dec 11 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-9
249- fix linking without rpath, prelink won't screw up the libraries
250  anymore (#475265)
251
252* Wed Dec 10 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-8
253- shorter probe interval is used in init script, making the service startup
254  quicker in most situations (#475101)
255
256* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.0.14-7
257- Rebuild for Python 2.6
258
259* Thu Oct 30 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-6
260- removed static libraries from the -devel subpackage
261- fixed openipmigui.desktop file
262
263* Thu Oct 23 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-5
264- fixed typos in the descriptions
265- added .desktop file for openipmigui tool
266
267* Mon Oct 20 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-4
268- fixed description of the package
269
270* Thu Oct 16 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-3
271- split ipmitool to separate package
272- added 'reload' functionality to init script
273- added seraparate -gui subpackage
274
275* Wed Jul 30 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-2
276- Fixed rpath problem in libOpenIPMIposix.so.0.0.1
277
278* Tue Jul 29 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-1
279- Fixed several specfile problems (#453751)
280- Update to OpenIPMI-2.0.14
281
282* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.13-2
283- Autorebuild for GCC 4.3
284
285* Wed Dec 05 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.13-1
286- Updated to OpenIPMI-2.0.13
287- Rebuild due to new openssl
288
289* Wed Oct 10 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-3
290- Added missing perl-devel buildrequires
291
292* Mon Sep 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
293- Added missing popt-devel buildrequires
294
295* Fri Aug 17 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
296- Fix rebuild problems due to glibc change
297- License review and fixes
298
299* Tue Apr 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-1
300- Update to OpenIPMI-2.0.11
301
302* Tue Feb 27 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-8
303- Update for ipmitool-1.8.9
304
305* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 2.0.6-7
306- rebuild for python 2.5
307
308* Tue Nov 28 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-6.fc7
309- Update due to new net-snmp-5.4
310- Some specfile updates
311
312* Tue Jul 18 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-5
313- Fixed check for udev in initscript (#197956)
314
315* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.0.6-4.1
316- rebuild
317
318* Fri Jun 16 2006 Bill Nottingham <notting@redhat.com> 2.0.6-4
319- don't include <linux/compiler.h>
320
321* Fri Jun 16 2006 Jon Masters <jcm@redhat.com> 2.0.6-3
322- Fix a build requires (needs glibc-kernheaders)
323
324* Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> 2.0.6-2
325- Bump for new glib2
326
327* Tue May 16 2006 Phil Knirsch <pknirsch@redhat.com> 2.0.6-1
328- Fixed bug with type conversion in ipmitool (#191091)
329- Added python bindings
330- Split off perl and python bindings in separate subpackages
331- Dropped obsolete patches
332- Added missing buildprereq on readline-devel
333- Made it install the python bindings properly on 64bit archs
334
335* Mon May 15 2006 Phil Knirsch <pknirsch@redhat.com>
336- Updated ipmitool to 1.8.8
337- Updated OpenIPMI to 2.0.6
338
339* Fri Feb 17 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-19
340- Added missing PreReq for chkconfig
341
342* Mon Feb 13 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2.1
343- rebump for build order issues during double-long bump
344
345* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2
346- bump again for double-long bug on ppc(64)
347
348* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.1
349- rebuilt for new gcc4.1 snapshot and glibc changes
350
351* Mon Feb 06 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-18
352- Updated ipmitool to latest upstream version.
353- Removed 3 patches for already fixed bugs in latest ipmitool.
354- Adapted warning message fix for ipmitool for latest version.
355
356* Tue Jan 24 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-17
357- Fixed some minor things in initscripts.
358
359* Mon Jan 09 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-16
360- Included FRU fix for displaying FRUs with ipmitool
361- Included patch for new option to specify a BMC password for IPMI 2.0 sessions
362
363* Tue Jan 03 2006 Radek Vokal <rvokal@redhat.com> 1.4.14-15
364- Rebuilt against new libnetsnmp
365
366* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
367- rebuilt
368
369* Wed Nov 23 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-14
370- Some more initscript and sysconfig updates from Dell.
371
372* Wed Nov 09 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-13
373- Rebuilt to link against latest openssl libs.
374- Fixed ipmitool not setting session privilege level (#172312)
375
376* Wed Nov 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-11
377- Rebuild to link against new net-snmp libs.
378
379* Tue Oct 11 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-10
380- Updated initscript to fix missing redhat-lsb bug (#169901)
381
382* Thu Sep 08 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-9
383- Another update to latest initscripts from Dell
384- Fixed some missing return statements for non-void functions (#164138)
385
386* Thu Sep 01 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-8
387- Updated initscript to latest version from Dell
388
389* Fri Aug 12 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-7
390- Fixed the unwanted output of failed module loading of the initscript. Behaves
391  now like all our other initscripts (#165476)
392
393* Fri Aug 05 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-6
394- Fixed build problem on 64bit machines
395
396* Fri Jul 15 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-5
397- Fixed missing change to not autostart in the initscript
398
399* Wed Jul 06 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-4
400- Made the initscript a replacing configfile
401
402* Mon Jul 04 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-3
403- Updated versions of the initscripts and sysconf files
404- Fixed typo in preun script and changelog
405
406* Mon Jun 27 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-2
407- Updated to OpenIPMI-1.4.14
408- Split the main package into normal and libs package for multilib support
409- Added ipmitool-1.8.2 to OpenIPMI and put it in tools package
410- Added sysconf and initscript (#158270)
411- Fixed oob subscripts (#149142)
412
413* Wed Mar 30 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-5
414- Correctly put libs in the proper packages
415
416* Thu Mar 17 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-4
417- gcc4 rebuild fixes
418- Added missing gdbm-devel buildprereq
419
420* Wed Mar 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-3
421- bump release and rebuild with gcc 4
422
423* Tue Feb 08 2005 Karsten Hopp <karsten@redhat.de> 1.4.11-2
424- update
425
426* Tue Oct 26 2004 Phil Knirsch <pknirsch@redhat.com>
427- Initial version
Note: See TracBrowser for help on using the repository browser.