source: projects/specs/branches/6/M/ModemManager/ModemManager-vl.spec @ 3791

Revision 3791, 9.1 KB checked in by Takemikaduchi, 13 years ago (diff)

NetworkManager: update to 0.8.4

Line 
1#%define snapshot .git20100720
2%define snapshot %{nil}
3%define ppp_version 2.4.5
4
5Summary: Mobile broadband modem management service
6Summary(ja): Mobile broadband modem management service
7Name: ModemManager
8Version: 0.4
9Release: 2%{?snapshot}%{?_dist_release}
10License: GPLv2+
11Group: System Environment/Base
12URL: http://www.gnome.org/projects/NetworkManager/
13
14#
15# Source from git://anongit.freedesktop.org/ModemManager/ModemManager
16# tarball built with:
17#    ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
18#    make distcheck
19#
20Source: %{name}-%{version}%{?snapshot}.tar.bz2
21Patch1: %{name}-0.3-jp-modems.patch
22Patch20: %{name}-0.4-git20110428.patch
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25Requires: dbus-glib
26Requires: glib2
27BuildRequires: glib2-devel >= 2.26.1
28BuildRequires: dbus-glib-devel >= 0.92
29BuildRequires: libgudev-devel >= 143
30BuildRequires: ppp = %{ppp_version}
31BuildRequires: ppp-devel = %{ppp_version}
32BuildRequires: polkit-devel
33BuildRequires: automake autoconf intltool libtool
34# for xsltproc
35BuildRequires: libxslt
36
37%description
38The ModemManager service provides a consistent API to operate many different
39modems, including mobile broadband (3G) devices.
40
41%prep
42%setup -q
43%patch1 -p1 -b .jp-modems
44%patch20 -p1 -b .git20110428
45
46%build
47autoreconf -i
48pppddir=`ls -1d %{_libdir}/pppd/2*`
49%configure \
50        --enable-more-warnings=yes \
51        --with-udev-base-dir=/lib/udev \
52        --with-tests=yes \
53        --with-docs=yes \
54        --disable-static \
55        --with-pppd-plugin-dir=$pppddir \
56        --with-polkit=no
57
58make %{?_smp_mflags}
59
60%check
61make check
62
63%install
64make install DESTDIR=$RPM_BUILD_ROOT
65
66rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
67rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.la
68rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
69rm -f $RPM_BUILD_ROOT%{_includedir}/mm/mm-modem.h
70
71%post
72/sbin/ldconfig
73touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
74
75%postun
76/sbin/ldconfig
77if [ $1 -eq 0 ]; then
78  touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
79  gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
80fi
81
82%posttrans
83gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
84
85%files
86%defattr(0644, root, root, 0755)
87%doc COPYING README
88%{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager.conf
89%{_datadir}/dbus-1/interfaces/*.xml
90%{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager.service
91%attr(0755,root,root) %{_sbindir}/modem-manager
92%dir %{_libdir}/%{name}
93%attr(0755,root,root) %{_libdir}/%{name}/*.so*
94/lib/udev/rules.d/*
95%{_datadir}/polkit-1/actions/*.policy
96%{_datadir}/icons/hicolor/22x22/apps/modem-manager.png
97
98%changelog
99* Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
100- update Patch20 (ModemManager-0.4-git20110428.patch)
101- delete Patch21,22
102
103* Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
104- update to 0.4
105- add Patch20 (ModemManager-0.4-git20100720.patch)
106- add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
107- add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
108
109* Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
110- initial build for Vine Linux
111
112* Sun May  2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
113- core: ignore some failures on disconnect (rh #578280)
114- core: add support for platform serial devices
115- gsm: better Blackberry DUN support
116- gsm: periodically poll access technology
117- cdma: prevent crash on modem removal (rh #571921)
118- mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
119- novatel: better signal strength reporting on CDMA cards
120- novatel: add access technology and mode preference support on GSM cards
121- zte: fix mode preference retrieval
122- longcheer: add support for Zoom modems (4595, 4596, etc)
123- longcheer: add access technology and mode preference support
124
125* Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
126- Silence %%post
127- Update scripts
128
129* Fri Apr  9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
130- gsm: fix parsing Blackberry supported character sets response
131
132* Thu Apr  8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
133- mbm: fix retrieval of current allowed mode
134- gsm: fix initialization issues with some devices (like Blackberries)
135
136* Mon Apr  5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
137- core: fix detection of some generic devices (rh #579247)
138- core: fix detection regression of some Huawei devices in 0.3-5
139- cdma: periodically poll registration state and signal quality
140- cdma: really fix registration detection on various devices (rh #569067)
141
142* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
143- core: fix PPC/SPARC/etc builds
144
145* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
146- core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
147- cdma: handle signal quality requests while connected for more devices
148- cdma: handle serving system requests while connected for more devices
149- gsm: determine current access technology earlier
150- huawei: work around automatic registration issues on some devices
151
152* Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
153- core: ensure enabled modems are disabled when MM stops
154- core: better capability detection for Blackberry devices (rh #573510)
155- cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
156- gsm: don't block modem when it requires PIN2
157- option: fix access technology updates
158
159* Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
160- mbm: add device IDs for C3607w
161- mbm: fail earlier during connection failures
162- mbm: fix username/password authentication when checked by the network
163- hso: implement asynchronous signal quality updates
164- option: implement asynchronous signal quality updates
165- novatel: correctly handle CDMA signal quality
166- core: basic PolicyKit support
167- core: fix direct GSM registration information requests
168- core: general GSM PIN/PUK unlock fixes
169- core: poll GSM registration state internally for quicker status updates
170- core: implement GSM 2G/3G preference
171- core: implement GSM roaming allowed/disallowed preference
172- core: emit signals on access technology changes
173- core: better handling of disconnections
174- core: fix simple CDMA status requests
175
176* Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
177- core: startup speed improvements
178- core: GSM PIN checking improvements
179- huawei: fix EVDO-only connections on various devices (rh #553199)
180- longcheer: add support for more devices
181
182* Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
183- anydata: new plugin for AnyData CDMA modems (rh #547294)
184- core: fix crashes when devices are unplugged during operation (rh #553953)
185- cdma: prefer primary port for status/registration queries
186- core: fix probing/detection of some PIN-locked devices (rh #551376)
187- longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
188- gsm: fix Nokia N80 network scan parsing
189
190* Fri Jan  1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
191- core: fix apparent hangs by limiting retried serial writes
192- gsm: ensure modem state is reset when disabled
193
194* Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
195- sierra: fix CDMA registration detection in some cases (rh #547513)
196
197* Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
198- sierra: ensure CDMA device is powered up when trying to use it
199- cdma: better signal quality parsing (fixes ex Huawei EC168C)
200- zte: handle unsolicited messages better during probing
201
202* Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
203- cdma: fix signal strength reporting on some devices
204- cdma: better registration state detection when dialing (ex Sierra 5275)
205- option: always use the correct tty for dialing commands
206
207* Mon Dec  7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
208- core: fix reconnect after manual disconnect (rh #541314)
209- core: fix various segfaults during registration
210- core: fix probing of various modems on big-endian architectures (ie PPC)
211- core: implement modem states to avoid duplicate operations
212- hso: fix authentication for Icera-based devices like iCON 505
213- zte: use correct port for new devices
214- nozomi: fix detection
215
216* Thu Nov  5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
217- Update to latest git
218- core: fix pppd 2.4.5 errors about 'baudrate 0'
219- cdma: wait for network registration before trying to connect
220- gsm: add cell access technology reporting
221- gsm: allow longer-running network scans
222- mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
223- nokia: don't power down phones on disconnect
224- hso: fix disconnection/disable
225
226* Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
227- Fixes for Motorola and Ericsson devices
228- Fixes for CDMA "serving-system" command parsing
229
230* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
231- Fix a typo in one of the udev rules files
232
233* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
234- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
235
236* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
237- Fix source repo location
238- Fix directory ownership
239
240* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
241- Initial version
242
Note: See TracBrowser for help on using the repository browser.