source: projects/specs/branches/6/J/Judy/Judy-vl.spec @ 1219

Revision 1219, 4.0 KB checked in by inagaki, 14 years ago (diff)

NEW: Judy, libstroke

Line 
1Name:           Judy
2Version:        1.0.4
3Release:        7%{?_dist_release}
4Summary:        General purpose dynamic array
5
6Group:          System Environment/Libraries
7# The source code itself says:
8# "GNU Lesser General Public License as published by the
9#  Free Software Foundation; either version 2 of the License,
10#  or (at your option) any later version."
11# This will probably change to LGPLv2 in a future upstream release,
12# but until then, LGPLv2+ is the proper license.  Confirmed
13# with upstream on 2008/11/28.
14License:        LGPLv2+
15URL:            http://sourceforge.net/projects/judy/
16Source0:        http://downloads.sourceforge.net/judy/Judy-%{version}.tar.gz
17Source1:        README.Fedora
18# Make tests use shared instead of static libJudy.
19Patch0:         Judy-1.0.4-test-shared.patch
20# The J1* man pages were incorrectly being symlinked to Judy, rather
21# than Judy1.  This patch corrects that.  Submitted upstream 2008/11/27.
22Patch1:         Judy-1.0.4-fix-Judy1-mans.patch
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25
26#BuildRequires:
27#Requires:       
28
29%description
30Judy is a C library that provides a state-of-the-art core technology
31that implements a sparse dynamic array. Judy arrays are declared
32simply with a null pointer. A Judy array consumes memory only when it
33is populated, yet can grow to take advantage of all available memory
34if desired. Judy's key benefits are scalability, high performance, and
35memory efficiency. A Judy array is extensible and can scale up to a
36very large number of elements, bounded only by machine memory. Since
37Judy is designed as an unbounded array, the size of a Judy array is
38not pre-allocated but grows and shrinks dynamically with the array
39population.
40
41
42%package devel
43Summary:        Development libraries and headers for Judy
44Group:          Development/Libraries
45Requires:       %{name} = %{version}-%{release}
46
47%description devel
48This package contains the development libraries and header files
49for developing applications that use the Judy library.
50
51
52%prep
53%setup -q
54%patch0 -p1 -b .test-shared
55%patch1 -p1 -b .fix-Judy1-mans
56cp -p %{SOURCE1} .
57
58
59%build
60%configure --disable-static
61make
62#%{?_smp_mflags}
63# fails to compile properly with parallel make:
64# http://sourceforge.net/tracker/index.php?func=detail&aid=2129019&group_id=55753&atid=478138
65
66
67%install
68rm -rf $RPM_BUILD_ROOT
69make install DESTDIR=$RPM_BUILD_ROOT
70# get rid of static libs and libtool archives
71rm -f $RPM_BUILD_ROOT/%{_libdir}/*.{a,la}
72# clean out zero length and generated files from doc tree
73rm -rf doc/man
74rm -f doc/Makefile* doc/ext/README_deliver
75[ -s doc/ext/COPYRIGHT ] || rm -f doc/ext/COPYRIGHT
76[ -s doc/ext/LICENSE ] || rm -f doc/ext/LICENSE
77
78
79%check
80cd test
81./Checkit
82
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%post -p /sbin/ldconfig
88
89%postun -p /sbin/ldconfig
90
91
92%files
93%defattr(-,root,root,-)
94%doc AUTHORS ChangeLog COPYING README README.Fedora
95%{_libdir}/*.so.*
96
97%files devel
98%defattr(-,root,root,-)
99%doc doc
100%{_libdir}/*.so
101%{_includedir}/*
102%{_mandir}/man3/*
103
104
105%changelog
106* Sun Jun 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.4-7
107- Initial build for Vine Linux
108
109* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.4-6
110- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
111
112* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.4-5
113- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
114
115* Sat Dec 13 2008 Charles R. Anderson <cra@wpi.edu> 1.0.4-4
116- for Judy1 man page fix, patch Makefile.{am,in} instead of
117  relying on autotools to regenerate the latter.
118- Add README.Fedora with upstream's license explanation.
119
120* Thu Nov 30 2008 Charles R. Anderson <cra@wpi.edu> 1.0.4-3
121- fix Judy1 man page symlinks
122- use valid tag License: LGPLv2+ confirmed with upstream
123- use version macro in Source0
124- remove Makefiles from installed doc tree
125
126* Thu Nov 27 2008 Charles R. Anderson <cra@wpi.edu> 1.0.4-2
127- patch tests to run with shared library
128- run tests in check section
129
130* Sun Oct 05 2008 Charles R. Anderson <cra@wpi.edu> 1.0.4-1
131- Initial package for Fedora
Note: See TracBrowser for help on using the repository browser.