source: projects/specs/branches/6/J/JF/JF-vl.spec @ 3370

Revision 3370, 5.0 KB checked in by iwaim, 13 years ago (diff)

JF-20110119-1

Line 
1%define _docdir %{_defaultdocdir}
2
3Summary: HOWTO, FAQ, and other documents in Japanese
4Summary(ja): 日本語のHOWTO, FAQ, その他の文書です
5Name: JF
6Version: 20110119
7Release: 1%{?_dist_release}
8License: distributable
9Group: Applications/Documentation
10URL: http://www.linux.or.jp/JF/
11Source0: http://www.linux.or.jp/JF/JFdocs/JFtxt.tar.bz2
12
13BuildArch: noarch
14Buildroot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: nkf
16
17Vendor: Project Vine
18Distribution: Vine Linux
19
20%description
21Japanese HOWTOs (instructions for how to do things on Linux), FAQs,
22etc. collected from the property of JF (Japanese FAQ) Project.
23There are Japanese translations from English HOWTOs, FAQs, etc. and
24documents that are originally written in Japanese.
25
26%description -l ja
27HOWTO (Linux でいろいろなことを実現する方法を書いた文書)や FAQ
28(Frequently Asked Questions:よくある質問と回答)の日本語版など JF
29(Japanese FAQ Project) の資産から、Linuxの基本操作に必要な文書を集めま
30した。英語版 HOWTO, mini-HOWTO, FAQ の和訳、日本固有のドキュメントなど
31が含まれています。
32
33%prep
34%setup -n JFdocs -q
35# remove documents prohibited to distiribute non-commercially...
36# http://www.linux.or.jp/JF/copyright.html
37rm -f Astronomy-HOWTO*
38rm -f Chinese-HOWTO*
39rm -f DHCP*
40rm -f Debian-Jigdo*
41rm -f Ftape-HOWTO*
42rm -f GIS-GRASS*
43rm -f Offline-Mailing*
44rm -f Quota*
45rm -f Scanner-HOWTO-mtekscan*
46rm -f Securing-X-Windows*
47rm -f StarOffice*
48rm -f Swap-Space*
49
50# remove unneeded documents
51rm -f Parted-README.txt
52rm -f BTTV-Mini-HOWTO-0.3.txt
53
54%build
55toUTF8(){
56for i in `find .` ; do
57    if [ -f $i ]; then
58        nkf -w8 -Lu $i >${i%.*}.new
59        mv ${i%.*}.new $i
60    fi
61done
62}
63
64toUTF8
65
66%install
67rm -rf %{buildroot}
68mkdir -p %{buildroot}%{_docdir}/JF
69
70tar cf - . | (cd %{buildroot}%{_docdir}/JF && tar xfBp -)
71
72(cd %{buildroot}%{_docdir}/JF; gzip -r --best *)
73
74%clean
75rm -rf %{buildroot}
76
77%files
78%defattr(-,root,root)
79%{_docdir}/JF/
80
81%changelog
82* Sat Apr  9 2011 IWAI, Masaharu <iwai@alib.jp> 20110119-1
83- source as of 20110119
84- update description
85
86* Fri Mar 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20100222-1
87- source as of 20100222
88- convert to UTF8 instead of EUC-JP
89- s/BuildPreReq/BuildRequires/
90
91* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20090320-1
92- source as of 20090320
93- spec in utf-8
94
95* Mon Apr 28 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 20080415-1
96- source as of 20080415
97
98* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20070728-0vl1
99- source as of 20070728
100
101* Fri Sep 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20060910-0vl1
102- source as of 20060910
103
104* Sat May 20 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20060412-0vl1
105- source as of 20060520
106
107* Wed Sep 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20050910-0vl1
108- source as of 20050910
109
110* Thu Dec 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20041213-0vl1
111- source as of 20041213
112
113* Sat Sep 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20040924-0vl1
114- source as of 20040924
115- remove Swap-Space
116
117* Sat Mar 20 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20040316-0vl1
118- source as of 20040316
119- remove Swap-Space
120
121* Wed Sep 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20030914-0vl1
122- source as of 20030914
123- remove Debian-Jigdo
124
125* Fri Jun  6 2003 Jun Nishii <jun@vinelinux.org> 20030415-0vl1
126- fix toEUC
127
128* Wed Apr 16 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20030415-0vl1
129- source as of 20030415
130- remove Securing-X-Windows
131
132* Tue Feb 18 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20030216-0vl1
133- source as of 20030216
134
135* Sun Sep 22 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20020905-0vl1
136- source as of 20020905
137- remove Astronomy-HOWTO
138
139* Sun Jun 2 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20020415-0vl1
140- source as of 20020415
141
142* Tue Jan 15 2002 Toru Sagami <sagami@vinelinux.org> 20020115-0vl1
143- source as of 20020115
144
145* Sat Nov 17 2001 Toru Sagami <sagami@vinelinux.org>
146- 20011115-0vl1
147
148* Fri Aug 17 2001 <sagami@vinelinux.org>
149- 20010815-0vl1: introduced %%{_docdir} definition
150
151* Sun Jul 15 2001 <sagami@vinelinux.org>
152- 20010715-0vl1: eliminate CR at the EOL
153
154* Sun May 27 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
155- 20010527-0vl1
156- modified the list of non-free documents
157- comply with RFC2606 (LAN-mini-HOWTO)
158
159* Wed Apr 18 2001 sagami@vinelinux.org
160- 20010415-0vl1
161
162* Mon Dec 25 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
163- 20001225-0vl1
164- added Ethernet-HOWTO, which no longer prevents from commercial distributing
165
166* Mon Sep  4 2000 Jun Nishii <jun@vinelinux.org>
167- 20000831-0vl1
168
169* Wed May 10 2000 Toru Sagami <czs14350@nifty.ne.jp>
170- 20000509-0vl1
171- fixed summary, Buildroot, Distribution
172- fixed description by Yoshihiro Ota
173
174* Thu Jan 27 2000 Yasuhide OOMORI <baoying@flatout.org>
175- [JF-20000125-1]
176- updated to 20000125.
177
178* Thu Jul 29 1999 Jun Nishii <jun@flatout.org>
179- updated to 199907
180
181* Mon Feb 15 1999 Jun Nishii <jun@flatout.org>
182- updated to 199902
183- use JFeuc.tar.bz2
184
185* Tue Feb 2 1999 Jun Nishii <jun@flatout.org>
186- updated to 199901
187- Now we use version number yyyymm instead of yymmdd
188  to avoid 2000 y problem B)
Note: See TracBrowser for help on using the repository browser.