source: projects/specs/branches/6/G/Gtk-Perl/Gtk-Perl-vl.spec @ 521

Revision 521, 6.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define       _noVersionedDependencies  1
2
3Summary:      Perl extention for Gtk+/Gnome
4Summary(ja):  Perl から Gtk+ や Gnome を使うためのモジュール集
5Name:         Gtk-Perl
6Version:      0.7008
7Release:      32%{?_dist_release}
8License:      GPL
9Group:        Development/Libraries
10Source:       ftp://ftp.cpan.org/pub/perl/CPAN/modules/by-module/Gtk/Gtk-Perl-%{version}.tar.gz
11Source10: filter-depends.sh
12
13# Patches from Mandrake 27mdk
14Patch0: Gtk-Perl-add-ensure_focus.patch.bz2
15Patch1: Gtk-Perl-0.7003-workaround-gdk_event_copy-withnowindow.patch.bz2
16Patch2: Gtk-Perl-0.7005-add-XSetInputFocus.patch.bz2
17# fix compilation with gtkhtml >= 1.1.0
18Patch3: Gtk-Perl-0.7008-gtkhtml11.patch.bz2
19Patch4: Gtk-Perl-0.7008-fix-mozilla.patch.bz2
20Patch7: Gtk-Perl-0.7008-force-GtkHTML-and-no-GtkXmHTML.patch.bz2
21Patch8: Gtk-Perl-0.7008-fix-memory-leak-with-Gdk::Pixmap-created-from-a-Gdk::Pixbuf.patch.bz2
22# (fc) 0.7008-25mdk fix compilation with gnome-print >= 0.30 and gdkpixbuf >= 0.20
23Patch9: Gtk-Perl-0.7008-gnomeprint.patch.bz2
24
25#Patch10:       Gtk-Perl-%{version}-pixbuf.patch
26URL:          http://projects.prosa.it/gtkperl/
27BuildRoot:    %{_tmppath}/%{name}-%{version}-root
28
29## Build Requires for all modules (except experimental bonobo and mozilla)
30BuildPreReq:  perl >= 1:5.6.0
31BuildPreReq:  gtk+-devel, libglade-devel, imlib-devel
32BuildPreReq:  gdk-pixbuf-devel, gnome-libs-devel
33#BuildPreReq:  gtkhtml-devel, gnome-print-devel
34
35## Requires for basic modules
36Requires:     perl >= 1:5.6.0
37Provides:     gtk+perl = %{version}
38Obsoletes:    gtk+perl
39
40# internal perl provides
41#Provides: perl(Gnome::Applet::Types)
42#Provides: perl(Gtk::GLArea::Types)
43Provides: perl(Gtk::Gdk::Pixbuf::Types)
44Provides: perl(Gtk::GladeXML::Types)
45Provides: perl(Gtk::XmHTML::Types)
46
47Vendor:       Project Vine
48Distribution: Vine Linux
49
50%define __find_requires %{SOURCE10}
51
52%description
53Gtk-Perl is a set of modules that let you exploit Gtk+ and Gnome
54libraries from Perl.
55
56This package contains basic Gtk modules, as well as Imlib, GdkPixbuf,
57Gnome, XmHtml and Glade support.
58
59
60%description -l ja
61Gtk-Perl モジュールを使うと,Perl から Gtk+ や Gnome のライブラリを
62利用することができます.
63
64このパッケージには基本となる Gtk モジュールの他,Imlib, GdkPixbuf,
65Gnome, XmHtml, Glade のサポートが含まれています.
66
67
68#%package extras
69#Summary:     Perl extension for Gtk+/Gnome - additional modules
70#Summary(ja): Perl から Gtk+ や Gnome を使う為の追加モジュール集
71#Group:        Development/Languages
72#
73### Requires for additional modules
74#Requires:    %{name} = %{version}-%{release}
75#Requires:    gtkhtml, gnome-print
76#
77#
78#%description extras
79#Gtk-Perl is a set of modules that let you exploit Gtk+ and Gnome
80#libraries from Perl.
81#
82#This extra package currently contains GtkHTML and GnomePrint support.
83#
84#%description extras -l ja
85#Gtk-Perl モジュールを使うと,Perl から Gtk+ や Gnome のライブラリを
86#利用することができます.
87#
88#この追加パッケージには現在 GtkHTML と GnomePrint のサポートが含まれています.
89
90
91%prep
92[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
93
94%setup -q -n Gtk-Perl-%{version}
95
96%patch0 -p1
97%patch1 -p1
98%patch2 -p1
99#%patch3 -p1 -b .gtkhtml11
100%patch4 -p1
101#%patch7 -p1
102%patch8 -p1
103%patch9 -p1 -b .gnomeprint
104
105#%patch10 -p1 -b .pixbuf
106
107# fix for new MakeMaker (ie new perl 5.8.0)
108perl -pi -e '/CCCMD/ && s|/m;|/mg;|' */Makefile.PL
109
110# temporal removal of Applet module
111rm -rf Applet
112
113%build
114#perl Makefile.PL --with-gdkimlib --with-gdkpixbuf --with-gtkxmhtml \
115#        --with-gnome --with-applets --with-glade \
116#        --without-gtkglarea \
117#        --without-gtkhtml --without-gnomeprint
118#        # --with-gtkhtml --with-gnomeprint
119#        # --without-bonobo --without-mozilla
120#
121#make
122
123CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
124make
125
126for i in GdkImlib GdkPixbuf Glade Gnome Gtk GtkXmHTML ; do
127    pushd $i
128        CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
129        make
130    popd
131done
132
133
134%install
135rm -rf ${RPM_BUILD_ROOT}
136
137#make PREFIX=${RPM_BUILD_ROOT}/usr/ install
138
139# prepare sample scripts
140mkdir samples
141cp -a test.pl samples/.
142for X in GdkImlib GdkPixbuf Glade Gnome Gtk GtkXmHTML; do
143(cd $X;
144mkdir ../samples/$X;
145cp -a samples ../samples/$X/samples);
146done
147
148#mkdir samples-extras
149#cp -a test.pl samples-extras/.
150#for X in GnomePrint GtkHTML; do
151#(cd $X;
152#mkdir ../samples-extras/$X; \
153#cp -a samples ../samples-extras/$X/samples);
154#done
155make DESTDIR=$RPM_BUILD_ROOT install 
156
157for i in GdkImlib GdkPixbuf Glade Gnome Gtk GtkXmHTML ; do
158    pushd $i
159        make DESTDIR=$RPM_BUILD_ROOT install
160    popd
161done
162
163
164pushd $RPM_BUILD_ROOT
165rm -f `find -type f -name "*.bs"`
166rm -f `find -type f -name .packlist`
167rm -f `find -type f -name .packlist`
168rm -f `find -type f -name "*::reference*"`
169popd
170
171find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
172
173find $RPM_BUILD_ROOT/usr -type f -print | sed "s@^$RPM_BUILD_ROOT@@g" | grep -v perllocal.pod > gtk-perl-files
174
175
176
177%clean
178[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
179
180
181%files
182%defattr(-,root,root)
183%doc ChangeLog INSTALL MANIFEST NOTES README VERSIONS WARNING
184%doc tools samples
185
186# Gdk/Gtk modules
187%{_libdir}/perl5/vendor_perl/*/*/Gtk
188%{_libdir}/perl5/vendor_perl/*/*/auto/Gtk
189%{_libdir}/perl5/vendor_perl/*/*/auto/Gnome
190%{_libdir}/perl5/vendor_perl/*/*/Gtk.pm
191%{_libdir}/perl5/vendor_perl/*/*/Gnome.pm
192%{_libdir}/perl5/vendor_perl/*/*/Gnome
193%{_mandir}/*/*
194
195
196%changelog
197* Sun May  3 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7008-32
198- applied new versioning policy, spec in UTF-8
199- rebuilt with gnome-libs-1.4.2-2vl5 (linking with db-4.6.21)
200
201* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7008-31vl5
202- rebuilt with new toolchain
203
204* Sun Sep  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7008-31vl4
205- s/Copyright/License/
206- installed files to vendor_perl
207
208* Sat Nov  6 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.7008-31vl3
209- rebuilt with db4-4.2.52
210- remove Applet module
211
212* Fri May 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
213- rebuild with gdk-pixbuf-devel-0.21.0-0vl3
214
215* Thu May 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
216- syncd with rawhide 31 and Mandrake 27mdk
217
218* Mon Apr 14 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
219- rebuild
220- Patch1: for gdk-pixbuf-0.21
221
222* Mon Jul 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
223- 0.7008-0vl1
224- updated to 0.7008 release
225- disabled Gtk-Perl-extras subpackage at the moment
226
227* Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
228- 0.7007-0vl1
229- updated to 0.7007 release
230- split Gtk-Perl-extras subpackage
231
232* Fri Jun 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
233- 0.7004-0vl2
234- rebuilt with perl-5.6
235- package renamed to Gtk-Perl
236- add GdkPixbuf modules
237
238* Sun Jan 21 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
239- 0.7004-0vl1
240- upgraded for 0.7004 release
241- use %%{_tmppath}
242
243* Fri Apr 28 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
244- 0.7000-0vl1
245- first package for Vine/ppc
Note: See TracBrowser for help on using the repository browser.