source: projects/specs/branches/6/G/GConf2/GConf2-vl.spec @ 2996

Revision 2996, 15.4 KB checked in by daisuke, 13 years ago (diff)

GConf2: add gtk subpackage to include gconf-sanity-check-2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define libxml2_version 2.7.7
4%define orbit2_version 2.14.19
5%define glib2_version 2.26.0
6%define dbus_version 1.4.0
7%define dbus_glib_version 0.88
8
9Summary: A process-transparent configuration system
10Summary(ja): プロセス透過型設定システム
11Name: GConf2
12Version: 2.32.1
13Release: 2%{?_dist_release}
14License: LGPL
15Group: System Environment/Base
16Source: http://ftp.gnome.org/pub/GNOME/sources/GConf/2.32/GConf-%{version}.tar.bz2
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18URL: http://www.gnome.org
19BuildRequires: libxml2-devel >= %{libxml2_version}
20BuildRequires: ORBit2-devel >= %{orbit2_version}
21BuildRequires: glib2-devel >= %{glib2_version}
22BuildRequires: dbus-devel >= %{dbus_version}
23BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
24BuildRequires: gtk2-devel
25BuildRequires: openldap-devel
26BuildRequires: gtk-doc >= 0.9
27BuildRequires: polkit-devel >= 0.99
28BuildRequires: gobject-introspection-devel
29Requires: dbus
30
31Patch0: GConf-2.18.0.1-reload.patch
32# http://bugzilla.gnome.org/show_bug.cgi?id=568845
33Patch1: GConf-gettext.patch
34#
35Patch2: GConf-2.28.0-no-access-crash.patch
36# upstream fix
37Patch3: 0001-Make-the-defaults-mechanism-find-the-right-polkit-ac.patch
38# https://bugzilla.gnome.org/show_bug.cgi?id=608705
39Patch4: 0001-gconfd-Remove-worse-than-useless-signal-handlers-for.patch
40
41
42
43%description
44GConf is a process-transparent configuration database API used to
45store user preferences. It has pluggable backends and features to
46support workgroup administration.
47
48%description -l ja
49GConf は、ユーザの設定を保存するためのプロセス透過型の設定データ
50ベースの API です。バックエンドに接続しワークグループ管理をサポー
51トする機能を持っています。
52
53%package devel
54Summary: Headers and libraries for GConf development
55Summary(ja): GConf を使って開発するためのヘッダーファイルとライブラリ
56Group: Development/Libraries
57Requires: %{name} = %{version}
58Requires: libxml2-devel >= %{libxml2_version}
59Requires: ORBit2-devel >= %{orbit2_version}
60Requires: glib2-devel >= %{glib2_version}
61Requires: dbus-devel >= %{dbus_version}
62Requires: dbus-glib-devel >= %{dbus_glib_version}
63
64%description devel
65GConf development package. Contains files needed for doing
66development using GConf.
67
68%description -l ja devel
69GConf 開発パッケージです。GConf を使って開発するために必要なファ
70イルが含まれています。
71
72%package gtk
73Summary: Graphical GConf utilities
74Summary(ja): GConf グラフィカルユーティリティ
75Group: System Environment/Base
76Requires: %{name} = %{version}-%{release}
77
78%description gtk
79The GConf2-gtk package contains graphical GConf utilities
80which require GTK+.
81
82%description -l ja gtk
83GConf2-gtk パッケージには gtk2 を利用したグラフィカルな GConf
84ユーティリティが含まれています。
85
86
87
88%if %{build_compat32}
89#######################################################################
90# compat32
91%package -n compat32-%{name}
92Summary: A process-transparent configuration system
93Summary(ja): プロセス透過型設定システム
94Group: System Environment/Base
95Requires: compat32-glib2 >= %{glib2_version}
96
97%description -n compat32-%{name}
98GConf is a process-transparent configuration database API used to
99store user preferences. It has pluggable backends and features to
100support workgroup administration.
101
102%description -l ja -n compat32-%{name}
103GConf は、ユーザの設定を保存するためのプロセス透過型の設定データ
104ベースの API です。バックエンドに接続しワークグループ管理をサポー
105トする機能を持っています。
106
107%package -n compat32-%{name}-devel
108Summary: Headers and libraries for GConf development
109Summary(ja): GConf を使って開発するためのヘッダーファイルとライブラリ
110Group: Development/Libraries
111Requires: compat32-%{name} = %{version}
112Requires: %{name} = %{version}
113Requires: compat32-glib2 >= %{glib2_version}
114
115%description -n compat32-%{name}-devel
116GConf development package. Contains files needed for doing
117development using GConf.
118
119%description -l ja -n compat32-%{name}-devel
120GConf 開発パッケージです。GConf を使って開発するために必要なファ
121イルが含まれています。
122
123%endif
124
125%prep
126%setup -q -n GConf-%{version}
127
128%patch0 -p1 -b .reload
129%patch1 -p1 -b .gettext
130## %patch2 -p1 -b .no-access
131## %patch3 -p1 -b .defaults-actions
132## %patch4 -p1 -b .segv
133
134%build
135%configure --disable-gtk-doc --disable-static --enable-defaults-service --with-gtk=2.0
136%__make %{?_smp_mflags}
137
138%install
139rm -fr $RPM_BUILD_ROOT
140%__make install DESTDIR=$RPM_BUILD_ROOT
141
142mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas
143mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.system
144
145rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
146rm -f $RPM_BUILD_ROOT/%{_libdir}/GConf/2/*.la
147rm -f $RPM_BUILD_ROOT/%{_libdir}/gio/modules/*.la
148
149%find_lang %name
150
151%clean
152rm -rf $RPM_BUILD_ROOT
153
154%post
155/sbin/ldconfig
156if [ $1 -gt 1 ]; then
157    if ! fgrep -q gconf.xml.system %{_sysconfdir}/gconf/2/path; then
158        sed -i -e 's@xml:readwrite:$(HOME)/.gconf@&\n\n# Location for system-wide settings.\nxml:readonly:/etc/gconf/gconf.xml.system@' %{_sysconfdir}/gconf/2/path
159    fi
160fi
161   
162%postun -p /sbin/ldconfig
163
164%files -f %{name}.lang
165%defattr(-, root, root)
166%doc COPYING ChangeLog NEWS README backends/README.evoldap
167%config %{_sysconfdir}/gconf/2/path
168%config %{_sysconfdir}/gconf/2/evoldap.conf
169%dir %{_sysconfdir}/gconf
170%dir %{_sysconfdir}/gconf/2
171%dir %{_sysconfdir}/gconf/gconf.xml.defaults
172%dir %{_sysconfdir}/gconf/gconf.xml.mandatory
173%dir %{_sysconfdir}/gconf/gconf.xml.system
174%dir %{_sysconfdir}/gconf/schemas
175%{_bindir}/*
176%{_libexecdir}/*
177%{_libdir}/*.so.*
178%dir %{_libdir}/GConf
179%dir %{_libdir}/GConf/2
180%{_libdir}/GConf/2/*.so
181%{_libdir}/girepository-1.0
182%{_mandir}/man1/*
183%{_datadir}/sgml/gconf/gconf-1.0.dtd
184%{_datadir}/GConf
185%{_sysconfdir}/dbus-1/system.d/org.gnome.GConf.Defaults.conf
186%{_datadir}/polkit-1/actions/org.gnome.gconf.defaults.policy
187%{_datadir}/dbus-1/system-services/org.gnome.GConf.Defaults.service
188%{_datadir}/dbus-1/services/org.gnome.GConf.service
189%{_sysconfdir}/xdg/autostart/gsettings-data-convert.desktop
190%{_libdir}/gio/modules/libgsettingsgconfbackend.so
191
192%files devel
193%defattr(-, root, root)
194%{_libdir}/*.so
195%{_includedir}/gconf
196%{_datadir}/aclocal/*.m4
197%{_datadir}/gtk-doc
198%{_datadir}/gir-1.0
199%{_libdir}/pkgconfig/*
200
201%files gtk
202%defattr(-, root, root)
203%{_libexecdir}/gconf-sanity-check-2
204
205%if %{build_compat32}
206%files -n compat32-%{name}
207%defattr(-,root,root,-)
208%{_libdir}/*.so.*
209%dir %{_libdir}/GConf
210%dir %{_libdir}/GConf/2
211%{_libdir}/GConf/2/*.so
212%{_libdir}/girepository-1.0
213%{_libdir}/gio/modules/libgsettingsgconfbackend.so
214
215%files -n compat32-%{name}-devel
216%defattr(-, root, root)
217%{_libdir}/*.so
218%{_libdir}/pkgconfig/*
219
220%endif
221
222%changelog
223* Thu Mar 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-2
224- add gtk subpackage to include gconf-sanity-check-2
225- add --with-gtk=2.0
226
227* Sat Feb 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
228- new upstream release
229
230* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
231- new upstream release
232- add BuildRequires: gobject-introspection-devel
233- create compat32-%{name} package
234
235* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.28.1-2
236- build with rpm-4.8.1-1 for pkg-config file
237
238* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
239- new upstream release
240- drop Patch2, Patch3, Patch4
241
242* Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
243- import upstream patches from fedora
244  - Patch1: gettext fix
245  - Patch2: avoid crash wen gconftool-2 cant read the db
246  - Patch3: make the defaults mechanism use the right polkit actions
247  - Patch4: donot catch segv etc. let abrt catch them
248- build with polkit, add BR: polkit-devel
249
250* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-1
251- new upstream release
252
253* Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
254- add BR: dbus-devel, dbus-glib-devel (<BTS:0700>)
255
256* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
257- new upstream release
258
259* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
260- drop obsolete patch1
261
262* Sun Mar 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.0-2
263- rebuilt with openldap-2.4.11
264
265* Thu Mar 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
266- new upstream release
267
268* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
269- new upstream release
270
271* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.23.2-1
272- new upstream release
273
274* Tue Jul 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.22.0-2
275- spec in UTF-8
276
277* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
278- new upstream release
279
280* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
281- new upstream release
282- removed Prereq: install-info
283
284* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl2
285- rebuild with new environment
286
287* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
288- new upstream release
289
290* Mon Sep 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.14.0-0vl5
291- add BuildRequires: gtk2-devel
292
293* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.14.0-0vl4
294- rebuilt with openldap-2.3.27-0vl1
295
296* Sun Jul 02 2006 Satoshi MACHINO <machino@vinelinux.org> 2.14.0-0vl3
297- rebuilt with openldap-2.3.24-0vl1
298
299* Tue May 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
300- add BuildRequires: openldap-devel
301
302* Sun Mar 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
303- new upstream release
304
305* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl2
306- reload gconf2 when schema is added/removed (patch0 from mdk)
307- only sync db once when installing multiple schemas. (patch1 from fc)
308
309* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl1
310- new upstream release
311
312* Wed Jan 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-0vl1
313- new upstream release
314
315* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
316- new upstream release
317
318* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.92-0vl1
319- new upstream release
320
321* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
322- new upstream release
323
324* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
325- new upstream version
326
327* Thu Nov 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
328- add Japanese summaries and descriptions.
329  thanks to spec file translation project.
330
331* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
332- new upstream release
333
334* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0.1-0vl1
335- new upstream release
336
337* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
338- new upstream release
339
340* Tue Sep 02 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.3-0vl1
341- new upstream release
342
343* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
344- new upstream release
345- fix specfile kanjicode
346
347* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
348- new upstream release
349
350* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90-0vl1
351- new upstream release
352
353* Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
354- build for Vine Linux
355
356* Fri Aug 30 2002 Havoc Pennington <hp@redhat.com>
357- add GCONF_LOCAL_LOCKS mode, and syslog encoding patch from tagoh
358
359* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
360- add dialog to offer to delete gconf locks
361
362* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
363- 1.2.1
364- include libexecdir stuff
365
366* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
367- move .pc fle to -devel package
368
369* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
370- automated rebuild
371
372* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
373- automated rebuild
374
375* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
376- fix warning on gnome-panel install
377
378* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
379- 1.2.0
380- own libdir/GConf/2 directory
381- include gtk-doc docs
382- don't include static lib for backend modules
383
384* Thu Jun 06 2002 Havoc Pennington <hp@redhat.com>
385- rebuild in different environment
386
387* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
388- 1.1.11
389- remove AUTHORS for rpmlint
390
391* Sun May 26 2002 Tim Powers <timp@redhat.com>
392- automated rebuild
393
394* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
395- rebuild in different environment
396
397* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
398- rebuild in different environment
399
400* Thu May  2 2002 Havoc Pennington <hp@redhat.com>
401- 1.1.10
402
403* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
404- 1.1.9
405
406* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
407- 1.1.8
408- remove .la files
409
410* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
411- Version 1.1.6
412- Rebuild for dependencies
413
414* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
415- automated rebuild
416
417* Fri Jan  4 2002 Havoc Pennington <hp@redhat.com>
418- 1.1.5.93 snap with important bugfix so gconf actually works
419
420* Thu Jan  3 2002 Havoc Pennington <hp@redhat.com>
421- 1.1.5.92 snap with GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
422
423* Thu Jan  3 2002 Havoc Pennington <hp@redhat.com>
424- 1.1.5.91 snap with gconf.m4 fix for libgnome
425
426* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
427- since every other build seems to avoid libglib-1.3.so.11,
428  rebuild and hope
429
430* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
431- cvs snap 1.1.5.90
432
433* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
434- GConf 1.1.5, glib 1.3.11
435
436* Sat Oct 27 2001 Havoc Pennington <hp@redhat.com>
437- rebuild for glib 1.3.10
438
439* Sun Oct 14 2001 Havoc Pennington <hp@redhat.com>
440- 1.1.3
441
442* Fri Oct  5 2001 Havoc Pennington <hp@redhat.com>
443- cvs snap, remove bonobo-activation deps
444
445* Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
446- update to new CVS snap, rebuild
447
448* Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
449- create gconf2 rpm based on gconf1, comment out pofiles
450- include .pc files
451
452* Fri Sep 14 2001 Havoc Pennington <hp@redhat.com>
453- fix description/summary
454
455* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
456- Add po files from sources.redhat.com
457
458* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
459- Add po files from sources.redhat.com
460
461* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
462- upgrade to 1.0.4 release I just made
463- fixes #51223, syslog spew
464
465* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
466- move gconf-config to devel RPM
467
468* Mon Jul 23 2001 Havoc Pennington <hp@redhat.com>
469- how many releases of GConf can I make before it works?
470
471* Sun Jul 22 2001 Havoc Pennington <hp@redhat.com>
472- Upgrade to 1.0.2 (which contains only bugfixes that
473  I reviewed and/or wrote myself)
474
475* Wed Jul 18 2001 Havoc Pennington <hp@redhat.com>
476- create the %{_sysconfdir}/gconf/gconf.xml.defaults directory
477
478* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
479- Install the .la files in the devel package.
480
481* Fri Jul  6 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
482- Use %%{_tmppath}
483- Move the .so files to the devel subpackage
484- langify
485- Move changelog to the end, where it should be :)
486- Don't specify (a bad) doc directory
487- Don't define name, version and release and use it in the rpm headers later
488- Remove "Packager:"
489- s/Copyright/License/
490
491* Fri Jun 22 2001 Havoc Pennington <hp@redhat.com>
492- add --direct option to gconftool to avoid spawning oafd,
493  then commented out gconftool entirely since it checks
494  whether gconfd is running and that spawns oafd anyhow.
495  oafd simply needs to exit when unused.
496
497* Tue May 15 2001 Havoc Pennington <hp@redhat.com>
498- Fix post, pointed out by Bill
499
500* Mon May 14 2001 Havoc Pennington <hp@redhat.com>
501- Upgrade to 1.0.1
502
503* Tue Apr 17 2001 Jonathan Blandford <jrb@redhat.com>
504- Import to Red Hat build system.
505
506* Sun Jun 11 2000  Eskil Heyn Olsen <deity@eazel.com>
507
508- Created the .spec file
Note: See TracBrowser for help on using the repository browser.