source: projects/specs/branches/6/E/Eterm/Eterm-vl.spec @ 521

Revision 521, 8.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define ver 0.9
2Summary: Enlightened terminal emulator
3Summary(ja): Enlightened 端末エミュレータ
4Name: Eterm
5Version: %{ver}
6Release: 1%{?_dist_release}
7License: BSD
8Group: User Interface/X
9URL: http://www.eterm.org/
10#Source0: ftp://ftp.eterm.org/pub/Eterm/Eterm-%{ver}.tar.gz
11#Source1: ftp://ftp.eterm.org/pub/Eterm/Eterm-bg-%{ver}.tar.gz
12Source0: http://www.eterm.org/download/Eterm-%{ver}.tar.gz
13Source1: http://www.eterm.org/download/Eterm-bg-%{ver}.tar.gz
14#patch for vine
15Patch100: Eterm-0.9-compoundtext.patch
16Patch101: Eterm-0.9-vinefont.patch
17Patch102: Eterm-0.9-ja_nls.patch
18Patch103: Eterm-0.9-mbwrap.patch
19Patch200: Eterm-0.9-config.sub.patch
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22Requires: xorg-x11-libs
23Requires: imlib >= 1.9.6
24Requires: libpng
25Requires: libtiff
26Requires: libungif
27Requires: zlib
28BuildRequires: xorg-x11-devel
29BuildRequires: imlib-devel >= 1.9.6
30BuildRequires: libpng-devel
31BuildRequires: libtiff-devel
32BuildRequires: libungif-devel
33BuildRequires: zlib-devel
34BuildRequires: desktop-file-utils
35
36%description
37Eterm is a color vt102 terminal emulator with enhanced graphical
38capabilities.  Eterm is intended to be a replacement for xterm for
39Enlightenment window manager users, but it can also be used as a
40replacement for xterm by users without Enlightenment.  Eterm supports
41various themes and is very configurable, in keeping with the
42philosophy of Enlightenment. If you install Eterm, you'll also need to
43have the Imlib library installed.
44
45%description -l ja
46Etermは先進的なグラフィカル機能を持ったvt102カラー端末エミュレータです。
47Etermは、 Enlightenment ウィンドウマネージャ用に、xtermの代替を目的とし
48ていますが、 Enlightenmentなしでも、 代替xtermとして利用することもでき
49ます。Etermはさまざまなテーマをサポートしており、 Enlightenmentの哲学に
50従って 自由に設定することができます。 Etermをインストールするなら、
51Imlibライブラリもインストールする必要があります。
52
53%package backgrounds
54Summary: Backgrounds for Eterm
55Summary(ja): Eterm用背景画像集
56Group: User Interface/X
57Requires: Eterm = %{ver}
58
59%description backgrounds
60Install this package if you want additional backgrounds for Eterm
61
62%description backgrounds -l ja
63Eterm用の追加背景画像が欲しい場合、これをインストールしてください。
64
65%prep
66%setup -q -n Eterm-%{ver} 1
67%patch100 -p1 -b .compoundtext
68%patch101 -p1 -b .vinefont
69%patch102 -p1 -b .ja_nls
70%patch103 -p1
71%patch200 -p1 -b .config.sub
72
73find . -type f -size 0 -print | xargs rm -f
74
75%build
76%configure \
77        --target=%{_arch}-pc-linux-gnu \
78        --enable-multi-charset \
79        --enable-trans \
80        --enable-xim \
81        --without-sense-of-humor
82
83make
84
85
86%install
87rm -rf $RPM_BUILD_ROOT
88mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
89cat > $RPM_BUILD_ROOT%{_datadir}/applications/Eterm.desktop <<EOF
90[Desktop Entry]
91Encoding=UTF-8
92Name=Eterm
93Name[ja]=Eterm 日本語端末
94Comment=Enlightened Terminal
95Comment[ja]=Enlightened 端末エミュレータ
96TryExec=Eterm
97Exec=Eterm
98Icon=gnome-eterm
99Terminal=false
100Type=Application
101Categories=Utility;TerminalEmulator;
102EOF
103chmod 0644 $RPM_BUILD_ROOT%{_datadir}/applications/Eterm.desktop
104desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/Eterm.desktop
105
106mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/wmconfig/
107cat > $RPM_BUILD_ROOT%{_sysconfdir}/X11/wmconfig/Eterm <<EOF
108Eterm name "Eterm"
109Eterm description "A featureful, themeable X11 terminal emulator."
110Eterm exec "Eterm &"
111Eterm group Utilities/Shells
112EOF
113chmod 0644 $RPM_BUILD_ROOT%{_sysconfdir}/X11/wmconfig/Eterm
114
115%makeinstall
116
117( cd $RPM_BUILD_ROOT
118  mv .%{_bindir}/Eterm .%{_bindir}/Eterm-%{ver}
119  cd $RPM_BUILD_ROOT%{_bindir}
120  ln -sf Eterm-%{ver} Eterm
121  cd $RPM_BUILD_ROOT
122  chmod +x .%{_libdir}/lib*so* ||:
123)
124
125(cd $RPM_BUILD_ROOT%{_datadir}/Eterm/pix/ ; \
126 for i in tiled-pixmaps.list scaled-pixmaps.list pixmaps.list ; do \
127  mv $i $i.base ; done)
128
129tar -zxvf %{SOURCE1}
130
131make -C bg all
132%makeinstall -C bg
133
134#get the package listing for Eterm-backgrounds
135echo "%defattr(-,root,root)" > rpm-Eterm-bg-files
136cat > rpm-Eterm-bg-files <<EOF
137%defattr(-,root,root)
138%{_datadir}/Eterm/pix/tiled-pixmaps.list
139%{_datadir}/Eterm/pix/scaled-pixmaps.list
140%{_datadir}/Eterm/pix/pixmaps.list
141EOF
142find ./bg/ -type f -not -name '*.list' -not -name 'Makefile*' \
143       -not -name 'README*' -not -name 014.jpg \
144        -not -name 40.jpg -not -name blackstone.jpg -not -name backwave.jpg \
145        -not -name circuit.jpg -not -name nebula.jpg \
146        -not -name fourthday.jpg -not -name gaia.jpg \
147        -not -name galleon.jpg -not -name night_of_the_dragon.jpg \
148        | sed "s#^\./bg/[scati]*le#%{_datadir}/Eterm/pix#g" >> rpm-Eterm-bg-files
149
150# remove *.la files
151rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
152
153
154%post
155/sbin/ldconfig
156update-desktop-database %{_datadir}/applications
157
158(cd %{_datadir}/Eterm/pix;
159if [ -f tiled-pixmaps.list.base ] ; then
160        for i in tiled-pixmaps.list scaled-pixmaps.list pixmaps.list; do mv -f $i.base $i ; done
161else
162  exit 0
163fi
164)
165
166
167%preun
168for i in tiled-pixmaps.list scaled-pixmaps.list pixmaps.list ; do \
169  rm -f %{_datadir}/Eterm/pix/$i* ; done
170
171%postun
172/sbin/ldconfig
173update-desktop-database %{_datadir}/applications
174
175
176%pre backgrounds
177for i in tiled-pixmaps.list scaled-pixmaps.list pixmaps.list ; do \
178    mv -f %{_datadir}/Eterm/pix/$i %{_datadir}/Eterm/pix/$i.base; done
179
180%preun backgrounds
181for i in tiled-pixmaps.list scaled-pixmaps.list pixmaps.list ; do \
182    mv -f %{_datadir}/Eterm/pix/$i.base %{_datadir}/Eterm/pix/$i ; done
183
184%clean
185rm -rf $RPM_BUILD_ROOT
186
187
188%files
189%defattr(-,root,root)
190%doc doc/Eterm_reference.html doc/Eterm.1.html
191%doc COPYING README ChangeLog
192%config %{_sysconfdir}/X11/wmconfig/Eterm
193%config(missingok) %{_datadir}/Eterm/pix/*.list.base
194%config %{_datadir}/applications/Eterm.desktop
195%{_bindir}/*
196%{_libdir}/*.so
197%{_libdir}/*.a
198%{_mandir}/man1/*
199%dir %{_datadir}/Eterm
200%{_datadir}/Eterm/themes
201%dir %{_datadir}/Eterm/pix
202%{_datadir}/Eterm/pix/014.jpg
203%{_datadir}/Eterm/pix/40.jpg
204%{_datadir}/Eterm/pix/blackstone.jpg
205%{_datadir}/Eterm/pix/backwave.jpg
206%{_datadir}/Eterm/pix/circuit.jpg
207%{_datadir}/Eterm/pix/nebula.jpg
208%{_datadir}/Eterm/pix/fourthday.jpg
209%{_datadir}/Eterm/pix/gaia.jpg
210%{_datadir}/Eterm/pix/galleon.jpg
211%{_datadir}/Eterm/pix/night_of_the_dragon.jpg
212%{_datadir}/Eterm/pix/bar_horizontal_[123].png
213%{_datadir}/Eterm/pix/bar_vertical_[123].png
214%{_datadir}/Eterm/pix/button_arrow_up_[123].png
215%{_datadir}/Eterm/pix/button_arrow_down_[123].png
216%{_datadir}/Eterm/pix/menu[123].png
217
218%files backgrounds -f rpm-Eterm-bg-files
219
220
221%changelog
222* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 0.9-1vl5
223- applied new versioning policy and spec in utf-8
224- added BuildRequires: xorg-x11-devel desktop-file-utils
225- removed %{_libdir}/*.la in %%files
226- moved Eterm.desktop to %%{_datadir}/applications/
227
228* Sat Sep 01 2007 Shu KONNO <owa@bg.wakwak.com> 0.9-0vl8
229- added Patch200: Eterm-0.9-config.sub.patch
230
231* Thu Oct  7 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9-0vl7
232- fixed Requires: and BuildRequires:
233- fixed post and pre scriptlet
234- added /etc/X11/applnk/Utilities/Eterm.desktop
235
236* Thu Sep 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9-0vl6
237- rebuild with new toolchains
238- s/Copyright/License/
239
240* Fri Nov 30 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 0.9-0vl5
241- fixed a bug of multi byte character wrap
242  used rpm macros
243
244* Tue Jul 11 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
245- added ja_nls patch for menu.
246
247* Tue Feb 15 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
248- modify compoundtext patch to fix a bug to write CUT_BUEFFER without COMPOUND_TEXT.
249
250* Sat Jan 29 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
251- making noarch rpm for Eterm-backgrounds
252- added vinefont and compoundtext patches
253
254* Fri Dec 10 1999 Michael Jennings <mej@eterm.org>
255- Added Tim's spec file to CVS as Eterm.spec.in for 0.9
256
257* Wed Dec 8 1999 Tim Powers <timp@redhat.com>
258- using unified patch for utempter and themes from Michael Jennings
259
260* Tue Dec 7 1999 Tim Powers <timp@redhat.com>
261- added wmconfig entry
262- split up into 2 packages, Eterm proper, and Eterm-backgrounds
263- thanks to ewt, we no longer have to make Eterm suid root, uses utempter
264        instead
265
266* Mon Dec 6 1999 Tim Powers <timp@redhat.com>
267- updated to 0.8.10
268- patched so that Eterm finds pix/themes in the right place
269- new version fixes problems with utmp, conforms to Eterm docs.
270- added RedHat.Eterm_suid which includes instructions on how to run Eterm in
271        order to have it seen by "w" and "who" as a regular user
272
273* Fri Aug 20 1999 Tim Powers <timp@redhat.com>
274- fixed roblem with removing all files when uninstalling Eterm.
275
276* Tue Jul 27 1999 Tim Powers <timp@redhat.com>
277- updated version to 0.8.9
278- cleaned up spec
279- updated patch
280- includes new backgrounds
281- built for 6.1
282
283* Mon Apr 05 1999 Michael Maher <mike@redhat.com>
284- update to 0.8.8
285
286* Fri Oct 23 1998 Jeff Johnson <jbj@redhat.com>
287- update to 0.8.7.
288
289* Fri Oct 08 1998 Michael Maher <mike@redhat.com>
290- built eterm
Note: See TracBrowser for help on using the repository browser.