source: projects/specs/branches/6/E/ElectricFence/ElectricFence-vl.spec @ 6356

Revision 6356, 4.0 KB checked in by Takemikaduchi, 12 years ago (diff)

adjtimex,coriander,corosync,cproto,cscope,dbmail,dcraw: new upstream release
others: rebuild

Line 
1Summary: A debugger which detects memory allocation violations.
2Name: ElectricFence
3Version: 2.2.2
4Release: 13%{?_dist_release}
5License: GPL
6Group: Development/Tools
7Source: ftp://ftp.perens.com/pub/ElectricFence/beta/%{name}-%{version}.tar.gz
8Patch1: ElectricFence-2.0.5-longjmp.patch
9Patch2: ElectricFence-2.1-vaarg.patch
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11
12%description
13ElectricFence is a utility for C programming and
14debugging. ElectricFence uses the virtual memory hardware of your
15system to detect when software overruns malloc() buffer boundaries,
16and/or to detect any accesses of memory released by
17free(). ElectricFence will then stop the program on the first
18instruction that caused a bounds violation and you can use your
19favorite debugger to display the offending statement.
20
21Install ElectricFence if you need a debugger to find malloc()
22violations.
23
24
25%prep
26%setup -q
27%patch1 -p1 -b .longjmp
28%patch2 -p1 -b .vaarg
29
30%build
31make CFLAGS='${RPM_OPT_FLAGS} -DUSE_SEMAPHORE -fPIC'
32
33%install
34rm -rf %{buildroot}
35mkdir -p %{buildroot}{%{_bindir},%{_libdir},%{_mandir}/man3}
36
37make    BIN_INSTALL_DIR=%{buildroot}%{_bindir} \
38        LIB_INSTALL_DIR=%{buildroot}%{_libdir} \
39        MAN_INSTALL_DIR=%{buildroot}%{_mandir}/man3 \
40        install
41
42echo ".so man3/efence.3" > %{buildroot}%{_mandir}/man3/libefence.3
43
44%clean
45rm -rf %{buildroot}
46
47%post -p /sbin/ldconfig
48%postun -p /sbin/ldconfig
49
50%files
51%defattr(-,root,root)
52%doc README CHANGES COPYING
53%{_bindir}/*
54%{_libdir}/*
55%{_mandir}/*/*
56
57
58%changelog
59* Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.2-13
60- rebuild with Vine6 environment
61
62* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-12
63- applied new versioning policy
64
65* Fri Aug 24 2007 Shu KONNO <owa@bg.wakwak.com> 2.2.2-11vl3
66- s/Copyright/License/
67
68* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 2.2.2-11vl2
69- rebuild
70
71* Fri Dec 06 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.2-11vl1
72- based on 2.2.2-11 from Rawhide and built for Vine Linux
73
74* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
75- automated rebuild
76
77* Thu May 23 2002 Tim Powers <timp@redhat.com>
78- automated rebuild
79
80* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
81- automated rebuild
82
83* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
84- Bump release + rebuild.
85
86* Thu Nov 16 2000 Tim Powers <timp@redhat.com>
87- use -fPIC, not -fpic, also -DUSE_SEMAPHORE to make it thread safe,
88  as per bug #20935
89
90* Tue Sep 19 2000 Bill Nottingham <notting@redhat.com>
91- use -fpic
92
93* Fri Aug 18 2000 Tim Waugh <twaugh@redhat.com>
94- fix efence.3/libefence.3 confusion (#16412).
95
96* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
97- added ldconfig stuff to ;post and postun
98- added Requires /sbin/ldconfig
99* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
100- automatic rebuild
101
102* Wed Jul 05 2000 Preston Brown <pbrown@redhat.com>
103- back in main distro
104- 2.2.2 version - claimed beta, but no releases in over a year.
105- FHS macros
106
107* Fri May 26 2000 Tim Powers <timp@redhat.com>
108- moved to Powertools
109- fix map page location to be in /usr/share/man
110
111* Tue May 16 2000 Jakub Jelinek <jakub@redhat.com>
112- fix build on ia64
113
114* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
115- fix description
116- man pages are compressed
117
118* Tue Jan  4 2000 Jeff Johnson <jbj@redhat.com>
119- remove ExcludeArch: alpha (#6683).
120
121* Sat Apr 10 1999 Matt Wilson <msw@redhat.com>
122- version 2.1
123
124* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
125- auto rebuild in the new build environment (release 13)
126
127* Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
128- build for glibc 2.1
129
130* Fri Aug 21 1998 Jeff Johnson <jbj@redhat.com>
131- create efence.3 (problem #830)
132
133* Tue Aug  4 1998 Jeff Johnson <jbj@redhat.com>
134- build root
135
136* Mon Jun 01 1998 Prospector System <bugs@redhat.com>
137- translations modified for de
138
139* Mon Jun 01 1998 Prospector System <bugs@redhat.com>
140- need to use sigsetjmp() and siglongjmp() for proper testing
141
142* Fri May 01 1998 Prospector System <bugs@redhat.com>
143- translations modified for de, fr, tr
144
145* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
146- use ExcludeArch instead of Exclude
147
148* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
149- built against glibc
Note: See TracBrowser for help on using the repository browser.