source: projects/setup/trunk/setup.spec @ 8717

Revision 8717, 29.9 KB checked in by daisuke, 10 years ago (diff)

add initial version

RevLine 
[8717]1Summary: A set of system configuration and setup files
2Name: setup
3Version: 2.8.31
4Release: 1%{?dist}
5License: Public Domain
6Group: System Environment/Base
7URL: https://fedorahosted.org/setup/
8Source0: https://fedorahosted.org/releases/s/e/%{name}/%{name}-%{version}.tar.bz2
9BuildArch: noarch
10BuildRequires: bash tcsh perl
11Conflicts: initscripts < 4.26, bash <= 2.0.4-21
12
13%description
14The setup package contains a set of important system configuration and
15setup files, such as passwd, group, and profile.
16
17%prep
18%setup -q
19./shadowconvert.sh
20
21%build
22
23%check
24# Run any sanity checks.
25make check
26
27%install
28rm -rf %{buildroot}
29mkdir -p %{buildroot}/etc/profile.d
30cp -ar * %{buildroot}/etc
31rm -f %{buildroot}/etc/uidgid
32rm -f %{buildroot}/etc/COPYING
33mkdir -p %{buildroot}/var/log
34touch %{buildroot}/var/log/lastlog
35touch %{buildroot}/etc/environment
36chmod 0644 %{buildroot}/etc/environment
37chmod 0400 %{buildroot}/etc/{shadow,gshadow}
38chmod 0644 %{buildroot}/var/log/lastlog
39touch %{buildroot}/etc/fstab
40touch %{buildroot}/etc/mtab
41
42# remove unpackaged files from the buildroot
43rm -f %{buildroot}/etc/Makefile
44rm -f %{buildroot}/etc/serviceslint
45rm -f %{buildroot}/etc/uidgidlint
46rm -f %{buildroot}/etc/shadowconvert.sh
47rm -f %{buildroot}/etc/setup.spec
48
49%clean
50rm -rf %{buildroot}
51
52#throw away useless and dangerous update stuff until rpm will be able to
53#handle it ( http://rpm.org/ticket/6 )
54%post -p <lua>
55for i, name in ipairs({"passwd", "shadow", "group", "gshadow"}) do
56     os.remove("/etc/"..name..".rpmnew")
57end
58if posix.access("/usr/bin/newaliases", "x") then
59  os.execute("/usr/bin/newaliases >/dev/null")
60end
61
62%files
63%defattr(-,root,root,-)
64%doc uidgid COPYING
65%verify(not md5 size mtime) %config(noreplace) /etc/passwd
66%verify(not md5 size mtime) %config(noreplace) /etc/group
67%verify(not md5 size mtime) %attr(0000,root,root) %config(noreplace,missingok) /etc/shadow
68%verify(not md5 size mtime) %attr(0000,root,root) %config(noreplace,missingok) /etc/gshadow
69%config(noreplace) /etc/services
70%verify(not md5 size mtime) %config(noreplace) /etc/exports
71%config(noreplace) /etc/aliases
72%config(noreplace) /etc/environment
73%config(noreplace) /etc/filesystems
74%config(noreplace) /etc/host.conf
75%verify(not md5 size mtime) %config(noreplace) /etc/hosts
76%config(noreplace) /etc/hosts.allow
77%config(noreplace) /etc/hosts.deny
78%verify(not md5 size mtime) %config(noreplace) /etc/motd
79%config(noreplace) /etc/printcap
80%verify(not md5 size mtime) %config(noreplace) /etc/inputrc
81%config(noreplace) /etc/bashrc
82%config(noreplace) /etc/profile
83%config(noreplace) /etc/protocols
84%attr(0600,root,root) %config(noreplace,missingok) /etc/securetty
85%config(noreplace) /etc/csh.login
86%config(noreplace) /etc/csh.cshrc
87%dir /etc/profile.d
88%config(noreplace) %verify(not md5 size mtime) /etc/shells
89%ghost %attr(0644,root,root) %verify(not md5 size mtime) /var/log/lastlog
90%ghost %verify(not md5 size mtime) %config(noreplace,missingok) /etc/fstab
91
92%changelog
93* Mon Jan 24 2011 Ondrej Vasik <ovasik@redhat.com> 2.8.31-1
94- drop ownership of /etc/mtab, now owned by util-linux
95
96* Tue Jan 18 2011 Ondrej Vasik <ovasik@redhat.com> 2.8.30-1
97- remove explicit buildroot
98- reserve uidgid pair 173:173 for abrt(#670231)
99
100* Fri Dec 03 2010 Ondrej Vasik <ovasik@redhat.com> 2.8.29-1
101- run newaliases in the post to prevent sendmail messages
102  about old alias database in the log(#658921)
103
104* Fri Nov 12 2010 Ondrej Vasik <ovasik@redhat.com> 2.8.28-1
105- update services and protocols to latest IANA reservations
106- reserve uidgid pair 109:109 for rhevm(#652287)
107
108* Tue Sep 07 2010 Ondrej Vasik <ovasik@redhat.com> 2.8.27-1
109- add double quotes arround sourced profile.d scripts -
110  allow special characters in script names
111
112* Wed Aug 18 2010 Ondrej Vasik <ovasik@redhat.com> 2.8.26-1
113- fix regression in the change to printf(#624900)
114
115* Thu Aug 12 2010 Ondrej Vasik <ovasik@redhat.com> 2.8.25-1
116- use printf instead of echo in bashrc scripts(#620435)
117- update services to latest IANA
118
119* Wed Jul 28 2010 Ondrej Vasik <ovasik@redhat.com> 2.8.24-1
120- do show messages from profile.d scripts in interactive
121  login ksh shell(#616418)
122- respect umask settings even with login shell
123
124* Tue Jun 29 2010 Ondrej Vasik <ovasik@redhat.com> 2.8.23-1
125- reserve uidgid pair 172:172 for rtkit (#609171)
126
127* Tue Jun 15 2010 Ondrej Vasik <ovasik@redhat.com> 2.8.22-1
128- reserve uidgid pair 170:170 for avahi-autoipd
129- reserve uidgid pair 171:171 for pulse (pulseaudio)
130- update reserved homedir for avahi
131
132* Mon Jun 07 2010 Ondrej Vasik <ovasik@redhat.com> 2.8.21-1
133- update name of group reserved by cyrus-imapd to saslauth
134
135* Mon May 24 2010 Ondrej Vasik <ovasik@redhat.com> 2.8.20-1
136- speedup pathmunge() by using portable case(#544652)
137
138* Wed May 19 2010 Ondrej Vasik <ovasik@redhat.com> 2.8.19-1
139- fix syntax error in bashrc pathmunge(since bash 3.2)(#592799)
140
141* Tue Apr 27 2010 Ondrej Vasik <ovasik@redhat.com> 2.8.18-1
142- reserve uidgid pair 140:140 for ricci daemon(#585957)
143- reserve uidgid pair 141:141 for luci daemon(#585958)
144
145* Wed Mar 31 2010 Ondrej Vasik <ovasik@redhat.com> 2.8.17-1
146- verify md5sum/size/mtime in the case of /etc/hosts.allow
147  and /etc/hosts.deny (#578263)
148- do the same for /etc/services and /etc/protocols, we
149  provide (almost) complete IANA set, so no reason to modify
150  it in most cases outside of setup package
151
152* Fri Mar 26 2010 Ondrej Vasik <ovasik@redhat.com> 2.8.16-3
153- bad ugly double-thirteen friday(fix previous badfix)
154
155* Fri Mar 26 2010 Ondrej Vasik <ovasik@redhat.com> 2.8.16-2
156- fix not set path for csh shell caused by 2.8.16 update
157
158* Fri Mar 26 2010 Ondrej Vasik <ovasik@redhat.com> 2.8.16-1
159- drop X11R6 hierarchy dir from tcsh path (#576940)
160- update services to latest IANA
161- update protocols to latest IANA
162
163* Thu Jan 21 2010 Ondrej Vasik <ovasik@redhat.com> 2.8.15-1
164- reserve uidgid pair 155:155 for stap-server(#555813)
165- reserve uidgid pair 113:113 for usbmuxd(#556525)
166
167* Tue Jan 12 2010 Ondrej Vasik <ovasik@redhat.com> 2.8.14-1
168- reserve uidgid pair 133:133 for bacula(#554705)
169
170* Tue Jan 05 2010 Ondrej Vasik <ovasik@redhat.com> 2.8.13-1
171- update services to latest IANA
172- avoid one /usr/bin/id stat call in /etc/profile(#549056)
173
174* Thu Dec 17 2009 Ondrej Vasik <ovasik@redhat.com> 2.8.12-1
175- speed up pathmunge inside bashrc (#544652)
176- do not use deprecated egrep in profile
177
178* Thu Dec 03 2009 Ondrej Vasik <ovasik@redhat.com> 2.8.11-1
179- don't have HISTCONTROL ignorespace by default (#520632),
180  but do not override it when it is already set
181- add csync alias for port 2005 / tcp, udp
182
183* Wed Nov 11 2009 Ondrej Vasik <ovasik@redhat.com> 2.8.10-1
184- reserve uidgid pair 112:112 for vhostmd (#534110)
185- update /etc/services to latest IANA
186
187* Tue Sep 08 2009 Ondrej Vasik <ovasik@redhat.com> 2.8.9-1
188- reserve uidgid pair 108:108 for ovirt from libvirt (#513261)
189- reserve uidgid pair 111:111 for saned from sane-backends
190  (#520634)
191
192* Mon Aug 17 2009 Ondrej Vasik <ovasik@redhat.com> 2.8.8-1
193- change permissions on /etc/shadow and /etc/gshadow to 0000 and
194  use capabilities for them(#517577)
195
196* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.7-2
197- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
198
199* Tue Jul 21 2009 Ondrej Vasik <ovasik@redhat.com> 2.8.7-1
200- increase threshold for uidgid reservations to 200
201- reserve uidgid pair 107:107 for qemu (libvirt,#511957)
202- reflect threshold in profile and bashrc, do inform about
203  uidgid file existence there
204- remove old remnants about portmap from hosts.deny(#509919)
205
206* Mon Jun 29 2009 Ondrej Vasik <ovasik@redhat.com> 2.8.6-1
207- update protocols and services to latest IANA
208- add example for tty in prompt(#503304)
209
210* Wed May 20 2009 Ondrej Vasik <ovasik@redhat.com> 2.8.5-1
211- use history-search-backward/forward for pageup/pagedown
212  mapping in inputrc (#500989)
213- add HISTCONTROL="ignoreboth" to /etc/profile to not include
214  duplicities and lines starting with space into the history
215  (#500819)
216
217* Tue May 12 2009 Ondrej Vasik <ovasik@redhat.com> 2.8.4-1
218- add oprofile (16:16) to uidgid
219- use os.remove instead of os.execute in lua post
220  - no dependency on /bin/sh (thanks Panu Matilainen)
221
222* Wed Apr 22 2009 Ondrej Vasik <ovasik@redhat.com> 2.8.3-2
223- rewrite postun scriptlet to <lua> to prevent /bin/sh
224  dependency
225
226* Fri Apr 10 2009 Ondrej Vasik <ovasik@redhat.com> 2.8.3-1
227- do not disable coredumps in profile/csh.cshrc scripts,
228  coredumps already disabled in rawhide's RLIMIT_CORE(#495035)
229
230* Wed Mar 25 2009 Ondrej Vasik <ovasik@redhat.com> 2.8.2-2
231- reserve uid 65 for nslcd (will share group 55 ldap, #491899)
232
233* Tue Mar 24 2009 Ondrej Vasik <ovasik@redhat.com> 2.8.2-1
234- ship COPYING file, update protocols and services
235  to latest IANA
236
237* Mon Mar 23 2009 Ondrej Vasik <ovasik@redhat.com> 2.8.1-2
238- fix sources syntax, add sources URL (#226412)
239
240* Thu Feb 26 2009 Ondrej Vasik <ovasik@redhat.com> 2.8.1-1
241- do ship/generate /etc/{shadow,gshadow} files(#483251)
242- do ship default /etc/hosts with setup (#483244)
243- activate multi on (required for IPv6 only localhost
244  recognition out-of-the-box) (#486461)
245- added postun section for cleaning of dangerous .rpmnew
246  files after updates
247- make profile and bashrc more portable (ksh, #487419)
248
249* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.7-5
250- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
251
252* Mon Feb 02 2009 Ondrej Vasik <ovasik@redhat.com> 2.7.7-4
253- drop <lua> scriptlet completely(audio/video group
254  temporarily created by packages which use it for
255  updates(#477769))
256
257* Fri Jan 30 2009 Ondrej Vasik <ovasik@redhat.com> 2.7.7-3
258- add support for ctrl+arrow shortcut in rxvt(#474110)
259
260* Thu Jan 29 2009 Ondrej Vasik <ovasik@redhat.com> 2.7.7-2
261- reserve 87 gid for polkituser (just uid was reserved),
262  reserve 18 gid for dialout(to prevent conflicts with
263  polkituser gid)
264
265* Thu Jan 22 2009 Ondrej Vasik <ovasik@redhat.com> 2.7.7-1
266- synchronize /etc/services with latest IANA, do not use
267  tabs in that file to have consistent output
268- fix indentation in /etc/profile and /etc/bashrc
269  (#481074)
270- assign uid 36 for vdsm, gid 36 for kvm
271  (#346151,#481021)
272
273* Tue Jan 20 2009 Ondrej Vasik <ovasik@redhat.com> 2.7.6-1
274- make uidgid file better parsable (synchronize tabs)
275- reserve gid 11 for group cdrom (udev,MAKEDEV)
276- reserve gid 33 for group tape (udev,MAKEDEV)
277- reserve gid 87 for group dialout (udev,MAKEDEV)
278
279* Tue Jan 06 2009 Ondrej Vasik <ovasik@redhat.com> 2.7.5-4
280- use lua language in post to prevent additional
281  dependencies
282
283* Thu Dec 18 2008 Ondrej Vasik <ovasik@redhat.com> 2.7.5-3
284- add pkiuser (17:17) to uidgid
285- temporarily create video/audio group in post section
286  (#476886)
287
288* Wed Dec 10 2008 Ondrej Vasik <ovasik@redhat.com> 2.7.5-2
289- do not export PATH twice(#449286 NOTABUG revert)
290- do not export INPUTRC(to respect just created ~/.inputrc)
291  (#443717)
292
293* Thu Nov 27 2008 Ondrej Vasik <ovasik@redhat.com> 2.7.5-1
294- Modified upstream URL, synchronized with upstream git
295
296* Wed Nov 19 2008 Ondrej Vasik <ovasik@redhat.com> 2.7.4-3
297- update protocols to latest IANA list (2008-04-18)
298- update services to latest IANA list (2008-11-17)
299- mark /etc/protocols and /etc/inputrc %%config(noreplace)
300- added URL, fixed few rpmlint warnings
301- do own audio and video group (#458843), create it in default
302  /etc/group
303
304* Tue Nov 18 2008 Ondrej Vasik <ovasik@redhat.com> 2.7.4-2
305- again process profile.d scripts in noninteractive shells,
306  but do not display stderr/stdout messages(#457243)
307- fix wrong prompt for csh/tcsh (#443854)
308- don't show error message about missing hostname in profile
309  (#301481)
310- reserve rquotad port 875 in /etc/services (#455859)
311- export PATH after processing profile.d scripts (#449286)
312- assign gid's for audio (:63) and video (:39) group(#458843),
313  assign uidgid pair (52:52) for puppet (#471918)
314- fix /etc/services duplicities to pass serviceslint
315
316* Thu Oct 09 2008 Phil Knirsch <pknirsch@redhat.com> 2.7.4-1
317- Include new serviceslint for speedup (#465642)
318- Cleaned up services due to newly discovered bugs in it with new serviceslint
319
320* Wed Sep 03 2008 Phil Knirsch <pknirsch@redhat.com> 2.7.3-1
321- Added SBinSanity patch as an approved feature (#458176)
322
323* Wed Aug 06 2008 Phil Knirsch <pknirsch@redhat.com> 2.7.2-1
324- Added uidgid pair for condor
325- Added uidgid pair for trousers
326
327* Fri Jul 25 2008 Phil Knirsch <pknirsch@redhat.com> 2.7.1-1
328- Bump to 2.7.1 to avoid version problems with F-9
329- Removed group news as well (#437462)
330
331* Tue Jun 17 2008 Phil Knirsch <pknirsch@redhat.com> 2.6.16-1
332- Dropped user news from default /etc/passwd (#437462)
333
334* Thu Jun 05 2008 Phil Knirsch <pknirsch@redhat.com> 2.6.15-1
335- Added prelude-manager and snortd to uidgid list
336
337* Mon Apr 07 2008 Phil Knirsch <pknirsch@redhat.com> 2.6.14-1
338- Updated /etc/services to latest IANA version (#315571)
339
340* Fri Apr 04 2008 Phil Knirsch <pknirsch@redhat.com>
341- Fixed a problem with the new prompt for tcsh and screen terminal (#438550)
342
343* Thu Mar 20 2008 Phil Knirsch <pknirsch@redhat.com> 2.6.13-1
344- Drop the wrong precmd for csh for xterm and screen terminals
345
346* Tue Feb 26 2008 Phil Knirsch <pknirsch@redhat.com> 2.6.12-1
347- Corrected wrong /etc/profile.d behaviour for non-interactive bash and tcsh
348
349* Fri Feb 22 2008 Phil Knirsch <pknirsch@redhat.com> 2.6.11-1
350- Fixed problem with /etc/profile.d/* and non-interactive tcsh (#299221)
351- Fixed xterm -title problem (#387581)
352- Fixed problem with /etc/profile.d/*.csh not being executed for none loginshells anymore
353  (#381631, #429838)
354- Corrected missing shell for news user in uidgid and passwd
355
356* Thu Aug 16 2007 Phil Knirsch <pknirsch@redhat.com> 2.6.10-1
357- License review and update
358
359* Tue Jul 24 2007 Phil Knirsch <pknirsch@redhat.com> 2.6.9-1
360- Assigned uid 87 for PolicyKit package (#244950)
361- Fixed precmd fix if TERM isn't set (#242732)
362
363* Wed Jun 06 2007 Phil Knirsch <pknirsch@redhat.com> 2.6.7-1
364- Fixed precmd setting to behave like bash for (t)csh (#242732)
365
366* Thu May 24 2007 Phil Knirsch <pknirsch@redhat.com> 2.6.6-1
367- Added another set of proposed changes to /etc/csh.cshrc (#199817)
368- Added missing documentation in /etc/hosts.[allow|deny] (#157053)
369
370* Wed May 23 2007 Phil Knirsch <pknirsch@redhat.com> 2.6.5-1
371- Fixed tcsh behaviour for non login shells (#191233)
372- Fixed umask setting for tcsh to behave identical to bash logins (#199817)
373- Added ipv6-crypt and ipv6-auth for backwards compatibility (#210546)
374
375* Wed Apr 18 2007 Phil Knirsch <pknirsch@redhat.com> 2.6.4-1
376- Modified the 111/[tcp/udp] entries to work with rpcbind (#236639)
377
378* Mon Mar 12 2007 Phil Knirsch <pknirsch@redhat.com> 2.6.3-1
379- Changed winbind_auth to wbpriv by request of the samba maintainer
380
381* Tue Dec 12 2006 Phil Knirsch <pknirsch@redhat.com> 2.6.2-1.fc7
382- Updated uidgid for split of pcap into arpwatcher and tcpdump.
383
384* Tue Nov 28 2006 Phil Knirsch <pknirsch@redhat.com> 2.6.1-1.fc7
385- Update version and rebuilt
386
387* Tue Nov 28 2006 Phil Knirsch <pknirsch@redhat.com> 2.5.57-1
388- Revert change for umask in /etc/bashrc (#217523)
389
390* Thu Nov 16 2006 Phil Knirsch <pknirsch@redhat.com> 2.5.56-1
391- Added an entry for samba and winbind_auth
392
393* Wed Oct 11 2006 Phil Knirsch <pknirsch@redhat.com> 2.5.55-1
394- Extended the protocols to include the missing hopopt (#209191)
395
396* Tue Oct 10 2006 Phil Knirsch <pknirsch@redhat.com> 2.5.54-1
397- Update /etc/protocols to latest officiall IANA version (#209191)
398
399* Thu Jul 27 2006 Phil Knirsch <pknirsch@redhat.com> 2.5.53-1
400- Added utempter gid for new libutempter package (#200240)
401
402* Mon Jun 19 2006 Phil Knirsch <pknirsch@redhat.com> 2.5.52-1
403- Lock password for root account by default (#182206)
404
405* Wed May 03 2006 Karsten Hopp <karsten@redhat.de>
406- remove gkrellmd from the reserved uid/gid list (#186974)
407
408* Tue Mar 21 2006 Florian La Roche <laroche@redhat.com> 2.5.50-1
409- use stricter umask of 022 for all logins
410
411* Thu Feb 23 2006 Phil Knirsch <pknirsch@redhat.com> 2.5.49-1
412- Really switch to new /etc/services file
413- Added /etc/fstab and /etc/mtab to ownership of setup (#177061)
414
415* Tue Jan 31 2006 Phil Knirsch <pknirsch@redhat.com> 2.5.48-1
416- Switched to the new large /etc/services file which fixes #112298, #133683,
417  #166443, #168872, #171228.
418- Fixed pathmunge problem with bashrc (#123621)
419- Removed /usr/X11R6/bin from default PATH (#173856)
420
421* Tue Jan 24 2006 Phil Knirsch <pknirsch@redhat.com>
422- Fixed bug with PROMPT_COMMAND being broken for wierd dirs (#142125)
423- Added hfsplus to know filesystems (#172820)
424
425* Mon Oct 17 2005 Bill Nottingham <notting@redhat.com>
426- make motd noreplace (#170539)
427
428* Tue Sep  6 2005 Bill Nottingham <notting@redhat.com> 2.5.47-1
429- make lastlog 0644  (#167200)
430
431* Mon Jun 20 2005 Bill Nottingham <notting@redhat.com> 2.5.46-1
432- add buildrequires on bash, tcsh (#161016)
433- move core dump size setting from csh.login to csh.cshrc (#156914)
434
435* Fri Jun 17 2005 Bill Nottingham <notting@redhat.com> 2.5.45-1
436- ksh doesn't implement EUID/UID. Work around that. (#160731)
437
438* Thu May 19 2005 Bill Nottingham <notting@redhat.com> 2.5.44-1
439- fix csh.cshrc when -e is used (#158265)
440
441* Mon Apr 25 2005 Bill Nottingham <notting@redhat.com> 2.5.43-1
442- remove mailman aliases (#155841)
443
444* Mon Apr 18 2005 Bill Nottingham <notting@redhat.com> 2.5.42-1
445- fix lastlog conflict (#155256)
446
447* Fri Apr 15 2005 Bill Nottingham <notting@redhat.com> 2.5.41-1
448- get rid of 'id' error messages if there is no /usr (#142707)
449
450* Mon Jan 31 2005 Bill Nottingham <notting@redhat.com> 2.5.40-1
451- have similar prompt changes for su to root in tcsh as in bash (#143826)
452
453* Tue Nov 23 2004 Bill Nottingham <notting@redhat.com> 2.5.39-1
454- ghost lastlog (#139539)
455
456* Thu Nov 18 2004 Bill Nottingham <notting@redhat.com> 2.5.38-1
457- fix bash/tcsh coredump size inconsistency (#139821)
458
459* Wed Oct 27 2004 Bill Nottingham <notting@redhat.com> 2.5.37-1
460- fix inconsistency in profile.d handling (#136859, <agrajag@dragaera.net>)
461
462* Fri Oct  8 2004 Bill Nottingham <notting@redhat.com> 2.5.36-1
463- fix duplicate alias
464
465* Tue Sep 28 2004 Bill Nottingham <notting@redhat.com> 2.5.35-1
466- add /etc/environment
467
468* Mon Sep 27 2004 Rik van Riel <riel@redhat.com> 2.5.34-2
469- mark /etc/services config(noreplace) (#133683)
470
471* Thu Sep 23 2004 Bill Nottingham <notting@redhat.com> 2.5.34-1
472- add dict (#107807)
473- add cyrus services (#118832)
474- move delete-char binding for csh (#113682)
475- do the same path munging for csh as for bash (#57708)
476- add postfix aliases (#117661)
477- fix bashrc login shell check (#104491)
478- add odmr to services (#101098)
479- add distcc to services (#91535)
480- add xterm forware/backward word bindings (#80860)
481
482* Mon May 24 2004 Bill Nottingham <notting@redhat.com>
483- make pathmunge available for profile.d scripts (#123621)
484
485* Wed May 19 2004 Joe Orton <jorton@redhat.com> 2.5.33-2
486- add IANA Register Port for svn to /etc/services (#122863)
487
488* Wed May  5 2004 Nalin Dahyabhai <nalin@redhat.com> 2.5.33-1
489- fix syntax error in csh.cshrc
490
491* Tue May  4 2004 Bill Nottingham <notting@redhat.com> 2.5.32-1
492- set MAIL in csh.cshrc (#115376)
493- fix inputrc check in csh.login (#115073)
494
495* Mon Jan 26 2004 Bill Nottingham <notting@redhat.com> 2.5.31-1
496- move /etc/aliases here
497
498* Mon Dec  8 2003 Bill Nottingham <notting@redhat.com> 2.5.30-1
499- remove stty `tput kbs` section (#91357)
500
501* Tue Sep  2 2003 Bill Nottingham <notting@redhat.com> 2.5.27-1
502- securetty should be noreplace (#103585)
503
504* Fri Mar 14 2003 Bill Nottingham <notting@redhat.com> 2.5.26-1
505- clean up some typos in /etc/services (#86129)
506
507* Mon Feb 17 2003 Florian La Roche <Florian.LaRoche@redhat.de>
508- add "console" to /etc/securetty for mainframe
509
510* Mon Jan 20 2003 Nalin Dahyabhai <nalin@redhat.com> 2.5.24-1
511- allocate uid/gid for mgetty
512
513* Thu Jan  9 2003 Dan Walsh <dwalsh@redhat.com> 2.5.23-1
514- added PXE to /etc/services
515
516* Wed Jan  1 2003 Bill Nottingham <notting@redhat.com> 2.5.22-1
517- remove bogus entries from inputrc (#80652)
518
519* Fri Nov 29 2002 Tim Powers <timp@redhat.com> 2.5.21-1
520- remove unpackaged files from the buildroot
521
522* Thu Aug 29 2002 Bill Nottingham <notting@redhat.com> 2.5.20-1
523- shopt -s checkwinsize everywhere
524
525* Wed Aug 28 2002 Preston Brown <pbrown@redhat.com> 2.5.19-1
526- fix bug #61129 (~ substitution)
527
528* Wed Aug 15 2002 Jens Petersen <petersen@redhat.com> 2.5.18-1
529- bring back the screen case in /etc/bashrc, since /etc/screenrc no
530  longer sets defhstatus (#60596, #60597)
531
532* Sun Aug 11 2002 Florian La Roche <Florian.LaRoche@redhat.de> 2.5.17-1
533- add "set mark-symlinked-directories on" to /etc/inputrc
534
535* Mon Jul 22 2002 Phil Knirsch <pknirsch@redhat.com> 2.5.16-2
536- Added shopt -s checkwinsize to /etc/bashrc for xterm resizing
537
538* Fri Jul 19 2002 Jens Petersen <petersen@redhat.com> 2.5.16-1
539- dont special case screen in /etc/bashrc, since it overrides the user's
540  screenrc title setting (#60596)
541
542* Thu Jul 18 2002 Florian La Roche <Florian.LaRoche@redhat.de> 2.5.14-1
543- move home dir of "news" to /etc/news
544
545* Tue May 28 2002 Nalin Dahyabhai <nalin@redhat.com> 2.5.13-1
546- allocate uid/gid for privilege-separated sshd
547
548* Thu May 23 2002 Tim Powers <timp@redhat.com> 2.5.12-2
549- automated rebuild
550
551* Wed Apr  3 2002 Bill Nottingham <notting@redhat.com> 2.5.12-1
552- fix misformatted comment in /etc/services, allocate uid/gid for
553  frontpage
554
555* Thu Mar 28 2002 Bill Nottingham <notting@redhat.com> 2.5.11-1
556- add newline in /etc/shells (#62271)
557
558* Thu Mar 28 2002 Nalin Dahyabhai <nalin@redhat.com> 2.5.10-1
559- allocate uid for the vcsa user
560
561* Tue Mar 12 2002 Bill Nottingham <notting@redhat.com> 2.5.9-1
562- re-add ext3 to /etc/filesystems
563
564* Mon Mar 11 2002 Bill Nottingham <notting@redhat.com> 2.5.8-1
565- add nologin to /etc/shells (#53963)
566- fix some quoting issues (#59627)
567- fix screen status line (#60596)
568- fix path regexps (#59624)
569- move profile.d stuff to csh.cshrc (#59946)
570
571* Fri Mar  8 2002 Nalin Dahyabhai <nalin@redhat.com>
572- add bprd, bpdbm, bpjava-msvc, vnetd, bpcd, and vopied to /etc/services
573
574* Tue Sep 25 2001 Nalin Dahyabhai <nalin@redhat.com>
575- change rmtcfg to an alias for bvcontrol, which is a registered name
576
577* Mon Sep 17 2001 Nalin Dahyabhai <nalin@redhat.com> 2.5.7-1
578- add entries to services (ipp, wnn4, and so on)
579- try to remove duplicates in services (remove nameserver as alias for domain,
580  and readnews as alias for netnews)
581
582* Mon Aug 20 2001 Bill Nottingham <notting@redhat.com>
583- change FTP user's home dir to /var/ftp (#52091)
584- %%ghost /etc/shadow, /etc/gshadow
585
586* Fri Aug 17 2001 Bill Nottingham <notting@redhat.com>
587- add /etc/shells to filelist (#51813)
588
589* Mon Aug 13 2001 Bill Nottingham <notting@redhat.com>
590- put lock in /etc/group (#51654)
591
592* Wed Aug  8 2001 Bill Nottingham <notting@redhat.com>
593- lock only needs to be a gid
594- don't set dspmbyte=euc here; do it in lang.csh, and only if necessary (#50318)
595
596* Mon Aug  6 2001 Jeff Johnson <jbj@redhat.com>
597- add lock.lock uid/gid 54 to own /var/lock directory.
598
599* Thu Jul 19 2001 Bill Nottingham <notting@redhat.com>
600- add forward/backward-word mappings (#48783)
601- add pgpkeyserver port to /etc/services (#49407)
602
603* Thu Jul 19 2001 Preston Brown <pbrown@redhat.com>
604- core files disabled by default.  Developers can enable them.
605
606* Fri Jul 13 2001 Bill Nottingham <notting@redhat.com> 2.5.1-1
607- revert news user back to no shell (#48701)
608
609* Tue Jul 10 2001 Bill Nottingham <notting@redhat.com> 2.5.0-1
610- move profile.d parsing from csh.cshrc to csh.login (#47417)
611
612* Sat Jul  7 2001 Nalin Dahyabhai <nalin@redhat.com> 2.4.15-1
613- reorder /etc/services to match comments again
614- protocol 118 is stp, not st
615- update URLs in /etc/protocols and /etc/services
616
617* Thu Jul  5 2001 Preston Brown <pbrown@redhat.com> 2.4.14-1
618- put */sbin in path if user ID is 0.
619
620* Mon Jun 25 2001 Bill Nottingham <notting@redhat.com>
621- add an entry to /etc/services for ssh X11 forwarding (#44944)
622
623* Wed Jun 13 2001 Bill Nottingham <notting@redhat.com>
624- take ttyS0 out of securetty on main tree
625
626* Tue Jun 12 2001 Philip Copeland <bryce@redhat.com>
627- added ttyS0 to securetty for serial console usage
628
629* Tue Jun 12 2001 Bill Nottingham <notting@redhat.com>
630- add rndc to /etc/services (#40265)
631- test for read bit, not execute bit, for profile.d (#35714)
632
633* Sun Jun 03 2001 Florian La Roche <Florian.LaRoche@redhat.de>
634- add "canna" entry to /etc/services
635
636* Mon May 21 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.4.10-1
637- Fix bugs #24159 and #30634 again; whoever moved bashrc from bash
638  to setup used an old version. :((
639
640* Wed May  2 2001 Preston Brown <pbrown@redhat.com> 2.4.9-1
641- bashrc moved here from bash package
642- set umask in bashrc, so it applies for ALL shells.
643
644* Fri Apr 27 2001 Preston Brown <pbrown@redhat.com> 2.4.8-1
645- /sbin/nologin for accounts that aren't "real."
646
647* Sat Apr  7 2001 Preston Brown <pbrown@redhat.com>
648- revert control-arrow forward/backward word (broken)
649
650* Tue Mar 27 2001 Preston Brown <pbrown@redhat.com>
651- fix japanese input with tcsh (#33211)
652
653* Tue Mar  6 2001 Bill Nottingham <notting@redhat.com>
654- fix some weirdness with rxvt (#30799)
655
656* Wed Feb 28 2001 Bill Nottingham <notting@redhat.com>
657- add SKK input method (#29759)
658
659* Fri Feb 23 2001 Preston Brown <pbrown@redhat.com>
660
661* Wed Feb 21 2001 Bill Nottingham <notting@redhat.com>
662- fix inputrc, Yet Again. (#28617)
663
664* Thu Feb 15 2001 Bill Nottingham <notting@redhat.com>
665- add in uidgid file, put it in %%doc
666
667* Wed Feb  7 2001 Adrian Havill <havill@redhat.com>
668- bindkey for delete in the case of tcsh
669
670* Wed Feb  7 2001 Bill Nottingham <notting@redhat.com>
671- add some more stuff to /etc/services (#25396, patch from
672  <pekkas@netcore.fi>)
673
674* Tue Feb  6 2001 Nalin Dahyabhai <nalin@redhat.com>
675- add gii/tcp = 616 for gated
676
677* Tue Jan 30 2001 Bill Nottingham <notting@redhat.com>
678- wrap some inputrc settings with tests for mode, term (#24117)
679
680* Mon Jan 29 2001 Bill Nottingham <notting@redhat.com>
681- overhaul /etc/protocols (#18530)
682- add port 587 to /etc/services (#25001)
683- add corbaloc (#19581)
684- don't set /usr/X11R6/bin in $PATH if it's already set (#19968)
685
686* Fri Dec  1 2000 Nalin Dahyabhai <nalin@redhat.com>
687- Clean up /etc/services, separating registered numbers from unregistered
688  ("squatted") numbers, and adding some.
689
690* Mon Nov 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
691- Add smtps (465/tcp) and submission (587/tcp) to /etc/services for TLS
692  support (postfix >= 20001030-2)
693
694* Sun Aug  6 2000 Bill Nottingham <notting@redhat.com>
695- /var/log/lastlog is %%config(noreplace) (#15412)
696- some of the various %%verify changes (#14819)
697
698* Thu Aug  3 2000 Nalin Dahyabhai <nalin@redhat.com>
699- linuxconf should be 98, not 99
700
701* Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
702- fix some of the csh stuff (#14622)
703
704* Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
705- stop setting "multi on" in /etc/host.conf
706
707* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
708- automatic rebuild
709
710* Tue Jun 27 2000 Bill Nottingham <notting@redhat.com>
711- add hfs filesystem
712
713* Wed Jun 21 2000 Preston Brown <pbrown@redhat.com>
714- printcap is a noreplace file now
715
716* Sun Jun 18 2000 Bill Nottingham <notting@redhat.com>
717- fix typo
718
719* Tue Jun 13 2000 Nalin Dahyabhai <nalin@redhat.com>
720- add linuxconf/tcp = 99 to /etc/services
721
722* Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
723- add some stuff to /etc/services
724- tweak ulimit call again
725
726* Tue Jun  6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
727- homedir of ftp is now /var/ftp
728
729* Sun May 14 2000 Nalin Dahyabhai <nalin@redhat.com>
730- move profile.d logic in csh.login to csh.cshrc
731
732* Tue Apr 18 2000 Nalin Dahyabhai <nalin@redhat.com>
733- redirect ulimit -S -c to /dev/null to avoid clutter
734
735* Thu Apr 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
736- s/ulimit -c/ulimit -S -c/ - bash 2.x adaption
737
738* Mon Apr 03 2000 Nalin Dahyabhai <nalin@redhat.com>
739- Add more of the kerberos-related services from IANA's registry and krb5
740
741* Wed Mar 29 2000 Bernhard Rosenkraenzer <bero@redhat.com>
742- Add 2.4'ish vc/* devices to securetty
743
744* Thu Feb 17 2000 Preston Brown <pbrown@redhat.com>
745- add /etc/filesystems with sane defaults
746
747* Wed Feb 16 2000 Bill Nottingham <notting@redhat.com>
748- don't set prompt in /etc/profile (it's done in /etc/bashrc)
749
750* Fri Feb  5 2000 Bill Nottingham <notting@redhat.com>
751- yet more inputrc tweaks from Hans de Goede (hans@highrise.nl)
752
753* Sun Jan 30 2000 Bill Nottingham <notting@redhat.com>
754- yet more inputrc tweaks from Hans de Goede (hans@highrise.nl)
755
756* Sun Jan 23 2000 Bill Nottingham <notting@redhat.com>
757- fix mailq line. (#7140)
758
759* Fri Jan 21 2000 Bill Nottingham <notting@redhat.com>
760- add ldap to /etc/services
761
762* Tue Jan 18 2000 Bill Nottingham <notting@redhat.com>
763- kill HISTFILESIZE, it's broken
764
765* Tue Jan 18 2000 Preston Brown <pbrown@redhat.com>
766- some inputrc tweaks
767
768* Wed Jan 12 2000 Bill Nottingham <notting@redhat.com>
769- make some more stuff noreplace
770
771* Fri Nov 19 1999 Bill Nottingham <notting@redhat.com>
772- fix mailq line. (#7140)
773
774* Fri Oct 29 1999 Bill Nottingham <notting@redhat.com>
775- split csh.login into csh.login and csh.cshrc (#various)
776- fix pop service names (#6206)
777- fix ipv6 protocols entries (#6219)
778
779* Thu Sep  2 1999 Jeff Johnson <jbj@redhat.com>
780- rename /etc/csh.cshrc to /etc/csh.login (#2931).
781- (note: modified /etc/csh.cshrc should end up in /etc/csh.cshrc.rpmsave)
782
783* Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
784- add defattr.
785- fix limit command in /etc/csh.cshrc (#4582).
786
787* Thu Jul  8 1999 Bill Nottingham <notting@redhat.com>
788- move /etc/inputrc here.
789
790* Mon Apr 19 1999 Bill Nottingham <notting@redhat.com>
791- always use /etc/inputrc
792
793* Wed Mar 31 1999 Preston Brown <pbrown@redhat.com>
794- added alias pointing to imap from imap2
795
796* Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
797- updated protocols/services from debian to comply with more modern
798- IETF/RFC standards
799
800* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
801- auto rebuild in the new build environment (release 4)
802
803* Thu Feb 18 1999 Jeff Johnson <jbj@redhat.com>
804- unset variables used in /etc/csh.cshrc (#1212)
805
806* Mon Jan 18 1999 Jeff Johnson <jbj@redhat.com>
807- compile for Raw Hide.
808
809* Tue Oct 13 1998 Cristian Gafton <gafton@redhat.com>
810- fix the csh.cshrc re: ${PATH} undefined
811
812* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
813- translations modified for de, fr, tr
814
815* Fri Dec 05 1997 Erik Troan <ewt@redhat.com>
816- /etc/profile uses $i, which needs to be unset
817
818* Mon Nov 03 1997 Donnie Barnes <djb@redhat.com>
819- made /etc/passwd and /etc/group %%config(noreplace)
820
821* Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
822- removed /etc/inetd.conf, /etc/rpc
823- flagged /etc/securetty as missingok
824- fixed buildroot stuff in spec file
825
826* Thu Jul 31 1997 Erik Troan <ewt@redhat.com>
827- made a noarch package
828
829* Wed Apr 16 1997 Erik Troan <ewt@redhat.com>
830- Don't verify md5sum, size, or timestamp of /var/log/lastlog, /etc/passwd,
831  or /etc/group.
Note: See TracBrowser for help on using the repository browser.