source: projects/setup/trunk/setup-vl.spec @ 8717

Revision 8717, 12.8 KB checked in by daisuke, 10 years ago (diff)

add initial version

Line 
1Summary: A set of system configuration and setup files.
2Summary(ja): システム設定およびセットアップファイル一式
3Name: setup
4Version: 2.8.31
5Release: 1%{?_dist_release}
6License: Public Domain
7Group: System Environment/Base
8URL: https://fedorahosted.org/setup/
9
10Source: setup-%{version}.tar.bz2
11Patch: setup-2.8.1-vine.patch
12
13Buildroot: %{_tmppath}/%{name}-%{version}-root
14BuildArch: noarch
15Conflicts: initscripts < 4.26, bash <= 2.0.4-21
16
17%description
18The setup package contains a set of important system configuration and
19setup files, such as passwd, group, and profile.
20
21%description -l ja
22このsetupパッケージには、passwd, group, profile などの、
23重要なシステム設定ファイルが含まれてます。
24
25%prep
26%setup -q
27%patch -p1
28./shadowconvert.sh
29
30%install
31rm -rf %{buildroot}
32mkdir -p %{buildroot}/etc/profile.d
33cp -ar * %{buildroot}/etc
34rm -f %{buildroot}/etc/uidgid
35rm -f %{buildroot}/etc/COPYING
36mkdir -p %{buildroot}/var/log
37touch %{buildroot}/etc/{shadow,gshadow}
38touch %{buildroot}/var/log/lastlog
39touch %{buildroot}/etc/environment
40chmod 0644 %{buildroot}/etc/environment
41chmod 0400 %{buildroot}/etc/{shadow,gshadow}
42chmod 0644 %{buildroot}/var/log/lastlog
43touch %{buildroot}/etc/fstab
44
45# remove unpackaged files
46rm -f %{buildroot}/etc/Makefile
47rm -f %{buildroot}/etc/services.orig
48rm -f %{buildroot}/etc/serviceslint
49rm -f %{buildroot}/etc/uidgidlint
50rm -f %{buildroot}/etc/shadowconvert.sh
51rm -f %{buildroot}/etc/setup.spec
52rm -f $RPM_BUILD_ROOT/etc/{bashrc,aliases}
53
54%clean
55rm -rf %{buildroot}
56
57#throw away useless and dangerous update stuff until rpm will be able to
58#handle it ( http://rpm.org/ticket/6 )
59%post -p <lua>
60for i, name in ipairs({"passwd", "shadow", "group", "gshadow"}) do
61     os.remove("/etc/"..name..".rpmnew")
62end
63
64%files
65%defattr(-,root,root)
66%doc uidgid COPYING
67%verify(not md5 size mtime) %config(noreplace) /etc/passwd
68%verify(not md5 size mtime) %config(noreplace) /etc/group
69%verify(not md5 size mtime) %config(noreplace,missingok) /etc/shadow
70%verify(not md5 size mtime) %config(noreplace,missingok) /etc/gshadow
71%verify(not md5 size mtime) %config(noreplace) /etc/services
72%verify(not md5 size mtime) %config(noreplace) /etc/exports
73%config(noreplace) /etc/environment
74%config(noreplace) /etc/filesystems
75%config(noreplace) /etc/host.conf
76%verify(not md5 size mtime) %config(noreplace) /etc/hosts
77%verify(not md5 size mtime) %config(noreplace) /etc/hosts.allow
78%verify(not md5 size mtime) %config(noreplace) /etc/hosts.deny
79%verify(not md5 size mtime) %config(noreplace) /etc/motd
80%config(noreplace) /etc/printcap
81%verify(not md5 size mtime) %config(noreplace) /etc/inputrc
82# config(noreplace) /etc/bashrc
83%config(noreplace) /etc/profile
84%verify(not md5 size mtime) %config(noreplace) /etc/protocols
85%attr(0600,root,root) %config(noreplace,missingok) /etc/securetty
86%config(noreplace) /etc/csh.login
87%config(noreplace) /etc/csh.cshrc
88%dir /etc/profile.d
89%config(noreplace) %verify(not md5 size mtime) /etc/shells
90%ghost %attr(0644,root,root) %verify(not md5 size mtime) /var/log/lastlog
91%ghost %verify(not md5 size mtime) %config(noreplace,missingok) /etc/fstab
92
93%changelog
94* Thu Apr 14 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.31-1
95- update to 2.8.31
96- use <lua> for post scriptlet
97
98* Sat Mar 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-1
99- update to 2.8.1
100- spec in utf-8
101- new versioning policy
102- add %%postun to remove dangerous .rpmnew files
103
104* Sat May 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.7-2vl5
105- add /etc/environment
106- add /etc/{fstab,mtab} as %%ghost
107- add console to /etc/securetty
108- import /etc/services from FC
109- set mark-symlinked-directories in /etc/inputrc
110- add /sbin/nologin to /etc/shells
111
112* Fri Mar 04 2005 Satoshi MACHINO <machino@vinelinux.org> 2.5.7-2vl4
113- updated setup-2.5.7-vine.patch
114        -- changed /etc/printcap for using cups
115
116* Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.5.7-2vl3
117- source /etc/profile.d/*.sh in /etc/profile
118
119* Sun Feb 24 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.7-2vl1
120- merge with new upstream version
121
122* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
123- automated rebuild
124
125* Mon Aug 27 2001 Preston Brown <pbrown@redhat.com>
126- add ext3 to /etc/filesystems
127
128* Mon Aug 20 2001 Bill Nottingham <notting@redhat.com>
129- change FTP user's home dir to /var/ftp (#52091)
130- %%ghost /etc/shadow, /etc/gshadow
131
132* Fri Aug 17 2001 Bill Nottingham <notting@redhat.com>
133- add /etc/shells to filelist (#51813)
134
135* Mon Aug 13 2001 Bill Nottingham <notting@redhat.com>
136- put lock in /etc/group (#51654)
137
138* Wed Aug  8 2001 Bill Nottingham <notting@redhat.com>
139- lock only needs to be a gid
140- don't set dspmbyte=euc here; do it in lang.csh, and only if necessary (#50318)
141
142* Mon Aug  6 2001 Jeff Johnson <jbj@redhat.com>
143- add lock.lock uid/gid 54 to own /var/lock directory.
144
145* Thu Jul 19 2001 Bill Nottingham <notting@redhat.com>
146- add forward/backward-word mappings (#48783)
147- add pgpkeyserver port to /etc/services (#49407)
148
149* Thu Jul 19 2001 Preston Brown <pbrown@redhat.com>
150- core files disabled by default.  Developers can enable them.
151
152* Fri Jul 13 2001 Bill Nottingham <notting@redhat.com> 2.5.1-1
153- revert news user back to no shell (#48701)
154
155* Tue Jul 10 2001 Bill Nottingham <notting@redhat.com> 2.5.0-1
156- move profile.d parsing from csh.cshrc to csh.login (#47417)
157
158* Sat Jul  7 2001 Nalin Dahyabhai <nalin@redhat.com> 2.4.15-1
159- reorder /etc/services to match comments again
160- protocol 118 is stp, not st
161- update URLs in /etc/protocols and /etc/services
162
163* Thu Jul  5 2001 Preston Brown <pbrown@redhat.com> 2.4.14-1
164- put */sbin in path if user ID is 0.
165
166* Mon Jun 25 2001 Bill Nottingham <notting@redhat.com>
167- add an entry to /etc/services for ssh X11 forwarding (#44944)
168
169* Wed Jun 13 2001 Bill Nottingham <notting@redhat.com>
170- take ttyS0 out of securetty on main tree
171
172* Tue Jun 12 2001 Philip Copeland <bryce@redhat.com>
173- added ttyS0 to securetty for serial console usage
174
175* Tue Jun 12 2001 Bill Nottingham <notting@redhat.com>
176- add rndc to /etc/services (#40265)
177- test for read bit, not execute bit, for profile.d (#35714)
178
179* Sun Jun 03 2001 Florian La Roche <Florian.LaRoche@redhat.de>
180- add "canna" entry to /etc/services
181
182* Mon May 21 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.4.10-1
183- Fix bugs #24159 and #30634 again; whoever moved bashrc from bash
184  to setup used an old version. :((
185
186* Wed May  2 2001 Preston Brown <pbrown@redhat.com> 2.4.9-1
187- bashrc moved here from bash package
188- set umask in bashrc, so it applies for ALL shells.
189
190* Fri Apr 27 2001 Preston Brown <pbrown@redhat.com> 2.4.8-1
191- /sbin/nologin for accounts that aren't "real."
192
193* Sat Apr  7 2001 Preston Brown <pbrown@redhat.com>
194- revert control-arrow forward/backward word (broken)
195
196* Tue Mar 27 2001 Preston Brown <pbrown@redhat.com>
197- fix japanese input with tcsh (#33211)
198
199* Tue Mar  6 2001 Bill Nottingham <notting@redhat.com>
200- fix some weirdness with rxvt (#30799)
201
202* Wed Feb 28 2001 Bill Nottingham <notting@redhat.com>
203- add SKK input method (#29759)
204
205* Fri Feb 23 2001 Preston Brown <pbrown@redhat.com>
206
207* Wed Feb 21 2001 Bill Nottingham <notting@redhat.com>
208- fix inputrc, Yet Again. (#28617)
209
210* Thu Feb 15 2001 Bill Nottingham <notting@redhat.com>
211- add in uidgid file, put it in %doc
212
213* Wed Feb  7 2001 Adrian Havill <havill@redhat.com>
214- bindkey for delete in the case of tcsh
215
216* Wed Feb  7 2001 Bill Nottingham <notting@redhat.com>
217- add some more stuff to /etc/services (#25396, patch from
218  <pekkas@netcore.fi>)
219
220* Tue Feb  6 2001 Nalin Dahyabhai <nalin@redhat.com>
221- add gii/tcp = 616 for gated
222
223* Tue Jan 30 2001 Bill Nottingham <notting@redhat.com>
224- wrap some inputrc settings with tests for mode, term (#24117)
225
226* Mon Jan 29 2001 Bill Nottingham <notting@redhat.com>
227- overhaul /etc/protocols (#18530)
228- add port 587 to /etc/services (#25001)
229- add corbaloc (#19581)
230- don't set /usr/X11R6/bin in $PATH if it's already set (#19968)
231
232* Fri Dec  1 2000 Nalin Dahyabhai <nalin@redhat.com>
233- Clean up /etc/services, separating registered numbers from unregistered
234  ("squatted") numbers, and adding some.
235
236* Mon Nov 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
237- Add smtps (465/tcp) and submission (587/tcp) to /etc/services for TLS
238  support (postfix >= 20001030-2)
239
240* Mon Nov  6 2000 Kazuhisa TAKEI <takei@vinelinux.org>
241- rebuild in  rpm 3.0.6
242
243* Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
244- remove reading profile.d process from /etc/profile
245  the process moved to /etc/bashrc...
246
247* Thu Sep 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
248- 2.2.1-1vl2
249- removed /etc/filesystems in %files section
250
251* Sun Aug  6 2000 Bill Nottingham <notting@redhat.com>
252- /var/log/lastlog is %config(noreplace) (#15412)
253- some of the various %verify changes (#14819)
254
255* Thu Aug  3 2000 Nalin Dahyabhai <nalin@redhat.com>
256- linuxconf should be 98, not 99
257
258* Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
259- fix some of the csh stuff (#14622)
260
261* Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
262- stop setting "multi on" in /etc/host.conf
263
264* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
265- automatic rebuild
266
267* Tue Jun 27 2000 Bill Nottingham <notting@redhat.com>
268- add hfs filesystem
269
270* Wed Jun 21 2000 Preston Brown <pbrown@redhat.com>
271- printcap is a noreplace file now
272
273* Sun Jun 18 2000 Bill Nottingham <notting@redhat.com>
274- fix typo
275
276* Tue Jun 13 2000 Lisa Sagami <czs14350@nifty.ne.jp>
277- merged RH 2.2.1-1 and Vine 2.0.5-1vl3
278
279* Tue Jun 13 2000 Nalin Dahyabhai <nalin@redhat.com>
280- add linuxconf/tcp = 99 to /etc/services
281
282* Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
283- add some stuff to /etc/services
284- tweak ulimit call again
285
286* Tue Jun  6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
287- homedir of ftp is now /var/ftp
288
289* Sun May 14 2000 Nalin Dahyabhai <nalin@redhat.com>
290- move profile.d logic in csh.login to csh.cshrc
291
292* Tue Apr 18 2000 Nalin Dahyabhai <nalin@redhat.com>
293- redirect ulimit -S -c to /dev/null to avoid clutter
294
295* Thu Apr 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
296- s/ulimit -c/ulimit -S -c/ - bash 2.x adaption
297
298* Mon Apr 03 2000 Nalin Dahyabhai <nalin@redhat.com>
299- Add more of the kerberos-related services from IANA's registry and krb5
300
301* Wed Mar 29 2000 Bernhard Rosenkraenzer <bero@redhat.com>
302- Add 2.4'ish vc/* devices to securetty
303
304* Thu Feb 17 2000 Preston Brown <pbrown@redhat.com>
305- add /etc/filesystems with sane defaults
306
307* Wed Feb 16 2000 Bill Nottingham <notting@redhat.com>
308- don't set prompt in /etc/profile (it's done in /etc/bashrc)
309
310* Fri Feb  5 2000 Bill Nottingham <notting@redhat.com>
311- yet more inputrc tweaks from Hans de Goede (hans@highrise.nl)
312
313* Sun Jan 30 2000 Bill Nottingham <notting@redhat.com>
314- yet more inputrc tweaks from Hans de Goede (hans@highrise.nl)
315
316* Sun Jan 23 2000 Bill Nottingham <notting@redhat.com>
317- fix mailq line. (#7140)
318
319* Fri Jan 21 2000 Bill Nottingham <notting@redhat.com>
320- add ldap to /etc/services
321
322* Tue Jan 18 2000 Bill Nottingham <notting@redhat.com>
323- kill HISTFILESIZE, it's broken
324
325* Tue Jan 18 2000 Preston Brown <pbrown@redhat.com>
326- some inputrc tweaks
327
328* Wed Jan 12 2000 Bill Nottingham <notting@redhat.com>
329- make some more stuff noreplace
330
331* Fri Nov 19 1999 Bill Nottingham <notting@redhat.com>
332- fix mailq line. (#7140)
333
334* Fri Oct 29 1999 Bill Nottingham <notting@redhat.com>
335- split csh.login into csh.login and csh.cshrc (#various)
336- fix pop service names (#6206)
337- fix ipv6 protocols entries (#6219)
338
339* Thu Sep  2 1999 Jeff Johnson <jbj@redhat.com>
340- rename /etc/csh.cshrc to /etc/csh.login (#2931).
341- (note: modified /etc/csh.cshrc should end up in /etc/csh.cshrc.rpmsave)
342
343* Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
344- add defattr.
345- fix limit command in /etc/csh.cshrc (#4582).
346
347* Thu Jul  8 1999 Bill Nottingham <notting@redhat.com>
348- move /etc/inputrc here.
349
350* Mon Apr 19 1999 Bill Nottingham <notting@redhat.com>
351- always use /etc/inputrc
352
353* Wed Mar 31 1999 Preston Brown <pbrown@redhat.com>
354- added alias pointing to imap from imap2
355
356* Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
357- updated protocols/services from debian to comply with more modern
358- IETF/RFC standards
359
360* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
361- auto rebuild in the new build environment (release 4)
362
363* Thu Feb 18 1999 Jeff Johnson <jbj@redhat.com>
364- unset variables used in /etc/csh.cshrc (#1212)
365
366* Mon Jan 18 1999 Jeff Johnson <jbj@redhat.com>
367- compile for Raw Hide.
368
369* Tue Oct 13 1998 Cristian Gafton <gafton@redhat.com>
370- fix the csh.cshrc re: ${PATH} undefined
371
372* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
373- translations modified for de, fr, tr
374
375* Fri Dec 05 1997 Erik Troan <ewt@redhat.com>
376- /etc/profile uses $i, which needs to be unset
377
378* Mon Nov 03 1997 Donnie Barnes <djb@redhat.com>
379- made /etc/passwd and /etc/group %config(noreplace)
380
381* Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
382- removed /etc/inetd.conf, /etc/rpc
383- flagged /etc/securetty as missingok
384- fixed buildroot stuff in spec file
385
386* Thu Jul 31 1997 Erik Troan <ewt@redhat.com>
387- made a noarch package
388
389* Wed Apr 16 1997 Erik Troan <ewt@redhat.com>
390- Don't verify md5sum, size, or timestamp of /var/log/lastlog, /etc/passwd,
391  or /etc/group.
Note: See TracBrowser for help on using the repository browser.